|
|
|
@ -1,7 +1,6 @@
|
|
|
|
|
diff -Naur x265_2.2.old/source/CMakeLists.txt x265_2.2/source/CMakeLists.txt
|
|
|
|
|
--- x265_2.2.old/source/CMakeLists.txt 2017-04-11 12:14:19.717605457 +0200
|
|
|
|
|
+++ x265_2.2/source/CMakeLists.txt 2017-04-11 12:14:27.499743262 +0200
|
|
|
|
|
@@ -548,7 +548,15 @@
|
|
|
|
|
--- a/source/CMakeLists.txt
|
|
|
|
|
+++ b/source/CMakeLists.txt
|
|
|
|
|
@@ -611,7 +611,15 @@
|
|
|
|
|
if(MSVC)
|
|
|
|
|
set_target_properties(x265-shared PROPERTIES OUTPUT_NAME libx265)
|
|
|
|
|
else()
|
|
|
|
@ -18,15 +17,15 @@ diff -Naur x265_2.2.old/source/CMakeLists.txt x265_2.2/source/CMakeLists.txt
|
|
|
|
|
endif()
|
|
|
|
|
if(UNIX)
|
|
|
|
|
set_target_properties(x265-shared PROPERTIES VERSION ${X265_BUILD})
|
|
|
|
|
diff -Naur x265_2.2.old/source/encoder/api.cpp x265_2.2/source/encoder/api.cpp
|
|
|
|
|
--- x265_2.2.old/source/encoder/api.cpp 2017-04-11 12:14:19.727605634 +0200
|
|
|
|
|
+++ x265_2.2/source/encoder/api.cpp 2017-04-11 12:21:58.928758432 +0200
|
|
|
|
|
@@ -356,7 +356,7 @@
|
|
|
|
|
--- a/source/encoder/api.cpp
|
|
|
|
|
+++ b/source/encoder/api.cpp
|
|
|
|
|
@@ -704,7 +704,7 @@
|
|
|
|
|
#define ext ".dylib"
|
|
|
|
|
#else
|
|
|
|
|
#include <dlfcn.h>
|
|
|
|
|
-#define ext ".so"
|
|
|
|
|
+#define ext ".so." xstr(X265_BUILD)
|
|
|
|
|
#endif
|
|
|
|
|
#if defined(__GNUC__) && __GNUC__ >= 8
|
|
|
|
|
#pragma GCC diagnostic ignored "-Wcast-function-type"
|
|
|
|
|
|
|
|
|
|
static int g_recursion /* = 0 */;
|
|
|
|
|