Update to 3.0

el8
Leigh Scott 6 years ago
parent 16754e9fd8
commit 7f5fcc77e3

1
.gitignore vendored

@ -8,3 +8,4 @@ x265_1.6.tar.gz
/x265_2.7.tar.gz
/x265_2.8.tar.gz
/x265_2.9.tar.gz
/x265_3.0.tar.gz

@ -1 +1 @@
693ee4ce7929a59735f441107310f0bb x265_2.9.tar.gz
8ff1780246bb7ac8506239f6129c04ec x265_3.0.tar.gz

@ -1,7 +1,6 @@
diff -Naur x265_2.2.old/source/CMakeLists.txt x265_2.2/source/CMakeLists.txt
--- x265_2.2.old/source/CMakeLists.txt 2017-04-11 12:14:19.717605457 +0200
+++ x265_2.2/source/CMakeLists.txt 2017-04-11 12:14:27.499743262 +0200
@@ -548,7 +548,15 @@
--- a/source/CMakeLists.txt
+++ b/source/CMakeLists.txt
@@ -611,7 +611,15 @@
if(MSVC)
set_target_properties(x265-shared PROPERTIES OUTPUT_NAME libx265)
else()
@ -18,15 +17,15 @@ diff -Naur x265_2.2.old/source/CMakeLists.txt x265_2.2/source/CMakeLists.txt
endif()
if(UNIX)
set_target_properties(x265-shared PROPERTIES VERSION ${X265_BUILD})
diff -Naur x265_2.2.old/source/encoder/api.cpp x265_2.2/source/encoder/api.cpp
--- x265_2.2.old/source/encoder/api.cpp 2017-04-11 12:14:19.727605634 +0200
+++ x265_2.2/source/encoder/api.cpp 2017-04-11 12:21:58.928758432 +0200
@@ -356,7 +356,7 @@
--- a/source/encoder/api.cpp
+++ b/source/encoder/api.cpp
@@ -704,7 +704,7 @@
#define ext ".dylib"
#else
#include <dlfcn.h>
-#define ext ".so"
+#define ext ".so." xstr(X265_BUILD)
#endif
static int g_recursion /* = 0 */;
#if defined(__GNUC__) && __GNUC__ >= 8
#pragma GCC diagnostic ignored "-Wcast-function-type"

@ -1,6 +1,6 @@
--- a/source/CMakeLists.txt
+++ b/source/CMakeLists.txt
@@ -196,7 +196,7 @@
@@ -212,7 +212,7 @@
add_definitions(-std=gnu++98)
endif()
if(ENABLE_PIC)
@ -9,4 +9,3 @@
endif(ENABLE_PIC)
if(NATIVE_BUILD)
if(INTEL_CXX)

@ -1,9 +1,9 @@
%global _so_version 165
%global _so_version 169
Summary: H.265/HEVC encoder
Name: x265
Version: 2.9
Release: 3%{?dist}
Version: 3.0
Release: 1%{?dist}
URL: http://x265.org/
# source/Lib/TLibCommon - BSD
# source/Lib/TLibEncoder - BSD
@ -19,7 +19,6 @@ Patch2: x265-detect_cpu_armhfp.patch
Patch3: x265-arm-cflags.patch
Patch4: x265-pkgconfig_path_fix.patch
Patch5: x265-2.8-asm-primitives.patch
Patch6: https://sources.debian.org/data/main/x/x265/2.9-3/debian/patches/0003-detect512-is-needed-on-all-architectures.patch
BuildRequires: gcc-c++
BuildRequires: cmake3
@ -141,6 +140,9 @@ done
%{_libdir}/pkgconfig/x265.pc
%changelog
* Thu Feb 28 2019 Leigh Scott <leigh123linux@googlemail.com> - 3.0-1
- Update to 3.0
* Sun Dec 30 2018 Leigh Scott <leigh123linux@googlemail.com> - 2.9-3
- Rebuild against newer nasm on el7 (rfbz #5128)

Loading…
Cancel
Save