Update patches for 1.8

el8
Nicolas Chauvet 9 years ago
parent 38f3e9ad61
commit 710c6f5565

@ -1,9 +1,9 @@
diff -up x265_1.6/source/CMakeLists.txt.armhfp x265_1.6/source/CMakeLists.txt
--- x265_1.6/source/CMakeLists.txt.armhfp 2015-04-15 13:26:46.995287699 +0200
+++ x265_1.6/source/CMakeLists.txt 2015-04-15 13:27:29.015472793 +0200
@@ -51,9 +51,13 @@ if("${SYSPROC}" STREQUAL "" OR X86MATCH
add_definitions(-DX86_64=1)
endif()
diff -up x265_1.8/source/CMakeLists.txt.armhfp x265_1.8/source/CMakeLists.txt
--- x265_1.8/source/CMakeLists.txt.armhfp 2015-09-22 10:10:07.000000000 +0200
+++ x265_1.8/source/CMakeLists.txt 2015-10-24 12:17:17.675572785 +0200
@@ -57,9 +57,13 @@ elseif(POWERMATCH GREATER "-1")
set(POWER 1)
add_definitions(-DX265_ARCH_POWER=1)
elseif(${SYSPROC} STREQUAL "armv6l")
- message(STATUS "Detected ARM target processor")
+ message(STATUS "Detected ARMv6 target processor")

@ -1,12 +1,12 @@
diff -up x265_1.6/source/test/CMakeLists.txt.ts x265_1.6/source/test/CMakeLists.txt
--- x265_1.6/source/test/CMakeLists.txt.ts 2015-04-15 12:50:14.244622449 +0200
+++ x265_1.6/source/test/CMakeLists.txt 2015-04-15 12:50:32.534702116 +0200
@@ -22,7 +22,7 @@ add_executable(TestBench ${YASM_SRC}
diff -up x265_1.8/source/test/CMakeLists.txt.shared x265_1.8/source/test/CMakeLists.txt
--- x265_1.8/source/test/CMakeLists.txt.shared 2015-09-22 10:10:07.000000000 +0200
+++ x265_1.8/source/test/CMakeLists.txt 2015-10-24 12:15:04.846236808 +0200
@@ -23,7 +23,7 @@ add_executable(TestBench ${YASM_SRC}
mbdstharness.cpp mbdstharness.h
ipfilterharness.cpp ipfilterharness.h
intrapredharness.cpp intrapredharness.h)
-target_link_libraries(TestBench x265-static ${PLATFORM_LIBS})
+target_link_libraries(TestBench x265-shared ${PLATFORM_LIBS})
if(LINKER_OPTIONS)
set_target_properties(TestBench PROPERTIES LINK_FLAGS ${LINKER_OPTIONS})
endif()
if(EXTRA_LIB)
list(APPEND LINKER_OPTIONS "-L..")

@ -1,6 +1,6 @@
Summary: H.265/HEVC encoder
Name: x265
Version: 1.6
Version: 1.8
Release: 1%{?dist}
URL: http://x265.org/
Source0: http://ftp.videolan.org/pub/videolan/x265/x265_%{version}.tar.gz
@ -85,6 +85,9 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} test/TestBench
%{_libdir}/pkgconfig/x265.pc
%changelog
* Sat Oct 24 2015 Nicolas Chauvet <kwizart@gmail.com> - 1.8-1
- Update to 1.8
* Wed Apr 15 2015 Dominik Mierzejewski <rpm@greysector.net> 1.6-1
- update to 1.6 (ABI bump, rfbz#3593)
- release tarballs are now hosted on videolan.org

Loading…
Cancel
Save