- release tarballs are now hosted on videolan.org - drop obsolete patchesel8
parent
9068270774
commit
38f3e9ad61
@ -1 +1 @@
|
||||
1.2.tar.bz2
|
||||
x265_1.6.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
57a4b8300918c5412ceaa26bb8e0a0bb 1.2.tar.bz2
|
||||
32e4151f8b6a32b466b1055562ebfb4f x265_1.6.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
diff -up multicoreware-x265-d6257335c537/source/CMakeLists.txt.soname multicoreware-x265-d6257335c537/source/CMakeLists.txt
|
||||
--- multicoreware-x265-d6257335c537/source/CMakeLists.txt.soname 2014-08-08 11:55:36.315572972 +0200
|
||||
+++ multicoreware-x265-d6257335c537/source/CMakeLists.txt 2014-08-08 11:55:36.316572975 +0200
|
||||
@@ -276,15 +276,22 @@ if(ENABLE_SHARED)
|
||||
else()
|
||||
set_target_properties(x265-shared PROPERTIES OUTPUT_NAME x265)
|
||||
endif()
|
||||
- if(UNIX AND NOT APPLE)
|
||||
- set_target_properties(x265-shared PROPERTIES LINK_FLAGS "-Wl,-Bsymbolic,-znoexecstack")
|
||||
+ if(UNIX)
|
||||
+ set_target_properties(x265-shared PROPERTIES VERSION ${X265_BUILD})
|
||||
+ if(NOT APPLE)
|
||||
+ set_target_properties(x265-shared PROPERTIES LINK_FLAGS "-Wl,-Bsymbolic,-znoexecstack")
|
||||
+ endif()
|
||||
endif()
|
||||
+ set_target_properties(x265-shared PROPERTIES SOVERSION ${X265_BUILD})
|
||||
if(X265_LATEST_TAG)
|
||||
+ if(WINDOWS)
|
||||
+ set_target_properties(x265-shared PROPERTIES VERSION ${X265_LATEST_TAG})
|
||||
+ endif()
|
||||
# shared library is not installed if a tag is not found
|
||||
- set_target_properties(x265-shared PROPERTIES VERSION ${X265_LATEST_TAG} SOVERSION ${X265_BUILD})
|
||||
install(TARGETS x265-shared
|
||||
LIBRARY DESTINATION ${LIB_INSTALL_DIR}
|
||||
- ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
|
||||
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
|
||||
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR})
|
||||
endif()
|
||||
endif()
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up multicoreware-x265-d6257335c537/source/CMakeLists.txt.r multicoreware-x265-d6257335c537/source/CMakeLists.txt
|
||||
--- multicoreware-x265-d6257335c537/source/CMakeLists.txt.r 2014-07-09 10:25:15.000000000 +0200
|
||||
+++ multicoreware-x265-d6257335c537/source/CMakeLists.txt 2014-07-10 12:03:21.459088376 +0200
|
||||
@@ -308,7 +308,7 @@ if(X265_LATEST_TAG)
|
||||
# Produce a pkg-config file
|
||||
configure_file("x265.pc.in" "x265.pc" @ONLY)
|
||||
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/x265.pc"
|
||||
- DESTINATION "${CMAKE_INSTALL_PREFIX}/${LIB_INSTALL_DIR}/pkgconfig")
|
||||
+ DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")
|
||||
endif()
|
||||
|
||||
if(NOT WIN32)
|
@ -1,16 +0,0 @@
|
||||
diff -up multicoreware-x265-d6257335c537/source/CMakeLists.txt.pic multicoreware-x265-d6257335c537/source/CMakeLists.txt
|
||||
--- multicoreware-x265-d6257335c537/source/CMakeLists.txt.pic 2014-07-17 09:37:41.176441279 +0200
|
||||
+++ multicoreware-x265-d6257335c537/source/CMakeLists.txt 2014-07-17 10:18:03.001014597 +0200
|
||||
@@ -122,10 +122,10 @@ if(GCC)
|
||||
add_definitions(-fPIC)
|
||||
endif(X64 AND NOT WIN32)
|
||||
if(X86 AND NOT X64)
|
||||
- add_definitions(-march=i686)
|
||||
+ add_definitions(-march=i686 -fPIC)
|
||||
endif()
|
||||
if(ARM)
|
||||
- add_definitions(-march=armv6 -mfloat-abi=hard -mfpu=vfp)
|
||||
+ add_definitions(-fPIC)
|
||||
endif()
|
||||
check_cxx_compiler_flag(-Wno-narrowing CC_HAS_NO_NARROWING)
|
||||
check_cxx_compiler_flag(-ffast-math CC_HAS_FAST_MATH)
|
@ -1,13 +1,12 @@
|
||||
diff -up multicoreware-x265-d6257335c537/source/test/CMakeLists.txt.r multicoreware-x265-d6257335c537/source/test/CMakeLists.txt
|
||||
--- multicoreware-x265-d6257335c537/source/test/CMakeLists.txt.r 2014-07-09 10:25:15.000000000 +0200
|
||||
+++ multicoreware-x265-d6257335c537/source/test/CMakeLists.txt 2014-07-10 12:10:15.171798782 +0200
|
||||
@@ -17,7 +17,7 @@ add_executable(TestBench ${YASM_SRC}
|
||||
diff -up x265_1.6/source/test/CMakeLists.txt.ts x265_1.6/source/test/CMakeLists.txt
|
||||
--- x265_1.6/source/test/CMakeLists.txt.ts 2015-04-15 12:50:14.244622449 +0200
|
||||
+++ x265_1.6/source/test/CMakeLists.txt 2015-04-15 12:50:32.534702116 +0200
|
||||
@@ -22,7 +22,7 @@ add_executable(TestBench ${YASM_SRC}
|
||||
mbdstharness.cpp mbdstharness.h
|
||||
ipfilterharness.cpp ipfilterharness.h
|
||||
intrapredharness.cpp intrapredharness.h)
|
||||
-target_link_libraries(TestBench x265-static ${PLATFORM_LIBS})
|
||||
+target_link_libraries(TestBench x265-shared ${PLATFORM_LIBS})
|
||||
|
||||
add_executable(PoolTest testpool.cpp)
|
||||
-target_link_libraries(PoolTest x265-static ${PLATFORM_LIBS})
|
||||
+target_link_libraries(PoolTest x265-shared ${PLATFORM_LIBS})
|
||||
if(LINKER_OPTIONS)
|
||||
set_target_properties(TestBench PROPERTIES LINK_FLAGS ${LINKER_OPTIONS})
|
||||
endif()
|
||||
|
Loading…
Reference in new issue