f38
Andreas Bierfert 15 years ago
parent 93d42d4e5f
commit e2b7c35b40

@ -1 +1 @@
wine-1.1.38-fe.tar.bz2
wine-1.1.44.tar.bz2

@ -1 +1 @@
fdf4b8573b77da73b683e97128ee4150 wine-1.1.38-fe.tar.bz2
f18649bd71b9099fecad22436d239cba wine-1.1.44.tar.bz2

@ -0,0 +1,20 @@
--- dlls/winhttp/net.c.old 2010-04-04 18:11:01.266148279 +0300
+++ dlls/winhttp/net.c 2010-04-04 18:12:52.235163141 +0300
@@ -91,7 +91,7 @@
static void *libssl_handle;
static void *libcrypto_handle;
-static SSL_METHOD *method;
+static const SSL_METHOD *method;
static SSL_CTX *ctx;
static int hostname_idx;
static int error_idx;
@@ -113,7 +113,7 @@
static void *OpenSSL_ssl_handle;
static void *OpenSSL_crypto_handle;
-static SSL_METHOD *meth;
+const static SSL_METHOD *meth;
static SSL_CTX *ctx;
static int hostname_idx;
static int error_idx;

@ -0,0 +1,127 @@
--- dlls/mshtml/install.c.orig 2010-03-28 23:48:50.000000000 +0200
+++ dlls/mshtml/install.c 2010-03-29 20:43:54.000000000 +0200
@@ -284,6 +284,103 @@
return ret;
}
+static BOOL install_from_fedora_mingw32_wine_gecko(void) {
+ const char *data_dir, *subdir;
+ BOOL res;
+
+ LPWSTR dos_dir_name;
+ LPSTR dos_dir_name_a;
+ static WCHAR *(*wine_get_dos_file_name)(const char*);
+ static const WCHAR kernel32W[] = {'k','e','r','n','e','l','3','2','.','d','l','l',0};
+
+ char install_dir[MAX_PATH];
+ char gecko_dir[MAX_PATH];
+
+ SHFILEOPSTRUCTA sf;
+
+ TRACE("()\n");
+
+ if((data_dir = wine_get_data_dir()))
+ subdir = "/gecko/";
+ else if((data_dir = wine_get_build_dir()))
+ subdir = "/../gecko/";
+ else
+ return FALSE;
+
+ TRACE("data_dir=%s\n",data_dir);
+ TRACE("subdir=%s\n",subdir);
+
+ memcpy(gecko_dir, data_dir, MAX_PATH);
+ strncat(gecko_dir, subdir, MAX_PATH-strlen(gecko_dir));
+ strncat(gecko_dir, GECKO_VERSION, MAX_PATH-strlen(gecko_dir));
+ strncat(gecko_dir, "/", MAX_PATH-strlen(gecko_dir));
+
+ if(!wine_get_dos_file_name)
+ wine_get_dos_file_name = (void*)GetProcAddress(GetModuleHandleW(kernel32W), "wine_get_dos_file_name");
+
+ if(wine_get_dos_file_name) { /* Wine UNIX mode */
+ dos_dir_name = wine_get_dos_file_name(gecko_dir);
+ if(!dos_dir_name) {
+ ERR("Could not get dos file name of %s\n", debugstr_a(gecko_dir));
+ return FALSE;
+ }
+ } else {
+ return FALSE;
+ }
+
+ TRACE("gecko_dir=%s\n", debugstr_a(gecko_dir));
+ TRACE("dos_dir_name=%s\n", debugstr_w(dos_dir_name));
+
+
+ if(GetFileAttributesW(dos_dir_name) == INVALID_FILE_ATTRIBUTES) {
+ TRACE("mingw32-wine-gecko package not installed\n");
+ return FALSE;
+ }
+
+ GetSystemDirectoryA(install_dir, sizeof(install_dir));
+ strncat(install_dir, "\\gecko\\",MAX_PATH-strlen(install_dir));
+ res = CreateDirectoryA(install_dir, NULL);
+ if(!res && GetLastError() != ERROR_ALREADY_EXISTS) {
+ ERR("Could not create directory: %08u\n", GetLastError());
+ return FALSE;
+ }
+
+ strncat(install_dir, GECKO_VERSION, MAX_PATH-strlen(install_dir));
+ res = CreateDirectoryA(install_dir, NULL);
+ if(!res && GetLastError() != ERROR_ALREADY_EXISTS) {
+ ERR("Could not create directory: %08u\n", GetLastError());
+ return FALSE;
+ }
+
+ TRACE("install_dir=%s\n",debugstr_a(install_dir));
+
+ dos_dir_name_a = heap_strdupWtoA(dos_dir_name);
+
+ lstrcatA(dos_dir_name_a,"*.*");
+ TRACE("dos_dir_name_a=%s\n",debugstr_a(dos_dir_name_a));
+
+ memset(&sf,0,sizeof(sf));
+ sf.hwnd = 0;
+ sf.wFunc = FO_COPY;
+ sf.pFrom = dos_dir_name_a;
+ sf.pTo = install_dir;
+ sf.fFlags = FOF_NOCONFIRMATION, FOF_NOCONFIRMMKDIR | FOF_NOERRORUI | FOF_SILENT;
+ res = SHFileOperationA(&sf);
+
+ heap_free(dos_dir_name_a);
+
+ if(res != 0) {
+ ERR("Could not copy files: %08u\n", GetLastError());
+ return FALSE;
+ }
+
+ set_registry(install_dir);
+
+ clean_up();
+
+ return TRUE;
+}
+
static HRESULT WINAPI InstallCallback_QueryInterface(IBindStatusCallback *iface,
REFIID riid, void **ppv)
{
@@ -541,7 +638,8 @@
* - $datadir/gecko
* - download from URL stored in GeckoUrl value of HKCU/Software/MSHTML key
*/
- if(!install_from_registered_dir()
+ if ( !install_from_fedora_mingw32_wine_gecko()
+ && !install_from_registered_dir()
&& !install_from_default_dir()
&& !silent && (url = get_url()))
DialogBoxW(hInst, MAKEINTRESOURCEW(ID_DWL_DIALOG), 0, installer_proc);
--- dlls/mshtml/Makefile.in.orig 2010-03-29 15:13:47.000000000 +0200
+++ dlls/mshtml/Makefile.in 2010-03-29 15:49:55.000000000 +0200
@@ -4,7 +4,7 @@
VPATH = @srcdir@
MODULE = mshtml.dll
IMPORTLIB = mshtml
-IMPORTS = strmiids uuid urlmon shlwapi ole32 oleaut32 user32 gdi32 advapi32 kernel32
+IMPORTS = strmiids uuid urlmon shlwapi ole32 oleaut32 user32 gdi32 advapi32 kernel32 shell32
EXTRADEFS = -DCOM_NO_WINDOWS_H
DELAYIMPORTS = wininet

@ -1,6 +1,6 @@
--- configure.orig 2009-10-29 18:57:06.000000000 +0100
+++ configure 2009-10-29 18:58:49.000000000 +0100
@@ -6758,14 +6758,14 @@
--- configure.old 2010-04-02 20:43:45.000000000 +0300
+++ configure 2010-04-03 23:26:57.365947610 +0300
@@ -6727,14 +6727,14 @@
fi
@ -9,7 +9,7 @@
-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
+ as_ac_var=`$as_echo "ac_cv_cflags_-fPIC" | $as_tr_sh`
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC" >&5
+$as_echo_n "checking whether the compiler supports -fPIC " >&6; }
+$as_echo_n "checking whether the compiler supports -fPIC" >&6; }
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then :
$as_echo_n "(cached) " >&6
else
@ -18,8 +18,8 @@
+CFLAGS="$CFLAGS -fPIC"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main(int argc, char *argv) { return 0; }
@@ -6783,17 +6783,17 @@
int main(int argc, char **argv) { return 0; }
@@ -6752,17 +6752,17 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
$as_echo "$ac_res" >&6; }
if test `eval 'as_val=${'$as_ac_var'};$as_echo "$as_val"'` = yes; then :
@ -33,7 +33,7 @@
-$as_echo_n "checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib... " >&6; }
+ as_ac_var=`$as_echo "ac_cv_cflags_-fPIC" | $as_tr_sh`
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC" >&5
+$as_echo_n "checking whether the compiler supports -fPIC " >&6; }
+$as_echo_n "checking whether the compiler supports -fPIC" >&6; }
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then :
$as_echo_n "(cached) " >&6
else
@ -42,4 +42,4 @@
+CFLAGS="$CFLAGS -fPIC"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main(int argc, char *argv) { return 0; }
int main(int argc, char **argv) { return 0; }

@ -1,26 +0,0 @@
--- libs/wine/config.c.orig 2009-11-26 23:36:37.000000000 +0100
+++ libs/wine/config.c 2009-11-26 23:37:36.000000000 +0100
@@ -35,9 +35,9 @@
#endif
#include "wine/library.h"
-static const char server_config_dir[] = "/.wine"; /* config dir relative to $HOME */
-static const char server_root_prefix[] = "/tmp/.wine-"; /* prefix for server root dir */
-static const char server_dir_prefix[] = "/server-"; /* prefix for server dir */
+static const char server_config_dir[] = "/.wine-x86_64"; /* config dir relative to $HOME */
+static const char server_root_prefix[] = "/tmp/.wine-x86_64-"; /* prefix for server root dir */
+static const char server_dir_prefix[] = "/server-x86_64-"; /* prefix for server dir */
static char *bindir;
static char *dlldir;
--- dlls/ntdll/server.c.orig 2010-01-18 23:06:56.000000000 +0100
+++ dlls/ntdll/server.c 2010-01-18 23:07:27.000000000 +0100
@@ -698,7 +698,7 @@
{
static int started; /* we only try once */
char *argv[3];
- static char wineserver[] = "server/wineserver";
+ static char wineserver[] = "server/wineserver64";
static char debug[] = "-d";
if (!started)

@ -1,18 +1,13 @@
%define no64bit 0
Name: wine
Version: 1.1.40
Version: 1.1.44
Release: 1%{?dist}
Summary: A Windows 16/32/64 bit emulator
Group: Applications/Emulators
License: LGPLv2+
URL: http://www.winehq.org/
# special fedora tarball without winemp3
# It can be obtained by running rm -fr dlls/winemp3.acm in the winetree
# and removing the references from configure, configure.ac, Makefile.in,
# and programs/winecfg/libraries.c wrt. winemp3.
Source0: %{name}-%{version}-fe.tar.bz2
Source0: http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
Source1: wine.init
Source3: wine-README-Fedora
Source4: wine-32.conf
@ -37,22 +32,22 @@ Source201: wine.directory
# mime types
Source300: wine-mime-msi.desktop
Patch1: wine-rpath.patch
# explain how to use wine with pulseaudio
# see http://bugs.winehq.org/show_bug.cgi?id=10495
# and http://art.ified.ca/?page_id=40
Patch400: http://art.ified.ca/downloads/winepulse-0.35-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse-0.35.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.34-winecfg.patch
# rebased for .42 see #580073
Patch400: winepulse-0.35-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.36.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.36-winecfg.patch
Source402: README-FEDORA-PULSEAUDIO
Patch1: wine-rpath.patch
# upstream bugs
# currently non
# bugfix patches
# #533806
Patch600: wine-x86_64-prefix.patch
# enhancements
# add wine-gecko support
Patch1000: wine-gecko.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -108,11 +103,15 @@ BuildRequires: gnutls-devel
BuildRequires: pulseaudio-libs-devel
BuildRequires: gsm-devel
BuildRequires: openal-soft-devel
BuildRequires: libv4l-devel
BuildRequires: fontpackages-devel
# noarch
Requires: wine-common = %{version}-%{release}
Requires: wine-desktop = %{version}-%{release}
# 32bit
Requires: wine-fonts = %{version}-%{release}
# 32bit parts
Requires: wine-core(x86-32) = %{version}-%{release}
Requires: wine-capi(x86-32) = %{version}-%{release}
Requires: wine-cms(x86-32) = %{version}-%{release}
@ -127,6 +126,13 @@ Requires: wine-cms(x86-64) = %{version}-%{release}
Requires: wine-ldap(x86-64) = %{version}-%{release}
Requires: wine-twain(x86-64) = %{version}-%{release}
Requires: wine-pulseaudio(x86-64) = %{version}-%{release}
Requires: wine-wow(x86-64) = %{version}-%{release}
Conflicts: wine-wow(x86-32) = %{version}-%{release}
%endif
# 32bit only parts
%ifarch %{ix86}
Requires: wine-wow = %{version}-%{release}
%endif
%description
@ -144,7 +150,6 @@ wine-* sub packages.
%package core
Summary: Wine core package
Group: Applications/Emulators
Requires: wine-fonts = %{version}-%{release}
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
Obsoletes: wine <= 0.9.15-1%{?dist}
@ -166,9 +171,18 @@ Requires: freetype(x86-64)
Requires: gnutls(x86-64)
%endif
%description core
Wine core package includes the basic wine stuff needed by all other packages.
%package wow
Summary: Files for wine wow seperation
Group: Applications/Emulators
Requires: wine-core = %{version}-%{release}
%description wow
%{summary}
%package desktop
Summary: Desktop integration features for wine
Group: Applications/Emulators
@ -188,10 +202,84 @@ handler service.
Summary: Wine font files
Group: Applications/Emulators
BuildArch: noarch
Requires: wine-courier-fonts = %{version}-%{release}
Requires: wine-small-fonts = %{version}-%{release}
Requires: wine-system-fonts = %{version}-%{release}
Requires: wine-marlett-fonts = %{version}-%{release}
#Requires: wine-ms-sans-serif-fonts = %{version}-%{release}
#Requires: wine-tahoma-fonts = %{version}-%{release}
Requires: wine-symbol-fonts = %{version}-%{release}
%description fonts
%{summary}
%package courier-fonts
Summary: Wine Courier font family
Group: User Interface/X
BuildArch: noarch
Requires: fontpackages-filesystem
%description courier-fonts
%{summary}
%package small-fonts
Summary: Wine Small font family
Group: User Interface/X
BuildArch: noarch
Requires: fontpackages-filesystem
%description small-fonts
%{summary}
%package system-fonts
Summary: Wine System font family
Group: User Interface/X
BuildArch: noarch
Requires: fontpackages-filesystem
%description system-fonts
%{summary}
%package marlett-fonts
Summary: Wine Marlett font family
Group: User Interface/X
BuildArch: noarch
Requires: fontpackages-filesystem
%description marlett-fonts
%{summary}
#%package ms-sans-serif-fonts
#Summary: Wine MS Sans Serif font family
#Group: User Interface/X
#BuildArch: noarch
#Requires: fontpackages-filesystem
#%description ms-sans-serif-fonts
#%{summary}
#%package tahoma-fonts
#Summary: Wine Tahoma font family
#Group: User Interface/X
#BuildArch: noarch
#Requires: fontpackages-filesystem
#%description tahoma-fonts
#%{summary}
%package symbol-fonts
Summary: Wine Symbol font family
Group: User Interface/X
BuildArch: noarch
Requires: fontpackages-filesystem
%description symbol-fonts
%{summary}
%package common
Summary: Common files
Group: Applications/Emulators
@ -307,21 +395,19 @@ This package adds an openal driver for wine.
%prep
%setup -q -n %{name}-%{version}-fe
%setup -q
%patch1
%patch400 -p1
%patch400
%patch401 -p1
%patch402 -p1
%ifarch x86_64
%patch600
%endif
%patch1000
autoreconf
%build
export CFLAGS="$RPM_OPT_FLAGS"
export CFLAGS="$RPM_OPT_FLAGS -Wno-error"
%configure \
--sysconfdir=%{_sysconfdir}/wine \
--x-includes=%{_includedir} --x-libraries=%{_libdir} \
@ -350,12 +436,8 @@ rm -rf %{buildroot}
%ifarch %{ix86}
# rename wine to wine32
mv %{buildroot}%{_bindir}/wine{,32}
%endif
# if x86_64 rename to wine64
%ifarch x86_64
mv %{buildroot}%{_bindir}/wine{,64}
mv %{buildroot}%{_bindir}/wineserver{,64}
# create link to wine32 if ix86
ln -s %{_bindir}/wine32 %{buildroot}%{_bindir}/wine
%endif
mkdir -p %{buildroot}%{_sysconfdir}/wine
@ -449,11 +531,34 @@ install -p -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/
install -p -m644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/
%endif
install -p -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/wine
# deploy pulseaudio readme
cp %{SOURCE402} .
# install fonts
install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-courier-fonts
mv %{buildroot}/%{_datadir}/wine/fonts/cou* %{buildroot}/%{_datadir}/fonts/wine-courier-fonts/
install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-system-fonts
mv %{buildroot}/%{_datadir}/wine/fonts/*sys.* %{buildroot}/%{_datadir}/fonts/wine-system-fonts/
install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-small-fonts
mv %{buildroot}/%{_datadir}/wine/fonts/sma* %{buildroot}/%{_datadir}/fonts/wine-small-fonts/
install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-marlett-fonts
mv %{buildroot}/%{_datadir}/wine/fonts/marlett.ttf %{buildroot}/%{_datadir}/fonts/wine-marlett-fonts/
#install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-ms-sans-serif-fonts
#mv %{buildroot}/%{_datadir}/wine/fonts/sse* %{buildroot}/%{_datadir}/fonts/wine-ms-sans-serif-fonts/
rm -f %{buildroot}/%{_datadir}/wine/fonts/sse*
#install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-tahoma-fonts
#mv %{buildroot}/%{_datadir}/wine/fonts/tahoma* %{buildroot}/%{_datadir}/fonts/wine-tahoma-fonts/
rm -f %{buildroot}/%{_datadir}/wine/fonts/tahoma*
install -p -m 0755 -d %{buildroot}/%{_datadir}/fonts/wine-symbol-fonts
mv %{buildroot}/%{_datadir}/wine/fonts/symbol.ttf %{buildroot}/%{_datadir}/fonts/wine-symbol-fonts/
%clean
rm -rf %{buildroot}
@ -543,21 +648,22 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/write.exe.so
%{_libdir}/wine/dxdiag.exe.so
%{_bindir}/wine
%ifarch %{ix86}
%{_bindir}/wine32
%{_bindir}/wine-preloader
%{_bindir}/wineserver
%{_sysconfdir}/ld.so.conf.d/wine-32.conf
%endif
%ifarch x86_64
%{_bindir}/wine64
%{_bindir}/wineserver64
%{_sysconfdir}/ld.so.conf.d/wine-64.conf
%endif
%dir %{_libdir}/wine
%dir %{_libdir}/wine/fakedlls
%{_libdir}/wine/fakedlls/*
%{_libdir}/wine/attrib.exe.so
%{_libdir}/wine/cacls.exe.so
%{_libdir}/wine/expand.exe.so
%{_libdir}/wine/extrac32.exe.so
@ -565,8 +671,10 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/mshta.exe.so
%{_libdir}/wine/msiexec.exe.so
%{_libdir}/wine/net.exe.so
%{_libdir}/wine/ngen.exe.so
%{_libdir}/wine/ntoskrnl.exe.so
%{_libdir}/wine/oleview.exe.so
%{_libdir}/wine/ping.exe.so
%{_libdir}/wine/reg.exe.so
%{_libdir}/wine/regedit.exe.so
%{_libdir}/wine/regsvr32.exe.so
@ -576,7 +684,6 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/services.exe.so
%{_libdir}/wine/start.exe.so
%{_libdir}/wine/termsv.exe.so
%{_libdir}/wine/wineboot.exe.so
%{_libdir}/wine/winebrowser.exe.so
%{_libdir}/wine/wineconsole.exe.so
%{_libdir}/wine/winemenubuilder.exe.so
@ -630,6 +737,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/devenum.dll.so
%{_libdir}/wine/dinput.dll.so
%{_libdir}/wine/dinput8.dll.so
%{_libdir}/wine/dispex.dll.so
%{_libdir}/wine/dmband.dll.so
%{_libdir}/wine/dmcompos.dll.so
%{_libdir}/wine/dmime.dll.so
@ -729,7 +837,11 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/msrle32.dll.so
%{_libdir}/wine/mstask.dll.so
%{_libdir}/wine/msvcirt.dll.so
%{_libdir}/wine/msvcr70.dll.so
%{_libdir}/wine/msvcr71.dll.so
%{_libdir}/wine/msvcr80.dll.so
%{_libdir}/wine/msvcr90.dll.so
%{_libdir}/wine/msvcr100.dll.so
%{_libdir}/wine/msvcrt.dll.so
%{_libdir}/wine/msvcrt20.dll.so
%{_libdir}/wine/msvcrt40.dll.so
@ -779,6 +891,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/rsabase.dll.so
%{_libdir}/wine/rsaenh.dll.so
%{_libdir}/wine/rtutils.dll.so
%{_libdir}/wine/sc.exe.so
%{_libdir}/wine/sccbase.dll.so
%{_libdir}/wine/schannel.dll.so
%{_libdir}/wine/secur32.dll.so
@ -810,6 +923,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/updspapi.dll.so
%{_libdir}/wine/url.dll.so
%{_libdir}/wine/urlmon.dll.so
%{_libdir}/wine/usbd.sys.so
%{_libdir}/wine/user32.dll.so
%{_libdir}/wine/usp10.dll.so
%{_libdir}/wine/uxtheme.dll.so
@ -922,12 +1036,15 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/winsock.dll16.so
%{_libdir}/wine/wintab.dll16.so
%{_libdir}/wine/wow32.dll.so
#%{_libdir}/wine/wprocs.dll16.so
%endif
%files wow
%defattr(-,root,root,-)
%{_bindir}/wineserver
%{_libdir}/wine/wineboot.exe.so
%files common
%defattr(-,root,root,-)
%{_bindir}/wineprefixcreate
%{_bindir}/notepad
%{_bindir}/winedbg
%{_bindir}/winefile
@ -937,22 +1054,49 @@ update-desktop-database &>/dev/null || :
%{_bindir}/msiexec
%{_bindir}/regedit
%{_bindir}/regsvr32
%{_bindir}/wine
%{_bindir}/wineboot
%{_bindir}/wineconsole
%{_bindir}/winecfg
%dir %{_datadir}/wine
%{_mandir}/man1/wine.1.gz
%{_mandir}/man1/wineserver.1*
%{_mandir}/man1/wineprefixcreate.1*
%lang(fr) %{_mandir}/fr.UTF-8/man1/*
%lang(de) %{_mandir}/de.UTF-8/man1/*
%{_datadir}/wine/generic.ppd
%{_datadir}/wine/wine.inf
%{_datadir}/wine/l_intl.nls
%files fonts
%defattr(-,root,root,-)
%{_datadir}/wine/fonts
%files courier-fonts
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-courier-fonts
%files system-fonts
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-system-fonts
%files small-fonts
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-small-fonts
%files marlett-fonts
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-marlett-fonts
#%files ms-sans-serif-fonts
#%defattr(-,root,root,-)
#%{_datadir}/fonts/wine-ms-sans-serif-fonts
#%files tahoma-fonts
#%defattr(-,root,root,-)
#%{_datadir}/fonts/wine-tahoma-fonts
%files symbol-fonts
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-symbol-fonts
%files desktop
%defattr(-,root,root,-)
@ -1055,6 +1199,33 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/openal32.dll.so
%changelog
* Sun May 09 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.44-1
- version upgrade (#580024)
* Sun Apr 18 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.43-1
- version upgrade
* Sun Apr 11 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.42-1
- version upgrade
- rework for wow64
* Mon Mar 29 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.41-3
- add support for mingw32-wine-gecko
* Sun Mar 28 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.41-2
- convert to font package guidelines
- add libv4l-devel BR
* Sun Mar 28 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.41-1
- version upgrade (#577587, #576607)
- winepulse upgrade (0.36)
* Sat Mar 06 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.1.40-1
- version upgrade

@ -1,16 +1,14 @@
diff --git a/configure.ac b/configure.ac
index f823045..583f9c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
--- configure.ac.orig 2010-05-10 16:39:57.000000000 +0200
+++ configure.ac 2010-05-10 16:42:54.000000000 +0200
@@ -68,6 +68,7 @@
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
+AC_ARG_WITH(pulse, AC_HELP_STRING([--without-pulse],[do not use PulseAudio sound support]))
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
AC_ARG_WITH(v4l, AS_HELP_STRING([--without-v4l],[do not use v4l1 (v4l support)]))
AC_ARG_WITH(xcomposite,AS_HELP_STRING([--without-xcomposite],[do not use the Xcomposite extension]),
@@ -1308,6 +1309,30 @@ then
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
@@ -1361,6 +1362,31 @@
CFLAGS="$save_CFLAGS"
fi
@ -37,11 +35,12 @@ index f823045..583f9c1 100644
+fi
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
+
+
dnl **** Check for ALSA 1.x ****
AC_SUBST(ALSALIBS,"")
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
@@ -1460,7 +1485,7 @@ dnl **** Check for libodbc ****
@@ -1528,7 +1554,7 @@
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
dnl **** Check for any sound system ****
@ -50,7 +49,7 @@ index f823045..583f9c1 100644
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
"$ac_cv_header_soundcard_h" != "yes" -a \
@@ -2555,6 +2580,7 @@ WINE_CONFIG_DLL(winenas.drv)
@@ -2621,6 +2647,7 @@
WINE_CONFIG_DLL(wineoss.drv)
WINE_CONFIG_DLL(wineps.drv)
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)

@ -287,22 +287,22 @@ index 9f8a0a2..59837ef 100644
{IDS_DRIVER_OSS, "oss"},
{IDS_DRIVER_COREAUDIO, "coreaudio"},
diff --git a/programs/winecfg/libraries.c b/programs/winecfg/libraries.c
index 37cc12b..7c13fad 100644
index 19504d6..b5c84eb 100644
--- a/programs/winecfg/libraries.c
+++ b/programs/winecfg/libraries.c
@@ -81,6 +81,7 @@ static const char * const builtin_only[] =
"wineoss.drv",
@@ -73,6 +73,7 @@ static const char * const builtin_only[] =
"winedos",
"winemp3.acm",
"wineps",
"wineps.drv",
+ "winepulse.drv",
"winex11.drv",
"winmm",
"wintab32",
"wnaspi32",
diff --git a/programs/winecfg/resource.h b/programs/winecfg/resource.h
index f006861..57b2a15 100644
index 15c905b..67616fb 100644
--- a/programs/winecfg/resource.h
+++ b/programs/winecfg/resource.h
@@ -187,7 +187,7 @@
@@ -188,7 +188,7 @@
#define IDS_ACCEL_BASIC 8302
#define IDS_ACCEL_EMULATION 8303
#define IDS_DRIVER_ALSA 8304

@ -1,9 +1,9 @@
diff --git a/dlls/winepulse.drv/Makefile.in b/dlls/winepulse.drv/Makefile.in
new file mode 100644
index 0000000..80a751d
index 0000000..ed48381
--- /dev/null
+++ b/dlls/winepulse.drv/Makefile.in
@@ -0,0 +1,16 @@
@@ -0,0 +1,14 @@
+TOPSRCDIR = @top_srcdir@
+TOPOBJDIR = ../..
+SRCDIR = @srcdir@
@ -18,8 +18,6 @@ index 0000000..80a751d
+ pulse.c
+
+@MAKE_DLL_RULES@
+
+@DEPENDENCIES@ # everything below this line is overwritten by make depend
diff --git a/dlls/winepulse.drv/pulse.c b/dlls/winepulse.drv/pulse.c
new file mode 100644
index 0000000..9dd1f80
Loading…
Cancel
Save