- version upgrade

- fix init-script output (#252144)
- add lsb stuff (#247096)
f38
Andreas Bierfert 18 years ago
parent 4c30fec50e
commit c61ab5bde9

@ -1 +1 @@
wine-0.9.42-fe.tar.bz2 wine-0.9.43-fe.tar.bz2

@ -1 +1 @@
83b7a278e86d669a6a7ee551f2041b05 wine-0.9.42-fe.tar.bz2 9fe7207a88c20617c3b558e5e2bab109 wine-0.9.43-fe.tar.bz2

@ -1,6 +1,6 @@
--- configure.orig 2007-07-03 14:31:05.000000000 +0200 --- configure.orig 2007-08-18 09:42:40.000000000 +0200
+++ configure 2007-07-03 14:37:20.000000000 +0200 +++ configure 2007-08-18 09:44:10.000000000 +0200
@@ -13606,14 +13606,14 @@ @@ -8525,14 +8525,14 @@
fi fi
@ -19,44 +19,20 @@
cat >conftest.$ac_ext <<_ACEOF cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */ /* confdefs.h. */
_ACEOF _ACEOF
@@ -13663,17 +13663,17 @@ @@ -8582,8 +8582,8 @@
{ echo "$as_me:$LINENO: result: $ac_res" >&5 { echo "$as_me:$LINENO: result: $ac_res" >&5
echo "${ECHO_T}$ac_res" >&6; } echo "${ECHO_T}$ac_res" >&6; }
if test `eval echo '${'$as_ac_var'}'` = yes; then if test `eval echo '${'$as_ac_var'}'` = yes; then
- LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`" - LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
- LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine" - LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"
+ LDRPATH_INSTALL="" + LDRPATH_INSTALL=""
+ LDRPATH_LOCAL="" + LDRPATH_LOCAL=""
else else
- as_ac_var=`echo "ac_cv_cflags_-fPIC -Wl,-R,\$ORIGIN/../lib" | $as_tr_sh` as_ac_var=`echo "ac_cv_cflags_-fPIC -Wl,-R,\$ORIGIN/../lib" | $as_tr_sh`
-{ echo "$as_me:$LINENO: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5 { echo "$as_me:$LINENO: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5
-echo $ECHO_N "checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib... $ECHO_C" >&6; } --- configure.ac.orig 2007-08-18 09:44:15.000000000 +0200
+ as_ac_var=`echo "ac_cv_cflags_-fPIC" | $as_tr_sh` +++ configure.ac 2007-08-18 09:44:46.000000000 +0200
+{ echo "$as_me:$LINENO: checking whether the compiler supports -fPIC" >&5 @@ -439,13 +439,6 @@
+echo $ECHO_N "checking whether the compiler supports -fPIC $ECHO_C" >&6; }
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_wine_try_cflags_saved=$CFLAGS
-CFLAGS="$CFLAGS -fPIC -Wl,-R,\$ORIGIN/../lib"
+CFLAGS="$CFLAGS -fPIC"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -13723,8 +13723,8 @@
{ echo "$as_me:$LINENO: result: $ac_res" >&5
echo "${ECHO_T}$ac_res" >&6; }
if test `eval echo '${'$as_ac_var'}'` = yes; then
- LDRPATH_INSTALL="-Wl,-R,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
- LDRPATH_LOCAL="-Wl,-R,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"
+ LDRPATH_INSTALL=""
+ LDRPATH_LOCAL=""
fi
fi
--- configure.ac.orig 2007-07-03 14:37:34.000000000 +0200
+++ configure.ac 2007-07-03 14:37:59.000000000 +0200
@@ -1006,13 +1006,6 @@
WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic], WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
[AC_SUBST(LDEXECFLAGS,["-Wl,--export-dynamic"])]) [AC_SUBST(LDEXECFLAGS,["-Wl,--export-dynamic"])])
@ -67,6 +43,6 @@
- [LDRPATH_INSTALL="-Wl,-R,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`" - [LDRPATH_INSTALL="-Wl,-R,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
- LDRPATH_LOCAL="-Wl,-R,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"])]) - LDRPATH_LOCAL="-Wl,-R,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"])])
- -
case $host_cpu in WINE_TRY_CFLAGS([-Wl,--enable-new-dtags],
*i[[3456789]]86* | x86_64) [LDRPATH_INSTALL="$LDRPATH_INSTALL -Wl,--enable-new-dtags"])
WINE_TRY_CFLAGS([-Wl,--section-start,.interp=0x7bf00400],

@ -6,6 +6,14 @@
# chkconfig: 35 98 10 # chkconfig: 35 98 10
# description: Allow users to run Windows(tm) applications by just clicking \ # description: Allow users to run Windows(tm) applications by just clicking \
# on them (or typing ./file.exe) # on them (or typing ./file.exe)
### BEGIN INIT INFO
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: start and stop wine binary handler
# Description: Allow users to run Windows(tm) applications by just clicking
# on them (or typing ./file.exe)
### END INIT INFO
. /etc/rc.d/init.d/functions . /etc/rc.d/init.d/functions
RETVAL=0 RETVAL=0
@ -15,22 +23,23 @@ start() {
if [ -e /proc/sys/fs/binfmt_misc/windows ]; then if [ -e /proc/sys/fs/binfmt_misc/windows ]; then
echo -n $"Binary handler for Windows applications already registered" echo -n $"Binary handler for Windows applications already registered"
else else
echo -n $"Registering binary handler for Windows applications" echo -n $"Registering binary handler for Windows applications: "
/sbin/modprobe binfmt_misc &>/dev/null /sbin/modprobe binfmt_misc &>/dev/null
echo ':windows:M::MZ::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || : echo ':windows:M::MZ::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || :
echo ':windowsPE:M::PE::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || : echo ':windowsPE:M::PE::/usr/bin/wine:' >/proc/sys/fs/binfmt_misc/register || :
RETVAL=$?
[ $RETVAL -eq 0 ] && success || failure
fi fi
echo
} }
stop() { stop() {
echo -n $"Unregistering binary handler for Windows applications" echo -n $"Unregistering binary handler for Windows applications: "
echo "-1" >/proc/sys/fs/binfmt_misc/windows || : echo "-1" >/proc/sys/fs/binfmt_misc/windows || :
echo "-1" >/proc/sys/fs/binfmt_misc/windowsPE || : echo "-1" >/proc/sys/fs/binfmt_misc/windowsPE || :
} RETVAL=$?
[ $RETVAL -eq 0 ] && success || failure
reload() { echo
stop
start
} }
wine_status() { wine_status() {
@ -58,14 +67,15 @@ case "$1" in
stop stop
start start
;; ;;
condrestart) condrestart|try-restart)
if [ -e /proc/sys/fs/binfmt_misc/windows ]; then if [ -e /proc/sys/fs/binfmt_misc/windows ]; then
stop stop
start start
fi fi
;; ;;
*) *)
echo $"Usage: $prog {start|stop|status|restart|condrestart}" echo $"Usage: $prog {start|stop|status|restart|try-restart}"
exit 1 exit 1
esac esac
exit $RETVAL exit $RETVAL

@ -1,5 +1,5 @@
Name: wine Name: wine
Version: 0.9.42 Version: 0.9.43
Release: 1%{?dist} Release: 1%{?dist}
Summary: A Windows 16/32/64 bit emulator Summary: A Windows 16/32/64 bit emulator
@ -18,7 +18,7 @@ URL: http://www.winehq.org/
# Makefile.in:dlls/winemp3.acm/Makefile: dlls/winemp3.acm/Makefile.in dlls/Makedll.rules # Makefile.in:dlls/winemp3.acm/Makefile: dlls/winemp3.acm/Makefile.in dlls/Makedll.rules
# programs/winecfg/libraries.c: "winemp3.acm", # programs/winecfg/libraries.c: "winemp3.acm",
Source0: wine-0.9.42-fe.tar.bz2 Source0: wine-0.9.43-fe.tar.bz2
Source1: wine.init Source1: wine.init
Source3: wine-README-Fedora Source3: wine-README-Fedora
Source4: wine-32.conf Source4: wine-32.conf
@ -461,11 +461,13 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/dpnaddr.dll.so %{_libdir}/wine/dpnaddr.dll.so
%{_libdir}/wine/dpnet.dll.so %{_libdir}/wine/dpnet.dll.so
%{_libdir}/wine/dpnhpast.dll.so %{_libdir}/wine/dpnhpast.dll.so
%{_libdir}/wine/dpnlobby.dll.so
%{_libdir}/wine/dsound.dll.so %{_libdir}/wine/dsound.dll.so
%{_libdir}/wine/dswave.dll.so %{_libdir}/wine/dswave.dll.so
%{_libdir}/wine/dwmapi.dll.so %{_libdir}/wine/dwmapi.dll.so
%{_libdir}/wine/dxdiagn.dll.so %{_libdir}/wine/dxdiagn.dll.so
%{_libdir}/wine/eject.exe.so %{_libdir}/wine/eject.exe.so
%{_libdir}/wine/faultrep.dll.so
%{_libdir}/wine/gdi.exe16 %{_libdir}/wine/gdi.exe16
%{_libdir}/wine/gdi32.dll.so %{_libdir}/wine/gdi32.dll.so
%{_libdir}/wine/gdiplus.dll.so %{_libdir}/wine/gdiplus.dll.so
@ -485,6 +487,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/imm.dll16 %{_libdir}/wine/imm.dll16
%{_libdir}/wine/imm32.dll.so %{_libdir}/wine/imm32.dll.so
%{_libdir}/wine/infosoft.dll.so %{_libdir}/wine/infosoft.dll.so
%{_libdir}/wine/inkobj.dll.so
%{_libdir}/wine/inseng.dll.so %{_libdir}/wine/inseng.dll.so
%{_libdir}/wine/iphlpapi.dll.so %{_libdir}/wine/iphlpapi.dll.so
%{_libdir}/wine/itss.dll.so %{_libdir}/wine/itss.dll.so
@ -517,6 +520,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/msftedit.dll.so %{_libdir}/wine/msftedit.dll.so
%{_libdir}/wine/msg711.acm.so %{_libdir}/wine/msg711.acm.so
%{_libdir}/wine/mshtml.dll.so %{_libdir}/wine/mshtml.dll.so
%{_libdir}/wine/mshtml.tlb.so
%{_libdir}/wine/msi.dll.so %{_libdir}/wine/msi.dll.so
%{_libdir}/wine/msimg32.dll.so %{_libdir}/wine/msimg32.dll.so
%{_libdir}/wine/msisys.ocx.so %{_libdir}/wine/msisys.ocx.so
@ -629,6 +633,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/winex11.drv.so %{_libdir}/wine/winex11.drv.so
%{_libdir}/wine/wing.dll16 %{_libdir}/wine/wing.dll16
%{_libdir}/wine/wing32.dll.so %{_libdir}/wine/wing32.dll.so
%{_libdir}/wine/winhttp.dll.so
%{_libdir}/wine/wininet.dll.so %{_libdir}/wine/wininet.dll.so
%{_libdir}/wine/winmm.dll.so %{_libdir}/wine/winmm.dll.so
%{_libdir}/wine/winnls.dll16 %{_libdir}/wine/winnls.dll16
@ -687,6 +692,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/winhelp.exe.so %{_libdir}/wine/winhelp.exe.so
%{_libdir}/wine/winver.exe.so %{_libdir}/wine/winver.exe.so
%{_libdir}/wine/wordpad.exe.so %{_libdir}/wine/wordpad.exe.so
%{_libdir}/wine/write.exe.so
%{_datadir}/applications/fedora-wine-notepad.desktop %{_datadir}/applications/fedora-wine-notepad.desktop
%{_datadir}/applications/fedora-wine-winefile.desktop %{_datadir}/applications/fedora-wine-winefile.desktop
%{_datadir}/applications/fedora-wine-winemine.desktop %{_datadir}/applications/fedora-wine-winemine.desktop
@ -751,6 +757,12 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/*.def %{_libdir}/wine/*.def
%changelog %changelog
* Sat Aug 11 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 0.9.43-1
- version upgrade
- fix init-script output (#252144)
- add lsb stuff (#247096)
* Sat Jul 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> * Sat Jul 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 0.9.42-1 - 0.9.42-1
- version upgrade - version upgrade

Loading…
Cancel
Save