- version upgrade - use changed libOSMesa check from gentoo (>f18 still fails see rhbz#849405)f38
parent
c0370bb7cc
commit
b99de91493
@ -1,2 +1,2 @@
|
|||||||
65a98308d60f878462f4c404d2d013b2 wine-1.5.9.tar.bz2
|
930485c8df59edcf0a6e3fd87cca8b39 wine-1.5.11.tar.bz2
|
||||||
145243a4801c7ee6d3b631d71702995d wine-1.5.9.tar.bz2.sign
|
45750fa026fd05db8480cf243235c203 wine-1.5.11.tar.bz2.sign
|
||||||
|
@ -0,0 +1,33 @@
|
|||||||
|
From a233e35ca650db2758de0fd31450b8ce2d86d5e3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alexandre Rostovtsev <tetromino@gentoo.org>
|
||||||
|
Date: Tue, 7 Aug 2012 01:29:01 -0400
|
||||||
|
Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
|
||||||
|
|
||||||
|
If mesa had been built with shared glapi, glAccum is not available in
|
||||||
|
libOSMesa without explicitly linking to libGL. In addition, in
|
||||||
|
mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
|
||||||
|
libglapi if mesa was built with shared glapi, see
|
||||||
|
https://bugs.gentoo.org/show_bug.cgi?id=399813
|
||||||
|
---
|
||||||
|
configure.ac | 5 ++++-
|
||||||
|
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 4bd43d1..c7a718f 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1132,7 +1132,10 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
|
||||||
|
|
||||||
|
if test "$ac_cv_header_GL_osmesa_h" = "yes"
|
||||||
|
then
|
||||||
|
- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
||||||
|
+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$OPENGL_LIBS $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
||||||
|
+ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
|
||||||
|
+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi $OPENGL_LIBS $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
||||||
|
+ fi
|
||||||
|
fi
|
||||||
|
WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
|
||||||
|
[libOSMesa ${notice_platform}development files not found (or too old), OpenGL rendering in bitmaps won't be supported.])
|
||||||
|
--
|
||||||
|
1.7.8.6
|
||||||
|
|
Loading…
Reference in new issue