parent
4787aa7f07
commit
abc8d376de
@ -1,4 +1,4 @@
|
|||||||
/wine-1.6.tar.bz2.sign
|
/wine-1.6.tar.bz2.sign
|
||||||
/wine-1.6.tar.bz2
|
/wine-1.6.tar.bz2
|
||||||
/wine-1.7.1.tar.bz2
|
/wine-1.7.2.tar.bz2
|
||||||
/wine-1.7.1.tar.bz2.sign
|
/wine-1.7.2.tar.bz2.sign
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
3a3fae3e541ccaf1b891d89b5594ecc5 wine-1.7.1.tar.bz2
|
17ece5f22c691bd6067c86f0dd68cfd7 wine-1.7.2.tar.bz2
|
||||||
6bc7fe035e8968b32fa2a805a1e6320e wine-1.7.1.tar.bz2.sign
|
f88fbe903d2e7356a44eeb89e70d41ba wine-1.7.2.tar.bz2.sign
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From 1ede664b18bd8a88359a3cebb291ad49833ee033 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexandre Rostovtsev <tetromino@gentoo.org>
|
|
||||||
Date: Tue, 7 Aug 2012 01:29:01 -0400
|
|
||||||
Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
|
|
||||||
|
|
||||||
If mesa had been built with shared glapi, glAccum is not available in
|
|
||||||
libOSMesa without explicitly linking to libGL. In addition, in
|
|
||||||
mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
|
|
||||||
libglapi if mesa was built with shared glapi, see
|
|
||||||
https://bugs.gentoo.org/show_bug.cgi?id=399813
|
|
||||||
And in mesa-8.1.x, libOSMesa in addition needs libdl, libpthread, and
|
|
||||||
libstdc++, see https://bugs.gentoo.org/show_bug.cgi?id=431832
|
|
||||||
---
|
|
||||||
configure.ac | 8 +++++++-
|
|
||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index cc32c24..275b792 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1128,7 +1128,13 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
|
|
||||||
|
|
||||||
if test "x$with_osmesa" != "xno"
|
|
||||||
then
|
|
||||||
- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
|
||||||
+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
|
||||||
+ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
|
|
||||||
+ osmesa_save_CC=$CC
|
|
||||||
+ CC=$CXX
|
|
||||||
+ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi -lpthread -ldl $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
|
|
||||||
+ CC=$osmesa_save_CC
|
|
||||||
+ fi
|
|
||||||
WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
|
|
||||||
[libOSMesa ${notice_platform}development files not found (or too old), OpenGL rendering in bitmaps won't be supported.])
|
|
||||||
fi
|
|
||||||
--
|
|
||||||
1.8.0
|
|
||||||
|
|
File diff suppressed because it is too large
Load Diff
@ -1,29 +0,0 @@
|
|||||||
From 8f39a12639ee1d39c8caaf5f2ab72540d281814e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
|
||||||
Date: Sat, 29 Dec 2012 01:02:30 +0100
|
|
||||||
Subject: [PATCH] winmm: Load winealsa if winepulse is found
|
|
||||||
|
|
||||||
Fixes midi on winepulse
|
|
||||||
---
|
|
||||||
dlls/winmm/lolvldrv.c | 5 ++++-
|
|
||||||
1 files changed, 4 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/dlls/winmm/lolvldrv.c b/dlls/winmm/lolvldrv.c
|
|
||||||
index f387323..3b1be27 100644
|
|
||||||
--- a/dlls/winmm/lolvldrv.c
|
|
||||||
+++ b/dlls/winmm/lolvldrv.c
|
|
||||||
@@ -543,7 +543,10 @@ static void MMDRV_Init(void)
|
|
||||||
drvA = HeapAlloc(GetProcessHeap(), 0, size);
|
|
||||||
WideCharToMultiByte(CP_ACP, 0, pv.u.pwszVal, -1, drvA, size, NULL, NULL);
|
|
||||||
|
|
||||||
- MMDRV_Install(drvA, drvA, FALSE);
|
|
||||||
+ if (!strcasecmp(drvA, "winepulse.drv"))
|
|
||||||
+ MMDRV_Install("winealsa.drv", "winealsa.drv", 0);
|
|
||||||
+ else
|
|
||||||
+ MMDRV_Install(drvA, drvA, FALSE);
|
|
||||||
|
|
||||||
HeapFree(GetProcessHeap(), 0, drvA);
|
|
||||||
PropVariantClear(&pv);
|
|
||||||
--
|
|
||||||
1.6.5.GIT
|
|
||||||
|
|
Loading…
Reference in new issue