Update to 1.9.13

f38
Michael Cronenworth 9 years ago
parent 83d1daa2b8
commit aa3e243d34

6
.gitignore vendored

@ -1,3 +1,3 @@
/wine-1.9.12.tar.bz2 /wine-1.9.13.tar.bz2
/wine-1.9.12.tar.bz2.sign /wine-1.9.13.tar.bz2.sign
/wine-staging-1.9.12.tar.gz /wine-staging-1.9.13.tar.gz

@ -1,3 +1,3 @@
1043247aac3945ae9c3711a0daa84c87 wine-1.9.12.tar.bz2 0ef601ed1eb8e9b800eb0ee334d7ad6a wine-1.9.13.tar.bz2
1a2dc149ae76e542bb3b352c3633e50b wine-1.9.12.tar.bz2.sign 21e95ddaa66e8e7c8d650246d749e675 wine-1.9.13.tar.bz2.sign
ea3badb73deb93dfeee24f944070f8d1 wine-staging-1.9.12.tar.gz 234c7f88068dc25bd67ab67efda9c319 wine-staging-1.9.13.tar.gz

@ -0,0 +1,27 @@
From 8570aa372d00aa6410605b97a78614c61d74c4b3 Mon Sep 17 00:00:00 2001
From: Michael Cronenworth <mike@cchtml.com>
Date: Fri, 1 Jul 2016 16:31:11 -0500
Subject: [PATCH] winspool.drv: Support cups 2.2 header update
Signed-off-by: Michael Cronenworth <mike@cchtml.com>
---
dlls/winspool.drv/info.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/dlls/winspool.drv/info.c b/dlls/winspool.drv/info.c
index 3ba94cd..5468066 100644
--- a/dlls/winspool.drv/info.c
+++ b/dlls/winspool.drv/info.c
@@ -43,6 +43,9 @@
#include <signal.h>
#ifdef HAVE_CUPS_CUPS_H
# include <cups/cups.h>
+# if CUPS_VERSION_MAJOR > 2 || (CUPS_VERSION_MAJOR == 2 && CUPS_VERSION_MINOR > 1)
+# include <cups/ppd.h>
+# endif
#endif
#ifdef HAVE_APPLICATIONSERVICES_APPLICATIONSERVICES_H
--
2.5.5

@ -1,94 +0,0 @@
From 3e08f247b8bf105f1548648b93fad4a672ac7d7b Mon Sep 17 00:00:00 2001
From: Michael Cronenworth <mike@cchtml.com>
Date: Wed, 15 Jun 2016 19:03:22 -0500
Subject: [PATCH] configure: Check for GnuTLS block size function
Instead of providing an extern, perform a configure check. The
function return type changed from signed to unsigned in GnuTLS 3.5.
Signed-off-by: Michael Cronenworth <mike@cchtml.com>
---
configure | 37 +++++++++++++++++++++++++++++++++++++
configure.ac | 3 +++
dlls/secur32/schannel_gnutls.c | 3 ---
3 files changed, 40 insertions(+), 3 deletions(-)
diff --git a/configure b/configure
index d1a6a68..1c39a6c 100755
--- a/configure
+++ b/configure
@@ -11655,6 +11655,43 @@ CPPFLAGS=$ac_save_CPPFLAGS
test -z "$GNUTLS_CFLAGS" || GNUTLS_CFLAGS=`echo " $GNUTLS_CFLAGS" | sed 's/ -I\([^/]\)/ -I\$(top_builddir)\/\1/g'`
test -z "$GNUTLS_LIBS" || GNUTLS_LIBS=`echo " $GNUTLS_LIBS" | sed 's/ -L\([^/]\)/ -L\$(top_builddir)\/\1/g'`
+ if ${GNUTLS_CFLAGS:+false} :; then :
+ if ${PKG_CONFIG+:} false; then :
+ GNUTLS_CFLAGS=`$PKG_CONFIG --cflags gnutls 2>/dev/null`
+fi
+fi
+
+if ${GNUTLS_LIBS:+false} :; then :
+ if ${PKG_CONFIG+:} false; then :
+ GNUTLS_LIBS=`$PKG_CONFIG --libs gnutls 2>/dev/null`
+fi
+fi
+
+
+$as_echo "$as_me:${as_lineno-$LINENO}: gnutls cflags: $GNUTLS_CFLAGS" >&5
+$as_echo "$as_me:${as_lineno-$LINENO}: gnutls libs: $GNUTLS_LIBS" >&5
+ac_save_CPPFLAGS=$CPPFLAGS
+CPPFLAGS="$CPPFLAGS $GNUTLS_CFLAGS"
+ac_wine_check_funcs_save_LIBS="$LIBS"
+LIBS="$LIBS $GNUTLS_LIBS"
+for ac_func in gnutls_cipher_get_block_size
+do :
+ ac_fn_c_check_func "$LINENO" "gnutls_cipher_get_block_size" "ac_cv_func_gnutls_cipher_get_block_size"
+if test "x$ac_cv_func_gnutls_cipher_get_block_size" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_GNUTLS_CIPHER_GET_BLOCK_SIZE 1
+_ACEOF
+
+else
+ as_fn_append wine_notices "|libgnutls ${notice_platform}development files too old, no block size support."
+fi
+done
+
+LIBS="$ac_wine_check_funcs_save_LIBS"
+CPPFLAGS=$ac_save_CPPFLAGS
+test -z "$GNUTLS_CFLAGS" || GNUTLS_CFLAGS=`echo " $GNUTLS_CFLAGS" | sed 's/ -I\([^/]\)/ -I\$(top_builddir)\/\1/g'`
+test -z "$GNUTLS_LIBS" || GNUTLS_LIBS=`echo " $GNUTLS_LIBS" | sed 's/ -L\([^/]\)/ -L\$(top_builddir)\/\1/g'`
+
fi
if test "x$ac_cv_lib_soname_gnutls" = "x"; then :
case "x$with_gnutls" in
diff --git a/configure.ac b/configure.ac
index 7f234b2..6ae8dde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1268,6 +1268,9 @@ then
WINE_CHECK_LIB_FUNCS(gnutls_hash,[$GNUTLS_LIBS],,
[WINE_NOTICE([libgnutls ${notice_platform}development files too old, no bcrypt hash support.])])])],
[GNUTLS_CFLAGS=""])])
+ WINE_PACKAGE_FLAGS(GNUTLS,[gnutls],,,,
+ [WINE_CHECK_LIB_FUNCS(gnutls_cipher_get_block_size,[$GNUTLS_LIBS],,
+ [WINE_NOTICE([libgnutls ${notice_platform}development files too old, no block size support.])])])
fi
WINE_WARNING_WITH(gnutls,[test "x$ac_cv_lib_soname_gnutls" = "x"],
[libgnutls ${notice_platform}development files not found, no schannel support.])
diff --git a/dlls/secur32/schannel_gnutls.c b/dlls/secur32/schannel_gnutls.c
index b10b629..2388c55 100644
--- a/dlls/secur32/schannel_gnutls.c
+++ b/dlls/secur32/schannel_gnutls.c
@@ -41,9 +41,6 @@
WINE_DEFAULT_DEBUG_CHANNEL(secur32);
WINE_DECLARE_DEBUG_CHANNEL(winediag);
-/* Not present in gnutls version < 2.9.10. */
-extern int gnutls_cipher_get_block_size(gnutls_cipher_algorithm_t algorithm);
-
static void *libgnutls_handle;
#define MAKE_FUNCPTR(f) static typeof(f) * p##f
MAKE_FUNCPTR(gnutls_alert_get);
--
2.5.5

@ -25,7 +25,7 @@
%endif %endif
Name: wine Name: wine
Version: 1.9.12 Version: 1.9.13
Release: 1%{?dist} Release: 1%{?dist}
Summary: A compatibility layer for windows applications Summary: A compatibility layer for windows applications
@ -72,8 +72,7 @@ Source501: wine-tahoma.conf
Source502: wine-README-tahoma Source502: wine-README-tahoma
Patch511: wine-cjk.patch Patch511: wine-cjk.patch
# GnuTLS 3.5 fix Patch512: wine-cups-2.2.patch
Patch512: wine-gnutls-3.5.patch
# wine compholio patches for wine-staging # wine compholio patches for wine-staging
# pulseaudio-patch is covered by that patch-set, too. # pulseaudio-patch is covered by that patch-set, too.
@ -663,7 +662,7 @@ This package adds the opencl driver for wine.
%prep %prep
%setup -q -n wine-%{version} %setup -q -n wine-%{version}
%patch511 -p1 -b.cjk %patch511 -p1 -b.cjk
%patch512 -p1 -b.gnutls %patch512 -p1 -b.cups
# setup and apply wine-staging patches # setup and apply wine-staging patches
gzip -dc %{SOURCE900} | tar -xf - --strip-components=1 gzip -dc %{SOURCE900} | tar -xf - --strip-components=1
@ -2039,6 +2038,9 @@ fi
%endif %endif
%changelog %changelog
* Fri Jul 01 2016 Michael Cronenworth <mike@cchtml.com> 1.9.13-1
- version update
* Wed Jun 15 2016 Michael Cronenworth <mike@cchtml.com> 1.9.12-1 * Wed Jun 15 2016 Michael Cronenworth <mike@cchtml.com> 1.9.12-1
- version update - version update

Loading…
Cancel
Save