- winepulse .38
- new wine icon
f38
Andreas Bierfert 15 years ago
parent cf3e33e09f
commit 7538be339c

@ -1 +1 @@
wine-1.2-rc5.tar.bz2 wine-1.2-rc6.tar.bz2

@ -1 +1 @@
7a7911aec84ca059e623978db17fba19 wine-1.2-rc5.tar.bz2 689c6ae6baaa33ca6532af2cec05d26b wine-1.2-rc6.tar.bz2

@ -1,13 +1,13 @@
%define no64bit 0 %define no64bit 0
Name: wine Name: wine
Version: 1.2.0 Version: 1.2.0
Release: 0.5.rc5%{?dist} Release: 0.6.rc6%{?dist}
Summary: A Windows 16/32/64 bit emulator Summary: A Windows 16/32/64 bit emulator
Group: Applications/Emulators Group: Applications/Emulators
License: LGPLv2+ License: LGPLv2+
URL: http://www.winehq.org/ URL: http://www.winehq.org/
Source0: http://ibiblio.org/pub/linux/system/emulators/wine/wine-1.2-rc5.tar.bz2 Source0: http://ibiblio.org/pub/linux/system/emulators/wine/wine-1.2-rc6.tar.bz2
Source1: wine.init Source1: wine.init
Source3: wine-README-Fedora Source3: wine-README-Fedora
Source4: wine-32.conf Source4: wine-32.conf
@ -46,7 +46,7 @@ Patch200: wine-imagemagick-6.5.patch
# and http://art.ified.ca/?page_id=40 # and http://art.ified.ca/?page_id=40
# rebased for .42 see #580073 # rebased for .42 see #580073
Patch400: winepulse-0.35-configure.ac.patch Patch400: winepulse-0.35-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.36.patch Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.38.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.38-winecfg.patch Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.38-winecfg.patch
Source402: README-FEDORA-PULSEAUDIO Source402: README-FEDORA-PULSEAUDIO
@ -410,7 +410,7 @@ This package adds an openal driver for wine.
%prep %prep
%setup -q -n %{name}-1.2-rc5 %setup -q -n %{name}-1.2-rc6
%patch1 %patch1
%patch100 %patch100
@ -464,8 +464,10 @@ install -p -m 644 %{SOURCE201} \
# install desktop files # install desktop files
mkdir -p %{buildroot}%{_datadir}/pixmaps mkdir -p %{buildroot}%{_datadir}/pixmaps
install -p -m 644 programs/winemenubuilder/wine.xpm \ icotool -x --width=32 --height=32 --bit-depth=32 -o dlls/user32/resources/ \
%{buildroot}%{_datadir}/pixmaps/wine.xpm dlls/user32/resources/oic_winlogo.ico
install -p -m 644 dlls/user32/resources/*png \
%{buildroot}%{_datadir}/pixmaps/wine.png
icotool -x --width=32 --height=32 --bit-depth=32 -o programs/notepad/ \ icotool -x --width=32 --height=32 --bit-depth=32 -o programs/notepad/ \
programs/notepad/notepad.ico programs/notepad/notepad.ico
@ -1116,7 +1118,7 @@ update-desktop-database &>/dev/null || :
%{_datadir}/wine/generic.ppd %{_datadir}/wine/generic.ppd
%{_datadir}/wine/wine.inf %{_datadir}/wine/wine.inf
%{_datadir}/wine/l_intl.nls %{_datadir}/wine/l_intl.nls
%{_datadir}/pixmaps/*xpm %{_datadir}/pixmaps/*png
%files fonts %files fonts
%defattr(-,root,root,-) %defattr(-,root,root,-)
@ -1253,6 +1255,12 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/openal32.dll.so %{_libdir}/wine/openal32.dll.so
%changelog %changelog
* Sun Jul 04 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.6.rc6
- version upgrade
- use new winelogo from user32
- winepulse upgrade
* Sun Jun 27 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> * Sun Jun 27 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.5.rc5 - 1.2-0.5.rc5
- version upgrade - version upgrade

@ -831,10 +831,10 @@ index 0000000..9dd1f80
+} +}
diff --git a/dlls/winepulse.drv/wavein.c b/dlls/winepulse.drv/wavein.c diff --git a/dlls/winepulse.drv/wavein.c b/dlls/winepulse.drv/wavein.c
new file mode 100644 new file mode 100644
index 0000000..8aea538 index 0000000..af721b9
--- /dev/null --- /dev/null
+++ b/dlls/winepulse.drv/wavein.c +++ b/dlls/winepulse.drv/wavein.c
@@ -0,0 +1,588 @@ @@ -0,0 +1,589 @@
+/* +/*
+ * Wine Driver for PulseAudio - WaveIn Functionality + * Wine Driver for PulseAudio - WaveIn Functionality
+ * http://pulseaudio.org/ + * http://pulseaudio.org/
@ -1157,7 +1157,8 @@ index 0000000..8aea538
+ TRACE("Asking to open %s for recording.\n", wdi->device_name); + TRACE("Asking to open %s for recording.\n", wdi->device_name);
+ pa_stream_connect_record(wwi->stream, wdi->device_name, &wwi->buffer_attr, + pa_stream_connect_record(wwi->stream, wdi->device_name, &wwi->buffer_attr,
+ PA_STREAM_START_CORKED | + PA_STREAM_START_CORKED |
+ PA_STREAM_AUTO_TIMING_UPDATE); + PA_STREAM_AUTO_TIMING_UPDATE |
+ PA_STREAM_ADJUST_LATENCY);
+ +
+ for (;;) { + for (;;) {
+ pa_context_state_t cstate = pa_context_get_state(PULSE_context); + pa_context_state_t cstate = pa_context_get_state(PULSE_context);
@ -1425,10 +1426,10 @@ index 0000000..8aea538
+#endif /* HAVE_PULSEAUDIO */ +#endif /* HAVE_PULSEAUDIO */
diff --git a/dlls/winepulse.drv/waveout.c b/dlls/winepulse.drv/waveout.c diff --git a/dlls/winepulse.drv/waveout.c b/dlls/winepulse.drv/waveout.c
new file mode 100644 new file mode 100644
index 0000000..989dff5 index 0000000..99b7c18
--- /dev/null --- /dev/null
+++ b/dlls/winepulse.drv/waveout.c +++ b/dlls/winepulse.drv/waveout.c
@@ -0,0 +1,1024 @@ @@ -0,0 +1,1029 @@
+/* +/*
+ * Wine Driver for PulseAudio - WaveOut Functionality + * Wine Driver for PulseAudio - WaveOut Functionality
+ * http://pulseaudio.org/ + * http://pulseaudio.org/
@ -1472,6 +1473,9 @@ index 0000000..989dff5
+ +
+#if HAVE_PULSEAUDIO +#if HAVE_PULSEAUDIO
+ +
+/* Use this to make the infinite wait not so infinite */
+#define PULSE_INFINITE 10000
+
+/* state diagram for waveOut writing: +/* state diagram for waveOut writing:
+ * + *
+ * +---------+-------------+---------------+---------------------------------+ + * +---------+-------------+---------------+---------------------------------+
@ -1628,6 +1632,8 @@ index 0000000..989dff5
+ * Because of bugs pa_stream_set_buffer_attr() does not work on started + * Because of bugs pa_stream_set_buffer_attr() does not work on started
+ * streams for server version 0.9.11 to 0.9.14 */ + * streams for server version 0.9.11 to 0.9.14 */
+ PULSE_WaitForOperation(pa_stream_set_buffer_attr(wwo->stream, &wwo->buffer_attr, PULSE_StreamSuccessCallback, wwo)); + PULSE_WaitForOperation(pa_stream_set_buffer_attr(wwo->stream, &wwo->buffer_attr, PULSE_StreamSuccessCallback, wwo));
+ TRACE("Triggering stream and hoping for the best\n");
+ PULSE_WaitForOperation(pa_stream_trigger(wwo->stream, PULSE_StreamSuccessCallback, wwo));
+ } + }
+ pa_threaded_mainloop_unlock(PULSE_ml); + pa_threaded_mainloop_unlock(PULSE_ml);
+ } + }
@ -1651,8 +1657,8 @@ index 0000000..989dff5
+ * - we hit the beginning of a running loop + * - we hit the beginning of a running loop
+ * - we hit a wavehdr which hasn't finished playing + * - we hit a wavehdr which hasn't finished playing
+ */ + */
+ if (lpWaveHdr == wwo->lpLoopPtr) { TRACE("loop %p\n", lpWaveHdr); return INFINITE; } + if (lpWaveHdr == wwo->lpLoopPtr) { TRACE("loop %p\n", lpWaveHdr); return PULSE_INFINITE; }
+ if (lpWaveHdr == wwo->lpPlayPtr) { TRACE("play %p\n", lpWaveHdr); return INFINITE; } + if (lpWaveHdr == wwo->lpPlayPtr) { TRACE("play %p\n", lpWaveHdr); return PULSE_INFINITE; }
+ +
+ /* See if this data has been played, and if not, return when it will have been */ + /* See if this data has been played, and if not, return when it will have been */
+ wait = pa_bytes_to_usec(lpWaveHdr->reserved + lpWaveHdr->dwBufferLength, &wwo->sample_spec); + wait = pa_bytes_to_usec(lpWaveHdr->reserved + lpWaveHdr->dwBufferLength, &wwo->sample_spec);
@ -1673,7 +1679,7 @@ index 0000000..989dff5
+ } + }
+ /* No more wavehdrs */ + /* No more wavehdrs */
+ TRACE("Empty queue\n"); + TRACE("Empty queue\n");
+ return INFINITE; + return PULSE_INFINITE;
+} +}
+ +
+/************************************************************************** +/**************************************************************************
@ -2041,7 +2047,7 @@ index 0000000..989dff5
+ /* Try and connect */ + /* Try and connect */
+ TRACE("Connecting stream for playback on %s.\n", wdo->device_name); + TRACE("Connecting stream for playback on %s.\n", wdo->device_name);
+ pa_threaded_mainloop_lock(PULSE_ml); + pa_threaded_mainloop_lock(PULSE_ml);
+ pa_stream_connect_playback(wwo->stream, wdo->device_name, NULL, PA_STREAM_AUTO_TIMING_UPDATE | PA_STREAM_ADJUST_LATENCY, NULL, NULL); + pa_stream_connect_playback(wwo->stream, wdo->device_name, &wwo->buffer_attr, PA_STREAM_AUTO_TIMING_UPDATE | PA_STREAM_ADJUST_LATENCY, NULL, NULL);
+ +
+ /* Wait for connection */ + /* Wait for connection */
+ for (;;) { + for (;;) {
Loading…
Cancel
Save