- version upgrade

f38
Andreas Bierfert 15 years ago
parent d583f9ddaf
commit 493cffc050

@ -1 +1 @@
wine-1.2-rc6.tar.bz2
wine-1.2-rc7.tar.bz2

@ -1 +1 @@
689c6ae6baaa33ca6532af2cec05d26b wine-1.2-rc6.tar.bz2
05cc63418e603f3d689bcaa7c7768d01 wine-1.2-rc7.tar.bz2

@ -1,20 +0,0 @@
--- dlls/winhttp/net.c.old 2010-04-04 18:11:01.266148279 +0300
+++ dlls/winhttp/net.c 2010-04-04 18:12:52.235163141 +0300
@@ -91,7 +91,7 @@
static void *libssl_handle;
static void *libcrypto_handle;
-static SSL_METHOD *method;
+static const SSL_METHOD *method;
static SSL_CTX *ctx;
static int hostname_idx;
static int error_idx;
@@ -113,7 +113,7 @@
static void *OpenSSL_ssl_handle;
static void *OpenSSL_crypto_handle;
-static SSL_METHOD *meth;
+const static SSL_METHOD *meth;
static SSL_CTX *ctx;
static int hostname_idx;
static int error_idx;

@ -1,13 +1,13 @@
%define no64bit 0
Name: wine
Version: 1.2.0
Release: 0.6.rc6%{?dist}
Release: 0.7.rc7%{?dist}
Summary: A Windows 16/32/64 bit emulator
Group: Applications/Emulators
License: LGPLv2+
URL: http://www.winehq.org/
Source0: http://ibiblio.org/pub/linux/system/emulators/wine/wine-1.2-rc6.tar.bz2
Source0: http://ibiblio.org/pub/linux/system/emulators/wine/wine-1.2-rc7.tar.bz2
Source1: wine.init
Source3: wine-README-Fedora
Source4: wine-32.conf
@ -44,8 +44,7 @@ Patch200: wine-imagemagick-6.5.patch
# explain how to use wine with pulseaudio
# see http://bugs.winehq.org/show_bug.cgi?id=10495
# and http://art.ified.ca/?page_id=40
# rebased for .42 see #580073
Patch400: winepulse-0.35-configure.ac.patch
Patch400: http://art.ified.ca/downloads/winepulse/winepulse-0.38-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.38.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.38-winecfg.patch
Source402: README-FEDORA-PULSEAUDIO
@ -223,7 +222,10 @@ Requires: wine-marlett-fonts = %{version}-%{release}
#Requires: wine-tahoma-fonts = %{version}-%{release}
Requires: wine-symbol-fonts = %{version}-%{release}
# intermediate fix for #593140
Requires: liberation-sans-fonts liberation-serif-fonts liberation-narrow-fonts
Requires: liberation-sans-fonts liberation-serif-fonts liberation-mono-fonts
%if 0%{?fedora} > 12 || 0%{?rhel} > 6
Requires: liberation-narrow-fonts
%endif
%description fonts
%{summary}
@ -410,12 +412,12 @@ This package adds an openal driver for wine.
%prep
%setup -q -n %{name}-1.2-rc6
%setup -q -n %{name}-1.2-rc7
%patch1
%patch100
%patch200
%patch400
%patch400 -p1
%patch401 -p1
%patch402 -p1
%patch1000
@ -1126,30 +1128,37 @@ update-desktop-database &>/dev/null || :
%files courier-fonts
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_datadir}/fonts/wine-courier-fonts
%files system-fonts
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_datadir}/fonts/wine-system-fonts
%files small-fonts
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_datadir}/fonts/wine-small-fonts
%files marlett-fonts
%doc COPYING.LIB
%defattr(-,root,root,-)
%{_datadir}/fonts/wine-marlett-fonts
#%files ms-sans-serif-fonts
#%defattr(-,root,root,-)
#%doc COPYING.LIB
#%{_datadir}/fonts/wine-ms-sans-serif-fonts
#%files tahoma-fonts
#%defattr(-,root,root,-)
#%doc COPYING.LIB
#%{_datadir}/fonts/wine-tahoma-fonts
%files symbol-fonts
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_datadir}/fonts/wine-symbol-fonts
%files desktop
@ -1255,6 +1264,12 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/openal32.dll.so
%changelog
* Sun Jul 11 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.7.rc7
- version upgrade
- make sure font packages include the license file in case they are installed
standalone
* Sun Jul 04 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.6.rc6
- version upgrade

@ -1,6 +1,8 @@
--- configure.ac.orig 2010-05-10 16:39:57.000000000 +0200
+++ configure.ac 2010-05-10 16:42:54.000000000 +0200
@@ -68,6 +68,7 @@
diff --git a/configure.ac b/configure.ac
index 61f376e..6fe1261 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
@ -8,7 +10,7 @@
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
@@ -1361,6 +1362,31 @@
@@ -1386,6 +1387,31 @@ then
CFLAGS="$save_CFLAGS"
fi
@ -40,7 +42,7 @@
dnl **** Check for ALSA 1.x ****
AC_SUBST(ALSALIBS,"")
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
@@ -1528,7 +1554,7 @@
@@ -1553,7 +1579,7 @@ dnl **** Check for libodbc ****
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
dnl **** Check for any sound system ****
@ -49,7 +51,7 @@
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
"$ac_cv_header_soundcard_h" != "yes" -a \
@@ -2621,6 +2647,7 @@
@@ -2648,6 +2674,7 @@ WINE_CONFIG_DLL(winenas.drv)
WINE_CONFIG_DLL(wineoss.drv)
WINE_CONFIG_DLL(wineps.drv)
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
Loading…
Cancel
Save