- version upgrade
f38
Andreas Bierfert 14 years ago
parent 5a4e788d01
commit 1a96be6a00

1
.gitignore vendored

@ -3,3 +3,4 @@
/wine-1.3.7.tar.bz2
/wine-1.3.8.tar.bz2
/wine-1.3.9.tar.bz2
/wine-1.3.10.tar.bz2

@ -1 +1 @@
708862552219e1c97585b291ea7277c2 wine-1.3.9.tar.bz2
a9f616cdcfb07a832c25623d3a971c3c wine-1.3.10.tar.bz2

@ -1,6 +1,6 @@
%define no64bit 0
Name: wine
Version: 1.3.9
Version: 1.3.10
Release: 1%{?dist}
Summary: A Windows 16/32/64 bit emulator
@ -43,7 +43,7 @@ Patch200: wine-imagemagick-6.5.patch
# explain how to use wine with pulseaudio
# see http://bugs.winehq.org/show_bug.cgi?id=10495
# and http://art.ified.ca/?page_id=40
Patch400: winepulse-0.39-configure.ac.patch
Patch400: http://art.ified.ca/downloads/winepulse/winepulse-configure.ac-1.3.10.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.39.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.38-winecfg.patch
Source402: README-FEDORA-PULSEAUDIO
@ -434,10 +434,10 @@ This package adds an openal driver for wine.
%prep
%setup -q
%patch1
%patch100
%patch200
%patch400 -b .winepulse
%patch1 -b .rpath
%patch100 -b .fedorafonts
%patch200 -b .imagemagick
%patch400 -p1 -b .winepulse
%patch401 -p1 -b .winepulse
%patch402 -p1 -b .winepulse
@ -747,6 +747,7 @@ update-desktop-database &>/dev/null || :
%ifarch x86_64
%{_bindir}/wine64
%{_bindir}/wine64-preloader
%{_sysconfdir}/ld.so.conf.d/wine-64.conf
%endif
@ -954,6 +955,8 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/msvfw32.dll.so
%{_libdir}/wine/msvidc32.dll.so
%{_libdir}/wine/mswsock.dll.so
%{_libdir}/wine/msxml.dll.so
%{_libdir}/wine/msxml2.dll.so
%{_libdir}/wine/msxml3.dll.so
%{_libdir}/wine/msxml4.dll.so
%{_libdir}/wine/msxml6.dll.so
@ -1045,7 +1048,6 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/wer.dll.so
%{_libdir}/wine/wiaservc.dll.so
%{_libdir}/wine/windowscodecs.dll.so
%{_libdir}/wine/wineaudioio.drv.so
%{_libdir}/wine/winecoreaudio.drv.so
%{_libdir}/wine/winegstreamer.dll.so
%{_libdir}/wine/winejoystick.drv.so
@ -1338,6 +1340,10 @@ update-desktop-database &>/dev/null || :
%endif
%changelog
* Tue Dec 28 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.10-1
- version upgrade
* Sat Dec 11 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.9-1
- version upgrade

@ -1,6 +1,8 @@
--- configure.ac.orig 2010-12-13 10:58:43.000000000 +0100
+++ configure.ac 2010-12-13 11:01:06.000000000 +0100
@@ -81,6 +81,7 @@
diff --git a/configure.ac b/configure.ac
index 5e1810f..c941f93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
@ -8,9 +10,9 @@
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
@@ -1464,6 +1465,30 @@
[gstreamer-0.10 ${notice_platform}development files not found, gstreamer support disabled])
test "x$ac_cv_lib_gstapp_0_10_gst_app_buffer_new" = xyes || enable_winegstreamer=${enable_winegstreamer:-no}
@@ -1434,6 +1435,30 @@ then
CFLAGS="$save_CFLAGS"
fi
+dnl **** Check for PulseAudio ****
+AC_SUBST(PULSELIBS,"")
@ -36,19 +38,19 @@
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
+
dnl **** Check for ALSA 1.x ****
AC_SUBST(ALSALIBS,"")
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
@@ -1642,7 +1667,7 @@
dnl **** Check for gstreamer ****
if test "x$with_gstreamer" != "xno"
then
@@ -1630,7 +1655,7 @@ dnl **** Check for libodbc ****
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
dnl **** Check for any sound system ****
-if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
+if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
-if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
+if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
"$ac_cv_header_soundcard_h" != "yes" -a \
@@ -2797,6 +2822,7 @@
@@ -2797,6 +2822,7 @@ WINE_CONFIG_DLL(winenas.drv)
WINE_CONFIG_DLL(wineoss.drv)
WINE_CONFIG_DLL(wineps.drv)
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
Loading…
Cancel
Save