|
|
|
@ -1,6 +1,8 @@
|
|
|
|
|
--- configure.ac.orig 2010-12-13 10:58:43.000000000 +0100
|
|
|
|
|
+++ configure.ac 2010-12-13 11:01:06.000000000 +0100
|
|
|
|
|
@@ -81,6 +81,7 @@
|
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
|
|
|
index 5e1810f..c941f93 100644
|
|
|
|
|
--- a/configure.ac
|
|
|
|
|
+++ b/configure.ac
|
|
|
|
|
@@ -79,6 +79,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
|
|
|
|
|
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
|
|
|
|
|
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
|
|
|
|
|
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
|
|
|
|
@ -8,9 +10,9 @@
|
|
|
|
|
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
|
|
|
|
|
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
|
|
|
|
|
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
|
|
|
|
|
@@ -1464,6 +1465,30 @@
|
|
|
|
|
[gstreamer-0.10 ${notice_platform}development files not found, gstreamer support disabled])
|
|
|
|
|
test "x$ac_cv_lib_gstapp_0_10_gst_app_buffer_new" = xyes || enable_winegstreamer=${enable_winegstreamer:-no}
|
|
|
|
|
@@ -1434,6 +1435,30 @@ then
|
|
|
|
|
CFLAGS="$save_CFLAGS"
|
|
|
|
|
fi
|
|
|
|
|
|
|
|
|
|
+dnl **** Check for PulseAudio ****
|
|
|
|
|
+AC_SUBST(PULSELIBS,"")
|
|
|
|
@ -36,19 +38,19 @@
|
|
|
|
|
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
|
|
|
|
|
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
|
|
|
|
|
+
|
|
|
|
|
dnl **** Check for ALSA 1.x ****
|
|
|
|
|
AC_SUBST(ALSALIBS,"")
|
|
|
|
|
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
|
|
|
|
|
@@ -1642,7 +1667,7 @@
|
|
|
|
|
dnl **** Check for gstreamer ****
|
|
|
|
|
if test "x$with_gstreamer" != "xno"
|
|
|
|
|
then
|
|
|
|
|
@@ -1630,7 +1655,7 @@ dnl **** Check for libodbc ****
|
|
|
|
|
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
|
|
|
|
|
|
|
|
|
|
dnl **** Check for any sound system ****
|
|
|
|
|
-if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
|
|
|
+if test "x$ALSALIBS$AUDIOIOLIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
|
|
|
-if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
|
|
|
+if test "x$ALSALIBS$COREAUDIO$NASLIBS$ESDLIBS$PULSELIBS$ac_cv_lib_soname_jack" = "x" -a \
|
|
|
|
|
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
|
|
|
|
|
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
|
|
|
|
|
"$ac_cv_header_soundcard_h" != "yes" -a \
|
|
|
|
|
@@ -2797,6 +2822,7 @@
|
|
|
|
|
@@ -2797,6 +2822,7 @@ WINE_CONFIG_DLL(winenas.drv)
|
|
|
|
|
WINE_CONFIG_DLL(wineoss.drv)
|
|
|
|
|
WINE_CONFIG_DLL(wineps.drv)
|
|
|
|
|
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)
|