winepulse upgrade to 0.39

f38
Andreas Bierfert 15 years ago
parent 0d86e12d49
commit 0691f0d97c

@ -1,8 +1,8 @@
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 61f376e..6fe1261 100644 index 341ba181..998e063 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -76,6 +76,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]), @@ -78,6 +78,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi]) [if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]), AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi]) [if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
@ -10,39 +10,38 @@ index 61f376e..6fe1261 100644
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)])) AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]), AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi]) [if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
@@ -1386,6 +1387,31 @@ then @@ -1402,6 +1403,30 @@ then
CFLAGS="$save_CFLAGS" CFLAGS="$save_CFLAGS"
fi fi
+dnl **** Check for PulseAudio **** +dnl **** Check for PulseAudio ****
+AC_SUBST(PULSELIBS,"") +AC_SUBST(PULSELIBS,"")
+AC_SUBST(PULSECFLAGS,"") +AC_SUBST(PULSEINCL,"")
+if test "x$with_pulse" != "xno"; +if test "x$with_pulse" != "xno";
+then +then
+ ac_save_CPPFLAGS="$CPPFLAGS" + ac_save_CPPFLAGS="$CPPFLAGS"
+ if test "$PKG_CONFIG" != "false"; + if test "$PKG_CONFIG" != "false";
+ then + then
+ ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`" + ac_pulse_libs="`$PKG_CONFIG --libs libpulse 2>/dev/null`"
+ ac_pulse_cflags="`$PKG_CONFIG --cflags libpulse 2>/dev/null`" + ac_pulse_cflags="`$PKG_CONFIG --cflags-only-I libpulse 2>/dev/null`"
+ +
+ CPPFLAGS="$CPPFLAGS $ac_pulse_cflags" + CPPFLAGS="$CPPFLAGS $ac_pulse_cflags"
+ AC_CHECK_HEADERS(pulse/pulseaudio.h, + AC_CHECK_HEADERS(pulse/pulseaudio.h,
+ [AC_CHECK_LIB(pulse, pa_stream_is_corked, + [AC_CHECK_LIB(pulse, pa_stream_is_corked,
+ [AC_DEFINE(HAVE_PULSEAUDIO, 1, [Define if you have pulseaudio]) + [AC_DEFINE(HAVE_PULSEAUDIO, 1, [Define if you have pulseaudio])
+ PULSELIBS="$ac_pulse_libs" + PULSELIBS="$ac_pulse_libs"
+ PULSECFLAGS="$ac_pulse_cflags"],,$ac_pulse_libs) + PULSEINCL="$ac_pulse_cflags"],,$ac_pulse_libs)
+ ]) + ])
+ fi + fi
+ CPPFLAGS="$ac_save_CPPFLAGS" + CPPFLAGS="$ac_save_CPPFLAGS"
+fi +fi
+WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"], +WINE_WARNING_WITH(pulse, [test "$ac_cv_lib_pulse_pa_stream_is_corked" != "yes"],
+ [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.]) + [libpulse ${notice_platform}development files not found or too old, Pulse won't be supported.])
+
+ +
dnl **** Check for ALSA 1.x **** dnl **** Check for ALSA 1.x ****
AC_SUBST(ALSALIBS,"") AC_SUBST(ALSALIBS,"")
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes" if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
@@ -1553,7 +1579,7 @@ dnl **** Check for libodbc **** @@ -1580,7 +1605,7 @@ dnl **** Check for libodbc ****
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])]) WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
dnl **** Check for any sound system **** dnl **** Check for any sound system ****
@ -51,7 +50,7 @@ index 61f376e..6fe1261 100644
"$ac_cv_header_sys_soundcard_h" != "yes" -a \ "$ac_cv_header_sys_soundcard_h" != "yes" -a \
"$ac_cv_header_machine_soundcard_h" != "yes" -a \ "$ac_cv_header_machine_soundcard_h" != "yes" -a \
"$ac_cv_header_soundcard_h" != "yes" -a \ "$ac_cv_header_soundcard_h" != "yes" -a \
@@ -2648,6 +2674,7 @@ WINE_CONFIG_DLL(winenas.drv) @@ -2724,6 +2749,7 @@ WINE_CONFIG_DLL(winenas.drv)
WINE_CONFIG_DLL(wineoss.drv) WINE_CONFIG_DLL(wineoss.drv)
WINE_CONFIG_DLL(wineps.drv) WINE_CONFIG_DLL(wineps.drv)
WINE_CONFIG_DLL(wineps16.drv16,enable_win16) WINE_CONFIG_DLL(wineps16.drv16,enable_win16)

@ -1,17 +1,13 @@
diff --git a/dlls/winepulse.drv/Makefile.in b/dlls/winepulse.drv/Makefile.in diff --git a/dlls/winepulse.drv/Makefile.in b/dlls/winepulse.drv/Makefile.in
new file mode 100644 new file mode 100644
index 0000000..ed48381 index 0000000..a6fdbf8
--- /dev/null --- /dev/null
+++ b/dlls/winepulse.drv/Makefile.in +++ b/dlls/winepulse.drv/Makefile.in
@@ -0,0 +1,14 @@ @@ -0,0 +1,10 @@
+TOPSRCDIR = @top_srcdir@
+TOPOBJDIR = ../..
+SRCDIR = @srcdir@
+VPATH = @srcdir@
+MODULE = winepulse.drv +MODULE = winepulse.drv
+IMPORTS = winmm user32 kernel32 +IMPORTS = winmm user32 kernel32
+EXTRALIBS = @PULSELIBS@ +EXTRALIBS = @PULSELIBS@
+EXTRACFLAGS = @PULSEINCL@ +EXTRAINCL = @PULSEINCL@
+ +
+C_SRCS = waveout.c \ +C_SRCS = waveout.c \
+ wavein.c \ + wavein.c \
Loading…
Cancel
Save