Apply patch to compile with static-libgcc (#1056436)

f38
Michael Cronenworth 11 years ago
parent 945f389565
commit e437dabfce

@ -0,0 +1,22 @@
--- wine-mono-4.5.2/mono/configure.in.orig 2014-06-24 21:12:59.841794023 -0500
+++ wine-mono-4.5.2/mono/configure.in 2014-06-24 23:26:13.675935649 -0500
@@ -117,6 +117,8 @@
AC_DEFINE(MINGW_CROSS_COMPILE,1,[Cross-compiling using MinGW])
fi
HOST_CC="gcc"
+ CC="$host-gcc -static-libgcc"
+ CXX="$host-g++ -static-libgcc"
# Windows 2000 is required that includes Internet Explorer 5.01
CPPFLAGS="$CPPFLAGS -DWINVER=0x0500 -D_WIN32_WINNT=0x0500 -D_WIN32_IE=0x0501 -D_UNICODE -DUNICODE -DWIN32_THREADS -DFD_SETSIZE=1024 -DGC_NOT_DLL"
LDFLAGS="$LDFLAGS -lmswsock -lws2_32 -lole32 -loleaut32 -lpsapi -lversion -ladvapi32 -lwinmm -lkernel32"
--- wine-mono-4.5.2/mono/eglib/configure.ac.orig 2014-06-24 21:55:52.707897667 -0500
+++ wine-mono-4.5.2/mono/eglib/configure.ac 2014-06-24 23:28:01.488241190 -0500
@@ -57,6 +57,8 @@
SEARCHSEP=';'
OS="WIN32"
PIDTYPE='void *'
+ CC="$host-gcc -static-libgcc"
+ CXX="$host-g++ -static-libgcc"
;;
*-*darwin*)
platform_darwin=yes

@ -2,7 +2,7 @@
Name: wine-mono Name: wine-mono
Version: 4.5.2 Version: 4.5.2
Release: 3%{?dist} Release: 4%{?dist}
Summary: Mono library required for Wine Summary: Mono library required for Wine
License: GPLv2 and LGPLv2 and MIT and BSD and MS-PL and MPLv1.1 License: GPLv2 and LGPLv2 and MIT and BSD and MS-PL and MPLv1.1
@ -10,6 +10,7 @@ Group: Development/Libraries
URL: http://wiki.winehq.org/Mono URL: http://wiki.winehq.org/Mono
Source0: http://sourceforge.net/projects/wine/files/Wine%20Mono/%{version}/%{name}-%{version}.tar.gz Source0: http://sourceforge.net/projects/wine/files/Wine%20Mono/%{version}/%{name}-%{version}.tar.gz
Patch0: wine-mono-build-msifilename.patch Patch0: wine-mono-build-msifilename.patch
Patch1: wine-mono-static-gcc.patch
# see git://github.com/madewokherd/wine-mono # see git://github.com/madewokherd/wine-mono
@ -18,7 +19,6 @@ ExcludeArch: armv7hl ppc s390x
# 64 # 64
BuildRequires: mingw64-filesystem >= 95 BuildRequires: mingw64-filesystem >= 95
BuildRequires: mingw64-binutils
BuildRequires: mingw64-headers BuildRequires: mingw64-headers
BuildRequires: mingw64-cpp BuildRequires: mingw64-cpp
BuildRequires: mingw64-gcc BuildRequires: mingw64-gcc
@ -26,7 +26,6 @@ BuildRequires: mingw64-gcc-c++
BuildRequires: mingw64-crt BuildRequires: mingw64-crt
# 32 # 32
BuildRequires: mingw32-filesystem >= 95 BuildRequires: mingw32-filesystem >= 95
BuildRequires: mingw32-binutils
BuildRequires: mingw32-headers BuildRequires: mingw32-headers
BuildRequires: mingw32-cpp BuildRequires: mingw32-cpp
BuildRequires: mingw32-gcc BuildRequires: mingw32-gcc
@ -51,6 +50,7 @@ Windows Mono library required for Wine.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b.msifilename %patch0 -p1 -b.msifilename
%patch1 -p1 -b.static-gcc
%build %build
# make sure this builds on x86-64 # make sure this builds on x86-64
@ -94,6 +94,9 @@ cp MonoGame/LICENSE.txt MonoGame-LICENSE.txt
%{_datadir}/wine/mono/wine-mono-%{version}.msi %{_datadir}/wine/mono/wine-mono-%{version}.msi
%changelog %changelog
* Tue Jun 24 2014 Michael Cronenworth <mike@cchtml.com> - 4.5.2-4
- Rebuilt to use static libgcc (#1056436)
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-3 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Loading…
Cancel
Save