parent
4a152898d5
commit
3dd1f4d15d
@ -1 +1 @@
|
|||||||
/wine-mono-4.8.3.tar.gz
|
/wine-mono-4.9.0.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
SHA512 (wine-mono-4.8.3.tar.gz) = 85d579a22308b6d47b597940b6af968f5c113008349f316068514a456a0761fd69cda72e76ed33835bf0d078e7f48df32af2c04cf2a5c519c7abbb4812ab8879
|
SHA512 (wine-mono-4.9.0.tar.gz) = eb8ed323365dba8ecebbc82ed5c0a98af2a403e736a221997d924d361f78bc696e955cb37cad207911f333c6fce42b8e9d6f95f401f62c0400561144d8bb2cb3
|
||||||
|
@ -1,26 +1,19 @@
|
|||||||
--- wine-mono-4.8.1/build-winemono.sh.orig 2015-04-20 10:34:32.150114394 -0500
|
--- wine-mono-4.9.0/Makefile.orig 2015-04-20 10:34:32.150114394 -0500
|
||||||
+++ wine-mono-4.8.1/build-winemono.sh 2015-04-20 10:33:13.699274928 -0500
|
+++ wine-mono-4.9.0/Makefile 2015-04-20 10:33:13.699274928 -0500
|
||||||
@@ -73,6 +73,7 @@
|
@@ -106,6 +106,7 @@
|
||||||
cd "$BUILDDIR/build-cross-$ARCH"
|
$$(BUILDDIR)/mono-$(1)/Makefile: $$(SRCDIR)/mono/configure $$(BUILDDIR)/.dir
|
||||||
if test 1 != $REBUILD || test ! -e Makefile; then
|
mkdir -p $$(@D)
|
||||||
CPPFLAGS="-gdwarf-2 -gstrict-dwarf" "$SRCDIR"/mono/configure --prefix="$BUILDDIR/build-cross-$ARCH-install" --build=$BUILD --target=$MINGW --host=$MINGW --with-tls=none --disable-mcs-build --enable-win32-dllmain=yes --with-libgc-threads=win32 PKG_CONFIG=false mono_cv_clang=no || exit 1
|
cd $$(BUILDDIR)/mono-$(1); CPPFLAGS="-gdwarf-2 -gstrict-dwarf" $$(SRCDIR_ABS)/mono/configure --prefix="$$(BUILDDIR_ABS)/build-cross-$(1)-install" --build=$$(shell $$(SRCDIR)/mono/config.guess) --target=$$(MINGW_$(1)) --host=$$(MINGW_$(1)) --with-tls=none --disable-mcs-build --enable-win32-dllmain=yes --with-libgc-threads=win32 PKG_CONFIG=false mono_cv_clang=no
|
||||||
+ sed -e 's+compiler_flags="-specs=/usr/lib/rpm/redhat/redhat-hardened-ld"+compiler_flags="-static"+' -i libtool
|
+ sed -e 's+compiler_flags="-specs=/usr/lib/rpm/redhat/redhat-hardened-ld"+compiler_flags="-static"+' -i $$(BUILDDIR)/mono-$(1)/libtool
|
||||||
sed -e 's/-lgcc_s//' -i libtool
|
sed -e 's/-lgcc_s//' -i $$(BUILDDIR)/mono-$(1)/libtool
|
||||||
fi
|
|
||||||
WINEPREFIX=/dev/null make $MAKEOPTS || exit 1
|
|
||||||
@@ -162,6 +163,7 @@
|
|
||||||
cd "$BUILDDIR/build-cross-cli"
|
|
||||||
if test 1 != $REBUILD || test ! -e Makefile; then
|
|
||||||
"$SRCDIR"/mono/configure --prefix="$BUILDDIR/build-cross-cli-install" --with-mcs-docs=no --disable-system-aot || exit 1
|
|
||||||
+ sed -e 's+compiler_flags="-specs=/usr/lib/rpm/redhat/redhat-hardened-ld"+compiler_flags="-static"+' -i libtool
|
|
||||||
fi
|
|
||||||
|
|
||||||
# put a System.Native library somewhere monolite can find it during the build
|
$$(BUILDDIR)/mono-$(1)/.built: $$(BUILDDIR)/mono-$(1)/Makefile $$(MONO_MONO_SRCS)
|
||||||
@@ -232,6 +234,7 @@
|
@@ -260,6 +261,7 @@
|
||||||
# build mono-basic
|
$(BUILDDIR)/mono-unix/Makefile: $(SRCDIR)/mono/configure $(BUILDDIR)/.dir
|
||||||
cd "$SRCDIR/mono-basic"
|
mkdir -p $(@D)
|
||||||
./configure --prefix="$BUILDDIR/build-cross-cli-win32-install" || exit 1
|
cd $(@D) && $(SRCDIR_ABS)/mono/configure --prefix="$(BUILDDIR_ABS)/mono-unix-install" --with-mcs-docs=no --disable-system-aot
|
||||||
+ sed -e 's+compiler_flags="-specs=/usr/lib/rpm/redhat/redhat-hardened-ld"+compiler_flags="-static"+' -i libtool
|
+ sed -e 's+compiler_flags="-specs=/usr/lib/rpm/redhat/redhat-hardened-ld"+compiler_flags="-static"+' -i $(@D)/libtool
|
||||||
make $MAKEOPTS || exit 1
|
|
||||||
make install || exit 1
|
|
||||||
|
|
||||||
|
$(BUILDDIR)/mono-unix/mono/lib/libSystem.Native.so: $(BUILDDIR)/mono-unix/Makefile $(MONO_LIBNATIVE_SRCS)
|
||||||
|
mkdir -p $(@D)
|
||||||
|
|
||||||
|
Loading…
Reference in new issue