Update weston and backport build fix

The build was failing due to the neatvnc version
in the Fedora repos being newer than the upper limit
listed in the weston build files.
Weston is not affected by the changes in neatvnc
so we can raise the upper version limit for neatvnc.

Backports https://gitlab.freedesktop.org/wayland/weston/-/merge_requests/1534.
epel10
Septatrix 8 months ago
parent 2030691985
commit 3c64870f27

1
.gitignore vendored

@ -59,3 +59,4 @@
/weston-12.0.1.tar.gz /weston-12.0.1.tar.gz
/weston-12.0.2.tar.gz /weston-12.0.2.tar.gz
/weston-13.0.0.tar.gz /weston-13.0.0.tar.gz
/weston-13.0.3.tar.gz

@ -0,0 +1,29 @@
From 05e5405651054c580b248c4ab2791ed8d66369e3 Mon Sep 17 00:00:00 2001
From: Lukasz Czechowski <lukasz.czechowski@thaumatec.com>
Date: Mon, 3 Jun 2024 13:39:27 +0200
Subject: [PATCH] vnc: Allow neatvnc in version 0.8.0
Neat VNC 0.8.0 does not introduce any changes that breaks API used
by VNC backend, so it is safe to extend compatibility.
Signed-off-by: Lukasz Czechowski <lukasz.czechowski@thaumatec.com>
---
libweston/backend-vnc/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libweston/backend-vnc/meson.build b/libweston/backend-vnc/meson.build
index b7b69165..39b15cf9 100644
--- a/libweston/backend-vnc/meson.build
+++ b/libweston/backend-vnc/meson.build
@@ -3,7 +3,7 @@ if not get_option('backend-vnc')
endif
config_h.set('BUILD_VNC_COMPOSITOR', '1')
-dep_neatvnc = dependency('neatvnc', version: ['>= 0.7.0', '< 0.8.0'], required: false, fallback: ['neatvnc', 'neatvnc_dep'])
+dep_neatvnc = dependency('neatvnc', version: ['>= 0.7.0', '< 0.9.0'], required: false, fallback: ['neatvnc', 'neatvnc_dep'])
if not dep_neatvnc.found()
error('VNC backend requires neatvnc which was not found. Or, you can use \'-Dbackend-vnc=false\'.')
endif
--
2.45.2

@ -1 +1 @@
SHA512 (weston-13.0.0.tar.gz) = f17ffdfaa4ca4106f87975c5183823bcf241a42cdd4245013cec993f6f50f62593ea552654ed2c470a999bf4e3a0cba354d03b654e15ba2d50676aaeb198fbdc SHA512 (weston-13.0.3.tar.gz) = 1af96ad032353d7ed51a6efaac49ea3b13511f8e36c8d70cb853286bf12d2bf18727aad590ef1e4d2b45da28d827812a1ec8b315cd73ad7d9266c4e587945f9e

@ -1,13 +1,14 @@
%global apiver 13 %global apiver 13
Name: weston Name: weston
Version: %{apiver}.0.0 Version: %{apiver}.0.3
Release: 5%{?dist} Release: 1%{?dist}
Summary: Reference compositor for Wayland Summary: Reference compositor for Wayland
License: BSD and CC-BY-SA License: BSD and CC-BY-SA
URL: http://wayland.freedesktop.org/ URL: http://wayland.freedesktop.org/
Source0: https://gitlab.freedesktop.org/wayland/%{name}/-/archive/%{version}/%{name}-%{version}.tar.gz Source0: https://gitlab.freedesktop.org/wayland/%{name}/-/archive/%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-vnc-Allow-neatvnc-in-version-0.8.0.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: gcc-c++ BuildRequires: gcc-c++
@ -209,6 +210,10 @@ Common headers for weston
%{_datadir}/libweston-%{apiver}/protocols/ %{_datadir}/libweston-%{apiver}/protocols/
%changelog %changelog
* Wed Jul 17 2024 Nils Kattenbeck <nilskemail+fedora@gmail.com> - 13.0.3-1
- Update to 13.0.3
- Fix build error caused by neatvnc version increase
* Tue Feb 20 2024 Neal Gompa <ngompa@fedoraproject.org> - 13.0.0-5 * Tue Feb 20 2024 Neal Gompa <ngompa@fedoraproject.org> - 13.0.0-5
- Split desktop session into its own subpackage - Split desktop session into its own subpackage

Loading…
Cancel
Save