parent
e78720d818
commit
fab4ac4b55
@ -1,35 +0,0 @@
|
|||||||
From 4adfd8064dbaad0e7d48e6668de322213ed621c8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Leigh Scott <leigh123linux@gmail.com>
|
|
||||||
Date: Wed, 4 Mar 2020 21:43:41 +0000
|
|
||||||
Subject: [PATCH 1/4] Use better FLAGS for ptools
|
|
||||||
|
|
||||||
---
|
|
||||||
libvmaf/src/third_party/ptools/Makefile.Linux | 5 +++--
|
|
||||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libvmaf/src/third_party/ptools/Makefile.Linux b/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
||||||
index 73d8241..99d4e83 100644
|
|
||||||
--- a/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
||||||
+++ b/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
||||||
@@ -10,7 +10,8 @@ CC = g++
|
|
||||||
OC = ./opencontainers_1_8_4
|
|
||||||
OCINC = $(OC)/include
|
|
||||||
|
|
||||||
-CFLAGS = -Wall -Wextra -fpic -O -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
|
|
||||||
+CFLAGS_COMMON = -Wall -Wextra -fpic -O
|
|
||||||
+CFLAGS = $(CFLAGS) -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
|
|
||||||
|
|
||||||
## How to build with OCString
|
|
||||||
##CFLAGS = -Wall -O4 -DLINUX_ -DOC_USE_OC_STRING -DOC_USE_OC_EXCEPTIONS -DOC_ONLY_NEEDED_STL -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC)
|
|
||||||
@@ -30,7 +31,7 @@ all: midasyeller_ex midastalker_ex midastalker_ex2 httpclient_ex midasserver_ex
|
|
||||||
$(CC) $(CFLAGS) -c $<
|
|
||||||
|
|
||||||
libptools.so : $(COM_OBJS)
|
|
||||||
- $(CC) $(CCFLAGS) $(COM_OBJS) -shared -o libptools.so
|
|
||||||
+ $(CC) $(CCFLAGS) $(COM_OBJS) $(LDFLAGS) -shared -Wl,-soname,libptools.so.0 -o libptools.so
|
|
||||||
|
|
||||||
midasserver_ex : $(COM_OBJS) midasserver_ex.o
|
|
||||||
$(CC) $(CCFLAGS) $(COM_OBJS) midasserver_ex.o -pthread -o midasserver_ex
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
@ -1,39 +0,0 @@
|
|||||||
--- a/libvmaf/src/meson.build
|
|
||||||
+++ b/libvmaf/src/meson.build
|
|
||||||
@@ -187,6 +187,7 @@ ptools_sources = [
|
|
||||||
]
|
|
||||||
|
|
||||||
thread_lib = dependency('threads')
|
|
||||||
+pugixml_lib = dependency('pugixml')
|
|
||||||
math_lib = cc.find_library('m', required : false)
|
|
||||||
|
|
||||||
libptools = shared_library(
|
|
||||||
@@ -241,7 +242,6 @@ libvmaf_feature_static_lib = static_libr
|
|
||||||
)
|
|
||||||
|
|
||||||
vmaf_sources = [
|
|
||||||
- third_party_dir + 'pugixml/pugixml.cpp',
|
|
||||||
src_dir + 'mem.c',
|
|
||||||
src_dir + 'combo.c',
|
|
||||||
src_dir + 'cpu_info.c',
|
|
||||||
@@ -257,7 +257,7 @@ libvmaf = both_libraries(
|
|
||||||
include_directories : vmaf_include,
|
|
||||||
c_args : vmaf_cflags_common,
|
|
||||||
cpp_args : vmaf_cflags_common,
|
|
||||||
- dependencies : [thread_lib, stdatomic_dependency],
|
|
||||||
+ dependencies : [thread_lib, pugixml_lib, stdatomic_dependency],
|
|
||||||
objects : [
|
|
||||||
platform_specific_cpu_objects,
|
|
||||||
libptools.extract_all_objects(),
|
|
||||||
--- a/libvmaf/src/vmaf.cpp
|
|
||||||
+++ b/libvmaf/src/vmaf.cpp
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
|
|
||||||
#include "vmaf.h"
|
|
||||||
#include "combo.h"
|
|
||||||
-#include "third_party/pugixml/pugixml.hpp"
|
|
||||||
+#include <pugixml.hpp>
|
|
||||||
#include "timer.h"
|
|
||||||
#include "jsonprint.h"
|
|
||||||
#include "debug.h"
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From 0e9e6df1542583a74a0d30b81b0872d95b11a6fc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Leigh Scott <leigh123linux@gmail.com>
|
|
||||||
Date: Wed, 4 Mar 2020 23:18:20 +0000
|
|
||||||
Subject: [PATCH 5/5] Use shared for vmafossexec
|
|
||||||
|
|
||||||
---
|
|
||||||
libvmaf/tools/meson.build | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/libvmaf/tools/meson.build b/libvmaf/tools/meson.build
|
|
||||||
index 2550f29..117bad0 100644
|
|
||||||
--- a/libvmaf/tools/meson.build
|
|
||||||
+++ b/libvmaf/tools/meson.build
|
|
||||||
@@ -8,7 +8,7 @@ vmafossexec = executable(
|
|
||||||
dependencies: [stdatomic_dependency],
|
|
||||||
c_args : vmaf_cflags_common,
|
|
||||||
cpp_args : vmaf_cflags_common,
|
|
||||||
- link_with : libvmaf.get_static_lib(),
|
|
||||||
+ link_with : libvmaf,
|
|
||||||
install : true,
|
|
||||||
)
|
|
||||||
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (vmaf-1.5.3.tar.gz) = 8d8420c72a6575669e88506e47a381c39b66b087b60aef359fb073cd2a54a8fdf48d2664e03e60612afc437b404bfab9d92b9f2441304a612e8d07a2d6947ba5
|
SHA512 (vmaf-2.1.1.tar.gz) = 82582b695ad5f0813a4e9080ac2195fcc6f4f8b29d68e5749b5a0585d5c02eaebcff7d7de47d4caf12bf658b236c13890aaca1e508383d96c6a2418909d91529
|
||||||
|
Loading…
Reference in new issue