Update to 2.1.1

epel9
Leigh Scott 4 years ago
parent e78720d818
commit fab4ac4b55

@ -1,35 +0,0 @@
From 4adfd8064dbaad0e7d48e6668de322213ed621c8 Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 21:43:41 +0000
Subject: [PATCH 1/4] Use better FLAGS for ptools
---
libvmaf/src/third_party/ptools/Makefile.Linux | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/libvmaf/src/third_party/ptools/Makefile.Linux b/libvmaf/src/third_party/ptools/Makefile.Linux
index 73d8241..99d4e83 100644
--- a/libvmaf/src/third_party/ptools/Makefile.Linux
+++ b/libvmaf/src/third_party/ptools/Makefile.Linux
@@ -10,7 +10,8 @@ CC = g++
OC = ./opencontainers_1_8_4
OCINC = $(OC)/include
-CFLAGS = -Wall -Wextra -fpic -O -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
+CFLAGS_COMMON = -Wall -Wextra -fpic -O
+CFLAGS = $(CFLAGS) -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
## How to build with OCString
##CFLAGS = -Wall -O4 -DLINUX_ -DOC_USE_OC_STRING -DOC_USE_OC_EXCEPTIONS -DOC_ONLY_NEEDED_STL -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC)
@@ -30,7 +31,7 @@ all: midasyeller_ex midastalker_ex midastalker_ex2 httpclient_ex midasserver_ex
$(CC) $(CFLAGS) -c $<
libptools.so : $(COM_OBJS)
- $(CC) $(CCFLAGS) $(COM_OBJS) -shared -o libptools.so
+ $(CC) $(CCFLAGS) $(COM_OBJS) $(LDFLAGS) -shared -Wl,-soname,libptools.so.0 -o libptools.so
midasserver_ex : $(COM_OBJS) midasserver_ex.o
$(CC) $(CCFLAGS) $(COM_OBJS) midasserver_ex.o -pthread -o midasserver_ex
--
2.24.1

@ -1,39 +0,0 @@
--- a/libvmaf/src/meson.build
+++ b/libvmaf/src/meson.build
@@ -187,6 +187,7 @@ ptools_sources = [
]
thread_lib = dependency('threads')
+pugixml_lib = dependency('pugixml')
math_lib = cc.find_library('m', required : false)
libptools = shared_library(
@@ -241,7 +242,6 @@ libvmaf_feature_static_lib = static_libr
)
vmaf_sources = [
- third_party_dir + 'pugixml/pugixml.cpp',
src_dir + 'mem.c',
src_dir + 'combo.c',
src_dir + 'cpu_info.c',
@@ -257,7 +257,7 @@ libvmaf = both_libraries(
include_directories : vmaf_include,
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
- dependencies : [thread_lib, stdatomic_dependency],
+ dependencies : [thread_lib, pugixml_lib, stdatomic_dependency],
objects : [
platform_specific_cpu_objects,
libptools.extract_all_objects(),
--- a/libvmaf/src/vmaf.cpp
+++ b/libvmaf/src/vmaf.cpp
@@ -28,7 +28,7 @@
#include "vmaf.h"
#include "combo.h"
-#include "third_party/pugixml/pugixml.hpp"
+#include <pugixml.hpp>
#include "timer.h"
#include "jsonprint.h"
#include "debug.h"

@ -1,25 +0,0 @@
From 0e9e6df1542583a74a0d30b81b0872d95b11a6fc Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 23:18:20 +0000
Subject: [PATCH 5/5] Use shared for vmafossexec
---
libvmaf/tools/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libvmaf/tools/meson.build b/libvmaf/tools/meson.build
index 2550f29..117bad0 100644
--- a/libvmaf/tools/meson.build
+++ b/libvmaf/tools/meson.build
@@ -8,7 +8,7 @@ vmafossexec = executable(
dependencies: [stdatomic_dependency],
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
- link_with : libvmaf.get_static_lib(),
+ link_with : libvmaf,
install : true,
)
--
2.24.1

@ -1 +1 @@
SHA512 (vmaf-1.5.3.tar.gz) = 8d8420c72a6575669e88506e47a381c39b66b087b60aef359fb073cd2a54a8fdf48d2664e03e60612afc437b404bfab9d92b9f2441304a612e8d07a2d6947ba5 SHA512 (vmaf-2.1.1.tar.gz) = 82582b695ad5f0813a4e9080ac2195fcc6f4f8b29d68e5749b5a0585d5c02eaebcff7d7de47d4caf12bf658b236c13890aaca1e508383d96c6a2418909d91529

@ -1,14 +1,11 @@
Name: vmaf Name: vmaf
Version: 1.5.3 Version: 2.1.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: Video Multi-Method Assessment Fusion Summary: Video Multi-Method Assessment Fusion
License: BSD-2-Clause-Patent License: BSD-2-Clause-Patent
URL: https://github.com/netflix/vmaf URL: https://github.com/netflix/vmaf
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: 0001-Use-better-FLAGS-for-ptools.patch
Patch1: 0002-Unbundle-pugixml.patch
Patch2: 0005-Use-shared-for-vmafossexec.patch
# This project relies on AVX # This project relies on AVX
ExclusiveArch: x86_64 ExclusiveArch: x86_64
@ -16,8 +13,8 @@ ExclusiveArch: x86_64
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: meson BuildRequires: meson
BuildRequires: nasm BuildRequires: nasm
BuildRequires: libsvm-devel BuildRequires: vim-common
BuildRequires: pugixml-devel
# Enforce our own build version for library # Enforce our own build version for library
Requires: libvmaf%{?_isa} = %{version}-%{release} Requires: libvmaf%{?_isa} = %{version}-%{release}
@ -38,6 +35,7 @@ https://github.com/Netflix/vmaf/blob/master/resource/doc/VMAF_ICIP17.pdf
%package -n libvmaf %package -n libvmaf
Summary: Library for %{name} Summary: Library for %{name}
Provides: bundled(libsvm) = 3.24
#Some repo provides it #Some repo provides it
Provides: %{name}-static = %{version}-%{release} Provides: %{name}-static = %{version}-%{release}
Obsoletes: %{name}-static < %{version}-%{release} Obsoletes: %{name}-static < %{version}-%{release}
@ -60,12 +58,12 @@ developing applications that use %{name}.
%prep %prep
%autosetup -p1 %autosetup -p1
# Unbundle # Unbundle
rm -rf libvmaf/src/third_party/pugixml rm -rf third_party/
rm -rf third_party/libsvm
%build %build
pushd libvmaf pushd libvmaf
%meson %meson \
-Ddefault_library=shared
%meson_build %meson_build
popd popd
@ -74,12 +72,6 @@ pushd libvmaf
%meson_install %meson_install
popd popd
#mv %{buildroot}%{_libdir}/libvmaf.so.0 \
# %{buildroot}%{_libdir}/libvmaf.so.0.0.0
#ln -s libvmaf.so.0.0.0 \
# %{buildroot}%{_libdir}/libvmaf.so.0
rm -f %{buildroot}%{_libdir}/libvmaf.a
#RPM Macros support #RPM Macros support
mkdir -p %{buildroot}%{rpmmacrodir} mkdir -p %{buildroot}%{rpmmacrodir}
cat > %{buildroot}%{rpmmacrodir}/macros.%{name} << EOF cat > %{buildroot}%{rpmmacrodir}/macros.%{name} << EOF
@ -88,19 +80,22 @@ cat > %{buildroot}%{rpmmacrodir}/macros.%{name} << EOF
EOF EOF
touch -r LICENSE %{buildroot}%{rpmmacrodir}/macros.%{name} touch -r LICENSE %{buildroot}%{rpmmacrodir}/macros.%{name}
%check
pushd libvmaf
ninja -vC %{_vpath_builddir} test
popd
%ldconfig_scriptlets -n libvmaf %ldconfig_scriptlets -n libvmaf
%files %files
%doc FAQ.md NOTICE.md README.md %doc FAQ.md README.md
%{_bindir}/vmafossexec %{_bindir}/vmaf
%{_datadir}/model/
%files -n libvmaf %files -n libvmaf
%doc CHANGELOG.md %doc CHANGELOG.md
%license LICENSE %license LICENSE
%{_libdir}/*.so.* %{_libdir}/*.so.1*
%files -n libvmaf-devel %files -n libvmaf-devel
%doc CONTRIBUTING.md %doc CONTRIBUTING.md
@ -111,6 +106,9 @@ touch -r LICENSE %{buildroot}%{rpmmacrodir}/macros.%{name}
%changelog %changelog
* Wed Mar 10 2021 Leigh Scott <leigh123linux@gmail.com> - 2.1.1-1
- Update to 2.1.1
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.3-2 * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

Loading…
Cancel
Save