Update to 1.3.14

epel8
Nicolas Chauvet 6 years ago
parent 7a3a7146ac
commit 5a040ff0a7

@ -1,15 +1,14 @@
From 14f859ed0ee63774c3aa86cb31ae0d2b8f4941fd Mon Sep 17 00:00:00 2001
From 870de42512805dcdd469ef0301476b3fc0e4bc95 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 12:32:54 +0200
Subject: [PATCH 01/11] Use PREFIX and LIBDIR build variable instead of custom
ones
Subject: [PATCH] Use PREFIX and LIBDIR build variable instead of custom ones
---
wrapper/Makefile | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)
diff --git a/wrapper/Makefile b/wrapper/Makefile
index 8658e83..6b02083 100644
index 9317515..868b13f 100644
--- a/wrapper/Makefile
+++ b/wrapper/Makefile
@@ -8,7 +8,8 @@ SRCDIR = $(TOP)/src
@ -19,10 +18,10 @@ index 8658e83..6b02083 100644
-INSTALL_PREFIX = /usr/local
+PREFIX ?= /usr/local
+LIBDIR ?= $(PREFIX)/lib
INCLUDES += -I$(TOP)/../feature/src
INCLUDES += -I$(TOP)/../feature/src/common
OBJS = \
$(OBJDIR)/alloc.o \
@@ -170,24 +171,24 @@ vmafossexec: $(OBJDIR)/main.o $(LIBVMAF)
@@ -168,24 +169,24 @@ vmafossexec: $(OBJDIR)/main.o $(LIBVMAF)
.PHONY: install
install:
@ -61,5 +60,5 @@ index 8658e83..6b02083 100644
.PHONY: clean
clean:
--
2.17.1
2.17.2

@ -1,17 +1,17 @@
From 524c2dea1569cef1aaeb26c2afd9a64e11c06254 Mon Sep 17 00:00:00 2001
From a6765396684ddd62fe660cb914e495e61a4dcab9 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 13:43:48 +0200
Subject: [PATCH 02/11] Unbundle pugixml
Subject: [PATCH] Unbundle pugixml
---
wrapper/Makefile | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/wrapper/Makefile b/wrapper/Makefile
index 6b02083..985a30f 100644
index 868b13f..4a891e1 100644
--- a/wrapper/Makefile
+++ b/wrapper/Makefile
@@ -42,9 +42,9 @@ OBJS = \
@@ -43,9 +43,9 @@ OBJS = \
$(OBJDIR)/vmaf.o \
$(OBJDIR)/darray.o \
$(OBJDIR)/libvmaf.o \
@ -23,7 +23,7 @@ index 6b02083..985a30f 100644
AVX_OBJS := \
$(OBJDIR)/convolution_avx.o \
@@ -160,9 +160,6 @@ $(OBJDIR)/vmaf.o: $(SRCDIR)/vmaf.cpp
@@ -158,9 +158,6 @@ $(OBJDIR)/vmaf.o: $(SRCDIR)/vmaf.cpp
$(OBJDIR)/%.o: $(SRCDIR)/%.c
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
@ -34,5 +34,5 @@ index 6b02083..985a30f 100644
ar rcs $@ $^
--
2.17.1
2.17.2

@ -1,26 +1,25 @@
From 6b8189523f590e0ec8bd67b15c58377d27fe63f7 Mon Sep 17 00:00:00 2001
From 80053ca29abc26ff6129ea5cb5c7e7545519b625 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 13:57:00 +0200
Subject: [PATCH 05/11] Switch pugixml include
Subject: [PATCH] Switch pugixml include
---
wrapper/src/vmaf.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
wrapper/src/vmaf.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/wrapper/src/vmaf.cpp b/wrapper/src/vmaf.cpp
index bed3502..a776931 100644
index fa1dce9..3e193bc 100644
--- a/wrapper/src/vmaf.cpp
+++ b/wrapper/src/vmaf.cpp
@@ -28,7 +28,8 @@
@@ -29,7 +29,7 @@
#include "vmaf.h"
#include "combo.h"
-#include "pugixml/pugixml.hpp"
+#include "svm.h"
+#include <pugixml.hpp>
#include "timer.h"
#include "jsonprint.h"
#include "debug.h"
--
2.17.1
2.17.2

@ -1,7 +1,7 @@
From 26c58a87b63742412f8845318dbd27585a734ed1 Mon Sep 17 00:00:00 2001
From f3b0da9d64e0ad5e668abc97137635f3c5da2d8f Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 14:33:30 +0200
Subject: [PATCH 06/11] Switch to shared library for libvmaf
Subject: [PATCH] Switch to shared library for libvmaf
---
feature/Makefile | 2 +-
@ -10,7 +10,7 @@ Subject: [PATCH 06/11] Switch to shared library for libvmaf
3 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/feature/Makefile b/feature/Makefile
index c786a27..127faed 100644
index 111d07c..86ced7d 100644
--- a/feature/Makefile
+++ b/feature/Makefile
@@ -5,7 +5,7 @@ TOP = $(shell pwd)
@ -35,7 +35,7 @@ index b721ec4..16e4e57 100644
.cproject
.project
diff --git a/wrapper/Makefile b/wrapper/Makefile
index 62bde27..8644c49 100644
index 4a891e1..2aeaf66 100644
--- a/wrapper/Makefile
+++ b/wrapper/Makefile
@@ -1,4 +1,4 @@
@ -44,7 +44,7 @@ index 62bde27..8644c49 100644
.PHONY: all
all: $(LIBVMAF) vmafossexec
@@ -172,7 +172,7 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.c
@@ -159,7 +159,7 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.c
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
$(LIBVMAF): $(OBJS) $(wildcard ../ptools/*.o)
@ -54,5 +54,5 @@ index 62bde27..8644c49 100644
vmafossexec: $(OBJDIR)/main.o $(LIBVMAF)
$(CXX) -s -o $@ $(LDFLAGS) $^ -pthread
--
2.17.1
2.17.2

@ -1,7 +1,7 @@
From ee9ed1dfd1a41a30bf9c6a5e11cf0ae4f70a37ed Mon Sep 17 00:00:00 2001
From 1b1b5db051e99bd7070fd996d46af4f88d030452 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 14:35:50 +0200
Subject: [PATCH 07/11] Unbundle libsvm
Subject: [PATCH] Unbundle libsvm
---
Makefile | 3 ---
@ -28,5 +28,5 @@ index 5a13baa..d2ba5cc 100644
-for dir in $(TARGETS); do \
cd $${dir}; $(MAKE) clean; cd ..; \
--
2.17.1
2.17.2

@ -1,17 +1,17 @@
From d3d9937d72928f8c98feb196caeccdde9bafa63e Mon Sep 17 00:00:00 2001
From b0fbd280173737102f1814e59452545c6d116cb1 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 14:43:21 +0200
Subject: [PATCH 08/11] Add pugixml LIBS
Subject: [PATCH] Add pugixml LIBS
---
wrapper/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/wrapper/Makefile b/wrapper/Makefile
index 8644c49..ceba5dc 100644
index 2aeaf66..ac6decc 100644
--- a/wrapper/Makefile
+++ b/wrapper/Makefile
@@ -172,7 +172,7 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.c
@@ -159,7 +159,7 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.c
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
$(LIBVMAF): $(OBJS) $(wildcard ../ptools/*.o)
@ -21,5 +21,5 @@ index 8644c49..ceba5dc 100644
vmafossexec: $(OBJDIR)/main.o $(LIBVMAF)
$(CXX) -s -o $@ $(LDFLAGS) $^ -pthread
--
2.17.1
2.17.2

@ -1,14 +1,14 @@
From 48f15b192920c283285276c01cf71331314d66a2 Mon Sep 17 00:00:00 2001
From 02e035cfe70c8c89e7b0f7ac8e9dd0548cfcab56 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 18:00:25 +0200
Subject: [PATCH 09/11] Avoid x86cpudetection code when not relevant
Subject: [PATCH] Avoid x86cpudetection code when not relevant
---
feature/src/common/cpu.c | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/feature/src/common/cpu.c b/feature/src/common/cpu.c
index 4befea2..165488a 100644
index 85156f8..3d48dcd 100644
--- a/feature/src/common/cpu.c
+++ b/feature/src/common/cpu.c
@@ -16,9 +16,10 @@
@ -35,5 +35,5 @@ index 4befea2..165488a 100644
+}
+#endif
--
2.17.1
2.17.2

@ -1,7 +1,7 @@
From 0a484f7a0af68364ce98d6b9a7f1389c08163a35 Mon Sep 17 00:00:00 2001
From 8b4d74a98a95aa12d58f9ebaded2c562b62111f7 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 19:16:00 +0200
Subject: [PATCH 10/11] Fix libvmaf.pc to use Libs.private for pthread m
Subject: [PATCH] Fix libvmaf.pc to use Libs.private for pthread m
This avoid to link to pthread and m when not needed
Also avoid to link to a specitic libstdc++
@ -13,7 +13,7 @@ Signed-off-by: Nicolas Chauvet <kwizart@gmail.com>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/wrapper/libvmaf.pc b/wrapper/libvmaf.pc
index 5d524f4..d025135 100644
index e48d5a8..416d327 100644
--- a/wrapper/libvmaf.pc
+++ b/wrapper/libvmaf.pc
@@ -10,6 +10,6 @@ URL: https://github.com/Netflix/vmaf
@ -26,5 +26,5 @@ index 5d524f4..d025135 100644
+Libs.private: -lpthread -lm
Cflags: -I${includedir}
--
2.17.1
2.17.2

@ -1 +1 @@
SHA512 (vmaf-a654f6f.tar.gz) = 37984568db2d86c996567f3d2b57bd93e5dfce1adf5233e2cf0c1f6a099e3b704c8b31ff20c8115f87d4d7d40bedaad198a033d3acd4b40b4710a9d7a64cd987
SHA512 (vmaf-8f41503.tar.gz) = 596b96d320a77da39b43b14c385866294ed3be09e3474f940f4bf768ad7e78478446ac42edd0547582839c914ddaf61b33cff493c4eae87b480bd1e0fa12ef7a

@ -1,10 +1,10 @@
%global commit0 a654f6f7f5998aedf2d6e2f6b3a9eece9753c3fb
%global commit0 8f41503605e6e55b34945e49cba864697e1ca683
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global commitdate0 20180914
%global commitdate0 20190403
Name: vmaf
Version: 1.3.9
Release: 2.%{commitdate0}git%{shortcommit0}%{?dist}
Version: 1.3.14
Release: 1.%{commitdate0}git%{shortcommit0}%{?dist}
Summary: Video Multi-Method Assessment Fusion
License: ASL 2.0
@ -12,7 +12,6 @@ URL: https://github.com/netflix/vmaf/
Source0: %{url}/archive/%{commit0}/%{name}-%{shortcommit0}.tar.gz
Patch0: 0001-Use-PREFIX-and-LIBDIR-build-variable-instead-of-cust.patch
Patch1: 0002-Unbundle-pugixml.patch
Patch2: 0003-Drop-AVX-when-not-relevant.patch
Patch3: 0004-Use-better-FLAGS-for-ptools.patch
Patch4: 0005-Switch-pugixml-include.patch
Patch5: 0006-Switch-to-shared-library-for-libvmaf.patch
@ -20,7 +19,6 @@ Patch6: 0007-Unbundle-libsvm.patch
Patch7: 0008-Add-pugixml-LIBS.patch
Patch8: 0009-Avoid-x86cpudetection-code-when-not-relevant.patch
Patch9: 0010-Fix-libvmaf.pc-to-use-Libs.private-for-pthread-m.patch
Patch10: 0011-Add-msse2-for-i686.patch
# This project relies on AVX
ExclusiveArch: x86_64
@ -131,6 +129,10 @@ touch -r LICENSE %{buildroot}%{rpmmacrodir}/macros.%{name}
%changelog
* Sat Apr 06 2019 Nicolas Chauvet <kwizart@gmail.com> - 1.3.14-1.20190403git8f415036
- Update to 1.13.4
- Rebase patches
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.9-2.20180914gita654f6f
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

Loading…
Cancel
Save