https://code.videolan.org/videolan/vlc/-/merge_requests/3843 https://bugzilla.redhat.com/show_bug.cgi?id=2215700epel10
parent
a726be4418
commit
9c51195472
@ -0,0 +1,48 @@
|
|||||||
|
Backport of https://code.videolan.org/videolan/vlc/-/merge_requests/3843
|
||||||
|
"Switch from deprecated MFX to VPL" for 3.0, as direct use of intel-mediasdk
|
||||||
|
is deprecated in favour of oneVPL.
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -2923,9 +2923,9 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
dnl
|
||||||
|
-dnl Intel QuickSync (aka MediaSDK) H264/H262 encoder
|
||||||
|
+dnl Intel oneAPI Video Processing Library
|
||||||
|
dnl
|
||||||
|
-PKG_ENABLE_MODULES_VLC([MFX], [qsv], [libmfx], [Intel QuickSync MPEG4-Part10/MPEG2 (aka H.264/H.262) encoder], [auto])
|
||||||
|
+PKG_ENABLE_MODULES_VLC([VPL], [qsv], [vpl], [Intel oneAPI Video Processing Library encoder], [auto])
|
||||||
|
|
||||||
|
dnl
|
||||||
|
dnl libfluidsynth (MIDI synthetizer) plugin
|
||||||
|
diff --git a/modules/codec/Makefile.am b/modules/codec/Makefile.am
|
||||||
|
--- a/modules/codec/Makefile.am
|
||||||
|
+++ b/modules/codec/Makefile.am
|
||||||
|
@@ -610,9 +610,9 @@ codec_LTLIBRARIES += $(LTLIBdav1d)
|
||||||
|
codec_LTLIBRARIES += $(LTLIBcrystalhd)
|
||||||
|
|
||||||
|
libqsv_plugin_la_SOURCES = codec/qsv.c
|
||||||
|
-libqsv_plugin_la_CFLAGS = $(AM_CFLAGS) $(MFX_CFLAGS)
|
||||||
|
+libqsv_plugin_la_CFLAGS = $(AM_CFLAGS) $(VPL_CFLAGS)
|
||||||
|
libqsv_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
|
||||||
|
-libqsv_plugin_la_LIBADD = $(MFX_LIBS)
|
||||||
|
+libqsv_plugin_la_LIBADD = $(VPL_LIBS)
|
||||||
|
EXTRA_LTLIBRARIES += libqsv_plugin.la
|
||||||
|
codec_LTLIBRARIES += $(LTLIBqsv)
|
||||||
|
|
||||||
|
diff --git a/modules/codec/qsv.c b/modules/codec/qsv.c
|
||||||
|
--- a/modules/codec/qsv.c
|
||||||
|
+++ b/modules/codec/qsv.c
|
||||||
|
@@ -33,7 +33,7 @@
|
||||||
|
#include <vlc_picture.h>
|
||||||
|
#include <vlc_codec.h>
|
||||||
|
|
||||||
|
-#include <mfx/mfxvideo.h>
|
||||||
|
+#include <vpl/mfxvideo.h>
|
||||||
|
|
||||||
|
#define SOUT_CFG_PREFIX "sout-qsv-"
|
||||||
|
|
||||||
|
--
|
||||||
|
GitLab
|
Loading…
Reference in new issue