Update to 1.1.8

el8
Nicolas Chauvet 14 years ago
parent f68128b59c
commit 3544f1dee3

@ -0,0 +1,12 @@
diff -up vlc-1.1.8/modules/video_filter/opencv_example.c.opencv22 vlc-1.1.8/modules/video_filter/opencv_example.c
--- vlc-1.1.8/modules/video_filter/opencv_example.c.opencv22 2010-04-13 02:22:27.000000000 +0200
+++ vlc-1.1.8/modules/video_filter/opencv_example.c 2011-03-23 10:47:05.053097995 +0100
@@ -191,7 +191,7 @@ static picture_t *Filter( filter_t *p_fi
CvSeq *faces = cvHaarDetectObjects( p_img[0], p_sys->p_cascade,
p_sys->p_storage, 1.15, 5,
CV_HAAR_DO_CANNY_PRUNING,
- cvSize(20, 20) );
+ cvSize(0, 0), cvSize(0, 0) );
//create the video_filter_region_info_t struct
if (faces && (faces->total > 0))
{

@ -21,7 +21,6 @@
%endif
%if 0%{?fedora} > 14
# Those need works in Rawhide
%global _without_opencv 1
%global _without_mozilla 1
%else
%global _with_gnomevfs 1
@ -30,7 +29,7 @@
Summary: The cross-platform open-source multimedia framework, player and server
Name: vlc
Version: 1.1.8
Release: 0%{?dist}
Release: 1%{?dist}
License: GPLv2+
Group: Applications/Multimedia
URL: http://www.videolan.org
@ -41,6 +40,7 @@ Source2: http://www.live555.com/liveMedia/public/live.%{live555_date}.tar.gz
Patch0: vlc-1.1.0-vlc-cache-gen_noerror.patch
Patch3: vlc-1.1.6-hardode_font_patch.patch
Patch4: vlc-1.1.4-tls_path.patch
Patch5: vlc-1.1.8-bugfix.opencv22.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: desktop-file-utils
@ -250,6 +250,9 @@ JACK audio plugin for the VLC media player.
%patch0 -p1 -b .noerror
%patch3 -p1 -b .hardode_path
%patch4 -p1 -b .tls_path
%if 0%{?fedora} >= 15
%patch5 -p1 -b .opencv22
%endif
sed -i.dmo_pic -e 's/fno-PIC/fPIC/' libs/loader/Makefile.in
rm modules/access/videodev2.h
@ -561,6 +564,9 @@ fi || :
%changelog
* Thu Mar 24 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.1.8-1
- Update to 1.1.8
* Fri Mar 11 2011 Nicolas Chauvet <kwizart@gmail.com> - 1.1.8-0.2.1
- Rebuilt for new x264/FFmpeg

Loading…
Cancel
Save