import vim-9.1.083-2.el10

cs10 imports/cs10/vim-9.1.083-2.el10
MSVSphere Packaging Team 4 months ago
commit 1c634b47be
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

5
.gitignore vendored

@ -0,0 +1,5 @@
SOURCES/gvim16.png
SOURCES/gvim32.png
SOURCES/gvim48.png
SOURCES/gvim64.png
SOURCES/vim-9.1-083.tar.bz2

@ -0,0 +1,5 @@
a7c81ffd40611b19c125c505699d8a6401f6e022 SOURCES/gvim16.png
2356345378a9f1ba3c9e9e6508b695611e8f2cfa SOURCES/gvim32.png
37ad682f67539da7f4d4b7316383115dfe43222d SOURCES/gvim48.png
c32bd520a1498b71ee9bbcddc7ad05df1565d085 SOURCES/gvim64.png
4e96020dcf38583ee23cd88eef077bc85ee2552d SOURCES/vim-9.1-083.tar.bz2

@ -0,0 +1 @@
%vimfiles_root %{_datadir}/vim/vimfiles

@ -0,0 +1,41 @@
# SPEC file overview:
# https://docs.fedoraproject.org/en-US/quick-docs/creating-rpm-packages/#con_rpm-spec-file-overview
# Fedora packaging guidelines:
# https://docs.fedoraproject.org/en-US/packaging-guidelines/
Name:
Version:
Release: 0%{?dist}
Summary:
License:
URL:
Source0:
BuildRequires:
Requires:
%description
%prep
%setup -q
%build
%configure
make %{?_smp_mflags}
%install
%make_install
%files
%doc
%license
%changelog

@ -0,0 +1,23 @@
#!/usr/bin/sh
# run vim if:
# - 'vi' command is used and 'vim' binary is available
# - 'vim' command is used
# NOTE: Set up a local alias if you want vim -> vi functionality. We will not
# do it globally, because it messes up with available startup options (see
# ':help starting', 'vi' is not capable of '-d'). The introducing an environment
# variable, which an user must set to get the feature, will do the same trick
# as setting an alias (needs user input, does not work with sudo), so it is left
# on user whether he decides to use an alias:
#
# alias vim=vi
#
# in bashrc file.
if test -f /usr/bin/vim
then
exec /usr/bin/vim "$@"
fi
# run vi otherwise
exec /usr/libexec/vi "$@"

@ -0,0 +1,10 @@
#!/usr/bin/sh
# run vim -R if available
if test -f /usr/bin/vim
then
exec /usr/bin/vim -R "$@"
fi
# run vi otherwise
exec /usr/libexec/vi -R "$@"

@ -0,0 +1,26 @@
diff -up vim90/src/term.c.fixkeys vim90/src/term.c
--- vim90/src/term.c.fixkeys 2022-10-20 14:45:53.896659582 +0200
+++ vim90/src/term.c 2022-10-20 14:48:28.958697659 +0200
@@ -851,14 +851,14 @@ static struct builtin_term builtin_termc
{K_XRIGHT, "\033[@;*C"}, // Esc [ C or Esc [ 1 ; C
{K_XLEFT, "\033[@;*D"}, // Esc [ D or Esc [ 1 ; D
// An extra set of function keys for vt100 mode
- {K_XF1, "\033O*P"},
- {K_XF2, "\033O*Q"},
- {K_XF3, "\033O*R"},
- {K_XF4, "\033O*S"},
- {K_F1, "\033[11;*~"},
- {K_F2, "\033[12;*~"},
- {K_F3, "\033[13;*~"},
- {K_F4, "\033[14;*~"},
+ {K_XF1, "\033[11~"},
+ {K_XF2, "\033[12~"},
+ {K_XF3, "\033[13~"},
+ {K_XF4, "\033[14~"},
+ {K_F1, "\033OP"},
+ {K_F2, "\033OQ"},
+ {K_F3, "\033OR"},
+ {K_F4, "\033OS"},
{K_F5, "\033[15;*~"},
{K_F6, "\033[17;*~"},
{K_F7, "\033[18;*~"},

@ -0,0 +1,12 @@
diff -up vim73/runtime/doc/vim.1.668894 vim73/runtime/doc/vim.1
--- vim73/runtime/doc/vim.1.668894 2010-05-15 13:04:00.000000000 +0200
+++ vim73/runtime/doc/vim.1 2012-08-28 12:41:36.000000000 +0200
@@ -73,7 +73,7 @@ To edit a file that starts with a dash,
.TP
\-
The file to edit is read from stdin. Commands are read from stderr, which
-should be a tty.
+should be a TTY.
.TP
\-t {tag}
The file to edit and the initial cursor position depends on a "tag", a sort

@ -0,0 +1,13 @@
diff --git a/runtime/syntax/spec.vim b/runtime/syntax/spec.vim
index 1a5a108..b709d20 100644
--- a/runtime/syntax/spec.vim
+++ b/runtime/syntax/spec.vim
@@ -111,7 +111,7 @@ syn region specDescriptionArea matchgroup=specSection start='^%description' end=
syn region specPackageArea matchgroup=specSection start='^%package' end='^%'me=e-1 contains=specPackageOpts,specPreAmble,specComment
"%% Scripts Section %%
-syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|clean\|check\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|patch\d*\|configure\|GNUconfigure\|setup\|autosetup\|autopatch\|find_lang\|make_build\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
+syn region specScriptArea matchgroup=specSection start='^%\(prep\|build\|install\|clean\|check\|pre\|postun\|preun\|post\|posttrans\)\>' skip='^%{\|^%\(define\|global\|patch\d*\|configure\|GNUconfigure\|setup\|autosetup\|autopatch\|find_lang\|make_build\|makeinstall\|make_install\)\>' end='^%'me=e-1 contains=specSpecialVariables,specVariables,@specCommands,specVariables,shDo,shFor,shCaseEsac,specNoNumberHilite,specCommandOpts,shComment,shIf,specSpecialChar,specMacroIdentifier,specSectionMacroArea,specSectionMacroBracketArea,shOperator,shQuote1,shQuote2
"%% Changelog Section %%
syn region specChangelogArea matchgroup=specSection start='^%changelog' end='^%'me=e-1 contains=specEmail,specURL,specWeekday,specMonth,specNumber,specComment,specLicense

@ -0,0 +1,33 @@
diff -up vim74/runtime/syntax/spec.vim.highlite vim74/runtime/syntax/spec.vim
--- vim74/runtime/syntax/spec.vim.highlite 2016-07-04 10:17:45.000000000 +0200
+++ vim74/runtime/syntax/spec.vim 2016-08-04 15:20:26.116049343 +0200
@@ -38,7 +38,7 @@ syn match specNoNumberHilite 'X11\|X11R6
syn match specManpageFile '[a-zA-Z]\.1'
"Day, Month and most used license acronyms
-syn keyword specLicense contained GPL LGPL BSD MIT GNU
+syn keyword specLicense contained GPL LGPL BSD MIT GNU distributable
syn keyword specWeekday contained Mon Tue Wed Thu Fri Sat Sun
syn keyword specMonth contained Jan Feb Mar Apr Jun Jul Aug Sep Oct Nov Dec
syn keyword specMonth contained January February March April May June July August September October November December
@@ -61,9 +61,9 @@ syn cluster specListedFiles contains=spe
"specCommands
syn match specConfigure contained '\./configure'
-syn match specTarCommand contained '\<tar\s\+[cxvpzIf]\{,5}\s*'
+syn match specTarCommand contained '\<tar\s\+[cxvpzIjf]\{,5}\s*'
syn keyword specCommandSpecial contained root
-syn keyword specCommand contained make xmkmf mkdir chmod ln find sed rm strip moc echo grep ls rm mv mkdir install cp pwd cat tail then else elif cd gzip rmdir ln eval export touch
+syn keyword specCommand contained make xmkmf mkdir chmod ln find sed rm strip moc echo grep ls rm mv mkdir install cp pwd cat tail then else elif cd gzip rmdir ln eval export touch bzip2 bunzip2 gunzip
syn cluster specCommands contains=specCommand,specTarCommand,specConfigure,specCommandSpecial
"frequently used rpm env vars
@@ -105,7 +105,7 @@ syn case ignore
"%% PreAmble Section %%
"Copyright and Serial were deprecated by License and Epoch
syn region specPreAmbleDeprecated oneline matchgroup=specError start='^\(Copyright\|Serial\)' end='$' contains=specEmail,specURL,specURLMacro,specLicense,specColon,specVariables,specSpecialChar,specMacroIdentifier
-syn region specPreAmble oneline matchgroup=specCommand start='^\(Prereq\|Summary\|Name\|Version\|Packager\|Requires\|Recommends\|Suggests\|Supplements\|Enhances\|Icon\|URL\|Source\d*\|Patch\d*\|Prefix\|Packager\|Group\|License\|Release\|BuildRoot\|Distribution\|Vendor\|Provides\|ExclusiveArch\|ExcludeArch\|ExclusiveOS\|Obsoletes\|BuildArch\|BuildArchitectures\|BuildRequires\|BuildConflicts\|BuildPreReq\|Conflicts\|AutoRequires\|AutoReq\|AutoReqProv\|AutoProv\|Epoch\)' end='$' contains=specEmail,specURL,specURLMacro,specLicense,specColon,specVariables,specSpecialChar,specMacroIdentifier
+syn region specPreAmble oneline matchgroup=specCommand start='^\(Prereq\|Summary\|Name\|Version\|Packager\|Requires\|Recommends\|Suggests\|Supplements\|Enhances\|Icon\|URL\|Source\d*\|Patch\d*\|Prefix\|Packager\|Group\|License\|Release\|BuildRoot\|Distribution\|Vendor\|Provides\|ExclusiveArch\|ExcludeArch\|ExcludeOS\|ExclusiveOS\|Obsoletes\|BuildArch\|BuildArchitectures\|BuildRequires\|BuildConflicts\|BuildPreReq\|Conflicts\|AutoRequires\|AutoReq\|AutoReqProv\|AutoProv\|Epoch\)' end='$' contains=specEmail,specURL,specURLMacro,specLicense,specColon,specVariables,specSpecialChar,specMacroIdentifier
"%% Description Section %%
syn region specDescriptionArea matchgroup=specSection start='^%description' end='^%'me=e-1 contains=specDescriptionOpts,specEmail,specURL,specNumber,specMacroIdentifier,specComment

@ -0,0 +1,87 @@
diff --git a/runtime/defaults.vim b/runtime/defaults.vim
index f1d5cd1..b08de8e 100644
--- a/runtime/defaults.vim
+++ b/runtime/defaults.vim
@@ -74,18 +74,6 @@ sunmap Q
" Revert with ":iunmap <C-U>".
inoremap <C-U> <C-G>u<C-U>
-" In many terminal emulators the mouse works just fine. By enabling it you
-" can position the cursor, Visually select and scroll with the mouse.
-" Only xterm can grab the mouse events when using the shift key, for other
-" terminals use ":", select text and press Esc.
-if has('mouse')
- if &term =~ 'xterm'
- set mouse=a
- else
- set mouse=nvi
- endif
-endif
-
" Only do this part when Vim was compiled with the +eval feature.
if 1
diff --git a/src/testdir/test_balloon.vim b/src/testdir/test_balloon.vim
index ed0c6c1..90c8c40 100644
--- a/src/testdir/test_balloon.vim
+++ b/src/testdir/test_balloon.vim
@@ -9,6 +9,7 @@ source screendump.vim
CheckScreendump
let s:common_script =<< trim [CODE]
+ set mouse=a
call setline(1, ["one one one", "two tXo two", "three three three"])
set balloonevalterm balloonexpr=MyBalloonExpr()..s:trailing balloondelay=100
let s:trailing = '<' " check that script context is set
diff --git a/src/testdir/test_popupwin.vim b/src/testdir/test_popupwin.vim
index b91689e..c6b70d1 100644
--- a/src/testdir/test_popupwin.vim
+++ b/src/testdir/test_popupwin.vim
@@ -553,6 +553,7 @@ func Test_popup_drag()
" create a popup that covers the command line
let lines =<< trim END
call setline(1, range(1, 20))
+ set mouse=a
split
vsplit
$wincmd w
@@ -621,6 +622,7 @@ func Test_popup_drag_minwidth()
" create a popup that does not fit
let lines =<< trim END
+ set mouse=a
call range(40)
\ ->map({_,i -> string(i)})
\ ->popup_create({
@@ -669,6 +671,7 @@ func Test_popup_drag_termwin()
let lines =<< trim END
set foldmethod=marker
call setline(1, range(100))
+ set mouse=a
for nr in range(7)
call setline(nr * 12 + 1, "fold {{{")
call setline(nr * 12 + 11, "end }}}")
@@ -722,6 +725,7 @@ func Test_popup_close_with_mouse()
let lines =<< trim END
call setline(1, range(1, 20))
+ set mouse=a
" With border, can click on X
let winid = popup_create('foobar', #{
\ close: 'button',
@@ -1557,6 +1561,7 @@ func Test_popup_beval()
let lines =<< trim END
call setline(1, range(1, 20))
call setline(5, 'here is some text to hover over')
+ set mouse=a
set balloonevalterm
set balloonexpr=BalloonExpr()
set balloondelay=100
@@ -2262,6 +2267,7 @@ func Test_popup_scrollbar()
let lines =<< trim END
call setline(1, range(1, 20))
+ set mouse=a
hi ScrollThumb ctermbg=blue
hi ScrollBar ctermbg=red
let winid = popup_create(['one', 'two', 'three', 'four', 'five',

@ -0,0 +1,85 @@
diff -up vim90/src/config.h.in.fips-warning vim90/src/config.h.in
--- vim90/src/config.h.in.fips-warning 2023-05-29 09:30:59.000000000 +0200
+++ vim90/src/config.h.in 2023-05-29 09:34:47.261645612 +0200
@@ -498,5 +498,14 @@
/* Define if _SC_SIGSTKSZ is available via sysconf() */
#undef HAVE_SYSCONF_SIGSTKSZ
+/* Do we need FIPS warning? */
+#undef HAVE_FIPS_WARNING
+
+/* Link to system-fips file */
+#undef SYSTEM_FIPS_FILE_LINK
+
+/* Link to fips_enabled file */
+#undef FIPS_ENABLED_FILE_LINK
+
/* Define if you want to load libgpm dynamically */
#undef DYNAMIC_GPM
diff -up vim90/src/configure.ac.fips-warning vim90/src/configure.ac
--- vim90/src/configure.ac.fips-warning 2023-05-29 09:34:47.257645645 +0200
+++ vim90/src/configure.ac 2023-05-29 09:34:47.262645604 +0200
@@ -589,6 +589,38 @@ else
AC_SUBST(XDIFF_OBJS_USED)
fi
+dnl Checking if we want FIPS warning
+
+AC_MSG_CHECKING(--enable-fips-warning)
+AC_ARG_ENABLE([fips-warning],
+ AS_HELP_STRING([--enable-fips-warning], [Enable FIPS warning]),
+ ,[enable_fips_warning="no"])
+
+if test "$enable_fips_warning" = "yes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_FIPS_WARNING])
+
+ dnl Setting path for system-fips file
+
+ AC_MSG_CHECKING(--with-system-fips-file argument)
+ AC_ARG_WITH([system-fips-file], [ --with-system-fips-file=PATH Link to system-fips file (default: /etc/system-fips)],
+ with_system_fips_file=$withval,
+ with_system_fips_file="/etc/system-fips")
+ AC_MSG_RESULT([$with_system_fips_file])
+ AC_DEFINE_UNQUOTED([SYSTEM_FIPS_FILE_LINK], ["$with_system_fips_file"])
+
+ dnl Setting link to fips_enabled file
+
+ AC_MSG_CHECKING(--with-fips-enabled-file argument)
+ AC_ARG_WITH([fips-enabled-file], [ --with-fips-enabled-file=PATH Link to fibs_enabled file (default: /proc/sys/crypto/fips_enabled)],
+ with_fips_enabled_file=$withval,
+ with_fips_enabled_file="/proc/sys/crypto/fips_enabled")
+ AC_MSG_RESULT([$with_fips_enabled_file])
+ AC_DEFINE_UNQUOTED([FIPS_ENABLED_FILE_LINK], ["$with_fips_enabled_file"])
+else
+ AC_MSG_RESULT(no)
+fi
+
dnl Check for Lua feature.
AC_MSG_CHECKING(--enable-luainterp argument)
AC_ARG_ENABLE(luainterp,
diff -up vim90/src/crypt.c.fips-warning vim90/src/crypt.c
--- vim90/src/crypt.c.fips-warning 2023-05-29 09:34:47.263645596 +0200
+++ vim90/src/crypt.c 2023-05-29 09:51:23.209779115 +0200
@@ -795,6 +795,21 @@ crypt_check_method(int method)
msg_scroll = TRUE;
msg(_("Warning: Using a weak encryption method; see :help 'cm'"));
}
+#ifdef HAVE_FIPS_WARNING
+ FILE *fips_enable_fd = fopen(FIPS_ENABLED_FILE_LINK, "r");
+ if (fips_enable_fd == NULL)
+ return;
+
+ int enabled = fgetc(fips_enable_fd);
+
+ if ( access(SYSTEM_FIPS_FILE_LINK, F_OK) != -1 && enabled == '1')
+ {
+ msg_scroll = TRUE;
+ msg(_("Warning: This cryptography is not FIPS 140-2 compliant."));
+ }
+
+ fclose(fips_enable_fd);
+#endif
}
/*

@ -0,0 +1,5 @@
# Ensure vim is set as EDITOR if it isn't already set
if ( ! ($?EDITOR) ) then
setenv EDITOR "/usr/bin/vim"
endif

@ -0,0 +1,8 @@
# Ensure vim is set as EDITOR if it isn't already set
# This is set as a universal variable so that any other definition
# by the user would win
# Cf. https://fishshell.com/docs/current/index.html#variables-scope
if ! set -q EDITOR;
set -x EDITOR /usr/bin/vim
end

@ -0,0 +1,5 @@
# Ensure vim is set as EDITOR if it isn't already set
if [ -z "$EDITOR" ]; then
export EDITOR="/usr/bin/vim"
fi

@ -0,0 +1,326 @@
diff -up vim73/runtime/doc/vim.man.rh1 vim73/runtime/doc/vim.man
--- vim73/runtime/doc/vim.man.rh1 2013-07-26 11:26:20.566576864 +0200
+++ vim73/runtime/doc/vim.man 2013-07-26 11:47:42.061351469 +0200
@@ -11,9 +11,9 @@ SYNOPSIS
vim [options] -t tag
vim [options] -q [errorfile]
- ex
+ ex gex
view
- gvim gview evim eview
+ gvim gview vimx evim eview
rvim rview rgvim rgview
DESCRIPTION
@@ -79,8 +79,13 @@ DESCRIPTION
the files. Can also be done with the "-R" argument.
gvim gview
- The GUI version. Starts a new window. Can also be done with
- the "-g" argument.
+ The GUI version. Starts a new window.
+
+ gex Starts a new gvim window in Ex mode. Can also be done with
+ the "-e" argument to gvim.
+
+ vimx Starts gvim in "Vi" mode similar to "vim", but with
+ additional features like xterm clipboard support.
evim eview
The GUI version in easy mode. Starts a new window. Can also
diff -urN vim73/runtime/doc/vim.1 vim73_new/runtime/doc/vim.1
--- vim73/runtime/doc/vim.1 2013-07-31 14:13:01.039765800 +0200
+++ vim73_new/runtime/doc/vim.1 2013-07-31 13:57:59.861912768 +0200
@@ -17,11 +17,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
@@ -114,7 +116,12 @@
gvim gview
The GUI version.
Starts a new window.
-Can also be done with the "\-g" argument.
+.TP
+gex
+Starts a new gvim window in Ex mode. Can also be done with the "-e" argument to gvim
+.TP
+vimx
+Starts gvim in "Vi" mode similar to "vim", but with additional features like xterm clipboard support
.TP
evim eview
The GUI version in easy mode.
@@ -458,6 +458,12 @@
\-\-remote\-wait\-silent
As \-\-remote\-wait, but without the warning when no server is found.
.TP
+\-\-remote\-tab[\-wait][\-silent]
+As \-\-remote but use tab page per file
+.TP
+\-\-role
+Set a unique role to identify the main window
+.TP
\-\-serverlist
List the names of all Vim servers that can be found.
.TP
diff -urN vim73/runtime/doc/vim-fr.1 vim73_new/runtime/doc/vim-fr.1
--- vim73/runtime/doc/vim-fr.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vim-fr.1 2013-07-31 13:59:10.587467916 +0200
@@ -24,11 +24,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim-fr.UTF-8.1 vim73_new/runtime/doc/vim-fr.UTF-8.1
--- vim73/runtime/doc/vim-fr.UTF-8.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vim-fr.UTF-8.1 2013-07-31 13:59:28.394852347 +0200
@@ -24,11 +24,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim-it.1 vim73_new/runtime/doc/vim-it.1
--- vim73/runtime/doc/vim-it.1 2010-07-27 22:22:52.000000000 +0200
+++ vim73_new/runtime/doc/vim-it.1 2013-07-31 13:59:43.474331077 +0200
@@ -17,11 +17,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim-it.UTF-8.1 vim73_new/runtime/doc/vim-it.UTF-8.1
--- vim73/runtime/doc/vim-it.UTF-8.1 2010-07-30 20:53:57.000000000 +0200
+++ vim73_new/runtime/doc/vim-it.UTF-8.1 2013-07-31 13:59:55.985898573 +0200
@@ -17,11 +17,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim.man vim73_new/runtime/doc/vim.man
--- vim73/runtime/doc/vim.man 2013-07-31 14:13:01.044765627 +0200
+++ vim73_new/runtime/doc/vim.man 2013-07-31 13:53:35.107064804 +0200
@@ -82,10 +82,10 @@
The GUI version. Starts a new window.
gex Starts a new gvim window in Ex mode. Can also be done with
- the "-e" argument to gvim.
+ the "-e" argument to gvim
vimx Starts gvim in "Vi" mode similar to "vim", but with
- additional features like xterm clipboard support.
+ additional features like xterm clipboard support
evim eview
The GUI version in easy mode. Starts a new window. Can also
diff -urN vim73/runtime/doc/vim-pl.1 vim73_new/runtime/doc/vim-pl.1
--- vim73/runtime/doc/vim-pl.1 2010-05-15 13:04:01.000000000 +0200
+++ vim73_new/runtime/doc/vim-pl.1 2013-07-31 14:00:21.282024131 +0200
@@ -17,11 +17,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim-pl.UTF-8.1 vim73_new/runtime/doc/vim-pl.UTF-8.1
--- vim73/runtime/doc/vim-pl.UTF-8.1 2010-05-15 13:37:38.000000000 +0200
+++ vim73_new/runtime/doc/vim-pl.UTF-8.1 2013-07-31 14:00:36.056513402 +0200
@@ -17,11 +17,13 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
.B evim
.B eview
.br
diff -urN vim73/runtime/doc/vim-ru.1 vim73_new/runtime/doc/vim-ru.1
--- vim73/runtime/doc/vim-ru.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vim-ru.1 2013-07-31 14:01:10.071337568 +0200
@@ -17,11 +17,15 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
+.B evim
+.B eview
.br
.B rvim
.B rview
diff -urN vim73/runtime/doc/vim-ru.UTF-8.1 vim73_new/runtime/doc/vim-ru.UTF-8.1
--- vim73/runtime/doc/vim-ru.UTF-8.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vim-ru.UTF-8.1 2013-07-31 14:01:34.494493301 +0200
@@ -17,11 +17,15 @@
.PP
.br
.B ex
+.B gex
.br
.B view
.br
.B gvim
.B gview
+.B vimx
+.B evim
+.B eview
.br
.B rvim
.B rview
diff -urN vim73/runtime/doc/vimtutor.1 vim73_new/runtime/doc/vimtutor.1
--- vim73/runtime/doc/vimtutor.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor.1 2013-07-31 14:10:10.093671964 +0200
@@ -4,6 +4,8 @@
.SH SYNOPSIS
.br
.B vimtutor [\-g] [language]
+.br
+.B gvimtutor
.SH DESCRIPTION
.B Vimtutor
starts the
diff -urN vim73/runtime/doc/vimtutor-it.1 vim73_new/runtime/doc/vimtutor-it.1
--- vim73/runtime/doc/vimtutor-it.1 2010-07-27 22:35:32.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-it.1 2013-07-31 14:10:33.564861055 +0200
@@ -4,6 +4,8 @@
.SH SINTASSI
.br
.B vimtutor [\-g] [lingua]
+.br
+.B gvimtutor
.SH DESCRIZIONE
.B Vimtutor
inizia il
diff -urN vim73/runtime/doc/vimtutor-it.UTF-8.1 vim73_new/runtime/doc/vimtutor-it.UTF-8.1
--- vim73/runtime/doc/vimtutor-it.UTF-8.1 2010-07-30 20:53:57.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-it.UTF-8.1 2013-07-31 14:10:40.483622016 +0200
@@ -4,6 +4,8 @@
.SH SINTASSI
.br
.B vimtutor [\-g] [lingua]
+.br
+.B gvimtutor
.SH DESCRIZIONE
.B Vimtutor
inizia il
diff -urN vim73/runtime/doc/vimtutor.man vim73_new/runtime/doc/vimtutor.man
--- vim73/runtime/doc/vimtutor.man 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor.man 2013-07-31 14:11:04.786782356 +0200
@@ -7,6 +7,7 @@
SYNOPSIS
vimtutor [-g] [language]
+ gvimtutor
DESCRIPTION
Vimtutor starts the Vim tutor. It copies the tutor file first, so that
diff -urN vim73/runtime/doc/vimtutor-pl.1 vim73_new/runtime/doc/vimtutor-pl.1
--- vim73/runtime/doc/vimtutor-pl.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-pl.1 2013-07-31 14:11:13.602477777 +0200
@@ -4,6 +4,8 @@
.SH SYNOPSIS
.br
.B vimtutor -g [j陑yk]
+.br
+.B gvimtutor
.SH OPIS
.B Vimtutor
uruchamia nauczyciela
diff -urN vim73/runtime/doc/vimtutor-pl.UTF-8.1 vim73_new/runtime/doc/vimtutor-pl.UTF-8.1
--- vim73/runtime/doc/vimtutor-pl.UTF-8.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-pl.UTF-8.1 2013-07-31 14:11:20.571237009 +0200
@@ -4,6 +4,8 @@
.SH SYNOPSIS
.br
.B vimtutor -g [j臋zyk]
+.br
+.B gvimtutor
.SH OPIS
.B Vimtutor
uruchamia nauczyciela
diff -urN vim73/runtime/doc/vimtutor-ru.1 vim73_new/runtime/doc/vimtutor-ru.1
--- vim73/runtime/doc/vimtutor-ru.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-ru.1 2013-07-31 14:11:35.673715221 +0200
@@ -4,6 +4,8 @@
.SH 腼磲钿钺<E992BF> 篝蝻脶
.br
.B vimtutor [掩偎]
+.br
+.B gvimtutor
.SH 镳轶犷殄
胂土文<E59C9F>
.B vimtutor
diff -urN vim73/runtime/doc/vimtutor-ru.UTF-8.1 vim73_new/runtime/doc/vimtutor-ru.UTF-8.1
--- vim73/runtime/doc/vimtutor-ru.UTF-8.1 2010-05-15 13:04:00.000000000 +0200
+++ vim73_new/runtime/doc/vimtutor-ru.UTF-8.1 2013-07-31 14:11:46.649335999 +0200
@@ -7,6 +7,8 @@
.SH 袨袩袠小袗袧袠袝
袣芯屑邪薪写邪
.B vimtutor
+.br
+.B gvimtutor
蟹邪锌褍褋泻邪械褌 褍褔械斜薪懈泻 锌芯
.B Vim.
袩褉懈 褝褌芯屑 褋薪邪褔邪谢邪 锌褉芯懈褋褏芯写懈褌 褋芯蟹写邪薪懈械 泻芯锌懈懈 褎邪泄谢邪 褍褔械斜薪懈泻邪,

@ -0,0 +1,87 @@
diff -up vim82/runtime/tools/demoserver.py.python-tests vim82/runtime/tools/demoserver.py
--- vim82/runtime/tools/demoserver.py.python-tests 2019-07-26 07:58:50.000000000 +0200
+++ vim82/runtime/tools/demoserver.py 2020-04-17 06:18:06.748977527 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
#
# Server that will accept connections from a Vim channel.
# Run this server and then in Vim you can open the channel:
diff -up vim82/src/auto/configure.python-tests vim82/src/auto/configure
--- vim82/src/auto/configure.python-tests 2020-04-17 06:07:48.000000000 +0200
+++ vim82/src/auto/configure 2020-04-17 06:18:06.750977509 +0200
@@ -6418,7 +6418,7 @@ eof
if test "x$MACOS_X" = "xyes" && test -n "${python_PYTHONFRAMEWORK}" && ${vi_cv_path_python} -c \
"import sys; sys.exit(${vi_cv_var_python_version} < 2.3)"; then
vi_cv_path_python_plibs="-framework Python"
- if test "x${vi_cv_path_python}" != "x/usr/bin/python" && test -n "${python_PYTHONFRAMEWORKPREFIX}"; then
+ if test "x${vi_cv_path_python}" != "x/usr/bin/python2" && test -n "${python_PYTHONFRAMEWORKPREFIX}"; then
vi_cv_path_python_plibs="-F${python_PYTHONFRAMEWORKPREFIX} -framework Python"
fi
else
diff -up vim82/src/configure.ac.python-tests vim82/src/configure.ac
--- vim82/src/configure.ac.python-tests 2020-04-17 06:07:48.000000000 +0200
+++ vim82/src/configure.ac 2020-04-17 06:18:06.750977509 +0200
@@ -1263,7 +1263,7 @@ eof
if test "x$MACOS_X" = "xyes" && test -n "${python_PYTHONFRAMEWORK}" && ${vi_cv_path_python} -c \
"import sys; sys.exit(${vi_cv_var_python_version} < 2.3)"; then
vi_cv_path_python_plibs="-framework Python"
- if test "x${vi_cv_path_python}" != "x/usr/bin/python" && test -n "${python_PYTHONFRAMEWORKPREFIX}"; then
+ if test "x${vi_cv_path_python}" != "x/usr/bin/python2" && test -n "${python_PYTHONFRAMEWORKPREFIX}"; then
vi_cv_path_python_plibs="-F${python_PYTHONFRAMEWORKPREFIX} -framework Python"
fi
else
diff -up vim82/src/testdir/test_channel_pipe.py.python-tests vim82/src/testdir/test_channel_pipe.py
--- vim82/src/testdir/test_channel_pipe.py.python-tests 2019-07-26 07:58:53.000000000 +0200
+++ vim82/src/testdir/test_channel_pipe.py 2020-04-17 06:18:06.751977500 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
#
# Server that will communicate over stdin/stderr
#
diff -up vim82/src/testdir/test_channel.py.python-tests vim82/src/testdir/test_channel.py
--- vim82/src/testdir/test_channel.py.python-tests 2020-04-17 06:18:06.751977500 +0200
+++ vim82/src/testdir/test_channel.py 2020-04-17 06:18:24.517813082 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
#
# Server that will accept connections from a Vim channel.
# Used by test_channel.vim.
diff -up vim82/src/testdir/test_channel_write.py.python-tests vim82/src/testdir/test_channel_write.py
--- vim82/src/testdir/test_channel_write.py.python-tests 2019-07-26 07:58:53.000000000 +0200
+++ vim82/src/testdir/test_channel_write.py 2020-04-17 06:18:06.751977500 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
#
# Program that writes a number to stdout repeatedly
#
diff -up vim82/src/testdir/test_makeencoding.py.python-tests vim82/src/testdir/test_makeencoding.py
--- vim82/src/testdir/test_makeencoding.py.python-tests 2019-07-26 07:58:53.000000000 +0200
+++ vim82/src/testdir/test_makeencoding.py 2020-04-17 06:18:06.751977500 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
# -*- coding: utf-8 -*-
# Test program for :make, :grep and :cgetfile.
diff -up vim82/src/testdir/test_netbeans.py.python-tests vim82/src/testdir/test_netbeans.py
--- vim82/src/testdir/test_netbeans.py.python-tests 2019-07-26 07:58:53.000000000 +0200
+++ vim82/src/testdir/test_netbeans.py 2020-04-17 06:18:06.751977500 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
#
# Server that will communicate with Vim through the netbeans interface.
# Used by test_netbeans.vim.
diff -up vim82/src/testdir/test_short_sleep.py.python-tests vim82/src/testdir/test_short_sleep.py
--- vim82/src/testdir/test_short_sleep.py.python-tests 2019-07-26 07:58:53.000000000 +0200
+++ vim82/src/testdir/test_short_sleep.py 2020-04-17 06:18:06.751977500 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/python3
#
# Program that sleeps for 100 msec
#

@ -0,0 +1,128 @@
" When started as "evim", evim.vim will already have done these settings.
if v:progname =~? "evim"
finish
endif
" Use Vim settings, rather than Vi settings (much better!).
" This must be first, because it changes other options as a side effect.
" Avoid side effects when it was already reset.
if &compatible
set nocompatible
endif
" When the +eval feature is missing, the set command above will be skipped.
" Use a trick to reset compatible only when the +eval feature is missing.
silent! while 0
set nocompatible
silent! endwhile
" Allow backspacing over everything in insert mode.
set backspace=indent,eol,start
"set ai " always set autoindenting on
"set backup " keep a backup file
set viminfo='20,\"50 " read/write a .viminfo file, don't store more
" than 50 lines of registers
set history=50 " keep 50 lines of command line history
set ruler " show the cursor position all the time
set showcmd " display incomplete commands
set wildmenu " display completion matches in a status line
set ttimeout " time out for key codes
set ttimeoutlen=100 " wait up to 100ms after Esc for special key
" Show @@@ in the last line if it is truncated.
set display=truncate
" Show a few lines of context around the cursor. Note that this makes the
" text scroll if you mouse-click near the start or end of the window.
set scrolloff=5
" Do incremental searching when it's possible to timeout.
if has('reltime')
set incsearch
endif
" Do not recognize octal numbers for Ctrl-A and Ctrl-X, most users find it
" confusing.
set nrformats-=octal
" Only do this part when compiled with support for autocommands
if has("autocmd")
augroup fedora
autocmd!
" In text files, always limit the width of text to 78 characters
" autocmd BufRead *.txt set tw=78
" When editing a file, always jump to the last cursor position
autocmd BufReadPost *
\ if line("'\"") > 0 && line ("'\"") <= line("$") |
\ exe "normal! g'\"" |
\ endif
" don't write swapfile on most commonly used directories for NFS mounts or USB sticks
autocmd BufNewFile,BufReadPre /media/*,/run/media/*,/mnt/* set directory=~/tmp,/var/tmp,/tmp
" start with spec file template
" 1724126 - do not open new file with .spec suffix with spec file template
" apparently there are other file types with .spec suffix, so disable the
" template
" autocmd BufNewFile *.spec 0r /usr/share/vim/vimfiles/template.spec
augroup END
endif
if has("cscope") && filereadable("/usr/bin/cscope")
set csprg=/usr/bin/cscope
set csto=0
set cst
set nocsverb
" add any database in current directory
if filereadable("cscope.out")
cs add $PWD/cscope.out
" else add database pointed to by environment
elseif $CSCOPE_DB != ""
cs add $CSCOPE_DB
endif
set csverb
endif
" Switch syntax highlighting on, when the terminal has colors
" Also switch on highlighting the last used search pattern.
if &t_Co > 2 || has("gui_running")
" Revert with ":syntax off".
syntax on
" I like highlighting strings inside C comments.
" Revert with ":unlet c_comment_strings".
let c_comment_strings=1
set hlsearch
endif
filetype plugin on
if &term=="xterm"
set t_Co=8
set t_Sb=[4%dm
set t_Sf=[3%dm
endif
" Convenient command to see the difference between the current buffer and the
" file it was loaded from, thus the changes you made.
" Only define it when not defined already.
" Revert with: ":delcommand DiffOrig".
if !exists(":DiffOrig")
command DiffOrig vert new | set bt=nofile | r ++edit # | 0d_ | diffthis
\ | wincmd p | diffthis
endif
if has('langmap') && exists('+langremap')
" Prevent that the langmap option applies to characters that result from a
" mapping. If set (default), this may break plugins (but it's backward
" compatible).
set nolangremap
endif
" Don't wake up system with blinking cursor:
let &guicursor = &guicursor . ",a:blinkon0"
" Source a global configuration file if available
if filereadable("/etc/vimrc.local")
source /etc/vimrc.local
endif

@ -0,0 +1,34 @@
if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
set fileencodings=ucs-bom,utf-8,latin1
endif
set nocompatible " Use Vim defaults (much better!)
set bs=indent,eol,start " allow backspacing over everything in insert mode
"set ai " always set autoindenting on
"set backup " keep a backup file
set history=50 " keep 50 lines of command line history
set ruler " show the cursor position all the time
" Only do this part when compiled with support for autocommands
if has("autocmd")
augroup fedora
autocmd!
" In text files, always limit the width of text to 78 characters
" autocmd BufRead *.txt set tw=78
" When editing a file, always jump to the last cursor position
autocmd BufReadPost *
\ if line("'\"") > 0 && line ("'\"") <= line("$") |
\ exe "normal! g'\"" |
\ endif
" don't write swapfile on most commonly used directories for NFS mounts or USB sticks
autocmd BufNewFile,BufReadPre /media/*,/run/media/*,/mnt/* set directory=~/tmp,/var/tmp,/tmp
" start with spec file template
autocmd BufNewFile *.spec 0r /usr/share/vim/vimfiles/template.spec
augroup END
endif
if &term=="xterm"
set t_Co=8
set t_Sb=[4%dm
set t_Sf=[3%dm
endif

File diff suppressed because it is too large Load Diff
Loading…
Cancel
Save