parent
be02be5507
commit
5cfca1ca8f
@ -1,46 +0,0 @@
|
|||||||
From a53ed4dda74d61d4cb56842dc0c6e6e7c3870e11 Mon Sep 17 00:00:00 2001
|
|
||||||
From: cantabile <cantabile.desu@gmail.com>
|
|
||||||
Date: Sun, 26 Jan 2020 00:00:22 +0200
|
|
||||||
Subject: [PATCH] Fix compilation with Python 3.8.
|
|
||||||
|
|
||||||
Fixes https://github.com/vapoursynth/vapoursynth/issues/518.
|
|
||||||
---
|
|
||||||
configure.ac | 18 ++++++++++++++++--
|
|
||||||
1 file changed, 16 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 1d1b05fc..7dcde996 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -234,7 +234,13 @@ AS_IF(
|
|
||||||
[
|
|
||||||
AM_PATH_PYTHON([3])
|
|
||||||
|
|
||||||
- PKG_CHECK_MODULES([PYTHON3], [python-$PYTHON_VERSION])
|
|
||||||
+ PKG_CHECK_MODULES([PYTHON3],
|
|
||||||
+ [python-$PYTHON_VERSION-embed],
|
|
||||||
+ [],
|
|
||||||
+ [
|
|
||||||
+ PKG_CHECK_MODULES([PYTHON3],
|
|
||||||
+ [python-$PYTHON_VERSION])
|
|
||||||
+ ])
|
|
||||||
|
|
||||||
AC_CONFIG_FILES([pc/vapoursynth-script.pc])
|
|
||||||
]
|
|
||||||
@@ -292,7 +298,15 @@ AS_IF(
|
|
||||||
|
|
||||||
AS_IF(
|
|
||||||
[test -z "$PYTHON3_LIBS"],
|
|
||||||
- [PKG_CHECK_MODULES([PYTHON3], [python-$PYTHON_VERSION])]
|
|
||||||
+ [
|
|
||||||
+ PKG_CHECK_MODULES([PYTHON3],
|
|
||||||
+ [python-$PYTHON_VERSION-embed],
|
|
||||||
+ [],
|
|
||||||
+ [
|
|
||||||
+ PKG_CHECK_MODULES([PYTHON3],
|
|
||||||
+ [python-$PYTHON_VERSION])
|
|
||||||
+ ])
|
|
||||||
+ ]
|
|
||||||
)
|
|
||||||
|
|
||||||
AS_CASE(
|
|
@ -1,12 +1,12 @@
|
|||||||
diff -U3 vapoursynth-R48.orig/Makefile.am vapoursynth-R48/Makefile.am
|
diff -Naur vapoursynth-R51.old/Makefile.am vapoursynth-R51/Makefile.am
|
||||||
--- vapoursynth-R48.orig/Makefile.am 2019-10-25 09:16:07.000000000 +0300
|
--- vapoursynth-R51.old/Makefile.am 2021-03-23 14:27:12.519657875 +0100
|
||||||
+++ vapoursynth-R48/Makefile.am 2019-12-01 01:28:57.161837465 +0300
|
+++ vapoursynth-R51/Makefile.am 2021-03-23 14:27:19.806783602 +0100
|
||||||
@@ -89,7 +89,7 @@
|
@@ -79,7 +79,7 @@
|
||||||
|
|
||||||
pkgconfig_DATA += pc/vapoursynth.pc
|
pkgconfig_DATA += pc/vapoursynth.pc
|
||||||
|
|
||||||
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version
|
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version
|
||||||
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION)
|
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION)
|
||||||
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
|
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
|
||||||
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la libvapoursynth_avx2.la
|
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la
|
||||||
|
|
||||||
|
Loading…
Reference in new issue