Update to R51, allow building for other archs beside x86

epel9
Simone Caronni 4 years ago
parent be02be5507
commit 5cfca1ca8f

@ -1,7 +1,6 @@
diff --git a/src/core/exprfilter.cpp b/src/core/exprfilter.cpp diff -Naur vapoursynth-R51.old/src/core/exprfilter.cpp vapoursynth-R51/src/core/exprfilter.cpp
index 8e6f154..1971f18 100644 --- vapoursynth-R51.old/src/core/exprfilter.cpp 2021-03-23 14:34:50.273555518 +0100
--- a/src/core/exprfilter.cpp +++ vapoursynth-R51/src/core/exprfilter.cpp 2021-03-23 14:36:17.148054372 +0100
+++ b/src/core/exprfilter.cpp
@@ -32,6 +32,7 @@ @@ -32,6 +32,7 @@
#include <unordered_map> #include <unordered_map>
#include <unordered_set> #include <unordered_set>
@ -10,10 +9,9 @@ index 8e6f154..1971f18 100644
#include "VapourSynth.h" #include "VapourSynth.h"
#include "VSHelper.h" #include "VSHelper.h"
#include "cpufeatures.h" #include "cpufeatures.h"
diff --git a/src/core/genericfilters.cpp b/src/core/genericfilters.cpp diff -Naur vapoursynth-R51.old/src/core/genericfilters.cpp vapoursynth-R51/src/core/genericfilters.cpp
index 613d98f..327512c 100644 --- vapoursynth-R51.old/src/core/genericfilters.cpp 2021-03-23 14:34:50.273555518 +0100
--- a/src/core/genericfilters.cpp +++ vapoursynth-R51/src/core/genericfilters.cpp 2021-03-23 14:36:17.149054389 +0100
+++ b/src/core/genericfilters.cpp
@@ -28,6 +28,7 @@ @@ -28,6 +28,7 @@
#include <array> #include <array>
#include <memory> #include <memory>
@ -22,10 +20,9 @@ index 613d98f..327512c 100644
#include <VapourSynth.h> #include <VapourSynth.h>
#include <VSHelper.h> #include <VSHelper.h>
#include "cpufeatures.h" #include "cpufeatures.h"
diff --git a/src/core/kernel/generic.cpp b/src/core/kernel/generic.cpp diff -Naur vapoursynth-R51.old/src/core/kernel/generic.cpp vapoursynth-R51/src/core/kernel/generic.cpp
index f4477bd..c00c619 100644 --- vapoursynth-R51.old/src/core/kernel/generic.cpp 2021-03-23 14:34:50.273555518 +0100
--- a/src/core/kernel/generic.cpp +++ vapoursynth-R51/src/core/kernel/generic.cpp 2021-03-23 14:36:17.149054389 +0100
+++ b/src/core/kernel/generic.cpp
@@ -22,6 +22,7 @@ @@ -22,6 +22,7 @@
#include <array> #include <array>
#include <cmath> #include <cmath>
@ -34,23 +31,21 @@ index f4477bd..c00c619 100644
#include <type_traits> #include <type_traits>
#include "generic.h" #include "generic.h"
diff --git a/src/filters/misc/miscfilters.cpp b/src/filters/misc/miscfilters.cpp diff -Naur vapoursynth-R51.old/src/filters/misc/miscfilters.cpp vapoursynth-R51/src/filters/misc/miscfilters.cpp
index b4a727a..8931cbb 100644 --- vapoursynth-R51.old/src/filters/misc/miscfilters.cpp 2021-03-23 14:34:50.276555570 +0100
--- a/src/filters/misc/miscfilters.cpp +++ vapoursynth-R51/src/filters/misc/miscfilters.cpp 2021-03-23 14:36:17.150054407 +0100
+++ b/src/filters/misc/miscfilters.cpp @@ -26,6 +26,7 @@
@@ -25,6 +25,7 @@
#include <cstddef>
#include <memory> #include <memory>
#include <stdexcept>
#include <vector> #include <vector>
+#include <limits> +#include <limits>
#include <VapourSynth.h> #include <VapourSynth.h>
#include <VSHelper.h> #include <VSHelper.h>
#include "../src/core/filtersharedcpp.h" #include "../src/core/filtersharedcpp.h"
diff --git a/src/filters/removegrain/clense.cpp b/src/filters/removegrain/clense.cpp diff -Naur vapoursynth-R51.old/src/filters/removegrain/clense.cpp vapoursynth-R51/src/filters/removegrain/clense.cpp
index 5fdc6b2..2507119 100644 --- vapoursynth-R51.old/src/filters/removegrain/clense.cpp 2021-03-23 14:34:50.276555570 +0100
--- a/src/filters/removegrain/clense.cpp +++ vapoursynth-R51/src/filters/removegrain/clense.cpp 2021-03-23 14:36:17.150054407 +0100
+++ b/src/filters/removegrain/clense.cpp @@ -26,6 +26,7 @@
@@ -26,6 +26,7 @@ OTHER DEALINGS IN THE SOFTWARE.
*/ */
#include "shared.h" #include "shared.h"

@ -1,46 +0,0 @@
From a53ed4dda74d61d4cb56842dc0c6e6e7c3870e11 Mon Sep 17 00:00:00 2001
From: cantabile <cantabile.desu@gmail.com>
Date: Sun, 26 Jan 2020 00:00:22 +0200
Subject: [PATCH] Fix compilation with Python 3.8.
Fixes https://github.com/vapoursynth/vapoursynth/issues/518.
---
configure.ac | 18 ++++++++++++++++--
1 file changed, 16 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 1d1b05fc..7dcde996 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,7 +234,13 @@ AS_IF(
[
AM_PATH_PYTHON([3])
- PKG_CHECK_MODULES([PYTHON3], [python-$PYTHON_VERSION])
+ PKG_CHECK_MODULES([PYTHON3],
+ [python-$PYTHON_VERSION-embed],
+ [],
+ [
+ PKG_CHECK_MODULES([PYTHON3],
+ [python-$PYTHON_VERSION])
+ ])
AC_CONFIG_FILES([pc/vapoursynth-script.pc])
]
@@ -292,7 +298,15 @@ AS_IF(
AS_IF(
[test -z "$PYTHON3_LIBS"],
- [PKG_CHECK_MODULES([PYTHON3], [python-$PYTHON_VERSION])]
+ [
+ PKG_CHECK_MODULES([PYTHON3],
+ [python-$PYTHON_VERSION-embed],
+ [],
+ [
+ PKG_CHECK_MODULES([PYTHON3],
+ [python-$PYTHON_VERSION])
+ ])
+ ]
)
AS_CASE(

@ -1,12 +1,12 @@
diff -U3 vapoursynth-R48.orig/Makefile.am vapoursynth-R48/Makefile.am diff -Naur vapoursynth-R51.old/Makefile.am vapoursynth-R51/Makefile.am
--- vapoursynth-R48.orig/Makefile.am 2019-10-25 09:16:07.000000000 +0300 --- vapoursynth-R51.old/Makefile.am 2021-03-23 14:27:12.519657875 +0100
+++ vapoursynth-R48/Makefile.am 2019-12-01 01:28:57.161837465 +0300 +++ vapoursynth-R51/Makefile.am 2021-03-23 14:27:19.806783602 +0100
@@ -89,7 +89,7 @@ @@ -79,7 +79,7 @@
pkgconfig_DATA += pc/vapoursynth.pc pkgconfig_DATA += pc/vapoursynth.pc
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version -libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION) +libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION)
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"' libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la libvapoursynth_avx2.la libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la

@ -1,22 +1,19 @@
#global _with_tests 1 #global _with_tests 1
#global _with_ffmpeg 1 #global _with_subtitles 1
#global _with_ImageMagick 1 #global _with_ImageMagick 1
Name: vapoursynth Name: vapoursynth
Version: 48 Version: 51
Release: 11%{?dist} Release: 1%{?dist}
Summary: Video processing framework with simplicity in mind Summary: Video processing framework with simplicity in mind
License: LGPLv2 License: LGPLv2
URL: http://www.vapoursynth.com URL: http://www.vapoursynth.com
Source0: https://github.com/%{name}/%{name}/archive/R%{version}/%{name}-R%{version}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/R%{version}/%{name}-R%{version}.tar.gz
Patch0: %{name}-version-info.patch Patch0: %{name}-version-info.patch
Patch1: https://github.com/vapoursynth/vapoursynth/commit/a53ed4dda74d61d4cb56842dc0c6e6e7c3870e11.patch#/%{name}-python38.patch Patch1: %{name}-gcc11.patch
Patch2: %{name}-gcc11.patch
ExclusiveArch: %{ix86} x86_64 BuildRequires: make
BuildRequires: make
BuildRequires: autoconf BuildRequires: autoconf
BuildRequires: automake BuildRequires: automake
BuildRequires: gcc-c++ BuildRequires: gcc-c++
@ -38,7 +35,7 @@ BuildRequires: python3dist(pytest)
BuildRequires: pkgconfig(Magick++) >= 7.0 BuildRequires: pkgconfig(Magick++) >= 7.0
} }
%{?_with_ffmpeg: %{?_with_subtitles:
BuildRequires: pkgconfig(libass) BuildRequires: pkgconfig(libass)
BuildRequires: pkgconfig(libavcodec) BuildRequires: pkgconfig(libavcodec)
BuildRequires: pkgconfig(libavformat) BuildRequires: pkgconfig(libavformat)
@ -109,7 +106,7 @@ autoreconf -vif
--enable-morpho \ --enable-morpho \
--enable-ocr \ --enable-ocr \
--enable-removegrain \ --enable-removegrain \
--%{?_with_ffmpeg:enable}%{!?_with_ffmpeg:disable}-subtext \ --%{?_with_subtitles:enable}%{!?_with_subtitles:disable}-subtext \
--enable-vinverse \ --enable-vinverse \
--enable-vivtc \ --enable-vivtc \
@ -136,7 +133,7 @@ rm -fr %{buildroot}%{_docdir}/%{name}
%files libs %files libs
%doc ChangeLog %doc ChangeLog
%license COPYING.LGPLv2.1 ofl.txt %license COPYING.LESSER
%dir %{_libdir}/%{name} %dir %{_libdir}/%{name}
%{_libdir}/lib%{name}.so.* %{_libdir}/lib%{name}.so.*
%{_libdir}/lib%{name}-script.so.* %{_libdir}/lib%{name}-script.so.*
@ -160,6 +157,10 @@ rm -fr %{buildroot}%{_docdir}/%{name}
%changelog %changelog
* Tue Mar 23 2021 Simone Caronni <negativo17@gmail.com> - 51-1
- Update to R51.
- Allow building for other archs beside x86.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 48-11 * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 48-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

Loading…
Cancel
Save