parent
06cb1fa1b0
commit
398c322573
@ -1,2 +1,3 @@
|
||||
/vapoursynth-R48.tar.gz
|
||||
/vapoursynth-R51.tar.gz
|
||||
/vapoursynth-R57.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (vapoursynth-R51.tar.gz) = feb218aa309e538a32054b4fdeaf291e5c817e1b49bd482cf9dfc6c17d055c367dc27f80863770ae3333a4d115c026ad47609ed70857d89c22ff16f5cc6d5292
|
||||
SHA512 (vapoursynth-R57.tar.gz) = 6310b35284acb436b8b49b3a116db736b40d8d51b40243d20e065e80685e66390fce7121c01a2654359673d87b5f589bc3f981d12befc438de14a58ba6614e5f
|
||||
|
@ -1,55 +0,0 @@
|
||||
diff -Naur vapoursynth-R51.old/src/core/exprfilter.cpp vapoursynth-R51/src/core/exprfilter.cpp
|
||||
--- vapoursynth-R51.old/src/core/exprfilter.cpp 2021-03-23 14:34:50.273555518 +0100
|
||||
+++ vapoursynth-R51/src/core/exprfilter.cpp 2021-03-23 14:36:17.148054372 +0100
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <unordered_map>
|
||||
#include <unordered_set>
|
||||
#include <vector>
|
||||
+#include <limits>
|
||||
#include "VapourSynth.h"
|
||||
#include "VSHelper.h"
|
||||
#include "cpufeatures.h"
|
||||
diff -Naur vapoursynth-R51.old/src/core/genericfilters.cpp vapoursynth-R51/src/core/genericfilters.cpp
|
||||
--- vapoursynth-R51.old/src/core/genericfilters.cpp 2021-03-23 14:34:50.273555518 +0100
|
||||
+++ vapoursynth-R51/src/core/genericfilters.cpp 2021-03-23 14:36:17.149054389 +0100
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <array>
|
||||
#include <memory>
|
||||
#include <vector>
|
||||
+#include <limits>
|
||||
#include <VapourSynth.h>
|
||||
#include <VSHelper.h>
|
||||
#include "cpufeatures.h"
|
||||
diff -Naur vapoursynth-R51.old/src/core/kernel/generic.cpp vapoursynth-R51/src/core/kernel/generic.cpp
|
||||
--- vapoursynth-R51.old/src/core/kernel/generic.cpp 2021-03-23 14:34:50.273555518 +0100
|
||||
+++ vapoursynth-R51/src/core/kernel/generic.cpp 2021-03-23 14:36:17.149054389 +0100
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <array>
|
||||
#include <cmath>
|
||||
#include <cstdint>
|
||||
+#include <limits>
|
||||
#include <type_traits>
|
||||
#include "generic.h"
|
||||
|
||||
diff -Naur vapoursynth-R51.old/src/filters/misc/miscfilters.cpp vapoursynth-R51/src/filters/misc/miscfilters.cpp
|
||||
--- vapoursynth-R51.old/src/filters/misc/miscfilters.cpp 2021-03-23 14:34:50.276555570 +0100
|
||||
+++ vapoursynth-R51/src/filters/misc/miscfilters.cpp 2021-03-23 14:36:17.150054407 +0100
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <memory>
|
||||
#include <stdexcept>
|
||||
#include <vector>
|
||||
+#include <limits>
|
||||
#include <VapourSynth.h>
|
||||
#include <VSHelper.h>
|
||||
#include "../src/core/filtersharedcpp.h"
|
||||
diff -Naur vapoursynth-R51.old/src/filters/removegrain/clense.cpp vapoursynth-R51/src/filters/removegrain/clense.cpp
|
||||
--- vapoursynth-R51.old/src/filters/removegrain/clense.cpp 2021-03-23 14:34:50.276555570 +0100
|
||||
+++ vapoursynth-R51/src/filters/removegrain/clense.cpp 2021-03-23 14:36:17.150054407 +0100
|
||||
@@ -26,6 +26,7 @@
|
||||
*/
|
||||
|
||||
#include "shared.h"
|
||||
+#include <limits>
|
||||
|
||||
#define CLENSE_RETERROR(x) do { vsapi->setError(out, (x)); vsapi->freeNode(d.cnode); vsapi->freeNode(d.pnode); vsapi->freeNode(d.nnode); return; } while (0)
|
||||
#define CLAMP(value, lower, upper) do { if (value < lower) value = lower; else if (value > upper) value = upper; } while(0)
|
@ -1,12 +1,12 @@
|
||||
diff -Naur vapoursynth-R51.old/Makefile.am vapoursynth-R51/Makefile.am
|
||||
--- vapoursynth-R51.old/Makefile.am 2021-03-23 14:27:12.519657875 +0100
|
||||
+++ vapoursynth-R51/Makefile.am 2021-03-23 14:27:19.806783602 +0100
|
||||
@@ -79,7 +79,7 @@
|
||||
diff -Naur vapoursynth-R57.old/Makefile.am vapoursynth-R57/Makefile.am
|
||||
--- vapoursynth-R57.old/Makefile.am 2022-03-02 08:35:44.861454145 +0100
|
||||
+++ vapoursynth-R57/Makefile.am 2022-03-02 08:36:52.981729877 +0100
|
||||
@@ -88,7 +88,7 @@
|
||||
|
||||
pkgconfig_DATA += pc/vapoursynth.pc
|
||||
|
||||
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version
|
||||
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION)
|
||||
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
|
||||
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la
|
||||
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version $(UNDEFINEDLDFLAGS)
|
||||
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION) $(UNDEFINEDLDFLAGS)
|
||||
libvapoursynth_la_CPPFLAGS = $(PTHREAD_CFLAGS) $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
|
||||
libvapoursynth_la_LIBADD = $(PTHREAD_LIBS) $(ZIMG_LIBS) $(DLOPENLIB)
|
||||
|
||||
|
Loading…
Reference in new issue