Update to 0.57, obsolete plugins

epel9 imports/e9/vapoursynth-57-1.el9
Simone Caronni 3 years ago
parent 06cb1fa1b0
commit 398c322573

1
.gitignore vendored

@ -1,2 +1,3 @@
/vapoursynth-R48.tar.gz /vapoursynth-R48.tar.gz
/vapoursynth-R51.tar.gz /vapoursynth-R51.tar.gz
/vapoursynth-R57.tar.gz

@ -1 +1 @@
SHA512 (vapoursynth-R51.tar.gz) = feb218aa309e538a32054b4fdeaf291e5c817e1b49bd482cf9dfc6c17d055c367dc27f80863770ae3333a4d115c026ad47609ed70857d89c22ff16f5cc6d5292 SHA512 (vapoursynth-R57.tar.gz) = 6310b35284acb436b8b49b3a116db736b40d8d51b40243d20e065e80685e66390fce7121c01a2654359673d87b5f589bc3f981d12befc438de14a58ba6614e5f

@ -1,55 +0,0 @@
diff -Naur vapoursynth-R51.old/src/core/exprfilter.cpp vapoursynth-R51/src/core/exprfilter.cpp
--- vapoursynth-R51.old/src/core/exprfilter.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/exprfilter.cpp 2021-03-23 14:36:17.148054372 +0100
@@ -32,6 +32,7 @@
#include <unordered_map>
#include <unordered_set>
#include <vector>
+#include <limits>
#include "VapourSynth.h"
#include "VSHelper.h"
#include "cpufeatures.h"
diff -Naur vapoursynth-R51.old/src/core/genericfilters.cpp vapoursynth-R51/src/core/genericfilters.cpp
--- vapoursynth-R51.old/src/core/genericfilters.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/genericfilters.cpp 2021-03-23 14:36:17.149054389 +0100
@@ -28,6 +28,7 @@
#include <array>
#include <memory>
#include <vector>
+#include <limits>
#include <VapourSynth.h>
#include <VSHelper.h>
#include "cpufeatures.h"
diff -Naur vapoursynth-R51.old/src/core/kernel/generic.cpp vapoursynth-R51/src/core/kernel/generic.cpp
--- vapoursynth-R51.old/src/core/kernel/generic.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/kernel/generic.cpp 2021-03-23 14:36:17.149054389 +0100
@@ -22,6 +22,7 @@
#include <array>
#include <cmath>
#include <cstdint>
+#include <limits>
#include <type_traits>
#include "generic.h"
diff -Naur vapoursynth-R51.old/src/filters/misc/miscfilters.cpp vapoursynth-R51/src/filters/misc/miscfilters.cpp
--- vapoursynth-R51.old/src/filters/misc/miscfilters.cpp 2021-03-23 14:34:50.276555570 +0100
+++ vapoursynth-R51/src/filters/misc/miscfilters.cpp 2021-03-23 14:36:17.150054407 +0100
@@ -26,6 +26,7 @@
#include <memory>
#include <stdexcept>
#include <vector>
+#include <limits>
#include <VapourSynth.h>
#include <VSHelper.h>
#include "../src/core/filtersharedcpp.h"
diff -Naur vapoursynth-R51.old/src/filters/removegrain/clense.cpp vapoursynth-R51/src/filters/removegrain/clense.cpp
--- vapoursynth-R51.old/src/filters/removegrain/clense.cpp 2021-03-23 14:34:50.276555570 +0100
+++ vapoursynth-R51/src/filters/removegrain/clense.cpp 2021-03-23 14:36:17.150054407 +0100
@@ -26,6 +26,7 @@
*/
#include "shared.h"
+#include <limits>
#define CLENSE_RETERROR(x) do { vsapi->setError(out, (x)); vsapi->freeNode(d.cnode); vsapi->freeNode(d.pnode); vsapi->freeNode(d.nnode); return; } while (0)
#define CLAMP(value, lower, upper) do { if (value < lower) value = lower; else if (value > upper) value = upper; } while(0)

@ -1,12 +1,12 @@
diff -Naur vapoursynth-R51.old/Makefile.am vapoursynth-R51/Makefile.am diff -Naur vapoursynth-R57.old/Makefile.am vapoursynth-R57/Makefile.am
--- vapoursynth-R51.old/Makefile.am 2021-03-23 14:27:12.519657875 +0100 --- vapoursynth-R57.old/Makefile.am 2022-03-02 08:35:44.861454145 +0100
+++ vapoursynth-R51/Makefile.am 2021-03-23 14:27:19.806783602 +0100 +++ vapoursynth-R57/Makefile.am 2022-03-02 08:36:52.981729877 +0100
@@ -79,7 +79,7 @@ @@ -88,7 +88,7 @@
pkgconfig_DATA += pc/vapoursynth.pc pkgconfig_DATA += pc/vapoursynth.pc
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version -libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version $(UNDEFINEDLDFLAGS)
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION) +libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION) $(UNDEFINEDLDFLAGS)
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"' libvapoursynth_la_CPPFLAGS = $(PTHREAD_CFLAGS) $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la libvapoursynth_la_LIBADD = $(PTHREAD_LIBS) $(ZIMG_LIBS) $(DLOPENLIB)

@ -1,17 +1,12 @@
#global _with_tests 1
#global _with_subtitles 1
#global _with_ImageMagick 1
Name: vapoursynth Name: vapoursynth
Version: 51 Version: 57
Release: 7%{?dist} Release: 1%{?dist}
Summary: Video processing framework with simplicity in mind Summary: Video processing framework with simplicity in mind
License: LGPLv2 License: LGPLv2
URL: http://www.vapoursynth.com URL: http://www.vapoursynth.com
Source0: https://github.com/%{name}/%{name}/archive/R%{version}/%{name}-R%{version}.tar.gz Source0: https://github.com/%{name}/%{name}/archive/R%{version}/%{name}-R%{version}.tar.gz
Patch0: %{name}-version-info.patch Patch0: %{name}-version-info.patch
Patch1: %{name}-gcc11.patch
BuildRequires: make BuildRequires: make
BuildRequires: autoconf BuildRequires: autoconf
@ -31,39 +26,27 @@ BuildRequires: %{name}-devel
BuildRequires: python3dist(pytest) BuildRequires: python3dist(pytest)
} }
%{?_with_ImageMagick:
BuildRequires: pkgconfig(Magick++) >= 7.0
}
%{?_with_subtitles:
BuildRequires: pkgconfig(libass)
BuildRequires: pkgconfig(libavcodec)
BuildRequires: pkgconfig(libavformat)
BuildRequires: pkgconfig(libavutil)
}
%description %description
VapourSynth is an application for video manipulation. Or a plugin. Or a library. VapourSynth is an application for video manipulation. Or a plugin. Or a library.
Its hard to tell because it has a core library written in C++ and a Python Its hard to tell because it has a core library written in C++ and a Python
module to allow video scripts to be created. module to allow video scripts to be created.
%package libs %package libs
Summary: VapourSynth's core library with a C++ API Summary: VapourSynth's core library with a C++ API
Obsoletes: lib%{name} < %{version}-%{release} Obsoletes: lib%{name} < %{version}-%{release}
Provides: lib%{name} == %{version}-%{release} Provides: lib%{name} == %{version}-%{release}
Obsoletes: %{name}-plugins < %{version}-%{release}
Provides: %{name}-plugins == %{version}-%{release}
%description libs %description libs
VapourSynth's core library with a C++ API. VapourSynth's core library with a C++ API.
%package -n python3-%{name} %package -n python3-%{name}
Summary: Python interface for VapourSynth Summary: Python interface for VapourSynth
%description -n python3-%{name} %description -n python3-%{name}
Python interface for VapourSynth/VSSCript. Python interface for VapourSynth/VSSCript.
%package devel %package devel
Summary: Development files for %{name} Summary: Development files for %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release} Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@ -71,26 +54,15 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description devel %description devel
Development files for %{name}. Development files for %{name}.
%package tools %package tools
Summary: Extra tools for VapourSynth Summary: Extra tools for VapourSynth
%description tools %description tools
This package contains the vspipe tool for interfacing with VapourSynth. This package contains the vspipe tool for interfacing with VapourSynth.
%package plugins
Summary: VapourSynth plugins
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description plugins
VapourSynth plugins.
%prep %prep
%autosetup -p1 -n %{name}-R%{version} %autosetup -p1 -n %{name}-R%{version}
%build %build
autoreconf -vif autoreconf -vif
%configure \ %configure \
@ -99,38 +71,29 @@ autoreconf -vif
--enable-core \ --enable-core \
--enable-vsscript \ --enable-vsscript \
--enable-vspipe \ --enable-vspipe \
--enable-python-module \ --enable-python-module
--enable-eedi3 \
--%{?_with_ImageMagick:enable}%{!?_with_ImageMagick:disable}-imwri \
--enable-miscfilters \
--enable-morpho \
--enable-ocr \
--enable-removegrain \
--%{?_with_subtitles:enable}%{!?_with_subtitles:disable}-subtext \
--enable-vinverse \
--enable-vivtc \
%make_build %make_build
%install %install
%py3_install %py3_install
%make_install %make_install
find %{buildroot} -type f -name "*.la" -delete find %{buildroot} -type f -name "*.la" -delete
# Create plugin directory
mkdir -p %{buildroot}%{_libdir}/%{name}
# Let RPM pick up docs in the files section # Let RPM pick up docs in the files section
rm -fr %{buildroot}%{_docdir}/%{name} rm -fr %{buildroot}%{_docdir}/%{name}
%ldconfig_scriptlets libs %ldconfig_scriptlets libs
%ldconfig_scriptlets -n python3-%{name} %ldconfig_scriptlets -n python3-%{name}
%{?_with_tests: %{?_with_tests:
%check %check
%{python3} -m pytest -v %{python3} -m pytest -v
} }
%files libs %files libs
%doc ChangeLog %doc ChangeLog
%license COPYING.LESSER %license COPYING.LESSER
@ -152,11 +115,11 @@ rm -fr %{buildroot}%{_docdir}/%{name}
%files tools %files tools
%{_bindir}/vspipe %{_bindir}/vspipe
%files plugins
%{_libdir}/%{name}/lib*.so
%changelog %changelog
* Wed Mar 02 2022 Simone Caronni <negativo17@gmail.com> - 57-1
- Update to R57.
- Plugins are now separate.
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 51-7 * Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 51-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

Loading…
Cancel
Save