Update to 0.9.4

epel9
Sandro Mani 5 years ago
parent ad878aecca
commit d50414208a

@ -1,14 +1,17 @@
%global _hardened_build 1
Name: uriparser
Version: 0.9.3
Release: 3%{?dist}
Version: 0.9.4
Release: 1%{?dist}
Summary: URI parsing library - RFC 3986
License: BSD
URL: https://uriparser.github.io/
Source0: https://github.com/%{name}/%{name}/releases/download/%{name}-%{version}/%{name}-%{version}.tar.bz2
# Don't use -isystem, pass -fPIE when building tests
Patch0: uriparser_buildtests.patch
BuildRequires: cmake
BuildRequires: doxygen
BuildRequires: gcc-c++
@ -80,6 +83,9 @@ LD_LIBRARY_PATH=".libs" make check
%changelog
* Sun May 31 2020 Sandro Mani <manisandro@gmail.com> - 0.9.4-1
- Update to 0.9.4
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -0,0 +1,19 @@
diff -rupN uriparser-0.9.4/CMakeLists.txt uriparser-0.9.4-new/CMakeLists.txt
--- uriparser-0.9.4/CMakeLists.txt 2020-05-31 17:11:30.000000000 +0200
+++ uriparser-0.9.4-new/CMakeLists.txt 2020-06-02 09:25:06.950566977 +0200
@@ -271,13 +271,14 @@ if(URIPARSER_BUILD_TESTS)
${LIBRARY_CODE_FILES}
)
+ set_property(TARGET testrunner PROPERTY POSITION_INDEPENDENT_CODE TRUE)
target_compile_definitions(testrunner PRIVATE URI_STATIC_BUILD)
if(MSVC)
target_compile_definitions(testrunner PRIVATE -D_CRT_SECURE_NO_WARNINGS)
endif()
- target_include_directories(testrunner SYSTEM PRIVATE
+ target_include_directories(testrunner PRIVATE
${GTEST_INCLUDE_DIRS}
)
Loading…
Cancel
Save