import uid_wrapper-1.3.0-7.el10

i10cs changed/i10cs/uid_wrapper-1.3.0-7.el10
MSVSphere Packaging Team 4 months ago
commit e03c267b20
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -0,0 +1,2 @@
SOURCES/uid_wrapper-1.3.0.tar.gz
SOURCES/uid_wrapper.keyring

@ -0,0 +1,2 @@
9f1132f209f05388df87e7a317ac67ba9f75fd27 SOURCES/uid_wrapper-1.3.0.tar.gz
3f2ab0bca02893402ba0ad172a6bd44456a65f86 SOURCES/uid_wrapper.keyring

@ -0,0 +1,16 @@
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEjf9T4Y8qvI2PPJIjfuD8TcwBTj0FAmPGqIYACgkQfuD8TcwB
Tj1n2xAAugnfwNIyCHmy/rcb/c6y5IYCFOgdtOdh6mGJhiEvpoa46Zovt6L621DG
laCnfaRiutocHb9u2S+xLddNG8l1ZnUB5mp3QYhey0tNtcHZiU+QV6OkesLsrm6l
98qBgZqoxaatR28SbXus5ypH3bCZIgturj8nme44Prck+V/vQuOAggGok02GwvuG
7CyR9cYA9vg4RrL60ZDXhMB6jWCVnbgHHMjxp5iyeyTMphPKMzCcWDNC9O93RQFJ
pe5AAwSIH8xmOZSb1Z+uVu3J0WnjubcK8PcoEIW/303d4XRvY+w1T+z1Qu+RxXCH
tRTg2+ysRnWtxcKALzbHmbTaggJpsFZyRuu8Rf7E4H+6cCSvQv8qYiIY4wqcebBE
+Xxytb9BYUY24n4HwkpL/3OScNxV5H4S2o2lHd7QT190IW26CaOJx1WGm90EGQKC
LUh8lPNJqETEIu5Dke3PiUoZJ0x7zd235NbmM3rmJ0B2bhtL/L3yP1H2zslMuus3
5D3XU0IkUykd6wtgO1He+v1JRZl+mFzkeGPakS9IoIj4E4QVJ3jQAe9UeHL4h3Ac
JG5Yl8T6BTyL72xJUjS0C1DOPSj13pZiUD4FTqHr7mUi9xT6Fmg+IK4xfIYMaqWh
3Pf9q+SyHmaml58rxi5CFYvfkhAIa1Frr/VUHg4izuuA6Gc1IgI=
=SrQO
-----END PGP SIGNATURE-----

@ -0,0 +1,31 @@
From 850f24c6366abda30bfd77734b90330b8809d306 Mon Sep 17 00:00:00 2001
From: Andreas Schneider <asn@samba.org>
Date: Fri, 17 Feb 2023 17:51:27 +0100
Subject: [PATCH] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Andreas Schneider <asn@samba.org>
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
---
tests/CMakeLists.txt | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 635e86e..68e050e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,5 +1,9 @@
project(tests C)
+if (TARGET cmocka::cmocka)
+ set(CMOCKA_LIBRARY cmocka::cmocka)
+endif()
+
add_library(uwrap_fake_socket_wrapper SHARED uwrap_fake_socket_wrapper.c)
target_compile_options(uwrap_fake_socket_wrapper
PRIVATE
--
2.39.2

@ -0,0 +1,230 @@
Name: uid_wrapper
Version: 1.3.0
Release: 7%{?dist}
Summary: A wrapper for privilege separation
License: GPL-3.0-or-later
Url: http://cwrap.org/
Source0: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
Source2: uid_wrapper.keyring
Patch0: uid_wrapper-fix-cmocka-1.1.6+-support.patch
BuildRequires: gcc
BuildRequires: cmake
BuildRequires: gnupg2
BuildRequires: libcmocka-devel >= 1.1.0
Recommends: cmake
Recommends: pkgconfig
%description
Some projects like a file server need privilege separation to be able to switch
to the connection user and do file operations. uid_wrapper convincingly lies
to the application letting it believe it is operating as root and even
switching between UIDs and GIDs as needed.
To use it set the following environment variables:
LD_PRELOAD=libuid_wrapper.so
UID_WRAPPER=1
This package doesn't have a devel package cause this project is for
development/testing.
%prep
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
%autosetup -p1
%build
%cmake \
-DUNIT_TESTING=ON
%cmake_build
%install
%cmake_install
%ldconfig_scriptlets
%check
%ifarch %{ix86}
%ctest -E '^test_syscall$'
%else
%ctest
%endif
%files
%doc AUTHORS README.md CHANGELOG
%license LICENSE
%{_libdir}/libuid_wrapper.so*
%dir %{_libdir}/cmake
%dir %{_libdir}/cmake/uid_wrapper
%{_libdir}/cmake/uid_wrapper/uid_wrapper-config-version.cmake
%{_libdir}/cmake/uid_wrapper/uid_wrapper-config.cmake
%dir %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/uid_wrapper.pc
%{_mandir}/man1/uid_wrapper.1*
%changelog
* Fri Oct 25 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.3.0-7
- Rebuilt for MSVSphere 10
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.3.0-7
- Bump release for June 2024 mass rebuild
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon Mar 06 2023 Andreas Schneider <asn@redhat.com> - 1.3.0-4
- Update License to SPDX expression
* Mon Feb 27 2023 Andreas Schneider <asn@redhat.com> - 1.3.0-3
- Fix building with cmocka >= 1.1.6
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Tue Jan 17 2023 Andreas Schneider <asn@redhat.com> - 1.3.0-1
- Update to version 1.3.0
o https://gitlab.com/cwrap/uid_wrapper/-/blob/uid_wrapper-1.3.0/CHANGELOG
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Dec 02 2021 Andreas Schneider <asn@redhat.com> - 1.2.9-1
- Rebase to version 1.2.9
- resolves: rhbz#2021214 - Add support for getgroups_chk()
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Mon Apr 19 2021 Andreas Schneider <asn@redhat.com> - 1.2.8-1
- Update to version 1.2.8
o https://gitlab.com/cwrap/uid_wrapper/-/blob/uid_wrapper-1.2.8/ChangeLog
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.7-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue Mar 03 2020 Anderson Sasaki <ansasaki@redhat.com> - 1.2.7-3
- Fix invalid library path in cmake configuration file (bz#1809275)
* Wed Feb 12 2020 Andreas Schneider <asn@redhat.com> - 1.2.7-2
- resolves: #1801869 - Fix invalid lib pkg-config lib path
* Tue Feb 11 2020 Andreas Schneider <asn@redhat.com> - 1.2.7-1
- Update to version 1.2.7
* Fix unsetting initial XIDs
* Fix manpage installation
* Fix cmake-config installation
* Fixed running with sanitizers
- resolves: #1690028 - Allow running without RTLD_DEEPBIND
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jul 31 2017 Andreas Schneider <asn@redhat.com> - 1.2.4-1
- Update to version 1.2.4
* Added deadlock workaround for glibc < 2.24
* Fixed a possible deadlock bug if uid_wrapper is turned off
* Logging is always turned on now
* Fixed a memory leak
* Limited number of groups during fork+exec
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Thu Jul 13 2017 Andreas Schneider <asn@redhat.com> - 1.2.2-1
- Update to version 1.2.2:
* Added support for fork'ed and then exec'ed processes
* Added support for Alpha
* Tue Jun 27 2017 Nils Philippsen <nils@redhat.com> - 1.2.1-3
- drop requirements on cmake, pkgconfig and rather own the directories for the
files augmenting these packages
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Mar 23 2016 Andreas Schneider <asn@redhat.com> - 1.2.1-1
- Update to version 1.2.1
* Documented missing options.
* Fixed a comipilation issue with -O3.
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Thu Oct 29 2015 Andreas Schneider <asn@redhat.com> - 1.2.0-1
- Update to version 1.2.0
* Added privilege checks for all set*uid and set*gid functions.
* Added a lot more and accurate tests which work as root.
* Fixed some minor issues
* Wed Sep 02 2015 Andreas Schneider <asn@redhat.com> - 1.1.1-1
- Update to version 1.1.1
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Jan 21 2015 Andreas Schneider <asn@redhat.com> - 1.1.0-1
- Update to version 1.1.0
* Mon Dec 15 2014 Michael Adam <madam@redhat.com> - 1.0.2-5
- Fix format errors in changelog.
- Require cmake.
- Don't own _libdir/pkgconfig, and require pkgconfig instead.
* Thu Oct 02 2014 Andreas Schneider <asn@redhat.com> - 1.0.2-4
- resolves: #1146410 - Do not own /usr/lib64/cmake.
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Mon Aug 04 2014 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 1.0.2-2
- Handle lack of SYS_access on AArch64
* Thu Jul 31 2014 Andreas Schneider <asn@redhat.com> - 1.0.2-1
- Update to version 1.0.2.
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Tue Mar 11 2014 Andreas Schneider <asn@redhat.com> - 1.0.1-3
- Fix some typos.
- resolves: #1060910 - Fedora import
* Tue Feb 11 2014 Andreas Schneider <asn@redhat.com> - 1.0.1-2
- Remove Group
- Remove glibc-devel build requirement
- Do not create a subpackage.
* Tue Feb 04 2014 Andreas Schneider <asn@redhat.com> - 1.0.1-1
- Update to version 1.0.1
* Added --libs to pkg-config.
* Added socket_wrapper-config.cmake
* Fixed a bug packaging the obj directory.
* Mon Feb 03 2014 Andreas Schneider <asn@redhat.com> - 1.0.0-1
- Initial version 1.0.0
Loading…
Cancel
Save