new upstream release

epel9
Rahul Sundaram 16 years ago
parent 894879bdfe
commit ab45fb4bd4

@ -1,33 +0,0 @@
--- transmission-1.61/configure~ 2009-05-12 02:34:04.000000000 +0200
+++ transmission-1.61/configure 2009-05-28 09:23:05.605365896 +0200
@@ -20128,10 +20128,6 @@
if test 0 = "0"; then
supported_build=yes
- if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -g -O3 -funroll-loops "
- CXXFLAGS="$CXXFLAGS -g -O3 -funroll-loops "
- fi
cat >>confdefs.h <<\_ACEOF
#define TR_STABLE_RELEASE 1
@@ -20139,10 +20135,6 @@
else
supported_build=no
- if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -g -O0"
- CXXFLAGS="$CXXFLAGS -g -O0"
- fi
if test 0 = "X"; then
cat >>confdefs.h <<\_ACEOF
@@ -21526,8 +21518,6 @@
if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -std=gnu99 -ggdb3 -Wall -W -Wpointer-arith -Wformat-security -Wcast-align -Wundef -Wcast-align -Wstrict-prototypes -Wmissing-declarations -Wmissing-format-attribute -Wredundant-decls -Wnested-externs -Wunused-parameter -Wwrite-strings"
-
{ $as_echo "$as_me:$LINENO: checking gcc version" >&5
$as_echo_n "checking gcc version... " >&6; }
GCC_VERSION=`$CC -dumpversion`

@ -1,190 +0,0 @@
diff -ur transmission-1.61.orig/cli/Makefile.in transmission-1.61/cli/Makefile.in
--- transmission-1.61.orig/cli/Makefile.in 2009-05-28 09:24:37.769618239 +0200
+++ transmission-1.61/cli/Makefile.in 2009-05-28 09:24:45.953608600 +0200
@@ -53,7 +53,6 @@
am__DEPENDENCIES_1 =
transmissioncli_DEPENDENCIES = \
$(top_builddir)/libtransmission/libtransmission.a \
- $(top_builddir)/third-party/libevent/libevent.la \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
@@ -278,7 +277,7 @@
transmissioncli_SOURCES = cli.c
transmissioncli_LDADD = \
$(top_builddir)/libtransmission/libtransmission.a \
- $(top_builddir)/third-party/libevent/libevent.la \
+ -levent -levent_core \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(INTLLIBS) \
diff -ur transmission-1.61.orig/configure transmission-1.61/configure
--- transmission-1.61.orig/configure 2009-05-28 09:24:37.944616797 +0200
+++ transmission-1.61/configure 2009-05-28 09:24:45.963613650 +0200
@@ -1038,7 +1038,6 @@
LIBNOTIFY_LIBS
DBUS_GLIB_CFLAGS
DBUS_GLIB_LIBS'
-ac_subdirs_all='third-party/libevent'
# Initialize some variables set by options.
ac_init_help=
@@ -24734,16 +24733,6 @@
-subdirs="$subdirs third-party/libevent"
-
-{ $as_echo "$as_me:$LINENO: invoking libevent's configure script" >&5
-$as_echo "$as_me: invoking libevent's configure script" >&6;}
-LIBEVENT_CPPFLAGS="-I\$(top_srcdir)/third-party/libevent"
-
-
-
-
-
pkg_failed=no
{ $as_echo "$as_me:$LINENO: checking for GTK" >&5
$as_echo_n "checking for GTK... " >&6; }
diff -ur transmission-1.61.orig/daemon/Makefile.in transmission-1.61/daemon/Makefile.in
--- transmission-1.61.orig/daemon/Makefile.in 2009-05-28 09:24:37.770626622 +0200
+++ transmission-1.61/daemon/Makefile.in 2009-05-28 09:24:46.123360682 +0200
@@ -58,7 +58,6 @@
$(top_builddir)/libtransmission/libtransmission.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
- $(top_builddir)/third-party/libevent/libevent.la \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
@@ -69,7 +68,7 @@
$(top_builddir)/libtransmission/libtransmission.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
- $(top_builddir)/third-party/libevent/libevent.la \
+ -levent -levent_core \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
@@ -299,7 +298,7 @@
$(top_builddir)/libtransmission/libtransmission.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
- $(top_builddir)/third-party/libevent/libevent.la \
+ -levent -levent_core \
$(INTLLIBS) \
$(LIBCURL_LIBS) \
$(ZLIB_LIBS) \
diff -ur transmission-1.61.orig/daemon/remote.c transmission-1.61/daemon/remote.c
--- transmission-1.61.orig/daemon/remote.c 2009-05-28 09:24:37.770626622 +0200
+++ transmission-1.61/daemon/remote.c 2009-05-28 09:24:46.144365896 +0200
@@ -23,7 +23,7 @@
#include <unistd.h> /* getcwd */
#endif
-#include <libevent/event.h>
+#include <event.h>
#define CURL_DISABLE_TYPECHECK /* otherwise -Wunreachable-code goes insane */
#include <curl/curl.h>
diff -ur transmission-1.61.orig/gtk/Makefile.in transmission-1.61/gtk/Makefile.in
--- transmission-1.61.orig/gtk/Makefile.in 2009-05-28 09:24:37.763616201 +0200
+++ transmission-1.61/gtk/Makefile.in 2009-05-28 09:24:46.125363829 +0200
@@ -72,7 +72,6 @@
am__DEPENDENCIES_1 =
transmission_DEPENDENCIES = \
$(top_builddir)/libtransmission/libtransmission.a \
- $(top_builddir)/third-party/libevent/libevent.la \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
@@ -389,7 +388,7 @@
dist_man_MANS = transmission.1
transmission_LDADD = \
$(top_builddir)/libtransmission/libtransmission.a \
- $(top_builddir)/third-party/libevent/libevent.la \
+ -levent -levent_core \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a $(GTK_LIBS) \
$(GIO_LIBS) $(LIBNOTIFY_LIBS) $(DBUS_GLIB_LIBS) \
diff -ur transmission-1.61.orig/gtk/util.c transmission-1.61/gtk/util.c
--- transmission-1.61.orig/gtk/util.c 2009-05-28 09:24:37.766615788 +0200
+++ transmission-1.61/gtk/util.c 2009-05-28 09:24:46.126365786 +0200
@@ -38,7 +38,7 @@
#include <dbus/dbus-glib.h>
#endif
-#include <libevent/evhttp.h>
+#include <evhttp.h>
#include <libtransmission/transmission.h> /* TR_RATIO_NA, TR_RATIO_INF */
#include <libtransmission/utils.h> /* tr_inf */
diff -ur transmission-1.61.orig/libtransmission/clients.c transmission-1.61/libtransmission/clients.c
--- transmission-1.61.orig/libtransmission/clients.c 2009-05-28 09:24:37.967615518 +0200
+++ transmission-1.61/libtransmission/clients.c 2009-05-28 09:24:46.127387929 +0200
@@ -17,7 +17,7 @@
#include <stdlib.h> /* strtol */
#include <string.h>
-#include <libevent/event.h> /* evbuffer */
+#include <event.h> /* evbuffer */
#include "transmission.h"
#include "clients.h"
diff -ur transmission-1.61.orig/libtransmission/Makefile.in transmission-1.61/libtransmission/Makefile.in
--- transmission-1.61.orig/libtransmission/Makefile.in 2009-05-28 09:24:37.964615931 +0200
+++ transmission-1.61/libtransmission/Makefile.in 2009-05-28 09:24:46.129387025 +0200
@@ -82,7 +82,6 @@
am__DEPENDENCIES_2 = ./libtransmission.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
- $(top_builddir)/third-party/libevent/libevent.la \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
@@ -462,7 +461,7 @@
./libtransmission.a \
$(top_builddir)/third-party/miniupnp/libminiupnp.a \
$(top_builddir)/third-party/libnatpmp/libnatpmp.a \
- $(top_builddir)/third-party/libevent/libevent.la \
+ -levent -levent_core \
$(INTLLIBS) \
$(LIBCURL_LIBS) \
$(OPENSSL_LIBS) \
diff -ur transmission-1.61.orig/libtransmission/net.c transmission-1.61/libtransmission/net.c
--- transmission-1.61.orig/libtransmission/net.c 2009-05-28 09:24:37.970613779 +0200
+++ transmission-1.61/libtransmission/net.c 2009-05-28 09:24:46.130388424 +0200
@@ -39,7 +39,7 @@
#include <fcntl.h>
#endif
-#include <evutil.h>
+#include <event.h>
#include "transmission.h"
#include "fdlimit.h"
diff -ur transmission-1.61.orig/libtransmission/rpc-server.c transmission-1.61/libtransmission/rpc-server.c
--- transmission-1.61.orig/libtransmission/rpc-server.c 2009-05-28 09:24:37.970613779 +0200
+++ transmission-1.61/libtransmission/rpc-server.c 2009-05-28 09:24:46.131363912 +0200
@@ -24,8 +24,8 @@
#include <zlib.h>
#endif
-#include <libevent/event.h>
-#include <libevent/evhttp.h>
+#include <event.h>
+#include <evhttp.h>
#include "transmission.h"
#include "bencode.h"
diff -ur transmission-1.61.orig/third-party/Makefile.in transmission-1.61/third-party/Makefile.in
--- transmission-1.61.orig/third-party/Makefile.in 2009-05-28 09:24:37.793612493 +0200
+++ transmission-1.61/third-party/Makefile.in 2009-05-28 09:24:46.132389615 +0200
@@ -243,7 +243,6 @@
top_srcdir = @top_srcdir@
transmissionlocaledir = @transmissionlocaledir@
SUBDIRS = \
- libevent \
libnatpmp \
miniupnp

@ -0,0 +1,33 @@
diff -urN transmission-1.71.orig/configure transmission-1.71/configure
--- transmission-1.71.orig/configure 2009-06-08 07:06:27.000000000 +0530
+++ transmission-1.71/configure 2009-06-12 19:50:00.279308724 +0530
@@ -20140,10 +20140,6 @@
else
supported_build=no
- if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -g -O0"
- CXXFLAGS="$CXXFLAGS -g -O0"
- fi
if test 0 = "X"; then
cat >>confdefs.h <<\_ACEOF
@@ -21525,10 +21521,6 @@
;;
esac
-if test "x$GCC" = "xyes" ; then
-
- CFLAGS="$CFLAGS -std=gnu99 -ggdb3 -Wall -W -Wpointer-arith -Wformat-security -Wcast-align -Wundef -Wcast-align -Wstrict-prototypes -Wmissing-declarations -Wmissing-format-attribute -Wredundant-decls -Wnested-externs -Wunused-parameter -Wwrite-strings"
-
{ $as_echo "$as_me:$LINENO: checking gcc version" >&5
$as_echo_n "checking gcc version... " >&6; }
GCC_VERSION=`$CC -dumpversion`
@@ -21541,7 +21533,6 @@
if test $GCC_VERSION_NUM -ge 304; then
CFLAGS="$CFLAGS -Wextra -Wdeclaration-after-statement -Winit-self"
fi
-fi
{ $as_echo "$as_me:$LINENO: checking for ANSI C header files" >&5
$as_echo_n "checking for ANSI C header files... " >&6; }

@ -1,6 +1,6 @@
Name: transmission
Version: 1.61
Version: 1.71
Release: 1%{?dist}
Summary: A lightweight GTK+ BitTorrent client
@ -9,8 +9,7 @@ Group: Applications/Internet
License: MIT and GPLv2
URL: http://www.transmissionbt.com/
Source0: http://download.m0k.org/transmission/files/transmission-%{version}.tar.bz2
Patch2: transmission-1.61-copt.patch
Patch3: transmission-1.61-libevent.patch
Patch1: transmission-1.71-copt.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: openssl-devel >= 0.9.4
@ -32,9 +31,9 @@ back-end.
%prep
%setup -q
%patch2 -p1 -b .copt
%patch3 -p1 -b .libevent
# don't use hardcoded compiler options
%patch1 -p1 -b .copt
%build
%configure --with-gtk --without-wx
@ -46,9 +45,7 @@ rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%find_lang %{name}
desktop-file-install --vendor fedora \
--delete-original \
--dir $RPM_BUILD_ROOT/%{_datadir}/applications/ \
desktop-file-install --dir $RPM_BUILD_ROOT/%{_datadir}/applications/ \
$RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
@ -80,6 +77,13 @@ update-desktop-database > /dev/null 2>&1 || :
%changelog
* Fri Jun 12 2009 Rahul Sundaram <sundaram@fedoraproject.org> - 1.71-1
- Update to upstream version 1.71
- Update compiler options patch to match new upstream release
- Drop patch for not using bundled libevent. Upstream now has been fixed to use the system copy whenever possible
- Don't use vendor tag for desktop file. It is not recommended anymore
- Follow https://fedoraproject.org/wiki/Packaging/Guidelines#All_patches_should_have_an_upstream_bug_link_or_comment
* Thu May 28 2009 Denis Leroy <denis@poolshark.org> - 1.61-1
- Update to upstream version 1.61
- fallocate patch upstreamed

Loading…
Cancel
Save