parent
4c01b43f19
commit
a3974510d0
@ -0,0 +1 @@
|
|||||||
|
Transmission-0.6.1.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
1156a88c77ab71782b9261881ea13811 Transmission-0.6.1.tar.gz
|
@ -0,0 +1,11 @@
|
|||||||
|
--- Transmission-0.6.1/configure.orig 2006-09-13 11:39:43.000000000 +0200
|
||||||
|
+++ Transmission-0.6.1/configure 2006-09-13 13:17:46.000000000 +0200
|
||||||
|
@@ -173,7 +173,7 @@
|
||||||
|
verbose gtk_test
|
||||||
|
if runcmd pkg-config gtk+-2.0
|
||||||
|
then
|
||||||
|
- if runcmd expr `pkg-config --modversion gtk+-2.0` '>=' 2.6.0
|
||||||
|
+ if [ 1 ];
|
||||||
|
then
|
||||||
|
cat > testconf.c << EOF
|
||||||
|
#include <gtk/gtk.h>
|
@ -0,0 +1,29 @@
|
|||||||
|
--- Transmission-0.6.1/mk/common.mk.orig 2006-09-13 11:40:03.000000000 +0200
|
||||||
|
+++ Transmission-0.6.1/mk/common.mk 2006-09-13 11:42:38.000000000 +0200
|
||||||
|
@@ -62,20 +62,20 @@
|
||||||
|
|
||||||
|
define INSTALL_BIN_RULE
|
||||||
|
@echo "Install $<"
|
||||||
|
- @$(MKDIR) $(PREFIX)/bin
|
||||||
|
- @$(CP) $< $(PREFIX)/bin/
|
||||||
|
+ @$(MKDIR) $(bindir)
|
||||||
|
+ @$(CP) $< $(bindir)/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define INSTALL_LOCALE_RULE
|
||||||
|
@echo "Install $<"
|
||||||
|
- @$(MKDIR) $(LOCALEDIR)/$*/LC_MESSAGES
|
||||||
|
- @$(CP) $< $(LOCALEDIR)/$*/LC_MESSAGES/transmission-gtk.mo
|
||||||
|
+ @$(MKDIR) $(datadir)/locale/$*/LC_MESSAGES
|
||||||
|
+ @$(CP) $< $(datadir)/locale/$*/LC_MESSAGES/transmission-gtk.mo
|
||||||
|
endef
|
||||||
|
|
||||||
|
define INSTALL_MAN_RULE
|
||||||
|
@echo "Install $<"
|
||||||
|
- @$(MKDIR) $(PREFIX)/man/man1
|
||||||
|
- @$(CP) $< $(PREFIX)/man/man1/
|
||||||
|
+ @$(MKDIR) $(mandir)/man1
|
||||||
|
+ @$(CP) $< $(mandir)/man1/
|
||||||
|
endef
|
||||||
|
|
||||||
|
RM = rm -Rf
|
@ -0,0 +1,93 @@
|
|||||||
|
|
||||||
|
Name: transmission
|
||||||
|
Version: 0.6.1
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: A lightweight GTK+ BitTorrent client
|
||||||
|
|
||||||
|
Group: Applications/Internet
|
||||||
|
License: MIT
|
||||||
|
URL: http://transmission.m0k.org/
|
||||||
|
Source0: http://download.m0k.org/transmission/files/Transmission-%{version}.tar.gz
|
||||||
|
Patch0: transmission-0.6.1-install.patch
|
||||||
|
Patch1: transmission-0.6.1-gtk.patch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: gtk2-devel >= 2.6.0
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: gettext intltool
|
||||||
|
|
||||||
|
Requires(post): desktop-file-utils
|
||||||
|
Requires(postun): desktop-file-utils
|
||||||
|
|
||||||
|
|
||||||
|
%description
|
||||||
|
Transmission is a free, lightweight BitTorrent client. It features a
|
||||||
|
simple, intuitive interface on top on an efficient, cross-platform
|
||||||
|
back-end.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Transmission-%{version}
|
||||||
|
%patch0 -p1 -b .inst
|
||||||
|
%patch1 -p1 -b .gtk
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
%makeinstall
|
||||||
|
%find_lang %{name}-gtk
|
||||||
|
|
||||||
|
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps/
|
||||||
|
install -p -m 644 macosx/Images/Network.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/transmission.png
|
||||||
|
|
||||||
|
cat << EOF > %{name}.desktop
|
||||||
|
[Desktop Entry]
|
||||||
|
Name=Transmission
|
||||||
|
Comment=Download from BitTorrents
|
||||||
|
Exec=transmission-gtk
|
||||||
|
Icon=transmission.png
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Encoding=UTF-8
|
||||||
|
Categories=Application;GTK;Network;Internet;X-Fedora;
|
||||||
|
MimeType=application/x-bittorrent;
|
||||||
|
EOF
|
||||||
|
|
||||||
|
desktop-file-install --vendor fedora \
|
||||||
|
--dir $RPM_BUILD_ROOT/%{_datadir}/applications/ %{name}.desktop
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
|
|
||||||
|
%post
|
||||||
|
update-desktop-database > /dev/null 2>&1 || :
|
||||||
|
|
||||||
|
|
||||||
|
%postun
|
||||||
|
update-desktop-database > /dev/null 2>&1 || :
|
||||||
|
|
||||||
|
|
||||||
|
%files -f %{name}-gtk.lang
|
||||||
|
%defattr(-, root, root, -)
|
||||||
|
%doc AUTHORS LICENSE NEWS README
|
||||||
|
%{_bindir}/transmission*
|
||||||
|
%{_datadir}/pixmaps/*
|
||||||
|
%{_datadir}/applications/*transmission.desktop
|
||||||
|
%doc %{_mandir}/man1/transmission*
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 25 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-2
|
||||||
|
- Removed ldconfig Requires
|
||||||
|
|
||||||
|
* Wed Sep 13 2006 Denis Leroy <denis@poolshark.org> - 0.6.1-1
|
||||||
|
- First version
|
||||||
|
|
Loading…
Reference in new issue