- Update to upstream 0.91

- Removal of -gtk suffix
- Obsoleting manpath patch
epel9
Denis Leroy 18 years ago
parent b7f9f91e8c
commit 72b3b462d0

@ -1 +1 @@
transmission-0.82.tar.gz
transmission-0.91.tar.bz2

@ -1 +1 @@
ddc7842b4c8f7882d90dcf874019ccdc transmission-0.82.tar.gz
7ab1d4eb381ac226008541748a06e5cf transmission-0.91.tar.bz2

@ -1,13 +0,0 @@
--- Transmission-0.71/mk/common.mk.orig 2007-04-25 18:54:30.000000000 +0200
+++ Transmission-0.71/mk/common.mk 2007-04-25 19:01:00.000000000 +0200
@@ -103,8 +103,8 @@
define INSTALL_MAN_RULE
@echo "Install $<"
- @$(MKDIR) $(DESTDIR)$(PREFIX)/man/man1
- @$(CP) $< $(DESTDIR)$(PREFIX)/man/man1/
+ @$(MKDIR) $(DESTDIR)$(PREFIX)/share/man/man1
+ @$(CP) $< $(DESTDIR)$(PREFIX)/share/man/man1/
endef
define INSTALL_DESKTOP_RULE

@ -1,17 +1,13 @@
Index: gtk/util.c
===================================================================
--- gtk/util.c (revision 2629)
+++ gtk/util.c (working copy)
@@ -319,7 +319,12 @@
{
--- transmission-0.91/gtk/util.c~ 2007-10-29 00:57:11.000000000 +0100
+++ transmission-0.91/gtk/util.c 2007-11-03 16:35:30.000000000 +0100
@@ -288,6 +288,10 @@
static char * wd = NULL;
const char * dir = tr_prefs_get( PREF_ID_DIR );
+
if (NULL == dir) {
char * dir = pref_string_get( PREF_KEY_DIR_DEFAULT );
if ( dir == NULL ) {
+#if GLIB_CHECK_VERSION(2, 13, 7)
+ dir = g_get_user_special_dir(G_USER_DIRECTORY_DOWNLOAD);
+ return dir;
+ dir = g_get_user_special_dir(G_USER_DIRECTORY_DOWNLOAD);
+ return dir;
+#endif
if (NULL == wd)
wd = g_get_current_dir();
dir = wd;
if( wd == NULL )
wd = g_get_current_dir();
dir = g_strdup( wd );

@ -1,18 +1,17 @@
Name: transmission
Version: 0.82
Version: 0.91
Release: 1%{?dist}
Summary: A lightweight GTK+ BitTorrent client
Group: Applications/Internet
License: MIT
URL: http://transmission.m0k.org/
Source0: http://download.m0k.org/transmission/files/transmission-%{version}.tar.gz
Patch0: transmission-0.71-manpath.patch
Patch1: transmission-0.81-downloaddir.patch
Source0: http://download.m0k.org/transmission/files/transmission-%{version}.tar.bz2
Patch0: transmission-0.81-downloaddir.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: openssl-devel
BuildRequires: openssl-devel >= 0.9.8
BuildRequires: gtk2-devel >= 2.6.0
BuildRequires: desktop-file-utils
BuildRequires: gettext intltool
@ -26,25 +25,24 @@ back-end.
%prep
%setup -q -c
%patch0 -p1 -b .manpath
%patch1 -p0 -b .dwnldir
%setup -q
%patch0 -p1 -b .dwnldir
%build
%configure
make %{?_smp_mflags} CC=%{__cc}
%configure --with-gtk --without-wx
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%find_lang %{name}-gtk
%find_lang %{name}
desktop-file-install --vendor fedora \
--delete-original \
--dir $RPM_BUILD_ROOT/%{_datadir}/applications/ \
$RPM_BUILD_ROOT/%{_datadir}/applications/%{name}-gtk.desktop
$RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
%clean
@ -59,17 +57,21 @@ update-desktop-database > /dev/null 2>&1 || :
update-desktop-database > /dev/null 2>&1 || :
%files -f %{name}-gtk.lang
%files -f %{name}.lang
%defattr(-, root, root, -)
%doc AUTHORS LICENSE NEWS README
%{_bindir}/transmission*
%{_datadir}/pixmaps/*
%{_datadir}/zsh/site-functions/*
%{_datadir}/applications/*transmission-gtk.desktop
%{_datadir}/applications/*transmission.desktop
%doc %{_mandir}/man1/transmission*
%changelog
* Sat Nov 3 2007 Denis Leroy <denis@poolshark.org> - 0.91-1
- Update to upstream 0.91
- Removal of -gtk suffix
- Obsoleting manpath patch
* Wed Sep 12 2007 Denis Leroy <denis@poolshark.org> - 0.82-1
- Update to upstream 0.82, many bug fixes
- Added patch to support default user download directory (Bastien Nocera)

Loading…
Cancel
Save