commit
2cb3dc7713
@ -0,0 +1 @@
|
|||||||
|
SOURCES/SVT-HEVC-1.5.1.tar.gz
|
@ -0,0 +1 @@
|
|||||||
|
45adf273d7ccea73221bcbb16c3ec548a79e25e2 SOURCES/SVT-HEVC-1.5.1.tar.gz
|
@ -0,0 +1,27 @@
|
|||||||
|
diff -uNdr SVT-HEVC-1.5.0_old/CMakeLists.txt SVT-HEVC-1.5.0_new/CMakeLists.txt
|
||||||
|
--- SVT-HEVC-1.5.0_old/CMakeLists.txt 2020-08-04 00:57:25.000000000 +0300
|
||||||
|
+++ SVT-HEVC-1.5.0_new/CMakeLists.txt 2021-02-07 10:58:15.333859295 +0300
|
||||||
|
@@ -100,11 +100,9 @@
|
||||||
|
-Wformat-security
|
||||||
|
-fPIE
|
||||||
|
-fPIC
|
||||||
|
- -D_FORTIFY_SOURCE=2
|
||||||
|
- /GS
|
||||||
|
- /sdl)
|
||||||
|
+ -D_FORTIFY_SOURCE=2)
|
||||||
|
if(MSVC)
|
||||||
|
- list(APPEND flags_to_test /MP)
|
||||||
|
+ list(APPEND flags_to_test /MP /GS /sdl)
|
||||||
|
else()
|
||||||
|
option(NATIVE "Build for native performance (march=native)")
|
||||||
|
list(INSERT flags_to_test 0 -Wall)
|
||||||
|
@@ -119,8 +117,7 @@
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
set(release_flags_to_test
|
||||||
|
- -O2
|
||||||
|
- -O3)
|
||||||
|
+ -O2)
|
||||||
|
set(debug_flags_to_test
|
||||||
|
-O0)
|
||||||
|
|
@ -0,0 +1,102 @@
|
|||||||
|
Name: svt-hevc
|
||||||
|
Version: 1.5.1
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: Scalable Video Technology for HEVC Encoder
|
||||||
|
|
||||||
|
License: BSD-2-Clause-Patent
|
||||||
|
URL: https://github.com/OpenVisualCloud/SVT-HEVC
|
||||||
|
Source0: %url/archive/v%{version}/SVT-HEVC-%{version}.tar.gz
|
||||||
|
# Correct build flags
|
||||||
|
Patch0: cmake.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: yasm
|
||||||
|
BuildRequires: meson
|
||||||
|
|
||||||
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
ExclusiveArch: x86_64
|
||||||
|
|
||||||
|
%description
|
||||||
|
The Scalable Video Technology for HEVC Encoder (SVT-HEVC Encoder) is an
|
||||||
|
HEVC-compliant encoder library core that achieves excellent density-quality
|
||||||
|
tradeoffs, and is highly optimized for Intel® Xeon™ Scalable Processor and
|
||||||
|
Xeon™ D processors.
|
||||||
|
|
||||||
|
%package libs
|
||||||
|
Summary: Libraries for svt-hevc
|
||||||
|
|
||||||
|
%description libs
|
||||||
|
Libraries for development svt-hevc.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Include files and mandatory libraries for development svt-hevc
|
||||||
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Include files and mandatory libraries for development svt-hevc.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n SVT-HEVC-%{version}
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake -G Ninja
|
||||||
|
|
||||||
|
%cmake_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cmake_install
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_bindir}/SvtHevcEncApp
|
||||||
|
|
||||||
|
%files libs
|
||||||
|
%license LICENSE.md
|
||||||
|
%doc README.md Docs/svt-hevc_encoder_user_guide.md
|
||||||
|
%{_libdir}/libSvtHevcEnc.so.1*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/%{name}
|
||||||
|
%{_libdir}/libSvtHevcEnc.so
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Jul 18 2023 Arkady L. Shane <ashejn@msvsphere.ru> - 1.5.1-3
|
||||||
|
- Rebuilt for MSVSphere 9.2
|
||||||
|
|
||||||
|
* Wed Feb 09 2022 RPM Fusion Release Engineering <sergiomb@rpmfusion.org> - 1.5.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 03 2021 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.5.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 18 2021 Vasiliy Glazov <vascom2@gmail.com> - 1.5.1-1
|
||||||
|
- Update to 1.5.1
|
||||||
|
|
||||||
|
* Sun Feb 07 2021 Vasiliy Glazov <vascom2@gmail.com> - 1.5.0-4
|
||||||
|
- Fix build for GCC 11
|
||||||
|
- Remove gstreamer plugin
|
||||||
|
|
||||||
|
* Thu Feb 04 2021 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.5.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 18 2020 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.5.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Aug 04 2020 Vasiliy Glazov <vascom2@gmail.com> - 1.5.0-1
|
||||||
|
- Update to 1.5.0
|
||||||
|
|
||||||
|
* Wed Feb 05 2020 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 1.4.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 30 2019 Vasiliy Glazov <vascom2@gmail.com> - 1.4.3-1
|
||||||
|
- Update to 1.4.3
|
||||||
|
|
||||||
|
* Tue Sep 17 2019 Vasiliy Glazov <vascom2@gmail.com> - 1.4.1-2
|
||||||
|
- Correct build gstreamer plugin
|
||||||
|
|
||||||
|
* Tue Sep 17 2019 Vasiliy Glazov <vascom2@gmail.com> - 1.4.1-1
|
||||||
|
- Initial release
|
Loading…
Reference in new issue