parent
6c6b61714e
commit
bfe1145227
@ -0,0 +1 @@
|
||||
simple-scan-0.9.5.tar.gz
|
@ -0,0 +1 @@
|
||||
simple-scan-0_9_5-2_fc12:HEAD:simple-scan-0.9.5-2.fc12.src.rpm:1268116529
|
@ -0,0 +1,23 @@
|
||||
diff -Naur simple-scan-0.9.5/configure.in simple-scan-0.9.5.fix/configure.in
|
||||
--- simple-scan-0.9.5/configure.in 2010-02-18 04:30:05.000000000 +0530
|
||||
+++ simple-scan-0.9.5.fix/configure.in 2010-03-05 15:39:25.210961305 +0530
|
||||
@@ -7,9 +7,9 @@
|
||||
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
|
||||
|
||||
AC_ISC_POSIX
|
||||
-AC_PROG_CC
|
||||
AM_PROG_CC_STDC
|
||||
AC_HEADER_STDC
|
||||
+AM_PROG_CC_C_O
|
||||
|
||||
AM_GCONF_SOURCE_2
|
||||
|
||||
diff -Naur simple-scan-0.9.5/src/Makefile.am simple-scan-0.9.5.fix/src/Makefile.am
|
||||
--- simple-scan-0.9.5/src/Makefile.am 2010-01-19 08:59:28.000000000 +0530
|
||||
+++ simple-scan-0.9.5.fix/src/Makefile.am 2010-03-05 15:39:34.747212114 +0530
|
||||
@@ -24,4 +24,4 @@
|
||||
|
||||
simple_scan_LDADD = \
|
||||
$(SIMPLE_SCAN_LIBS) \
|
||||
- -lsane
|
||||
+ -lsane -lm
|
@ -0,0 +1,83 @@
|
||||
Name: simple-scan
|
||||
Version: 0.9.5
|
||||
Release: 2%{?dist}
|
||||
Summary: Simple scanning utility
|
||||
|
||||
Group: Applications/Multimedia
|
||||
License: GPLv3+
|
||||
URL: https://launchpad.net/simple-scan
|
||||
Source0: http://launchpad.net/simple-scan/trunk/%version/+download/simple-scan-%version.tar.gz
|
||||
|
||||
# Upstream report at https://bugs.launchpad.net/simple-scan/+bug/534196
|
||||
Patch0: simple-scan-dso.patch
|
||||
|
||||
BuildRequires: intltool GConf2-devel gtk2-devel autoconf automake
|
||||
BuildRequires: libgudev-devel sane-backends-devel gnome-doc-utils
|
||||
# dso patch related dependencies
|
||||
BuildRequires: autoconf automake gnome-common
|
||||
Requires: gnome-icon-theme xdg-utils yelp
|
||||
Requires(pre): GConf2
|
||||
Requires(post): GConf2
|
||||
Requires(preun): GConf2
|
||||
|
||||
%description
|
||||
Simple Scan is an easy-to-use application, designed to let users connect their
|
||||
scanner and quickly have the image/document in an appropriate format.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .fix
|
||||
|
||||
%build
|
||||
|
||||
# dso patch
|
||||
./autogen.sh
|
||||
%configure --disable-schemas-install
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%find_lang %{name} --with-man --with-gnome
|
||||
|
||||
%pre
|
||||
if [ "$1" -gt 1 ] ; then
|
||||
export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
|
||||
gconftool-2 --makefile-uninstall-rule \
|
||||
%{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
|
||||
killall -HUP gconfd-2 || :
|
||||
fi
|
||||
|
||||
%post
|
||||
export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
|
||||
gconftool-2 --makefile-install-rule \
|
||||
%{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
|
||||
killall -HUP gconfd-2 || :
|
||||
|
||||
%preun
|
||||
if [ "$1" -eq 0 ] ; then
|
||||
export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
|
||||
gconftool-2 --makefile-uninstall-rule \
|
||||
%{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
|
||||
killall -HUP gconfd-2 || :
|
||||
fi
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS README TODO COPYING ChangeLog
|
||||
%{_mandir}/man1/simple-scan.1.gz
|
||||
%{_sysconfdir}/gconf/schemas/simple-scan.schemas
|
||||
%{_bindir}/simple-scan
|
||||
%{_datadir}/applications/simple-scan.desktop
|
||||
%{_datadir}/simple-scan/
|
||||
|
||||
%changelog
|
||||
* Mon Mar 08 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 0.9.5-2
|
||||
- Organize and comment patch dependencies and link to upstream bug report
|
||||
- add requires on yelp and add gconf schema scriptlets
|
||||
|
||||
* Fri Mar 05 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 0.9.5-1
|
||||
- initial build
|
Loading…
Reference in new issue