fix source, drop unneeded patches

epel9
Lucian Langa 15 years ago
parent 3dc468dcba
commit 676ebe27e0

@ -1 +1 @@
shapelib-1.2.10-1.20100216cvs.fc12.src.rpm shapelib-1.2.10-20100216.tar.gz

@ -1,119 +0,0 @@
diff -Naur shapelib-1.2.10.orig/Makefile shapelib-1.2.10/Makefile
--- shapelib-1.2.10.orig/Makefile 2003-04-07 06:03:22.000000000 -0700
+++ shapelib-1.2.10/Makefile 2004-08-12 10:41:15.000000000 -0700
@@ -1,5 +1,9 @@
+bindir = /usr/local/bin
+libdir = /usr/local/lib
+includedir = /usr/local/include
#LINKOPT = /usr/local/lib/libdbmalloc.a
+CC = gcc
CFLAGS = -g
default: all
@@ -99,21 +103,21 @@
LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
lib:
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c -o shpopen.o >/dev/null 2>&1
mv -f .libs/shpopen.lo shpopen.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c
rm -f .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c -o shptree.o >/dev/null 2>&1
mv -f .libs/shptree.lo shptree.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c
rm -f .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
mv -f .libs/dbfopen.lo dbfopen.lo
- /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ /bin/sh ./libtool --mode=link $(CC) $(CFLAGS) $(LINKOPTS) -o libshp.la -rpath $(libdir) -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
@@ -126,17 +130,23 @@
rm -fr .libs/libshp.lax
(cd .libs && rm -f libshp.la && ln -s ../libshp.la libshp.la)
-lib_install:
+lib_install:
cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
- /bin/sh ./libtool --mode=install /usr/bin/install -c libshp.la /usr/local/lib/libshp.la
- /usr/bin/install -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- /usr/bin/install -c .libs/libshp.la /usr/local/lib/libshp.la
- /usr/bin/install -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
- /usr/bin/install -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ mkdir -p $(libdir)
+ /bin/sh ./libtool --mode=install install -c libshp.la $(libdir)/libshp.la
+ install -c .libs/libshp.so.$(LIBSHP_VERSION) $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ (cd $(libdir) && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd $(libdir) && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ install -c .libs/libshp.la $(libdir)/libshp.la
+ install -c .libs/libshp.a $(libdir)/libshp.a
+ ranlib $(libdir)/libshp.a
+ chmod 644 $(libdir)/libshp.a
+ mkdir -p $(includedir)/libshp
+ install -c -m 644 shapefil.h $(includedir)/libshp/shapefil.h
+
+bin_install: all
+ mkdir -p $(bindir)
+ install dbfadd dbfcreate dbfdump shpadd shpcreate shpdump shptest $(bindir)/
+
+install: bin_install lib_install
diff -Naur shapelib-1.2.10.orig/contrib/Makefile shapelib-1.2.10/contrib/Makefile
--- shapelib-1.2.10.orig/contrib/Makefile 2003-04-07 06:03:22.000000000 -0700
+++ shapelib-1.2.10/contrib/Makefile 2004-08-12 10:59:35.000000000 -0700
@@ -1,11 +1,14 @@
+bindir = /usr/local/bin
#LINKOPT = /usr/local/lib/libdbmalloc.a
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
+CC = gcc
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
-CFLAGS = -g -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+EXTRACFLAGS = -g
+CFLAGS = $(EXTRACFLAGS) -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
SHPOBJ = ../shpopen.o ../dbfopen.o
@@ -32,7 +35,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -57,3 +60,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)

@ -1,95 +0,0 @@
diff -Naur shapelib-1.3.0b1/Makefile shapelib-1.3.0b1-mod/Makefile
--- shapelib-1.3.0b1/Makefile 2007-12-13 22:27:13.000000000 +0200
+++ shapelib-1.3.0b1-mod/Makefile 2010-02-05 08:25:04.000000000 +0200
@@ -1,11 +1,14 @@
-#LINKOPT = /usr/local/lib/libdbmalloc.a
-#LINKOPT = /usr/local/lib/cpl.a
CFLAGS = -g -Wall
-#CFLAGS = -g -DUSE_CPL
INSTALL = /usr/bin/install
LD = /usr/bin/ld
-#CC = g++
+
+bindir = /usr/local/bin
+libdir = /usr/local/lib
+includedir = /usr/local/include
+
+CC = gcc
+
default: all
@@ -103,25 +106,25 @@
# The following is contributed by Jan-Oliver Wagner, and should allow for
# creating shared libraries on most platforms with gcc, and libtool installed.
-SHPLIB_VERSION=1.2.9
+SHPLIB_VERSION=1.3.0
LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
lib:
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c -o shpopen.o >/dev/null 2>&1
mv -f .libs/shpopen.lo shpopen.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c
rm -f .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c -o shptree.o >/dev/null 2>&1
mv -f .libs/shptree.lo shptree.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c
rm -f .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
mv -f .libs/dbfopen.lo dbfopen.lo
- /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ /bin/sh ./libtool --mode=link $(CC) $(CFLAGS) $(LINKOPTS) -o libshp.la -rpath $(libdir) -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
@@ -136,15 +139,23 @@
lib_install:
cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
- /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
- $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ /bin/sh ./mkinstalldirs $(libdir)
+ /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) $(libdir)/libshp.so.$(LIBSHP_VERSION)
+
+ (cd $(libdir) && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd $(libdir) && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ $(INSTALL) -c .libs/libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.a $(libdir)/libshp.a
+ ranlib $(libdir)/libshp.a
+ chmod 644 $(libdir)/libshp.a
+ /bin/sh ./mkinstalldirs $(includedir)/libshp
+ $(INSTALL) -c -m 644 shapefil.h $(includedir)/libshp/shapefil.h
+
+bin_install: all
+ mkdir -p $(bindir)
+ install dbfadd dbfcreate dbfdump shpadd shpcreate shpdump shptest $(bindir)/
+
+install: bin_install lib_install
+

@ -1,37 +0,0 @@
diff -Naur shapelib-1.3.0b1/contrib/Makefile shapelib-1.3.0b1-mod/contrib/Makefile
--- shapelib-1.3.0b1/contrib/Makefile 2004-06-24 03:55:52.000000000 +0300
+++ shapelib-1.3.0b1-mod/contrib/Makefile 2010-01-07 09:42:05.000000000 +0200
@@ -1,13 +1,14 @@
+bindir = /usr/local/bin
#LINKOPT = /usr/local/lib/libdbmalloc.a
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+# ENDIAN = -D_LITTLE_ENDIAN
CFLAGS = -g -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
-SHPOBJ = ../shpopen.o ../dbfopen.o
+SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
SHPGOBJ = ../shpopen.o ../dbfopen.o shpgeo.o
@@ -32,7 +33,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +65,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)

@ -1,212 +0,0 @@
diff -Naur shapelib-1.3.0b1/Makefile shapelib-1.3.0b1-mod/Makefile
--- shapelib-1.3.0b1/Makefile 2010-01-07 09:58:13.000000000 +0200
+++ shapelib-1.3.0b1-mod/Makefile 2010-01-07 09:58:00.000000000 +0200
@@ -1,14 +1,12 @@
+#LINKOPT = /usr/local/lib/libdbmalloc.a
+#LINKOPT = /usr/local/lib/cpl.a
CFLAGS = -g -Wall
+#CFLAGS = -g -DUSE_CPL
INSTALL = /usr/bin/install
LD = /usr/bin/ld
-
-bindir = /usr/local/bin
-libdir = /usr/local/lib
-includedir = /usr/local/include
-
-CC = gcc
-
+LDFLAGS = --build-id
+#CC = g++
default: all
@@ -128,7 +126,7 @@
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
diff -Naur shapelib-1.3.0b1/Makefile.orig shapelib-1.3.0b1-mod/Makefile.orig
--- shapelib-1.3.0b1/Makefile.orig 1970-01-01 02:00:00.000000000 +0200
+++ shapelib-1.3.0b1-mod/Makefile.orig 2010-01-07 09:56:41.000000000 +0200
@@ -0,0 +1,151 @@
+
+#LINKOPT = /usr/local/lib/libdbmalloc.a
+#LINKOPT = /usr/local/lib/cpl.a
+CFLAGS = -g -Wall
+#CFLAGS = -g -DUSE_CPL
+INSTALL = /usr/bin/install
+LD = /usr/bin/ld
+LDFLAGS = --build-id
+#CC = g++
+
+default: all
+
+all: shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump shptest
+
+shpopen.o: shpopen.c shapefil.h
+ $(CC) $(CFLAGS) -c shpopen.c
+
+shptree.o: shptree.c shapefil.h
+ $(CC) $(CFLAGS) -c shptree.c
+
+dbfopen.o: dbfopen.c shapefil.h
+ $(CC) $(CFLAGS) -c dbfopen.c
+
+safileio.o: safileio.c shapefil.h
+ $(CC) $(CFLAGS) -c safileio.c
+
+shpcreate: shpcreate.c shpopen.o safileio.o
+ $(CC) $(CFLAGS) shpcreate.c shpopen.o safileio.o $(LINKOPT) -o shpcreate
+
+shpadd: shpadd.c shpopen.o safileio.o
+ $(CC) $(CFLAGS) shpadd.c shpopen.o safileio.o $(LINKOPT) -o shpadd
+
+shpdump: shpdump.c shpopen.o safileio.o
+ $(CC) $(CFLAGS) shpdump.c shpopen.o safileio.o $(LINKOPT) -o shpdump
+
+shprewind: shprewind.c shpopen.o safileio.o
+ $(CC) $(CFLAGS) shprewind.c shpopen.o safileio.o $(LINKOPT) -o shprewind
+
+dbfcreate: dbfcreate.c dbfopen.o safileio.o
+ $(CC) $(CFLAGS) dbfcreate.c dbfopen.o safileio.o $(LINKOPT) -o dbfcreate
+
+dbfadd: dbfadd.c dbfopen.o safileio.o
+ $(CC) $(CFLAGS) dbfadd.c dbfopen.o safileio.o $(LINKOPT) -o dbfadd
+
+dbfdump: dbfdump.c dbfopen.o safileio.o
+ $(CC) $(CFLAGS) dbfdump.c dbfopen.o safileio.o $(LINKOPT) -o dbfdump
+
+shptest: shptest.c shpopen.o safileio.o
+ $(CC) $(CFLAGS) shptest.c shpopen.o safileio.o $(LINKOPT) -o shptest
+
+shputils: shputils.c shpopen.o safileio.o dbfopen.o
+ $(CC) $(CFLAGS) shputils.c shpopen.o safileio.o dbfopen.o $(LINKOPT) -o shputils
+
+shptreedump: shptreedump.c shptree.o shpopen.o safileio.o
+ $(CC) $(CFLAGS) shptreedump.c shptree.o shpopen.o safileio.o $(LINKOPT) \
+ -o shptreedump
+
+clean:
+ rm -f *.o dbfdump dbfcreate dbfadd shpdump shpcreate shpadd shputils
+ rm -f shptreedump
+ rm -rf *.lo *.la .libs
+ rm -f shptest
+
+test: test2 test3
+
+#
+# Note this stream only works if example data is accessable.
+# Fetch ftp://gdal.velocet.ca/pub/outgoing/shape_eg_data.zip
+#
+test1:
+ @./stream1.sh > s1.out
+ @if test "`diff s1.out stream1.out`" = '' ; then \
+ echo "******* Stream 1 Succeeded *********"; \
+ rm s1.out; \
+ else \
+ echo "******* Stream 1 Failed *********"; \
+ diff s1.out stream1.out; \
+ fi
+
+test2:
+ @./stream2.sh > s2.out
+ @if test "`diff s2.out stream2.out`" = '' ; then \
+ echo "******* Stream 2 Succeeded *********"; \
+ rm s2.out; \
+ rm test*.s??; \
+ else \
+ echo "******* Stream 2 Failed *********"; \
+ diff s2.out stream2.out; \
+ fi
+
+test3:
+ @./makeshape.sh > s3.out
+ @if test "`diff s3.out stream3.out`" = '' ; then \
+ echo "******* Stream 3 Succeeded *********"; \
+ rm s3.out; \
+ rm test.*; \
+ else \
+ echo "******* Stream 3 Failed *********"; \
+ diff s3.out stream3.out; \
+ fi
+
+
+# -----------------------------------------------------------------------------
+# The following is contributed by Jan-Oliver Wagner, and should allow for
+# creating shared libraries on most platforms with gcc, and libtool installed.
+
+SHPLIB_VERSION=1.2.9
+LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
+
+lib:
+ /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ mv -f .libs/shpopen.lo shpopen.lo
+ /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ rm -f .libs/shptree.lo
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ mv -f .libs/shptree.lo shptree.lo
+ /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ rm -f .libs/dbfopen.lo
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ mv -f .libs/dbfopen.lo dbfopen.lo
+ /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
+ rm -fr .libs/libshp.lax
+ mkdir .libs/libshp.lax
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+
+ (cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ ar cru .libs/libshp.a shpopen.o shptree.o dbfopen.o
+ ranlib .libs/libshp.a
+ rm -fr .libs/libshp.lax
+ (cd .libs && rm -f libshp.la && ln -s ../libshp.la libshp.la)
+
+lib_install:
+ cp .libs/libshp.la .libs/libshp.lai
+ /bin/sh ./mkinstalldirs /usr/local/lib
+ /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
+ $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
+ (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
+ $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
+ $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
+ ranlib /usr/local/lib/libshp.a
+ chmod 644 /usr/local/lib/libshp.a
+ /bin/sh ./mkinstalldirs /usr/local/include/libshp
+ $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
diff -Naur shapelib-1.3.0b1/Makefile.rej shapelib-1.3.0b1-mod/Makefile.rej
--- shapelib-1.3.0b1/Makefile.rej 1970-01-01 02:00:00.000000000 +0200
+++ shapelib-1.3.0b1-mod/Makefile.rej 2010-01-07 09:58:00.000000000 +0200
@@ -0,0 +1,21 @@
+--- Makefile 2007-12-13 22:27:13.000000000 +0200
++++ Makefile 2010-01-07 09:53:12.000000000 +0200
+@@ -1,11 +1,14 @@
+
+-#LINKOPT = /usr/local/lib/libdbmalloc.a
+-#LINKOPT = /usr/local/lib/cpl.a
+ CFLAGS = -g -Wall
+-#CFLAGS = -g -DUSE_CPL
+ INSTALL = /usr/bin/install
+ LD = /usr/bin/ld
+-#CC = g++
++
++bindir = /usr/local/bin
++libdir = /usr/local/lib
++includedir = /usr/local/include
++
++CC = gcc
++
+
+ default: all
+

@ -1 +1 @@
2c0379f01e323f3addd251b0a66e16bc shapelib-1.2.10-1.20100216cvs.fc12.src.rpm f7c299ea1cacdb6e5f481e33fdbe86ba shapelib-1.2.10-20100216.tar.gz

Loading…
Cancel
Save