revert to latest cvs snapshot

epel9
Lucian Langa 15 years ago
parent 281079f3be
commit 3dc468dcba

@ -1 +1 @@
shapelib-1.3.0b1.tar.gz shapelib-1.2.10-1.20100216cvs.fc12.src.rpm

@ -0,0 +1,90 @@
diff -Naur shapelib-1.2.10/Makefile shapelib-1.2.10-mod/Makefile
--- shapelib-1.2.10/Makefile 2007-12-13 22:27:13.000000000 +0200
+++ shapelib-1.2.10-mod/Makefile 2010-02-16 09:31:24.000000000 +0200
@@ -7,6 +7,14 @@
LD = /usr/bin/ld
#CC = g++
+bindir = /usr/local/bin
+libdir = /usr/local/lib
+includedir = /usr/local/include
+
+CC = gcc
+CFLAGS = -g
+
+
default: all
all: shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump shptest
@@ -103,25 +111,26 @@
# The following is contributed by Jan-Oliver Wagner, and should allow for
# creating shared libraries on most platforms with gcc, and libtool installed.
-SHPLIB_VERSION=1.2.9
+SHPLIB_VERSION=1.2.11
LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
lib:
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c -o shpopen.o >/dev/null 2>&1
+
mv -f .libs/shpopen.lo shpopen.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c
rm -f .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c -o shptree.o >/dev/null 2>&1
mv -f .libs/shptree.lo shptree.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c
rm -f .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
mv -f .libs/dbfopen.lo dbfopen.lo
- /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ /bin/sh ./libtool --mode=link $(CC) $(CFLAGS) $(LINKOPTS) -o libshp.la -rpath $(libdir) -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
@@ -136,15 +145,21 @@
lib_install:
cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
- /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
- $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ /bin/sh ./mkinstalldirs $(libdir)
+ /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ (cd $(libdir) && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd $(libdir) && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ $(INSTALL) -c .libs/libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.a $(libdir)/libshp.a
+ ranlib $(libdir)/libshp.a
+ chmod 644 $(libdir)/libshp.a
+ /bin/sh ./mkinstalldirs $(includedir)/libshp
+ $(INSTALL) -c -m 644 shapefil.h $(includedir)/libshp/shapefil.h
+
+bin_install: all
+ mkdir -p $(bindir)
+ install dbfadd dbfcreate dbfdump shpadd shpcreate shpdump shptest $(bindir)/
+
+install: bin_install lib_install

@ -0,0 +1,29 @@
diff -Naur shapelib-1.2.10/contrib/Makefile shapelib-1.2.10-mod/contrib/Makefile
--- shapelib-1.2.10/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200
+++ shapelib-1.2.10-mod/contrib/Makefile 2010-02-16 10:18:48.000000000 +0200
@@ -3,7 +3,7 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
@@ -32,7 +32,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +64,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)

@ -0,0 +1,20 @@
diff -Naur shapelib-1.2.10/Makefile shapelib-1.2.10-mod/Makefile
--- shapelib-1.2.10/Makefile 2010-02-16 09:43:03.000000000 +0200
+++ shapelib-1.2.10-mod/Makefile 2010-02-16 09:43:43.000000000 +0200
@@ -13,6 +13,7 @@
CC = gcc
CFLAGS = -g
+LDFLAGS = --build-id
default: all
@@ -134,7 +135,7 @@
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)

@ -1,16 +1,19 @@
%define cvsdate 20100216
%define snapshot %{cvsdate}cvs
%define tarfile shapelib-%{version}-%{cvsdate}.tar.gz
# This RPM will possibly fail on PowerPCs, but I am ignoring this. # This RPM will possibly fail on PowerPCs, but I am ignoring this.
Summary: API in "C" for Shapefile handling Summary: API in "C" for Shapefile handling
Name: shapelib Name: shapelib
Version: 1.3.0b1 Version: 1.2.10
Release: 4%{?dist} Release: 1.%{snapshot}%{?dist}
# No version of the LGPL is given. # No version of the LGPL is given.
License: LGPLv2+ or MIT License: LGPLv2+ or MIT
URL: http://shapelib.maptools.org/ URL: http://shapelib.maptools.org/
Source: http://download.osgeo.org/shapelib/shapelib-%{version}.tar.gz Source: http://download.osgeo.org/shapelib/%{tarfile}
Patch0: shapelib-1.3.0b1-Makefile.patch Patch0: shapelib-1.2.10-Makefile.patch
Patch1: shapelib-1.2.10-endian.patch Patch1: shapelib-1.2.10-endian.patch
Patch2: shapelib-1.3.0b1-Makefile2.patch Patch2: shapelib-1.2.10-Makefile2.patch
Patch3: shapelib-1.3.0b1-buildid.patch Patch3: shapelib-1.2.10-buildid.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Group: Development/Libraries Group: Development/Libraries
BuildRequires: proj-devel >= 4.4.1 BuildRequires: proj-devel >= 4.4.1
@ -30,7 +33,7 @@ attribute file (.dbf).
This package contains libshp and the appropriate header files. This package contains libshp and the appropriate header files.
%prep %prep
%setup -q -T -b 0 %setup -q -n %{name}-%{version}
%patch0 -p1 -b .makefile %patch0 -p1 -b .makefile
%patch1 -p1 -b .endian %patch1 -p1 -b .endian
%patch2 -p1 -b .makefile2 %patch2 -p1 -b .makefile2
@ -78,6 +81,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so %{_libdir}/*.so
%changelog %changelog
* Tue Feb 16 2010 Lucian Langa <cooly@gnome.eu.org> - 1.2.10-1.20100216cvs
- revert to latest cvs snapshot
* Thu Feb 04 2010 Lucian Langa <cooly@gnome.eu.org> - 1.3.0b1-4 * Thu Feb 04 2010 Lucian Langa <cooly@gnome.eu.org> - 1.3.0b1-4
- misc cleanups - misc cleanups

@ -1 +1 @@
b8da228374611880ab52179b70c72f16 shapelib-1.3.0b1.tar.gz 2c0379f01e323f3addd251b0a66e16bc shapelib-1.2.10-1.20100216cvs.fc12.src.rpm

Loading…
Cancel
Save