remove endian definition from Makefile, leave it to endian.h

fixes p.e. https://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=197517
epel9
Karsten Hopp 14 years ago
parent 3a93a62fcd
commit 01b9083312

@ -1,15 +1,6 @@
diff -Naur shapelib-1.2.10/contrib/Makefile shapelib-1.2.10-mod/contrib/Makefile diff -Naur shapelib-1.2.10/contrib/Makefile shapelib-1.2.10-mod/contrib/Makefile
--- shapelib-1.2.10/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200 --- shapelib-1.2.10/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200
+++ shapelib-1.2.10-mod/contrib/Makefile 2010-02-16 10:18:48.000000000 +0200 +++ shapelib-1.2.10-mod/contrib/Makefile 2010-02-16 10:18:48.000000000 +0200
@@ -3,7 +3,7 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
@@ -32,7 +32,7 @@ @@ -32,7 +32,7 @@
shpdata: shpdata.c $(SHPGOBJ) shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata $(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata

@ -1,7 +1,19 @@
diff -Naur shapelib-1.3.0b2/contrib/Makefile shapelib-1.3.0b2.mod/contrib/Makefile diff -up shapelib-1.3.0b2/contrib/Makefile.makefile2 shapelib-1.3.0b2/contrib/Makefile
--- shapelib-1.3.0b2/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200 --- shapelib-1.3.0b2/contrib/Makefile.makefile2 2010-01-04 05:08:02.000000000 +0100
+++ shapelib-1.3.0b2.mod/contrib/Makefile 2010-05-19 23:42:22.000000000 +0300 +++ shapelib-1.3.0b2/contrib/Makefile 2011-04-21 18:10:35.000000000 +0200
@@ -32,7 +32,7 @@ @@ -2,10 +2,7 @@
#LINKOPT = /usr/local/lib/libdbmalloc.a
#CFLAGS = -g
-# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
-
-CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 -DDEBUG -DDEBUG2
SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
@@ -32,7 +29,7 @@ shpcentrd: shpcentrd.c $(SHPGOBJ)
shpdata: shpdata.c $(SHPGOBJ) shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata $(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
@ -10,7 +22,7 @@ diff -Naur shapelib-1.3.0b2/contrib/Makefile shapelib-1.3.0b2.mod/contrib/Makefi
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo $(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ) shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +64,7 @@ @@ -64,3 +61,7 @@ check: testproj
testproj: testproj:
tests/shpproj.sh tests/shpproj.sh

@ -2,7 +2,7 @@
Summary: API in "C" for Shapefile handling Summary: API in "C" for Shapefile handling
Name: shapelib Name: shapelib
Version: 1.3.0b2 Version: 1.3.0b2
Release: 7%{?dist} Release: 7.1%{?dist}
# No version of the LGPL is given. # No version of the LGPL is given.
License: LGPLv2+ or MIT License: LGPLv2+ or MIT
URL: http://shapelib.maptools.org/ URL: http://shapelib.maptools.org/
@ -33,7 +33,7 @@ This package contains libshp and the appropriate header files.
%setup -q -n %{name}-%{version} %setup -q -n %{name}-%{version}
%patch0 -p1 -b .makefile %patch0 -p1 -b .makefile
%patch1 -p1 -b .makefile2 %patch1 -p1 -b .makefile2
%patch2 -p1 -b .endian #patch2 -p1 -b .endian
%patch3 -p1 -b .buildid %patch3 -p1 -b .buildid
sed -i "s/\r//g" README sed -i "s/\r//g" README
chmod -x README chmod -x README
@ -78,6 +78,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so %{_libdir}/*.so
%changelog %changelog
* Thu Apr 21 2011 Karsten Hopp <karsten@redhat.com> 1.3.0b2-7.1
- remove endian definition from Makefile, leave it to endian.h
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0b2-7 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0b2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

Loading…
Cancel
Save