Update to 1.3.0 final

epel9
Sandro Mani 12 years ago
parent 2f5a80f524
commit 017724ff95

1
.gitignore vendored

@ -1 +1,2 @@
shapelib-1.3.0b2.tar.gz
/shapelib-1.3.0.tar.gz

@ -1,98 +0,0 @@
diff -Naur shapelib-1.2.10/Makefile shapelib-1.2.10-mod/Makefile
--- shapelib-1.2.10/Makefile 2007-12-13 22:27:13.000000000 +0200
+++ shapelib-1.2.10-mod/Makefile 2010-02-19 09:59:18.000000000 +0200
@@ -6,6 +6,13 @@
INSTALL = /usr/bin/install
LD = /usr/bin/ld
#CC = g++
+bindir = /usr/local/bin
+libdir = /usr/local/lib
+includedir = /usr/local/include
+
+CC = gcc
+CFLAGS = -g
+
default: all
@@ -103,29 +110,34 @@
# The following is contributed by Jan-Oliver Wagner, and should allow for
# creating shared libraries on most platforms with gcc, and libtool installed.
-SHPLIB_VERSION=1.2.9
+SHPLIB_VERSION=1.2.11
LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
lib:
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c -o shpopen.o >/dev/null 2>&1
mv -f .libs/shpopen.lo shpopen.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c
rm -f .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c -o shptree.o >/dev/null 2>&1
mv -f .libs/shptree.lo shptree.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c
rm -f .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
mv -f .libs/dbfopen.lo dbfopen.lo
- /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. $(CFLAGS) $(LINKOPTS) -c safileio.c
+ rm -f .libs/safileio.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC safileio.c -o .libs/safileio.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c safileio.c -o safileio.o >/dev/null 2>&1
+ mv -f .libs/safileio.lo safileio.lo
+ /bin/sh ./libtool --mode=link $(CC) $(CFLAGS) $(LINKOPTS) -o libshp.la -rpath $(libdir) -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo safileio.lo
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+ $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
@@ -136,15 +148,21 @@
lib_install:
cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
- /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
- $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ /bin/sh ./mkinstalldirs $(libdir)
+ /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ (cd $(libdir) && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd $(libdir) && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ $(INSTALL) -c .libs/libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.a $(libdir)/libshp.a
+ ranlib $(libdir)/libshp.a
+ chmod 644 $(libdir)/libshp.a
+ /bin/sh ./mkinstalldirs $(includedir)/libshp
+ $(INSTALL) -c -m 644 shapefil.h $(includedir)/libshp/shapefil.h
+
+bin_install: all
+ mkdir -p $(bindir)
+ install dbfadd dbfcreate dbfdump shpadd shpcreate shpdump shptest $(bindir)/
+
+install: bin_install lib_install

@ -1,20 +0,0 @@
diff -Naur shapelib-1.2.10/contrib/Makefile shapelib-1.2.10-mod/contrib/Makefile
--- shapelib-1.2.10/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200
+++ shapelib-1.2.10-mod/contrib/Makefile 2010-02-16 10:18:48.000000000 +0200
@@ -32,7 +32,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +64,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)

@ -1,24 +0,0 @@
--- shapelib-1.2.10/contrib/my_nan.h.orig 2005-02-13 12:04:41.484914852 +0000
+++ shapelib-1.2.10/contrib/my_nan.h 2005-02-13 12:07:03.306704589 +0000
@@ -21,16 +21,18 @@
#define _GNU_NAN_H 1
+#include <endian.h>
/* hacked to define NAN on Solaris 2.7 if it wasn't defined */
/* IEEE Not A Number. */
-#ifdef _BIG_ENDIAN
+#if __BYTE_ORDER == __BIG_ENDIAN
# define __nan_bytes { 0x7f, 0xf8, 0, 0, 0, 0, 0, 0 }
-#endif
-#ifdef _LITTLE_ENDIAN
+#elif __BYTE_ORDER == __LITTLE_ENDIAN
# define __nan_bytes { 0, 0, 0, 0, 0, 0, 0xf8, 0x7f }
+#else
+#error No endianness?
#endif
#ifdef __GNUC__

@ -1,98 +0,0 @@
diff -Naur shapelib-1.2.10/Makefile shapelib-1.2.10-mod/Makefile
--- shapelib-1.2.10/Makefile 2007-12-13 22:27:13.000000000 +0200
+++ shapelib-1.2.10-mod/Makefile 2010-02-19 09:59:18.000000000 +0200
@@ -6,6 +6,13 @@
INSTALL = /usr/bin/install
LD = /usr/bin/ld
#CC = g++
+bindir = /usr/local/bin
+libdir = /usr/local/lib
+includedir = /usr/local/include
+
+CC = gcc
+CFLAGS = -g
+
default: all
@@ -103,29 +110,34 @@
# The following is contributed by Jan-Oliver Wagner, and should allow for
# creating shared libraries on most platforms with gcc, and libtool installed.
-SHPLIB_VERSION=1.2.9
+SHPLIB_VERSION=1.3.1
LIBSHP_VERSION=1.0.1 # still once to be changed manually (see for 1:1:0), sorry
lib:
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shpopen.c -o shpopen.o >/dev/null 2>&1
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shpopen.c -o .libs/shpopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shpopen.c -o shpopen.o >/dev/null 2>&1
mv -f .libs/shpopen.lo shpopen.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c
rm -f .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c shptree.c -o shptree.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC shptree.c -o .libs/shptree.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c shptree.c -o shptree.o >/dev/null 2>&1
mv -f .libs/shptree.lo shptree.lo
- /bin/sh ./libtool --mode=compile gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c
rm -f .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
- gcc -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. -I/usr/local/include -g -O2 -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC dbfopen.c -o .libs/dbfopen.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c dbfopen.c -o dbfopen.o >/dev/null 2>&1
mv -f .libs/dbfopen.lo dbfopen.lo
- /bin/sh ./libtool --mode=link gcc -g -O2 -o libshp.la -rpath /usr/local/lib -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo
+ /bin/sh ./libtool --mode=compile $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. -I. $(CFLAGS) $(LINKOPTS) -c safileio.c
+ rm -f .libs/safileio.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c -fPIC -DPIC safileio.c -o .libs/safileio.lo
+ $(CC) -DPACKAGE=\"libshp\" -DVERSION=\"$(SHPLIB_VERSION)\" -DSTDC_HEADERS=1 -I. $(CFLAGS) $(LINKOPTS) -c safileio.c -o safileio.o >/dev/null 2>&1
+ mv -f .libs/safileio.lo safileio.lo
+ /bin/sh ./libtool --mode=link $(CC) $(CFLAGS) $(LINKOPTS) -o libshp.la -rpath $(libdir) -version-info 1:1:0 shpopen.lo shptree.lo dbfopen.lo safileio.lo
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+ $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
@@ -136,15 +148,21 @@
lib_install:
cp .libs/libshp.la .libs/libshp.lai
- /bin/sh ./mkinstalldirs /usr/local/lib
- /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- (cd /usr/local/lib && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
- (cd /usr/local/lib && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
- chmod +x /usr/local/lib/libshp.so.$(LIBSHP_VERSION)
- $(INSTALL) -c .libs/libshp.la /usr/local/lib/libshp.la
- $(INSTALL) -c .libs/libshp.a /usr/local/lib/libshp.a
- ranlib /usr/local/lib/libshp.a
- chmod 644 /usr/local/lib/libshp.a
- /bin/sh ./mkinstalldirs /usr/local/include/libshp
- $(INSTALL) -c -m 644 shapefil.h /usr/local/include/libshp/shapefil.h
+ /bin/sh ./mkinstalldirs $(libdir)
+ /bin/sh ./libtool --mode=install $(INSTALL) -c libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.so.$(LIBSHP_VERSION) $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ (cd $(libdir) && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
+ (cd $(libdir) && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
+ chmod +x $(libdir)/libshp.so.$(LIBSHP_VERSION)
+ $(INSTALL) -c .libs/libshp.la $(libdir)/libshp.la
+ $(INSTALL) -c .libs/libshp.a $(libdir)/libshp.a
+ ranlib $(libdir)/libshp.a
+ chmod 644 $(libdir)/libshp.a
+ /bin/sh ./mkinstalldirs $(includedir)/libshp
+ $(INSTALL) -c -m 644 shapefil.h $(includedir)/libshp/shapefil.h
+
+bin_install: all
+ mkdir -p $(bindir)
+ install dbfadd dbfcreate dbfdump shpadd shpcreate shpdump shptest $(bindir)/
+
+install: bin_install lib_install

@ -1,19 +0,0 @@
--- shapelib-1.3.0b1/Makefile 2010-03-09 08:41:01.000000000 +0200
+++ shapelib-1.3.0b1.mod/Makefile 2010-03-09 08:41:29.000000000 +0200
@@ -12,6 +12,7 @@
CC = gcc
CFLAGS = -g
+LDFLAGS = --build-id
default: all
@@ -137,7 +138,7 @@
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)

@ -1,32 +0,0 @@
diff -up shapelib-1.3.0b2/contrib/Makefile.makefile2 shapelib-1.3.0b2/contrib/Makefile
--- shapelib-1.3.0b2/contrib/Makefile.makefile2 2010-01-04 05:08:02.000000000 +0100
+++ shapelib-1.3.0b2/contrib/Makefile 2011-04-21 18:10:35.000000000 +0200
@@ -2,10 +2,7 @@
#LINKOPT = /usr/local/lib/libdbmalloc.a
#CFLAGS = -g
-# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
-
-CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
+CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 -DDEBUG -DDEBUG2
SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
@@ -32,7 +29,7 @@ shpcentrd: shpcentrd.c $(SHPGOBJ)
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +61,7 @@ check: testproj
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)

@ -1,85 +1,81 @@
# This RPM will possibly fail on PowerPCs, but I am ignoring this.
Summary: API in "C" for Shapefile handling
Name: shapelib
Version: 1.3.0b2
Release: 11.1%{?dist}
Name: shapelib
# Note: the f stands for "final". Since the NVR for 1.3.0b2 was 1.3.0b2-x and not 1.3.0-0.x.b2,
# and since for RPM 1.3.0 < 1.3.0b2, this is the only way to specifiy that 1.3.0 > 1.3.0b2
# without bumping the epoch.
Version: 1.3.0f
Release: 1%{?dist}
Summary: C library for handling ESRI Shapefiles
# No version of the LGPL is given.
License: LGPLv2+ or MIT
URL: http://shapelib.maptools.org/
Source: http://download.osgeo.org/shapelib/%{name}-%{version}.tar.gz
Patch0: shapelib-1.3.0b1-Makefile.patch
Patch1: shapelib-1.3.0b2-Makefile2.patch
Patch2: shapelib-1.2.10-endian.patch
Patch3: shapelib-1.3.0b1-buildid.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Group: Development/Libraries
License: LGPLv2+ or MIT
URL: http://shapelib.maptools.org/
Source: http://download.osgeo.org/shapelib/%{name}-1.3.0.tar.gz
# This patch replaces the handmade makefiles with autotools scripts. This patch was generated by
# git clone https://github.com/manisandro/shapelib.git
# cd shapelib
# git checkout autotools
# git diff master..autotools > shapelib_autotools.patch
#
# Upstream is notified about these modifications: http://bugzilla.maptools.org/show_bug.cgi?id=2447
Patch0: shapelib_autotools.patch
BuildRequires: autoconf automake libtool
BuildRequires: proj-devel >= 4.4.1
%package devel
Summary: Development files for shapelib
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description
The Shapefile C Library provides the ability to write
simple C programs for reading, writing and updating (to a
limited extent) ESRI Shapefiles, and the associated
attribute file (.dbf).
%package devel
Summary: Development files for shapelib
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package contains libshp and the appropriate header files.
%package tools
Summary: shapelib utility programs
Requires: %{name}%{?_isa} = %{version}-%{release}
%description tools
This package contains various utility programs distributed with shapelib.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .makefile
%patch1 -p1 -b .makefile2
#patch2 -p1 -b .endian
%patch3 -p1 -b .buildid
sed -i "s/\r//g" README
chmod -x README
%setup -q -n %{name}-1.3.0
%patch0 -p1
%build
make %{?_smp_mflags} libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" lib
make %{?_smp_mflags} libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" all
cd contrib
make %{?_smp_mflags} libdir=%{_libdir} EXTRACFLAGS="$RPM_OPT_FLAGS"
NOCONFIGURE=1 sh ./autogen.sh
%configure --disable-static
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
%make_install
%makeinstall
find %{buildroot} -name \*\.a -print | xargs rm -f
find %{buildroot} -name \*\.la -print | xargs rm -f
cd contrib
%makeinstall
%clean
rm -rf $RPM_BUILD_ROOT
# Remove static libraries
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%{_bindir}/*
%{_libdir}/*.so.*
%doc LICENSE.LGPL README README.tree web/*.html
%doc contrib/doc/shpproj.txt stream1.sh stream1.out stream2.sh
%doc stream2.out makeshape.sh stream3.out ChangeLog
%doc COPYING README README.tree ChangeLog web/*.html
%{_libdir}/libshp.so.*
%files devel
%defattr(-,root,root,-)
%doc LICENSE.LGPL README
%{_includedir}/*
%{_libdir}/*.so
%{_includedir}/shapefil.h
%{_libdir}/libshp.so
%{_libdir}/pkgconfig/%{name}.pc
%files tools
%doc contrib/doc/
%{_bindir}/*
%changelog
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0b2-11.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Aug 05 2013 Sandro Mani <manisandro@gmail.com> - 1.3.0f-1
- Update to 1.3.0 final
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0b2-10.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
@ -156,7 +152,7 @@ rm -rf $RPM_BUILD_ROOT
* Mon Apr 11 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.10-8
- Fix "invalid lvalue in assignment" for GCC4.
* Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
* Fri Apr 8 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
- rebuilt
* Sun Feb 13 2005 David Woodhouse <dwmw2@infradead.org> 0:1.2.10-6

File diff suppressed because it is too large Load Diff

@ -1 +1 @@
708ea578bc299dcd9f723569d12bee8d shapelib-1.3.0b2.tar.gz
2ff7d0b21d4b7506b452524492795f77 shapelib-1.3.0.tar.gz

Loading…
Cancel
Save