Fix saving of last user and session

epel9
Martin Briza 11 years ago
parent a91adb3992
commit a56145a68c

@ -0,0 +1,10 @@
--- sddm-7a008602f5f0a4ed8586ce24012983458a687d4e/src/daemon/Display.cpp.savelast 2013-11-25 19:41:15.824359536 +0100
+++ sddm-7a008602f5f0a4ed8586ce24012983458a687d4e/src/daemon/Display.cpp 2013-11-25 19:41:58.793247508 +0100
@@ -77,6 +77,7 @@ namespace SDDM {
// connect login result signals
connect(this, SIGNAL(loginFailed(QLocalSocket*)), m_socketServer, SLOT(loginFailed(QLocalSocket*)));
connect(this, SIGNAL(loginSucceeded(QLocalSocket*)), m_socketServer, SLOT(loginSucceeded(QLocalSocket*)));
+ connect(this, SIGNAL(loginSucceeded(QLocalSocket*)), this, SLOT(slotLoginSucceeded(QLocalSocket*)));
// get auth dir
QString authDir = daemonApp->configuration()->authDir();

@ -3,7 +3,7 @@
Name: sddm Name: sddm
Version: 0.2.0 Version: 0.2.0
Release: 0.21.20131125git%(echo %{sddm_commit} | cut -c-8)%{?dist} Release: 0.22.20131125git%(echo %{sddm_commit} | cut -c-8)%{?dist}
# code GPLv2+, fedora theme CC-BY-SA # code GPLv2+, fedora theme CC-BY-SA
License: GPLv2+ and CC-BY-SA License: GPLv2+ and CC-BY-SA
Summary: QML based X11 desktop manager Summary: QML based X11 desktop manager
@ -33,6 +33,7 @@ Patch2: sddm-git.e707e229-session-list.patch
Patch3: sddm-0.2.0-0.11.20130914git50ca5b20-xdmcp.patch Patch3: sddm-0.2.0-0.11.20130914git50ca5b20-xdmcp.patch
Patch4: sddm-auth.patch Patch4: sddm-auth.patch
Patch5: sddm-savelast.patch
Provides: service(graphical-login) = sddm Provides: service(graphical-login) = sddm
@ -76,6 +77,7 @@ A collection of sddm themes, including: circles, elarun, maldives, maui.
# disabled for now # disabled for now
#%patch3 -p1 -b .xdmcp #%patch3 -p1 -b .xdmcp
%patch4 -p1 -b .auth %patch4 -p1 -b .auth
%patch5 -p1 -b .savelast
# get rid of the architecture flag # get rid of the architecture flag
sed -i "s/-march=native//" CMakeLists.txt sed -i "s/-march=native//" CMakeLists.txt
@ -148,6 +150,9 @@ install -Dpm 644 %{SOURCE23} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/the
%{_datadir}/apps/sddm/themes/maui/ %{_datadir}/apps/sddm/themes/maui/
%changelog %changelog
* Mon Nov 25 2013 Martin Briza <mbriza@redhat.com> - 0.2.0-0.22.20131125git7a008602
- Fix saving of last session and user
* Mon Nov 25 2013 Martin Briza <mbriza@redhat.com> - 0.2.0-0.21.20131125git7a008602 * Mon Nov 25 2013 Martin Briza <mbriza@redhat.com> - 0.2.0-0.21.20131125git7a008602
- Rebase to current upstream - Rebase to current upstream
- Fix the theme (and improve it by a bit) - Fix the theme (and improve it by a bit)

Loading…
Cancel
Save