Updated to the latest upstream git

Notable changes: Greeter runs under the sddm user, it's possible to configure display setup, different install paths in /usr/share

Resolves: #1034414 #1035939 #1035950 #1036308 #1038548 #1045722 #1045937 #1065715 #1082229 #1007067 #1027711 #1031745 #1008951 #1016902 #1031415 #1020921
epel9
Martin Briza 11 years ago
parent 449e171310
commit 6a348c4aa1

1
.gitignore vendored

@ -2,3 +2,4 @@
/e707e22901049495818a9bedf71f0ba829564700.tar.gz /e707e22901049495818a9bedf71f0ba829564700.tar.gz
/50ca5b20354b6d338ce8836a613af19cedb1dca2.tar.gz /50ca5b20354b6d338ce8836a613af19cedb1dca2.tar.gz
/7a008602f5f0a4ed8586ce24012983458a687d4e.tar.gz /7a008602f5f0a4ed8586ce24012983458a687d4e.tar.gz
/db1d7381754a01a69b0f4c579c0267d80183c066.tar.gz

File diff suppressed because it is too large Load Diff

@ -0,0 +1,16 @@
#%PAM-1.0
auth required pam_env.so
auth required pam_permit.so
auth include postlogin
account required pam_nologin.so
account include system-auth
password include system-auth
session required pam_selinux.so close
session required pam_loginuid.so
session optional pam_console.so
-session optional pam_ck_connector.so
session required pam_selinux.so open
session optional pam_keyinit.so force revoke
session required pam_namespace.so
session include system-auth
session include postlogin

@ -1,25 +0,0 @@
diff --git a/src/greeter/SessionModel.cpp b/src/greeter/SessionModel.cpp
index 8c232ba..8269c4c 100644
--- a/src/greeter/SessionModel.cpp
+++ b/src/greeter/SessionModel.cpp
@@ -56,9 +56,6 @@ namespace SDDM {
// set role names
setRoleNames(roleNames);
#endif
- // add custom and failsafe session
- d->sessions << SessionPtr { new Session {"custom", "Custom", "custom", "Custom Session"} };
- d->sessions << SessionPtr { new Session {"failsafe", "Failsafe", "failsafe", "Failsafe Session"} };
// read session files
QDir dir(Configuration::instance()->sessionsDir());
dir.setNameFilters(QStringList() << "*.desktop");
@@ -84,6 +81,10 @@ namespace SDDM {
// close file
inputFile.close();
}
+ // add custom and failsafe session
+// hidden for now --mbriza
+// d->sessions << SessionPtr { new Session {"custom", "Custom", "custom", "Custom Session"} };
+ d->sessions << SessionPtr { new Session {"failsafe", "Failsafe", "failsafe", "Failsafe Session"} };
// find out index of the last session
for (int i = 0; i < d->sessions.size(); ++i) {
if (d->sessions.at(i)->file == Configuration::instance()->lastSession())

@ -1,14 +0,0 @@
--- sddm-7a008602f5f0a4ed8586ce24012983458a687d4e/src/daemon/Authenticator.cpp.pam_end 2013-12-16 15:26:35.749298583 +0100
+++ sddm-7a008602f5f0a4ed8586ce24012983458a687d4e/src/daemon/Authenticator.cpp 2013-12-16 15:26:45.273274332 +0100
@@ -418,10 +418,9 @@ namespace SDDM {
if (m_pam) {
m_pam->result = pam_close_session(m_pam->handle, 0);
m_pam->result = pam_setcred(m_pam->handle, PAM_DELETE_CRED);
- // for some reason this has to be called here too
- pam_end(m_pam->handle, m_pam->result);
delete m_pam;
m_pam = nullptr;
+ daemonApp->exit(0); // until PAM is fixed, we have to restart the whole service with audit
}
#endif

@ -1,9 +1,9 @@
%global _hardened_build 1 %global _hardened_build 1
%global sddm_commit 7a008602f5f0a4ed8586ce24012983458a687d4e %global sddm_commit db1d7381754a01a69b0f4c579c0267d80183c066
Name: sddm Name: sddm
Version: 0.2.0 Version: 0.2.0
Release: 0.26.20131125git%(echo %{sddm_commit} | cut -c-8)%{?dist} Release: 0.27.20131125git%(echo %{sddm_commit} | cut -c-8)%{?dist}
# code GPLv2+, fedora theme CC-BY-SA # code GPLv2+, fedora theme CC-BY-SA
License: GPLv2+ and CC-BY-SA License: GPLv2+ and CC-BY-SA
Summary: QML based X11 desktop manager Summary: QML based X11 desktop manager
@ -13,25 +13,20 @@ Source0: https://github.com/MartinBriza/sddm/archive/%{sddm_commit}.tar.g
# fedora standard sddm.conf # fedora standard sddm.conf
Source10: sddm.conf Source10: sddm.conf
# Originally kdm config, shamelessly stolen from gdm # Shamelessly stolen from gdm
Source11: sddm.pam Source11: sddm.pam
# Shamelessly stolen from gdm
Source12: sddm-autologin.pam
# We need to ship our own service file to handle Fedora-specific cases # We need to ship our own service file to handle Fedora-specific cases
Source12: sddm.service Source13: sddm.service
# systesmd tmpfiles support for /var/run/sddm # systesmd tmpfiles support for /var/run/sddm
Source13: tmpfiles-sddm.conf Source14: tmpfiles-sddm.conf
# fedora theme files # fedora theme files
Source21: fedora-Main.qml Source21: fedora-Main.qml
Source22: fedora-metadata.desktop Source22: fedora-metadata.desktop
Source23: fedora-theme.conf Source23: fedora-theme.conf
# Patch setting a better order of the xsessions and hiding the custom one
Patch2: sddm-git.e707e229-session-list.patch
Patch3: sddm-0.2.0-0.11.20130914git50ca5b20-xdmcp.patch
# Don't end the PAM session twice
Patch4: sddm-pam_end.patch
Provides: service(graphical-login) = sddm Provides: service(graphical-login) = sddm
BuildRequires: cmake BuildRequires: cmake
@ -50,8 +45,11 @@ Requires: system-logos
Requires: systemd Requires: systemd
Requires: xorg-x11-xinit Requires: xorg-x11-xinit
Requires: xorg-x11-server-Xorg Requires: xorg-x11-server-Xorg
Requires: %{name}-helper
%{?systemd_requires} %{?systemd_requires}
Requires(pre): shadow-utils
%description %description
SDDM is a modern display manager for X11 aiming to be fast, simple and SDDM is a modern display manager for X11 aiming to be fast, simple and
beautiful. It uses modern technologies like QtQuick, which in turn gives the beautiful. It uses modern technologies like QtQuick, which in turn gives the
@ -70,13 +68,6 @@ A collection of sddm themes, including: circles, elarun, maldives, maui.
%prep %prep
%setup -q -n %{name}-%{sddm_commit} %setup -q -n %{name}-%{sddm_commit}
%patch2 -p1 -b .session-list
%patch3 -p1 -b .xdmcp
%patch4 -p1 -b .pam_end
# get rid of the architecture flag
sed -i "s/-march=native//" CMakeLists.txt
%build %build
mkdir -p %{_target_platform} mkdir -p %{_target_platform}
@ -92,15 +83,23 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
install -Dpm 644 %{SOURCE10} %{buildroot}%{_sysconfdir}/sddm.conf install -Dpm 644 %{SOURCE10} %{buildroot}%{_sysconfdir}/sddm.conf
install -Dpm 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/pam.d/sddm install -Dpm 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/pam.d/sddm
install -Dpm 644 %{SOURCE12} %{buildroot}%{_unitdir}/sddm.service install -Dpm 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/pam.d/sddm-autologin
install -Dpm 644 %{SOURCE13} %{buildroot}%{_tmpfilesdir}/sddm.conf install -Dpm 644 %{SOURCE13} %{buildroot}%{_unitdir}/sddm.service
install -Dpm 644 %{SOURCE14} %{buildroot}%{_tmpfilesdir}/sddm.conf
mkdir -p %{buildroot}%{_localstatedir}/run/sddm mkdir -p %{buildroot}%{_localstatedir}/run/sddm
# install fedora theme # install fedora theme
install -Dpm 644 %{SOURCE21} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/Main.qml install -Dpm 644 %{SOURCE21} %{buildroot}%{_datadir}/sddm/themes/fedora/Main.qml
install -Dpm 644 %{SOURCE22} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/metadata.desktop install -Dpm 644 %{SOURCE22} %{buildroot}%{_datadir}/sddm/themes/fedora/metadata.desktop
install -Dpm 644 %{SOURCE23} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/theme.conf install -Dpm 644 %{SOURCE23} %{buildroot}%{_datadir}/sddm/themes/fedora/theme.conf
%pre
getent group sddm >/dev/null || groupadd -r sddm
getent passwd sddm >/dev/null || \
useradd -r -g sddm -d /var/lib/sddm -s /sbin/nologin \
-c "Simple Desktop Display Manager" sddm
exit 0
%post %post
%systemd_post sddm.service %systemd_post sddm.service
@ -115,9 +114,12 @@ install -Dpm 644 %{SOURCE23} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/the
%doc COPYING README.md CONTRIBUTORS %doc COPYING README.md CONTRIBUTORS
%config %{_sysconfdir}/sddm.conf %config %{_sysconfdir}/sddm.conf
%config(noreplace) %{_sysconfdir}/pam.d/sddm %config(noreplace) %{_sysconfdir}/pam.d/sddm
%config(noreplace) %{_sysconfdir}/pam.d/sddm-autologin
%config(noreplace) %{_sysconfdir}/pam.d/sddm-greeter
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.DisplayManager.conf %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.DisplayManager.conf
%{_bindir}/sddm %{_bindir}/sddm
%{_bindir}/sddm-greeter %{_bindir}/sddm-greeter
%{_libexecdir}/sddm-helper
%{_tmpfilesdir}/sddm.conf %{_tmpfilesdir}/sddm.conf
%attr(0711,root,root) %dir %{_localstatedir}/run/sddm %attr(0711,root,root) %dir %{_localstatedir}/run/sddm
%{_unitdir}/sddm.service %{_unitdir}/sddm.service
@ -125,23 +127,28 @@ install -Dpm 644 %{SOURCE23} %{buildroot}%{_datadir}/apps/sddm/themes/fedora/the
# or add Requires: kde-filesystem -- rex # or add Requires: kde-filesystem -- rex
%dir %{_datadir}/apps %dir %{_datadir}/apps
%dir %{_datadir}/apps/sddm %dir %{_datadir}/apps/sddm
%{_datadir}/apps/sddm/faces/ %{_datadir}/sddm/faces/
%{_datadir}/apps/sddm/flags/ %{_datadir}/sddm/flags/
%{_datadir}/apps/sddm/scripts/ %{_datadir}/sddm/scripts/
%{_datadir}/apps/sddm/sddm.conf.sample %{_datadir}/sddm/sddm.conf.sample
%dir %{_datadir}/apps/sddm/themes/ %dir %{_datadir}/apps/sddm/themes/
# default fedora theme # default fedora theme
%{_datadir}/apps/sddm/themes/fedora/ %{_datadir}/sddm/themes/fedora/
# %%lang'ify ? -- rex # %%lang'ify ? -- rex
%{_datadir}/apps/sddm/translations/ %{_datadir}/sddm/translations/
%files themes %files themes
%{_datadir}/apps/sddm/themes/circles/ %{_datadir}/sddm/themes/circles/
%{_datadir}/apps/sddm/themes/elarun/ %{_datadir}/sddm/themes/elarun/
%{_datadir}/apps/sddm/themes/maldives/ %{_datadir}/sddm/themes/maldives/
%{_datadir}/apps/sddm/themes/maui/ %{_datadir}/sddm/themes/maui/
%changelog %changelog
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-0.27.20131125gitdb1d7381
- Updated to the latest upstream git
- Notable changes: Greeter runs under the sddm user, it's possible to configure display setup, different install paths in /usr/share
- Resolves: #1034414 #1035939 #1035950 #1036308 #1038548 #1045722 #1045937 #1065715 #1082229 #1007067 #1027711 #1031745 #1008951 #1016902 #1031415 #1020921
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-0.26.20131125git7a008602 * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-0.26.20131125git7a008602
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

@ -1 +1 @@
23b2a10ad2a2f188c9a2cc4bcd35c275 7a008602f5f0a4ed8586ce24012983458a687d4e.tar.gz eeb5bc6c493b018f73482de460b29f78 db1d7381754a01a69b0f4c579c0267d80183c066.tar.gz

Loading…
Cancel
Save