Fri Feb 14 2003 Lon Hohberger <lhh@redhat.com> 3.9.13-5 - Closes a potential window to raise the warning noted in #84232. Fri Feb 14 2003 Lon Hohberger <lhh@redhat.com> 3.9.13-4 - Fix for #84232 Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Thu Dec 05 2002 Lon Hohberger <lhh@redhat.com> 3.9.13-2 - Fixed up patches; aggregated screenrc + status patches into one for build 2. Thu Dec 05 2002 Lon Hohberger <lhh@redhat.com> 3.9.13-1 - Import of 3.9.13 source tree. UTF-8 no longer dooms us. Mon Dec 02 2002 Lon Hohberger <lhh@redhat.com> 3.9.11-14 - Fix for #78423 Tue Nov 12 2002 Lon Hohberger <lhh@redhat.com> 3.9.11-13 - Fixed Makefile, bumped to 3.9.11-13 Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 3.9.11-12 - obey RPM_OPT_FLAGS always Mon Nov 11 2002 Bill Nottingham <notting@redhat.com> - remove hardcoded paths from pam config fileepel9
parent
40d34dfbff
commit
b30bd93b5b
@ -1 +1 @@
|
||||
screen-3.9.11.tar.gz
|
||||
screen-3.9.13.tar.bz2
|
||||
|
@ -0,0 +1,13 @@
|
||||
diff -ur screen-3.9.13/configure.in screen-3.9.13-lhh/configure.in
|
||||
--- screen-3.9.13/configure.in 2002-08-12 10:34:14.000000000 -0400
|
||||
+++ screen-3.9.13-lhh/configure.in 2002-12-05 16:54:44.000000000 -0500
|
||||
@@ -664,6 +664,9 @@
|
||||
AC_MSG_ERROR(!!! no tgetent - no screen))))))
|
||||
|
||||
AC_TRY_RUN([
|
||||
+
|
||||
+extern char *tgoto(char *,int,int);
|
||||
+
|
||||
main()
|
||||
{
|
||||
exit(strcmp(tgoto("%p1%d", 0, 1), "1") ? 0 : 1);
|
@ -0,0 +1,2 @@
|
||||
#%PAM-1.0
|
||||
auth required pam_stack.so service=system-auth
|
@ -0,0 +1,349 @@
|
||||
Summary: A screen manager that supports multiple logins on one terminal.
|
||||
Name: screen
|
||||
Version: 3.9.13
|
||||
Release: 5
|
||||
License: GPL2
|
||||
Group: Applications/System
|
||||
URL: http://www.gnu.org/software/screen
|
||||
Prereq: /sbin/install-info
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
BuildRequires: ncurses-devel
|
||||
Requires: ncurses
|
||||
|
||||
%define autoconf_ver -2.13
|
||||
|
||||
# The one and only true source
|
||||
#
|
||||
Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.bz2
|
||||
|
||||
# Except for the PAM configuration, that is.
|
||||
Source1: screen.pam
|
||||
|
||||
# Small tweak for ia64
|
||||
#
|
||||
Patch1: screen-3.9.13-ia64.patch
|
||||
|
||||
# Some tweaks of the default screenrc
|
||||
# really end users should visit /etc/screenrc and tweak
|
||||
# it to suit their personal preferances
|
||||
#
|
||||
Patch2: screen-3.9.13-screenrc.patch
|
||||
|
||||
# Due to the way the build system creates rpms in a buildroot
|
||||
# we need this tweak for utf8encodings
|
||||
#
|
||||
Patch3: screen-3.9.11-utf8-install.patch
|
||||
|
||||
# We need to allow rpm to strip the binary and we don't have a
|
||||
# libelf dependancy
|
||||
Patch4: screen-3.9.11-no-stripping-or-elf.patch
|
||||
|
||||
# Change sig_ign to sig_dfl in exit path
|
||||
Patch5: screen-3.9.13-child.patch
|
||||
|
||||
%description
|
||||
The screen utility allows you to have multiple logins on just one
|
||||
terminal. Screen is useful for users who telnet into a machine or are
|
||||
connected via a dumb terminal, but want to use more than just one
|
||||
login.
|
||||
|
||||
Install the screen package if you need a screen manager that can
|
||||
support multiple logins on one terminal.
|
||||
|
||||
|
||||
%prep
|
||||
|
||||
|
||||
%setup -q
|
||||
%patch1 -p1 -b .ia64
|
||||
%patch2 -p1 -b .screenrc
|
||||
%patch3 -p1 -b .utf8-install
|
||||
%patch4 -p1 -b .no-stripping-or-elf
|
||||
%patch5 -p0 -b .child
|
||||
|
||||
libtoolize --copy --force
|
||||
|
||||
if [ -x /usr/bin/autoconf%{autoconf_ver} ]; then
|
||||
autoconf%{autoconf_ver}
|
||||
else
|
||||
autoconf
|
||||
fi;
|
||||
|
||||
%build
|
||||
|
||||
%configure \
|
||||
--enable-pam \
|
||||
--enable-colors256 \
|
||||
--enable-rxvt_osc \
|
||||
--enable-locale \
|
||||
--enable-telnet \
|
||||
--with-sys-screenrc="/etc/screenrc"
|
||||
|
||||
# We would like to have braille support.
|
||||
#
|
||||
sed -e 's/.*#.*undef.*HAVE_BRAILLE.*/#define HAVE_BRAILLE 1/;' \
|
||||
< config.h > config.tmp.h
|
||||
mv config.tmp.h config.h
|
||||
|
||||
# We really don't want to be using /usr/local
|
||||
# because we wish to be FSB complient
|
||||
#
|
||||
sed -e 's/\/usr\/local\/etc/\/etc/g;' < etc/etcscreenrc > etc/etcscreenrc.tmp
|
||||
mv etc/etcscreenrc.tmp etc/etcscreenrc
|
||||
|
||||
find doc -type f | while read line; do
|
||||
sed -e 's/\(\/usr\)\?\/local\/etc/\/etc/g;' < $line > $line.tmp;
|
||||
mv $line.tmp $line
|
||||
done
|
||||
|
||||
rm doc/screen.info*
|
||||
make clean
|
||||
|
||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" make
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/etc
|
||||
%makeinstall DDESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
( cd $RPM_BUILD_ROOT
|
||||
rm -f .%{_bindir}/screen.old .%{_bindir}/screen
|
||||
mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
|
||||
)
|
||||
|
||||
install -c -m 0644 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
|
||||
cat etc/screenrc >> $RPM_BUILD_ROOT/etc/screenrc
|
||||
|
||||
# Better not forget to copy the pam file around
|
||||
#
|
||||
mkdir -p $RPM_BUILD_ROOT/etc/pam.d
|
||||
install -m 0644 $RPM_SOURCE_DIR/screen.pam $RPM_BUILD_ROOT/etc/pam.d/screen
|
||||
|
||||
# Remove files from the buildroot which we don't want packaged
|
||||
#
|
||||
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/screen.info.gz %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
|
||||
|
||||
if [ -d /tmp/screens ]; then
|
||||
# we're not setuid root anymore
|
||||
#
|
||||
chmod 777 /tmp/screens
|
||||
fi
|
||||
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/screen.info.gz %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
|
||||
fi
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc NEWS README doc/FAQ doc/README.DOTSCREEN
|
||||
|
||||
%attr(755,root,root) %{_bindir}/screen
|
||||
%{_mandir}/man1/screen.*
|
||||
%{_infodir}/screen.info*
|
||||
%{_datadir}/screen/utf8encodings/*
|
||||
%config /etc/screenrc
|
||||
%config /etc/pam.d/screen
|
||||
|
||||
%changelog
|
||||
* Fri Feb 14 2003 Lon Hohberger <lhh@redhat.com> 3.9.13-5
|
||||
- Closes a potential window to raise the warning noted
|
||||
in #84232.
|
||||
|
||||
* Fri Feb 14 2003 Lon Hohberger <lhh@redhat.com> 3.9.13-4
|
||||
- Fix for #84232
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Dec 05 2002 Lon Hohberger <lhh@redhat.com> 3.9.13-2
|
||||
- Fixed up patches; aggregated screenrc + status patches into one
|
||||
for build 2.
|
||||
|
||||
* Thu Dec 05 2002 Lon Hohberger <lhh@redhat.com> 3.9.13-1
|
||||
- Import of 3.9.13 source tree. UTF-8 no longer dooms us.
|
||||
|
||||
* Mon Dec 02 2002 Lon Hohberger <lhh@redhat.com> 3.9.11-14
|
||||
- Fix for #78423
|
||||
|
||||
* Tue Nov 12 2002 Lon Hohberger <lhh@redhat.com> 3.9.11-13
|
||||
- Fixed Makefile, bumped to 3.9.11-13
|
||||
|
||||
* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 3.9.11-12
|
||||
- obey RPM_OPT_FLAGS always
|
||||
|
||||
* Mon Nov 11 2002 Bill Nottingham <notting@redhat.com>
|
||||
- remove hardcoded paths from pam config file
|
||||
|
||||
* Wed Aug 14 2002 Philip Copeland <bryce@redhat.com> 3.9.11-10
|
||||
- #65344 - doomed by utf8
|
||||
|
||||
* Tue Aug 12 2002 Philip Copeland <bryce@redhat.com> 3.9.11-9
|
||||
- #60597 - what /shall/ we make the defaults today?
|
||||
|
||||
* Thu Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.9.11-8
|
||||
- Prevent the makefile from stripping the binary
|
||||
- Really get rid of the libelf dependancy
|
||||
|
||||
* Thu Jun 27 2002 Philip Copeland <bryce@redhat.com> 3.9.11-7
|
||||
- Get rid of libelf dependancy
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.9.11-6
|
||||
- automated rebuild
|
||||
|
||||
* Tue May 28 2002 Philip Copeland <bryce@redhat.com> 3.9.11-5
|
||||
- Missing bindkey to allow backspace to work
|
||||
- Rebuilt due to rpm bug
|
||||
|
||||
* Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
|
||||
- fix starting in non-en_US locales (#61835)
|
||||
|
||||
* Mon Apr 15 2002 Philip Copeland <bryce@redhat.com>
|
||||
- Various fixups including remembering to enable pam support
|
||||
|
||||
* Sat Feb 16 2002 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- update to 3.9.11
|
||||
- patch0/patch4 is not necessary anymore
|
||||
- do not compress man-pages/info-files in spec file
|
||||
- use configure to set telnet/screenrc instead of sed
|
||||
- add a hack to correctly install the new screenencodings
|
||||
- try to build up a better global /etc/screenrc instead of
|
||||
/etc/skel/.screenrc
|
||||
|
||||
* Fri Aug 3 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.9.9-3
|
||||
- fixed screenrc path sed command; #50046
|
||||
- added ncurses-devel build dep; #49692
|
||||
- fix typo in specfile that broke screenrc, #49535
|
||||
|
||||
* Tue Jul 10 2001 Tim Powers <timp@redhat.com>
|
||||
- gzip manpage
|
||||
|
||||
* Mon Jun 25 2001 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- itterate to 3.9.9
|
||||
- fixed FAQ
|
||||
- added electro@mrduck.net's PAM patch, crazy :)
|
||||
|
||||
* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
|
||||
- Bump release + rebuild.
|
||||
|
||||
* Tue Feb 13 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- fix configure.in to use correct code to check for select()
|
||||
|
||||
* Wed Jan 10 2001 Tim Waugh <twaugh@redhat.com>
|
||||
- Rebuild, which will hopefully fix bug #22537
|
||||
|
||||
* Sun Oct 01 2000 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- update to 3.9.8
|
||||
- change the .jbj patch and add some more "user" -> "auser" cases
|
||||
|
||||
* Thu Aug 15 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- Patched the documentation to change the 'C-a C-\' to 'C-a \',
|
||||
- which is what is the real behaviour. this fixes bug #16103
|
||||
|
||||
* Thu Aug 3 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- Fixed my fix, so that the hack goes in the /global/ file :)
|
||||
|
||||
* Thu Aug 3 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- Stuck an entry into the default screenrc file that forces
|
||||
- '^?' (backspace) to send '^H'.
|
||||
- Its an ugly fix for a termcap inheritance problem,
|
||||
- but it works, if anyone REALLY needs '^?' they can change it,
|
||||
- and I think we anger less people with this than the way it
|
||||
- currently behaves. (Read: vi and emacs work now)
|
||||
- POST NOTE (Aug 15): emacs is NOT happy with ^H, BUT screen thinks
|
||||
- that this is what backspace is supposed to do, so we don't change it.
|
||||
|
||||
* Thu Aug 3 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- Fixed some conflicting descriptions in the documentation
|
||||
|
||||
* Thu Aug 3 2000 Crutcher Dunnavant <crutcher@redhat.com>
|
||||
- got a patch from rzm@icm.edu.pl to fix bug #10353
|
||||
- which caused screen to crash when copying to a file buffer
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
|
||||
- rebuild, FHS tweaks
|
||||
|
||||
* Sat May 6 2000 Bill Nottingham <notting@redhat.com>
|
||||
- fix build for ia64
|
||||
|
||||
* Mon Apr 3 2000 Bernhard Rosenkränzer <bero@redhat.com>
|
||||
- rebuild with new ncurses
|
||||
|
||||
* Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- rebuild for sparc baud rates > 38400.
|
||||
|
||||
* Tue Feb 15 2000 Bernhard Rosenkränzer <bero@redhat.com>
|
||||
- Fix MD5 password support (Bug #9463)
|
||||
|
||||
* Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
|
||||
- handle compressed man pages
|
||||
|
||||
* Fri Dec 10 1999 Bill Nottingham <notting@redhat.com>
|
||||
- update to 3.9.5
|
||||
|
||||
* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
|
||||
- you know, we weren't just patching in Unix98 pty support for fun.
|
||||
|
||||
* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
|
||||
- put screendir in ~
|
||||
|
||||
* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 3.9.4.
|
||||
|
||||
* Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
|
||||
- force tty permissions/group
|
||||
|
||||
* Wed Jun 5 1999 Dale Lovelace <dale@redhat.com>
|
||||
- permissions on /etc/skel/.screenrc to 644
|
||||
|
||||
* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
|
||||
- take out warning of directory permissions so root can still use screen
|
||||
|
||||
* Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
|
||||
- take out warning of directory ownership so root can still use screen
|
||||
|
||||
* Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
|
||||
- patched in utempter support, turned off setuid bit
|
||||
|
||||
* Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
|
||||
- fixed unix98 pty support
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 3)
|
||||
|
||||
* Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
|
||||
- add patch for Unix98 pty support
|
||||
|
||||
* Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 3.7.6.
|
||||
|
||||
* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- build root
|
||||
|
||||
* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
|
||||
- translations modified for de, fr, tr
|
||||
|
||||
* Wed Oct 21 1997 Cristian Gafton <gafton@redhat.com>
|
||||
- upgraded to 3.7.4
|
||||
|
||||
* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
|
||||
- removed glibc 1.99 specific patch
|
||||
|
||||
* Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
|
||||
- added install-info support
|
||||
|
||||
* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
|
||||
- built against glibc
|
Loading…
Reference in new issue