New upstream release 4.7.0

- drop Patch6 (texinfo): it's no longer needed as contributor list
   uses @verbatim now
 - drop unused screen-altscreen.patch
 - added descriptions to patches

Resolves: #1757638
epel9
Vaclav Dolezal 5 years ago
parent 258b6de8e2
commit 1c81c3cfed

1
.gitignore vendored

@ -12,3 +12,4 @@ screen-4.0.3.tar.gz
/screen-4.6.0.tar.gz
/screen-4.6.1.tar.gz
/screen-4.6.2.tar.gz
/screen-4.7.0.tar.gz

@ -1,3 +1,5 @@
check crypt output (rhbz#815605)
diff --git a/misc.c b/misc.c
index 43e93a2..178fda9 100644
--- a/misc.c

@ -1,10 +1,10 @@
diff --git a/configure.ac b/configure.ac
index ffe2e37..768f762 100644
index ab799d2..6b8b03f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -203,7 +203,8 @@ AC_EGREP_CPP(yes,
], LIBS="$LIBS -lsocket -linet";seqptx=1)
@@ -188,7 +188,8 @@ AC_EGREP_CPP(yes,
], AC_NOTE(- you have a SVR4 system) AC_DEFINE(SVR4) svr4=1)
if test -n "$svr4" ; then
oldlibs="$LIBS"
-LIBS="$LIBS -lelf"
+# Humm we don't actually need to link against libelf for Linux
@ -12,7 +12,7 @@ index ffe2e37..768f762 100644
AC_CHECKING(SVR4)
AC_TRY_LINK([#include <utmpx.h>
],,
@@ -657,14 +658,10 @@ dnl
@@ -623,14 +624,10 @@ dnl
AC_CHECKING(for tgetent)
AC_TRY_LINK(,tgetent((char *)0, (char *)0);,,
olibs="$LIBS"
@ -29,22 +29,24 @@ index ffe2e37..768f762 100644
],,
LIBS="-ltermcap $olibs"
AC_CHECKING(libtermcap)
@@ -689,7 +686,7 @@ AC_MSG_ERROR(!!! no tgetent - no screen)))))))))
@@ -655,7 +652,7 @@ AC_MSG_ERROR(!!! no tgetent - no screen)))))))))
AC_TRY_RUN([
main()
{
- exit(strcmp(tgoto("%p1%d", 0, 1), "1") ? 0 : 1);
+ return 1;
}], AC_NOTE(- you use the termcap database),
AC_NOTE(- you use the terminfo database) AC_DEFINE(TERMINFO))
AC_CHECKING(ospeed)
@@ -887,9 +884,6 @@ fi
AC_NOTE(- you use the terminfo database) AC_DEFINE(TERMINFO),
AC_NOTE(- skipping check because we are cross compiling; assuming terminfo database is used) AC_DEFINE(TERMINFO))
@@ -861,11 +858,6 @@ fi
dnl
dnl **** loadav ****
dnl
-if test "$cross_compiling" = no ; then
-AC_CHECKING(for libutil(s))
-test -f /usr/lib/libutils.a && LIBS="$LIBS -lutils"
-test -f /usr/lib/libutil.a && LIBS="$LIBS -lutil"
-fi
AC_CHECKING(getloadavg)
AC_TRY_LINK(,[getloadavg((double *)0, 0);],

@ -1,8 +1,13 @@
Author: Loic Minier <lool@dooz.org>
Description: Unbreak several useful keybindings.
fix for nonworking ^a backspace (rhbz#708698)
diff --git a/termcap.c b/termcap.c
index 1d4724d..3270250 100644
--- a/termcap.c
+++ b/termcap.c
@@ -552,8 +552,6 @@
@@ -554,8 +554,6 @@ int map;
else
break;
}

@ -1,14 +0,0 @@
diff --git a/doc/screen.texinfo b/doc/screen.texinfo
--- a/doc/screen.texinfo
+++ b/doc/screen.texinfo
@@ -5796,8 +5796,8 @@ Contributors @*
============
@verbatim
- Thomas Renninger <treen@suse.com>,
- Axel Beckert <abe@deuxchevaux.org>,
+ Thomas Renninger <treen@@suse.com>,
+ Axel Beckert <abe@@deuxchevaux.org>,
Ken Beal <kbeal@@amber.ssd.csd.harris.com>,
Rudolf Koenig <rfkoenig@@informatik.uni-erlangen.de>,
Toerless Eckert <eckert@@informatik.uni-erlangen.de>,

@ -1,8 +1,15 @@
Clear scrollback buffer when locking terminal
Linux kernel 3.0 adds a new command to clear the scrollback buffer in
the linux console. It's available in the ncurses terminfo entry as
extended capability E3. This is useful to prevent an attacker to read
content of a locked terminal via Shift-PgUp key.
diff --git a/display.c b/display.c
index b11b18b..180f19c 100644
index a4d953a..9ce34dd 100644
--- a/display.c
+++ b/display.c
@@ -3818,4 +3818,10 @@ char **cmdv;
@@ -4079,4 +4079,10 @@ char **cmdv;
#endif /* BLANKER_PRG */
@ -14,10 +21,10 @@ index b11b18b..180f19c 100644
+}
diff --git a/extern.h b/extern.h
index 7966008..e1ec242 100644
index bb7d3fb..a2678e3 100644
--- a/extern.h
+++ b/extern.h
@@ -316,6 +316,7 @@ extern int color256to88 __P((int));
@@ -319,6 +319,7 @@ extern int color256to88 __P((int));
extern void ResetIdle __P((void));
extern void KillBlanker __P((void));
extern void DisplaySleep1000 __P((int, int));
@ -26,10 +33,10 @@ index 7966008..e1ec242 100644
/* resize.c */
extern int ChangeWindowSize __P((struct win *, int, int, int));
diff --git a/screen.c b/screen.c
index 64650e9..c68d949 100644
index c50952b..2fee7fa 100644
--- a/screen.c
+++ b/screen.c
@@ -1958,6 +1958,7 @@ void Detach(int mode)
@@ -1950,6 +1950,7 @@ void Detach(int mode)
case D_LOCK:
ClearAll();

@ -1,14 +0,0 @@
diff --git a/ansi.c b/ansi.c
index e76eef4..bbdc119 100644
--- a/ansi.c
+++ b/ansi.c
@@ -1444,8 +1444,8 @@ int c, intermediate;
else
{
if (curr->w_alt.on) {
- LeaveAltScreen(curr);
RestoreCursor(&curr->w_alt.cursor);
+ LeaveAltScreen(curr);
}
}
if (a1 == 47 && !i)

@ -3,8 +3,8 @@
Summary: A screen manager that supports multiple logins on one terminal
Name: screen
Version: 4.6.2
Release: 9%{?dist}
Version: 4.7.0
Release: 1%{?dist}
License: GPLv3+
URL: http://www.gnu.org/software/screen
Requires(pre): /usr/sbin/groupadd
@ -13,9 +13,7 @@ BuildRequires: automake gcc
# for %%_tmpfilesdir macro
BuildRequires: systemd
# Upstream source:
# wget ftp://ftp.gnu.org/gnu/screen/screen-%%{version}.tar.gz
Source0: screen-%{version}.tar.gz
Source0: https://ftp.gnu.org/gnu/screen/screen-%{version}.tar.gz
Source1: screen.pam
Patch1: screen-4.3.1-libs.patch
@ -23,7 +21,6 @@ Patch2: screen-4.3.1-screenrc.patch
Patch3: screen-E3.patch
Patch4: screen-4.3.1-suppress_remap.patch
Patch5: screen-4.3.1-crypt.patch
Patch6: screen-4.5.1-texinfo.patch
%description
The screen utility allows you to have multiple logins on just one
@ -117,6 +114,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%endif
%changelog
* Thu Oct 03 2019 Vaclav Dolezal <vdolezal@redhat.com> - 4.7.0-1
- New upstream release 4.7.0 (#1757638)
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.6.2-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (screen-4.6.2.tar.gz) = 224bd16ad5ae501d1b8bb7d2ba9cc19e6a0743de5a5b320109c2f6bf3b1ca564cc7094ed9211be13733d9d769cde77d13fe236341d448cad0518038ab1e85c99
SHA512 (screen-4.7.0.tar.gz) = 44c7a33e2ed772ce91998cdc07556ef7b972e5b100335e14702b273a234e437fe6415de459e7b6d34c6086282a432778629047424ef9159ac6fcf26d22b45745

Loading…
Cancel
Save