fix paths to gnu-efi (work around #1608293)

f38
Dominik 'Rathann' Mierzejewski 7 years ago
parent e18c2e43df
commit e0495cb027

@ -1,7 +1,15 @@
diff -up sbsigntools-0.9.1/configure.ac.gnuefi sbsigntools-0.9.1/configure.ac
--- sbsigntools-0.9.1/configure.ac.gnuefi 2018-02-21 17:48:52.000000000 +0100
+++ sbsigntools-0.9.1/configure.ac 2018-02-22 13:26:50.529433565 +0100
@@ -70,7 +70,7 @@ AM_CONDITIONAL(TEST_BINARY_FORMAT, [ tes
diff -up sbsigntools-0.9.1/configure.ac.orig sbsigntools-0.9.1/configure.ac
--- sbsigntools-0.9.1/configure.ac.orig 2018-02-21 17:48:52.000000001 +0100
+++ sbsigntools-0.9.1/configure.ac 2018-07-25 11:08:39.869451195 +0200
@@ -64,13 +64,13 @@ PKG_CHECK_MODULES(uuid, uuid,
AC_MSG_ERROR([libuuid (from the uuid package) is required]))
dnl gnu-efi headers require extra include dirs
-EFI_ARCH=$(uname -m | sed 's/i.86/ia32/;s/arm.*/arm/')
-AM_CONDITIONAL(TEST_BINARY_FORMAT, [ test "$EFI_ARCH" = "arm" -o "$EFI_ARCH" = "aarch64" ])
+EFI_ARCH=$(uname -m | sed -e 's/i.86/ia32/;s/arm.*/arm/' -e 's/x86_64/x64/' -e 's/aarch64/aa64/')
+AM_CONDITIONAL(TEST_BINARY_FORMAT, [ test "$EFI_ARCH" = "arm" -o "$EFI_ARCH" = "aa64" ])
##
# no consistent view of where gnu-efi should dump the efi stuff, so find it
##
@ -10,9 +18,18 @@ diff -up sbsigntools-0.9.1/configure.ac.gnuefi sbsigntools-0.9.1/configure.ac
if test -e $path/crt0-efi-$EFI_ARCH.o; then
CRTPATH=$path
fi
diff -up sbsigntools-0.9.1/tests/Makefile.am.gnuefi sbsigntools-0.9.1/tests/Makefile.am
--- sbsigntools-0.9.1/tests/Makefile.am.gnuefi 2018-02-21 17:48:52.000000000 +0100
+++ sbsigntools-0.9.1/tests/Makefile.am 2018-02-22 13:58:10.297539648 +0100
diff -up sbsigntools-0.9.1/tests/Makefile.am.orig sbsigntools-0.9.1/tests/Makefile.am
--- sbsigntools-0.9.1/tests/Makefile.am.orig 2018-02-21 17:48:52.000000001 +0100
+++ sbsigntools-0.9.1/tests/Makefile.am 2018-07-25 12:20:00.188006224 +0200
@@ -14,7 +14,7 @@ if TEST_BINARY_FORMAT
EFILDFLAGS = --defsym=EFI_SUBSYSTEM=0x0a
FORMAT = -O binary
else
-FORMAT = --target=efi-app-$(EFI_ARCH)
+FORMAT = --target=efi-app-$(EFI_ARCH:x64=x86_64)
endif
check_DATA = $(test_key) $(test_cert)
check_SCRIPTS = test-wrapper.sh
@@ -27,7 +27,7 @@ check_SCRIPTS = test-wrapper.sh
$(FORMAT) $^ $@

@ -2,7 +2,7 @@
Name: sbsigntools
Version: 0.9.1
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Signing utility for UEFI secure boot
License: GPLv3+
URL: https://build.opensuse.org/package/show/home:jejb1:UEFI/sbsigntools
@ -19,7 +19,7 @@ ExclusiveArch: x86_64 aarch64 %{arm} %{ix86}
BuildRequires: automake
BuildRequires: binutils-devel
BuildRequires: gcc
BuildRequires: gnu-efi-devel
BuildRequires: gnu-efi-devel >= 3.0.8-3
BuildRequires: help2man
BuildRequires: libuuid-devel
%if %{with check}
@ -67,6 +67,9 @@ make check
%{_mandir}/man1/sbverify.1.*
%changelog
* Wed Jul 25 2018 Dominik Mierzejewski <dominik@greysector.net> - 0.9.1-3
- fix paths to gnu-efi (work around #1608293)
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

Loading…
Cancel
Save