|
|
|
@ -1,7 +1,15 @@
|
|
|
|
|
diff -up sbsigntools-0.9.1/configure.ac.gnuefi sbsigntools-0.9.1/configure.ac
|
|
|
|
|
--- sbsigntools-0.9.1/configure.ac.gnuefi 2018-02-21 17:48:52.000000000 +0100
|
|
|
|
|
+++ sbsigntools-0.9.1/configure.ac 2018-02-22 13:26:50.529433565 +0100
|
|
|
|
|
@@ -70,7 +70,7 @@ AM_CONDITIONAL(TEST_BINARY_FORMAT, [ tes
|
|
|
|
|
diff -up sbsigntools-0.9.1/configure.ac.orig sbsigntools-0.9.1/configure.ac
|
|
|
|
|
--- sbsigntools-0.9.1/configure.ac.orig 2018-02-21 17:48:52.000000001 +0100
|
|
|
|
|
+++ sbsigntools-0.9.1/configure.ac 2018-07-25 11:08:39.869451195 +0200
|
|
|
|
|
@@ -64,13 +64,13 @@ PKG_CHECK_MODULES(uuid, uuid,
|
|
|
|
|
AC_MSG_ERROR([libuuid (from the uuid package) is required]))
|
|
|
|
|
|
|
|
|
|
dnl gnu-efi headers require extra include dirs
|
|
|
|
|
-EFI_ARCH=$(uname -m | sed 's/i.86/ia32/;s/arm.*/arm/')
|
|
|
|
|
-AM_CONDITIONAL(TEST_BINARY_FORMAT, [ test "$EFI_ARCH" = "arm" -o "$EFI_ARCH" = "aarch64" ])
|
|
|
|
|
+EFI_ARCH=$(uname -m | sed -e 's/i.86/ia32/;s/arm.*/arm/' -e 's/x86_64/x64/' -e 's/aarch64/aa64/')
|
|
|
|
|
+AM_CONDITIONAL(TEST_BINARY_FORMAT, [ test "$EFI_ARCH" = "arm" -o "$EFI_ARCH" = "aa64" ])
|
|
|
|
|
|
|
|
|
|
##
|
|
|
|
|
# no consistent view of where gnu-efi should dump the efi stuff, so find it
|
|
|
|
|
##
|
|
|
|
@ -10,9 +18,18 @@ diff -up sbsigntools-0.9.1/configure.ac.gnuefi sbsigntools-0.9.1/configure.ac
|
|
|
|
|
if test -e $path/crt0-efi-$EFI_ARCH.o; then
|
|
|
|
|
CRTPATH=$path
|
|
|
|
|
fi
|
|
|
|
|
diff -up sbsigntools-0.9.1/tests/Makefile.am.gnuefi sbsigntools-0.9.1/tests/Makefile.am
|
|
|
|
|
--- sbsigntools-0.9.1/tests/Makefile.am.gnuefi 2018-02-21 17:48:52.000000000 +0100
|
|
|
|
|
+++ sbsigntools-0.9.1/tests/Makefile.am 2018-02-22 13:58:10.297539648 +0100
|
|
|
|
|
diff -up sbsigntools-0.9.1/tests/Makefile.am.orig sbsigntools-0.9.1/tests/Makefile.am
|
|
|
|
|
--- sbsigntools-0.9.1/tests/Makefile.am.orig 2018-02-21 17:48:52.000000001 +0100
|
|
|
|
|
+++ sbsigntools-0.9.1/tests/Makefile.am 2018-07-25 12:20:00.188006224 +0200
|
|
|
|
|
@@ -14,7 +14,7 @@ if TEST_BINARY_FORMAT
|
|
|
|
|
EFILDFLAGS = --defsym=EFI_SUBSYSTEM=0x0a
|
|
|
|
|
FORMAT = -O binary
|
|
|
|
|
else
|
|
|
|
|
-FORMAT = --target=efi-app-$(EFI_ARCH)
|
|
|
|
|
+FORMAT = --target=efi-app-$(EFI_ARCH:x64=x86_64)
|
|
|
|
|
endif
|
|
|
|
|
check_DATA = $(test_key) $(test_cert)
|
|
|
|
|
check_SCRIPTS = test-wrapper.sh
|
|
|
|
|
@@ -27,7 +27,7 @@ check_SCRIPTS = test-wrapper.sh
|
|
|
|
|
$(FORMAT) $^ $@
|
|
|
|
|
|
|
|
|
|