Merge branch 'f28' into f29

f38
Dominik 'Rathann' Mierzejewski 6 years ago
commit 81092b6262

1
.gitignore vendored

@ -1 +1,2 @@
/sbsigntools-0.9.1.tar.xz /sbsigntools-0.9.1.tar.xz
/sbsigntools-0.9.2.tar.xz

@ -1,7 +1,7 @@
diff -up sbsigntools-0.9.1/configure.ac.orig sbsigntools-0.9.1/configure.ac diff -up sbsigntools-0.9.2/configure.ac.orig sbsigntools-0.9.2/configure.ac
--- sbsigntools-0.9.1/configure.ac.orig 2018-02-21 17:48:52.000000001 +0100 --- sbsigntools-0.9.2/configure.ac.orig 2019-02-28 01:20:11.000000000 +0100
+++ sbsigntools-0.9.1/configure.ac 2018-07-25 11:08:39.869451195 +0200 +++ sbsigntools-0.9.2/configure.ac 2019-02-28 10:55:56.214136475 +0100
@@ -64,13 +64,13 @@ PKG_CHECK_MODULES(uuid, uuid, @@ -64,8 +64,8 @@ PKG_CHECK_MODULES(uuid, uuid,
AC_MSG_ERROR([libuuid (from the uuid package) is required])) AC_MSG_ERROR([libuuid (from the uuid package) is required]))
dnl gnu-efi headers require extra include dirs dnl gnu-efi headers require extra include dirs
@ -12,15 +12,9 @@ diff -up sbsigntools-0.9.1/configure.ac.orig sbsigntools-0.9.1/configure.ac
## ##
# no consistent view of where gnu-efi should dump the efi stuff, so find it # no consistent view of where gnu-efi should dump the efi stuff, so find it
## diff -up sbsigntools-0.9.2/tests/Makefile.am.orig sbsigntools-0.9.2/tests/Makefile.am
-for path in /lib /lib64 /usr/lib /usr/lib64 /usr/lib32 /lib/efi /lib64/efi /usr/lib/efi /usr/lib64/efi; do --- sbsigntools-0.9.2/tests/Makefile.am.orig 2019-02-28 01:20:11.000000000 +0100
+for path in /lib /lib64 /usr/lib /usr/lib64 /usr/lib32 /lib/efi /lib64/efi /usr/lib/efi /usr/lib64/efi /usr/lib/gnuefi /usr/lib64/gnuefi ; do +++ sbsigntools-0.9.2/tests/Makefile.am 2019-02-28 10:55:14.399450851 +0100
if test -e $path/crt0-efi-$EFI_ARCH.o; then
CRTPATH=$path
fi
diff -up sbsigntools-0.9.1/tests/Makefile.am.orig sbsigntools-0.9.1/tests/Makefile.am
--- sbsigntools-0.9.1/tests/Makefile.am.orig 2018-02-21 17:48:52.000000001 +0100
+++ sbsigntools-0.9.1/tests/Makefile.am 2018-07-25 12:20:00.188006224 +0200
@@ -14,7 +14,7 @@ if TEST_BINARY_FORMAT @@ -14,7 +14,7 @@ if TEST_BINARY_FORMAT
EFILDFLAGS = --defsym=EFI_SUBSYSTEM=0x0a EFILDFLAGS = --defsym=EFI_SUBSYSTEM=0x0a
FORMAT = -O binary FORMAT = -O binary
@ -34,8 +28,8 @@ diff -up sbsigntools-0.9.1/tests/Makefile.am.orig sbsigntools-0.9.1/tests/Makefi
$(FORMAT) $^ $@ $(FORMAT) $^ $@
.$(OBJEXT).elf: .$(OBJEXT).elf:
- $(LD) $(EFILDFLAGS) -nostdlib -L $(CRTPATH) -shared -Bsymbolic $(CRTPATH)/crt0-efi-$(EFI_ARCH).o -T elf_$(EFI_ARCH)_efi.lds $< -o $@ -lefi -lgnuefi - $(LD) $(EFILDFLAGS) -nostdlib -L /usr/lib -L /usr/lib64 -L $(CRTPATH) -shared -Bsymbolic $(CRTPATH)/crt0-efi-$(EFI_ARCH).o -T elf_$(EFI_ARCH)_efi.lds $< -o $@ -lefi -lgnuefi
+ $(LD) $(EFILDFLAGS) -nostdlib -L $(CRTPATH) -shared -Bsymbolic $(CRTPATH)/crt0-efi-$(EFI_ARCH).o -T elf_$(EFI_ARCH)_efi.lds $< -o $@ @libdir@/libefi.a @libdir@/libgnuefi.a + $(LD) $(EFILDFLAGS) -nostdlib -L /usr/lib -L /usr/lib64 -L $(CRTPATH) -shared -Bsymbolic $(CRTPATH)/crt0-efi-$(EFI_ARCH).o -T elf_$(EFI_ARCH)_efi.lds $< -o $@ @libdir@/libefi.a @libdir@/libgnuefi.a
AM_CFLAGS=-fpic -I/usr/include/efi -I/usr/include/efi/$(EFI_ARCH) AM_CFLAGS=-fpic -I/usr/include/efi -I/usr/include/efi/$(EFI_ARCH)

@ -1,8 +1,8 @@
%bcond_without check %bcond_without check
Name: sbsigntools Name: sbsigntools
Version: 0.9.1 Version: 0.9.2
Release: 3%{?dist} Release: 1%{?dist}
Summary: Signing utility for UEFI secure boot Summary: Signing utility for UEFI secure boot
License: GPLv3+ License: GPLv3+
URL: https://build.opensuse.org/package/show/home:jejb1:UEFI/sbsigntools URL: https://build.opensuse.org/package/show/home:jejb1:UEFI/sbsigntools
@ -67,6 +67,9 @@ make check
%{_mandir}/man1/sbverify.1.* %{_mandir}/man1/sbverify.1.*
%changelog %changelog
* Thu Feb 28 2019 Dominik Mierzejewski <dominik@greysector.net> - 0.9.2-1
- update to 0.9.2
* Wed Jul 25 2018 Dominik Mierzejewski <dominik@greysector.net> - 0.9.1-3 * Wed Jul 25 2018 Dominik Mierzejewski <dominik@greysector.net> - 0.9.1-3
- fix paths to gnu-efi (work around #1608293) - fix paths to gnu-efi (work around #1608293)

@ -1 +1 @@
SHA512 (sbsigntools-0.9.1.tar.xz) = d4102ba950321d43b7e592f83fddd536adc974a43f97df8cab00e2fd44d226fec6814d4065fe591fbeb3c006015cbbcb62586192447ebf21a1539b72b96408f2 SHA512 (sbsigntools-0.9.2.tar.xz) = 30c90e181e7a4446a3fec60876ad0dea68237565ba8722a0f9b84733c9df0ceaf81d0be176e5b9abe2c794879d2e7c174b6a37fb1bdc5cb77708ea1a294024a1

Loading…
Cancel
Save