i8c-stream-rhel_next
changed/i8c-stream-rhel_next/rust-1.76.0-1.module_el8+1017+a755c136
commit
bfa9d702ce
@ -0,0 +1,2 @@
|
||||
SOURCES/rustc-1.76.0-src.tar.xz
|
||||
SOURCES/wasi-libc-03b228e46bb02fcc5927253e1b8ad715072b1ae4.tar.gz
|
@ -0,0 +1,2 @@
|
||||
755339e8131d618d3c1095a581f27afc573ad310 SOURCES/rustc-1.76.0-src.tar.xz
|
||||
124d114ffb627ada36bfa1df0216bcea0f55a15e SOURCES/wasi-libc-03b228e46bb02fcc5927253e1b8ad715072b1ae4.tar.gz
|
@ -0,0 +1,53 @@
|
||||
From 184d61d2c12aa2db01de9a14ccb2be0cfae5039b Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Fri, 9 Jun 2023 15:23:08 -0700
|
||||
Subject: [PATCH] Let environment variables override some default CPUs
|
||||
|
||||
---
|
||||
.../src/spec/targets/powerpc64le_unknown_linux_gnu.rs | 2 +-
|
||||
.../rustc_target/src/spec/targets/s390x_unknown_linux_gnu.rs | 2 +-
|
||||
.../rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/powerpc64le_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/powerpc64le_unknown_linux_gnu.rs
|
||||
index 194c3170e683..9806ca78297c 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/powerpc64le_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/powerpc64le_unknown_linux_gnu.rs
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
pub fn target() -> Target {
|
||||
let mut base = base::linux_gnu::opts();
|
||||
- base.cpu = "ppc64le".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_PPC64LE").unwrap_or("ppc64le").into();
|
||||
base.add_pre_link_args(LinkerFlavor::Gnu(Cc::Yes, Lld::No), &["-m64"]);
|
||||
base.max_atomic_width = Some(64);
|
||||
base.stack_probes = StackProbeType::Inline;
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/s390x_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/s390x_unknown_linux_gnu.rs
|
||||
index 6fc410eb2235..c8f84edb9715 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/s390x_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/s390x_unknown_linux_gnu.rs
|
||||
@@ -5,7 +5,7 @@ pub fn target() -> Target {
|
||||
let mut base = base::linux_gnu::opts();
|
||||
base.endian = Endian::Big;
|
||||
// z10 is the oldest CPU supported by LLVM
|
||||
- base.cpu = "z10".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_S390X").unwrap_or("z10").into();
|
||||
// FIXME: The ABI implementation in cabi_s390x.rs is for now hard-coded to assume the no-vector
|
||||
// ABI. Pass the -vector feature string to LLVM to respect this assumption. On LLVM < 16, we
|
||||
// also strip v128 from the data_layout below to match the older LLVM's expectation.
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
index 80e267c163fa..8436a00e66d5 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
pub fn target() -> Target {
|
||||
let mut base = base::linux_gnu::opts();
|
||||
- base.cpu = "x86-64".into();
|
||||
+ base.cpu = option_env!("RUSTC_TARGET_CPU_X86_64").unwrap_or("x86-64").into();
|
||||
base.plt_by_default = false;
|
||||
base.max_atomic_width = Some(64);
|
||||
base.add_pre_link_args(LinkerFlavor::Gnu(Cc::Yes, Lld::No), &["-m64"]);
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,53 @@
|
||||
From 61b5cc96337da2121221dd1bcdb63fd36551d065 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Wed, 1 Nov 2023 15:21:15 -0700
|
||||
Subject: [PATCH] Use lld provided by system
|
||||
|
||||
---
|
||||
compiler/rustc_target/src/spec/base/wasm.rs | 3 +--
|
||||
compiler/rustc_target/src/spec/targets/x86_64_unknown_none.rs | 2 +-
|
||||
compiler/rustc_target/src/spec/targets/x86_64_unknown_uefi.rs | 1 +
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/base/wasm.rs b/compiler/rustc_target/src/spec/base/wasm.rs
|
||||
index 87ade9e58cf4..2ddff95febab 100644
|
||||
--- a/compiler/rustc_target/src/spec/base/wasm.rs
|
||||
+++ b/compiler/rustc_target/src/spec/base/wasm.rs
|
||||
@@ -91,8 +91,7 @@ macro_rules! args {
|
||||
// arguments just yet
|
||||
limit_rdylib_exports: false,
|
||||
|
||||
- // we use the LLD shipped with the Rust toolchain by default
|
||||
- linker: Some("rust-lld".into()),
|
||||
+ linker: Some("lld".into()),
|
||||
linker_flavor: LinkerFlavor::WasmLld(Cc::No),
|
||||
|
||||
pre_link_args,
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_none.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_none.rs
|
||||
index 9aa95a35f8e5..a9172f9441b7 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_none.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_none.rs
|
||||
@@ -17,7 +17,7 @@ pub fn target() -> Target {
|
||||
static_position_independent_executables: true,
|
||||
relro_level: RelroLevel::Full,
|
||||
linker_flavor: LinkerFlavor::Gnu(Cc::No, Lld::Yes),
|
||||
- linker: Some("rust-lld".into()),
|
||||
+ linker: Some("lld".into()),
|
||||
features:
|
||||
"-mmx,-sse,-sse2,-sse3,-ssse3,-sse4.1,-sse4.2,-3dnow,-3dnowa,-avx,-avx2,+soft-float"
|
||||
.into(),
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_uefi.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_uefi.rs
|
||||
index 5abfb8162f70..13cb43bda1a4 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_uefi.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_uefi.rs
|
||||
@@ -16,6 +16,7 @@ pub fn target() -> Target {
|
||||
base.plt_by_default = false;
|
||||
base.max_atomic_width = Some(64);
|
||||
base.entry_abi = Conv::X86_64Win64;
|
||||
+ base.linker = Some("lld".into());
|
||||
|
||||
// We disable MMX and SSE for now, even though UEFI allows using them. Problem is, you have to
|
||||
// enable these CPU features explicitly before their first use, otherwise their instructions
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,102 @@
|
||||
From df0d6f1d8b46db82d7599ca8eff6e8f844cf52f2 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Thu, 28 Sep 2023 18:14:28 -0700
|
||||
Subject: [PATCH 1/2] bootstrap: allow disabling target self-contained
|
||||
|
||||
---
|
||||
config.example.toml | 5 +++++
|
||||
src/bootstrap/src/core/build_steps/compile.rs | 4 ++++
|
||||
src/bootstrap/src/core/config/config.rs | 8 ++++++++
|
||||
src/bootstrap/src/lib.rs | 5 +++++
|
||||
4 files changed, 22 insertions(+)
|
||||
|
||||
diff --git a/config.example.toml b/config.example.toml
|
||||
index e5df28a49af6..2fcd8b8cb057 100644
|
||||
--- a/config.example.toml
|
||||
+++ b/config.example.toml
|
||||
@@ -807,6 +807,11 @@ change-id = 116881
|
||||
# target triples containing `-none`, `nvptx`, `switch`, or `-uefi`.
|
||||
#no-std = <platform-specific> (bool)
|
||||
|
||||
+# Copy libc and CRT objects into the target lib/self-contained/ directory.
|
||||
+# Enabled by default on `musl`, `wasi`, and `windows-gnu` targets. Other
|
||||
+# targets may ignore this setting if they have nothing to be contained.
|
||||
+#self-contained = <platform-specific> (bool)
|
||||
+
|
||||
# =============================================================================
|
||||
# Distribution options
|
||||
#
|
||||
diff --git a/src/bootstrap/src/core/build_steps/compile.rs b/src/bootstrap/src/core/build_steps/compile.rs
|
||||
index 7021a9543582..11555c65ca87 100644
|
||||
--- a/src/bootstrap/src/core/build_steps/compile.rs
|
||||
+++ b/src/bootstrap/src/core/build_steps/compile.rs
|
||||
@@ -302,6 +302,10 @@ fn copy_self_contained_objects(
|
||||
compiler: &Compiler,
|
||||
target: TargetSelection,
|
||||
) -> Vec<(PathBuf, DependencyType)> {
|
||||
+ if builder.self_contained(target) != Some(true) {
|
||||
+ return vec![];
|
||||
+ }
|
||||
+
|
||||
let libdir_self_contained = builder.sysroot_libdir(*compiler, target).join("self-contained");
|
||||
t!(fs::create_dir_all(&libdir_self_contained));
|
||||
let mut target_deps = vec![];
|
||||
diff --git a/src/bootstrap/src/core/config/config.rs b/src/bootstrap/src/core/config/config.rs
|
||||
index 0a9175aa3ea5..a2e028b25036 100644
|
||||
--- a/src/bootstrap/src/core/config/config.rs
|
||||
+++ b/src/bootstrap/src/core/config/config.rs
|
||||
@@ -533,6 +533,7 @@ pub struct Target {
|
||||
pub wasi_root: Option<PathBuf>,
|
||||
pub qemu_rootfs: Option<PathBuf>,
|
||||
pub no_std: bool,
|
||||
+ pub self_contained: bool,
|
||||
}
|
||||
|
||||
impl Target {
|
||||
@@ -541,6 +542,9 @@ pub fn from_triple(triple: &str) -> Self {
|
||||
if triple.contains("-none") || triple.contains("nvptx") || triple.contains("switch") {
|
||||
target.no_std = true;
|
||||
}
|
||||
+ if triple.contains("-musl") || triple.contains("-wasi") || triple.contains("-windows-gnu") {
|
||||
+ target.self_contained = true;
|
||||
+ }
|
||||
target
|
||||
}
|
||||
}
|
||||
@@ -1051,6 +1055,7 @@ struct TomlTarget {
|
||||
wasi_root: Option<String> = "wasi-root",
|
||||
qemu_rootfs: Option<String> = "qemu-rootfs",
|
||||
no_std: Option<bool> = "no-std",
|
||||
+ self_contained: Option<bool> = "self-contained",
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1600,6 +1605,9 @@ fn get_table(option: &str) -> Result<TomlConfig, toml::de::Error> {
|
||||
if let Some(s) = cfg.no_std {
|
||||
target.no_std = s;
|
||||
}
|
||||
+ if let Some(s) = cfg.self_contained {
|
||||
+ target.self_contained = s;
|
||||
+ }
|
||||
target.cc = cfg.cc.map(PathBuf::from);
|
||||
target.cxx = cfg.cxx.map(PathBuf::from);
|
||||
target.ar = cfg.ar.map(PathBuf::from);
|
||||
diff --git a/src/bootstrap/src/lib.rs b/src/bootstrap/src/lib.rs
|
||||
index 33b8f1a7ce72..f36e53187576 100644
|
||||
--- a/src/bootstrap/src/lib.rs
|
||||
+++ b/src/bootstrap/src/lib.rs
|
||||
@@ -1335,6 +1335,11 @@ fn no_std(&self, target: TargetSelection) -> Option<bool> {
|
||||
self.config.target_config.get(&target).map(|t| t.no_std)
|
||||
}
|
||||
|
||||
+ /// Returns `true` if this is a self-contained `target`, if defined
|
||||
+ fn self_contained(&self, target: TargetSelection) -> Option<bool> {
|
||||
+ self.config.target_config.get(&target).map(|t| t.self_contained)
|
||||
+ }
|
||||
+
|
||||
/// Returns `true` if the target will be tested using the `remote-test-client`
|
||||
/// and `remote-test-server` binaries.
|
||||
fn remote_tested(&self, target: TargetSelection) -> bool {
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,78 @@
|
||||
From 79bb610c8fc5d9df7dd4720ae847b8f17e7b1ad4 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Thu, 28 Sep 2023 18:18:16 -0700
|
||||
Subject: [PATCH 2/2] set an external library path for wasm32-wasi
|
||||
|
||||
---
|
||||
compiler/rustc_codegen_ssa/src/back/link.rs | 9 +++++++++
|
||||
compiler/rustc_target/src/spec/mod.rs | 2 ++
|
||||
compiler/rustc_target/src/spec/targets/wasm32_wasi.rs | 6 +++++-
|
||||
3 files changed, 16 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/compiler/rustc_codegen_ssa/src/back/link.rs b/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||
index dd9d277fb775..3d0f0502f255 100644
|
||||
--- a/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||
+++ b/compiler/rustc_codegen_ssa/src/back/link.rs
|
||||
@@ -1496,6 +1496,12 @@ fn get_object_file_path(sess: &Session, name: &str, self_contained: bool) -> Pat
|
||||
return file_path;
|
||||
}
|
||||
}
|
||||
+ if let Some(lib_path) = &sess.target.options.external_lib_path {
|
||||
+ let file_path = Path::new(lib_path.as_ref()).join(name);
|
||||
+ if file_path.exists() {
|
||||
+ return file_path;
|
||||
+ }
|
||||
+ }
|
||||
for search_path in fs.search_paths() {
|
||||
let file_path = search_path.dir.join(name);
|
||||
if file_path.exists() {
|
||||
@@ -1982,6 +1988,9 @@ fn add_library_search_dirs(cmd: &mut dyn Linker, sess: &Session, self_contained:
|
||||
let lib_path = sess.target_filesearch(PathKind::All).get_self_contained_lib_path();
|
||||
cmd.include_path(&fix_windows_verbatim_for_gcc(&lib_path));
|
||||
}
|
||||
+ if let Some(lib_path) = &sess.target.options.external_lib_path {
|
||||
+ cmd.include_path(Path::new(lib_path.as_ref()));
|
||||
+ }
|
||||
}
|
||||
|
||||
/// Add options making relocation sections in the produced ELF files read-only
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index f04799482c83..25410b37ba24 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -1874,6 +1874,7 @@ pub struct TargetOptions {
|
||||
/// Objects to link before and after all other object code.
|
||||
pub pre_link_objects: CrtObjects,
|
||||
pub post_link_objects: CrtObjects,
|
||||
+ pub external_lib_path: Option<StaticCow<str>>,
|
||||
/// Same as `(pre|post)_link_objects`, but when self-contained linking mode is enabled.
|
||||
pub pre_link_objects_self_contained: CrtObjects,
|
||||
pub post_link_objects_self_contained: CrtObjects,
|
||||
@@ -2352,6 +2353,7 @@ fn default() -> TargetOptions {
|
||||
relro_level: RelroLevel::None,
|
||||
pre_link_objects: Default::default(),
|
||||
post_link_objects: Default::default(),
|
||||
+ external_lib_path: None,
|
||||
pre_link_objects_self_contained: Default::default(),
|
||||
post_link_objects_self_contained: Default::default(),
|
||||
link_self_contained: LinkSelfContainedDefault::False,
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/wasm32_wasi.rs b/compiler/rustc_target/src/spec/targets/wasm32_wasi.rs
|
||||
index 6dbcb01ea436..2151f86d0648 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/wasm32_wasi.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/wasm32_wasi.rs
|
||||
@@ -86,7 +86,11 @@ pub fn target() -> Target {
|
||||
options.post_link_objects_self_contained = crt_objects::post_wasi_self_contained();
|
||||
|
||||
// FIXME: Figure out cases in which WASM needs to link with a native toolchain.
|
||||
- options.link_self_contained = LinkSelfContainedDefault::True;
|
||||
+ options.link_self_contained = LinkSelfContainedDefault::False;
|
||||
+
|
||||
+ options.pre_link_objects = options.pre_link_objects_self_contained.clone();
|
||||
+ options.post_link_objects = options.post_link_objects_self_contained.clone();
|
||||
+ options.external_lib_path = Some("/usr/wasm32-wasi/lib/wasm32-wasi".into());
|
||||
|
||||
// Right now this is a bit of a workaround but we're currently saying that
|
||||
// the target by default has a static crt which we're taking as a signal
|
||||
--
|
||||
2.41.0
|
||||
|
@ -0,0 +1,2 @@
|
||||
%__cargo_vendor_path ^%{_defaultlicensedir}(/[^/]+)+/cargo-vendor.txt$
|
||||
%__cargo_vendor_provides %{_rpmconfigdir}/cargo_vendor.prov
|
@ -0,0 +1,127 @@
|
||||
#! /usr/bin/python3 -s
|
||||
# Stripped down replacement for cargo2rpm parse-vendor-manifest
|
||||
|
||||
import re
|
||||
import subprocess
|
||||
import sys
|
||||
from typing import Optional
|
||||
|
||||
|
||||
VERSION_REGEX = re.compile(
|
||||
r"""
|
||||
^
|
||||
(?P<major>0|[1-9]\d*)
|
||||
\.(?P<minor>0|[1-9]\d*)
|
||||
\.(?P<patch>0|[1-9]\d*)
|
||||
(?:-(?P<pre>(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?
|
||||
(?:\+(?P<build>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$
|
||||
""",
|
||||
re.VERBOSE,
|
||||
)
|
||||
|
||||
|
||||
class Version:
|
||||
"""
|
||||
Version that adheres to the "semantic versioning" format.
|
||||
"""
|
||||
|
||||
def __init__(self, major: int, minor: int, patch: int, pre: Optional[str] = None, build: Optional[str] = None):
|
||||
self.major: int = major
|
||||
self.minor: int = minor
|
||||
self.patch: int = patch
|
||||
self.pre: Optional[str] = pre
|
||||
self.build: Optional[str] = build
|
||||
|
||||
@staticmethod
|
||||
def parse(version: str) -> "Version":
|
||||
"""
|
||||
Parses a version string and return a `Version` object.
|
||||
Raises a `ValueError` if the string does not match the expected format.
|
||||
"""
|
||||
|
||||
match = VERSION_REGEX.match(version)
|
||||
if not match:
|
||||
raise ValueError(f"Invalid version: {version!r}")
|
||||
|
||||
matches = match.groupdict()
|
||||
|
||||
major_str = matches["major"]
|
||||
minor_str = matches["minor"]
|
||||
patch_str = matches["patch"]
|
||||
pre = matches["pre"]
|
||||
build = matches["build"]
|
||||
|
||||
major = int(major_str)
|
||||
minor = int(minor_str)
|
||||
patch = int(patch_str)
|
||||
|
||||
return Version(major, minor, patch, pre, build)
|
||||
|
||||
def to_rpm(self) -> str:
|
||||
"""
|
||||
Formats the `Version` object as an equivalent RPM version string.
|
||||
Characters that are invalid in RPM versions are replaced ("-" -> "_")
|
||||
|
||||
Build metadata (the optional `Version.build` attribute) is dropped, so
|
||||
the conversion is not lossless for versions where this attribute is not
|
||||
`None`. However, build metadata is not intended to be part of the
|
||||
version (and is not even considered when doing version comparison), so
|
||||
dropping it when converting to the RPM version format is correct.
|
||||
"""
|
||||
|
||||
s = f"{self.major}.{self.minor}.{self.patch}"
|
||||
if self.pre:
|
||||
s += f"~{self.pre.replace('-', '_')}"
|
||||
return s
|
||||
|
||||
|
||||
def break_the_build(error: str):
|
||||
"""
|
||||
This function writes a string that is an invalid RPM dependency specifier,
|
||||
which causes dependency generators to fail and break the build. The
|
||||
additional error message is printed to stderr.
|
||||
"""
|
||||
|
||||
print("*** FATAL ERROR ***")
|
||||
print(error, file=sys.stderr)
|
||||
|
||||
|
||||
def get_cargo_vendor_txt_paths_from_stdin() -> set[str]: # pragma nocover
|
||||
"""
|
||||
Read lines from standard input and filter out lines that look like paths
|
||||
to `cargo-vendor.txt` files. This is how RPM generators pass lists of files.
|
||||
"""
|
||||
|
||||
lines = {line.rstrip("\n") for line in sys.stdin.readlines()}
|
||||
return {line for line in lines if line.endswith("/cargo-vendor.txt")}
|
||||
|
||||
|
||||
def action_parse_vendor_manifest():
|
||||
paths = get_cargo_vendor_txt_paths_from_stdin()
|
||||
|
||||
for path in paths:
|
||||
with open(path) as file:
|
||||
manifest = file.read()
|
||||
|
||||
for line in manifest.strip().splitlines():
|
||||
crate, version = line.split(" v")
|
||||
print(f"bundled(crate({crate})) = {Version.parse(version).to_rpm()}")
|
||||
|
||||
|
||||
def main():
|
||||
try:
|
||||
action_parse_vendor_manifest()
|
||||
exit(0)
|
||||
|
||||
# print an error message that is not a valid RPM dependency
|
||||
# to cause the generator to break the build
|
||||
except (IOError, ValueError) as exc:
|
||||
break_the_build(str(exc))
|
||||
exit(1)
|
||||
|
||||
break_the_build("Uncaught exception: This should not happen, please report a bug.")
|
||||
exit(1)
|
||||
|
||||
|
||||
if __name__ == "__main__":
|
||||
main()
|
@ -0,0 +1,247 @@
|
||||
# __rustc: path to the default rustc executable
|
||||
%__rustc /usr/bin/rustc
|
||||
|
||||
# __rustdoc: path to the default rustdoc executable
|
||||
%__rustdoc /usr/bin/rustdoc
|
||||
|
||||
# rustflags_opt_level: default optimization level
|
||||
#
|
||||
# It corresponds to the "-Copt-level" rustc command line option.
|
||||
%rustflags_opt_level 3
|
||||
|
||||
# rustflags_debuginfo: default verbosity of debug information
|
||||
#
|
||||
# It corresponds to the "-Cdebuginfo" rustc command line option.
|
||||
# In some cases, it might be required to override this macro with "1" or even
|
||||
# "0", if memory usage gets too high during builds on some resource-constrained
|
||||
# architectures (most likely on 32-bit architectures), which will however
|
||||
# reduce the quality of the produced debug symbols.
|
||||
%rustflags_debuginfo 2
|
||||
|
||||
# rustflags_codegen_units: default number of parallel code generation units
|
||||
#
|
||||
# The default value of "1" results in generation of better code, but comes at
|
||||
# the cost of longer build times.
|
||||
%rustflags_codegen_units 1
|
||||
|
||||
# build_rustflags: default compiler flags for rustc (RUSTFLAGS)
|
||||
#
|
||||
# -Copt-level: set optimization level (default: highest optimization level)
|
||||
# -Cdebuginfo: set debuginfo verbosity (default: full debug information)
|
||||
# -Ccodegen-units: set number of parallel code generation units (default: 1)
|
||||
#
|
||||
# ref. https://doc.rust-lang.org/rustc/codegen-options/index.html
|
||||
%build_rustflags %{shrink:
|
||||
-Copt-level=%rustflags_opt_level
|
||||
-Cdebuginfo=%rustflags_debuginfo
|
||||
-Ccodegen-units=%rustflags_codegen_units
|
||||
-Cstrip=none
|
||||
}
|
||||
|
||||
# __cargo: cargo command with environment variables
|
||||
#
|
||||
# CARGO_HOME: This ensures cargo reads configuration file from .cargo/config,
|
||||
# and prevents writing any files to $HOME during RPM builds.
|
||||
%__cargo /usr/bin/env CARGO_HOME=.cargo RUSTFLAGS='%{build_rustflags}' /usr/bin/cargo
|
||||
|
||||
# __cargo_common_opts: common command line flags for cargo
|
||||
#
|
||||
# _smp_mflags: run builds and tests in parallel
|
||||
%__cargo_common_opts %{?_smp_mflags}
|
||||
|
||||
# cargo_prep: macro to set up build environment for cargo projects
|
||||
#
|
||||
# This involves four steps:
|
||||
# - create the ".cargo" directory if it doesn't exist yet
|
||||
# - dump custom cargo configuration into ".cargo/config"
|
||||
# - remove "Cargo.lock" if it exists (it breaks builds with custom cargo config)
|
||||
# - remove "Cargo.toml.orig" if it exists (it breaks running "cargo package")
|
||||
#
|
||||
# Options:
|
||||
# -V <number> - unpack and use vendored sources from Source<number> tarball
|
||||
# (deprecated; use -v instead)
|
||||
# -v <directory> - use vendored sources from <directory>
|
||||
# -N - Don't set up any registry. Only set up the build configuration.
|
||||
%cargo_prep(V:v:N)\
|
||||
%{-v:%{-V:%{error:-v and -V are mutually exclusive!}}}\
|
||||
%{-v:%{-N:%{error:-v and -N are mutually exclusive!}}}\
|
||||
(\
|
||||
set -euo pipefail\
|
||||
%{__mkdir} -p target/rpm\
|
||||
/usr/bin/ln -s rpm target/release\
|
||||
%{__rm} -rf .cargo/\
|
||||
%{__mkdir} -p .cargo\
|
||||
cat > .cargo/config << EOF\
|
||||
[build]\
|
||||
rustc = "%{__rustc}"\
|
||||
rustdoc = "%{__rustdoc}"\
|
||||
\
|
||||
[profile.rpm]\
|
||||
inherits = "release"\
|
||||
opt-level = %{rustflags_opt_level}\
|
||||
codegen-units = %{rustflags_codegen_units}\
|
||||
debug = %{rustflags_debuginfo}\
|
||||
strip = "none"\
|
||||
\
|
||||
[env]\
|
||||
CFLAGS = "%{build_cflags}"\
|
||||
CXXFLAGS = "%{build_cxxflags}"\
|
||||
LDFLAGS = "%{build_ldflags}"\
|
||||
\
|
||||
[install]\
|
||||
root = "%{buildroot}%{_prefix}"\
|
||||
\
|
||||
[term]\
|
||||
verbose = true\
|
||||
EOF\
|
||||
%{-V:%{__tar} -xoaf %{S:%{-V*}}}\
|
||||
%{!?-N:\
|
||||
cat >> .cargo/config << EOF\
|
||||
[source.vendored-sources]\
|
||||
directory = "%{-v*}%{-V:./vendor}"\
|
||||
\
|
||||
[source.crates-io]\
|
||||
registry = "https://crates.io"\
|
||||
replace-with = "vendored-sources"\
|
||||
EOF}\
|
||||
%{__rm} -f Cargo.toml.orig\
|
||||
)
|
||||
|
||||
# __cargo_parse_opts: function-like macro which parses common flags into the
|
||||
# equivalent command-line flags for cargo
|
||||
%__cargo_parse_opts(naf:) %{shrink:\
|
||||
%{-n:%{-a:%{error:Can't specify both -n and -a}}} \
|
||||
%{-f:%{-a:%{error:Can't specify both -f(%{-f*}) and -a}}} \
|
||||
%{-n:--no-default-features} \
|
||||
%{-a:--all-features} \
|
||||
%{-f:--features %{-f*}} \
|
||||
%{nil} \
|
||||
}
|
||||
|
||||
# NB: cargo_build/test/install do not use the -n/-a/-f argument parsing like
|
||||
# Fedora's rust-packaging, because that change would break anyone that's
|
||||
# already passing arguments directly to cargo after the macro. Instead, one can
|
||||
# explicitly use --no-default-features, --all-features, or --features XYZ.
|
||||
|
||||
# cargo_build: builds the crate with cargo
|
||||
%cargo_build\
|
||||
%{shrink: \
|
||||
%{__cargo} build \
|
||||
%{__cargo_common_opts} \
|
||||
--profile rpm \
|
||||
}
|
||||
|
||||
# cargo_test: runs the test suite with cargo
|
||||
#
|
||||
# To pass command-line arguments to the cargo test runners directly (for
|
||||
# example, to skip certain tests during package builds), the
|
||||
# "cargo test" argument parsing need to be bypassed,
|
||||
# i.e. "%%cargo_test -- --skip foo" for skipping all tests with names that
|
||||
# match "foo".
|
||||
%cargo_test\
|
||||
%{shrink: \
|
||||
%{__cargo} test \
|
||||
%{__cargo_common_opts} \
|
||||
--profile rpm \
|
||||
--no-fail-fast \
|
||||
}
|
||||
|
||||
# cargo_install: install files into the buildroot
|
||||
#
|
||||
# For "binary" crates, this macro installs all "bin" build targets to _bindir
|
||||
# inside the buildroot. The "--no-track" option prevents the creation of the
|
||||
# "$CARGO_HOME/.crates.toml" file, which is used to keep track of which version
|
||||
# of a specific binary has been installed, but which conflicts between builds
|
||||
# of different Rust applications and is not needed when building RPM packages.
|
||||
%cargo_install\
|
||||
(\
|
||||
set -euo pipefail \
|
||||
%{shrink: \
|
||||
%{__cargo} install \
|
||||
%{__cargo_common_opts} \
|
||||
--profile rpm \
|
||||
--no-track \
|
||||
--path . \
|
||||
} \
|
||||
)
|
||||
|
||||
# cargo_license: print license information for all crate dependencies
|
||||
#
|
||||
# The "no-build,no-dev,no-proc-macro" argument results in only crates which are
|
||||
# linked into the final binary to be considered.
|
||||
#
|
||||
# Additionally, deprecated SPDX syntax ("/" instead of "OR") is normalized
|
||||
# before sorting the results to ensure reproducible output of this macro.
|
||||
#
|
||||
# This macro must be called with the same feature flags as other cargo macros,
|
||||
# in particular, "cargo_build", otherwise its output will be incomplete.
|
||||
#
|
||||
# The "cargo tree" command called by this macro will fail if there are missing
|
||||
# (optional) dependencies.
|
||||
%cargo_license(naf:)\
|
||||
(\
|
||||
set -euo pipefail\
|
||||
%{shrink: \
|
||||
%{__cargo} tree \
|
||||
--workspace \
|
||||
--offline \
|
||||
--edges no-build,no-dev,no-proc-macro \
|
||||
--no-dedupe \
|
||||
%{__cargo_parse_opts %{-n} %{-a} %{-f:-f%{-f*}}} \
|
||||
--prefix none \
|
||||
--format "{l}: {p}" \
|
||||
| sed -e "s: ($(pwd)[^)]*)::g" -e "s: / :/:g" -e "s:/: OR :g" \
|
||||
| sort -u \
|
||||
}\
|
||||
)
|
||||
|
||||
# cargo_license_summary: print license summary for all crate dependencies
|
||||
#
|
||||
# This macro works in the same way as cargo_license, except that it only prints
|
||||
# a list of licenses, and not the complete license information for every crate
|
||||
# in the dependency tree. This is useful for determining the correct License
|
||||
# tag for packages that contain compiled Rust binaries.
|
||||
%cargo_license_summary(naf:)\
|
||||
(\
|
||||
set -euo pipefail\
|
||||
%{shrink: \
|
||||
%{__cargo} tree \
|
||||
--workspace \
|
||||
--offline \
|
||||
--edges no-build,no-dev,no-proc-macro \
|
||||
--no-dedupe \
|
||||
%{__cargo_parse_opts %{-n} %{-a} %{-f:-f%{-f*}}} \
|
||||
--prefix none \
|
||||
--format "# {l}" \
|
||||
| sed -e "s: / :/:g" -e "s:/: OR :g" \
|
||||
| sort -u \
|
||||
}\
|
||||
)
|
||||
|
||||
# cargo_vendor_manifest: write list of vendored crates and their versions
|
||||
#
|
||||
# The arguments for the internal "cargo tree" call emulate the logic
|
||||
# that determines which crates are included when running "cargo vendor".
|
||||
# The results are written to "cargo-vendor.txt".
|
||||
#
|
||||
# TODO: --all-features may be overly broad; this should be modified to
|
||||
# use %%__cargo_parse_opts to handle feature flags.
|
||||
%cargo_vendor_manifest()\
|
||||
(\
|
||||
set -euo pipefail\
|
||||
%{shrink: \
|
||||
%{__cargo} tree \
|
||||
--workspace \
|
||||
--offline \
|
||||
--edges normal,build \
|
||||
--no-dedupe \
|
||||
--all-features \
|
||||
--prefix none \
|
||||
--format "{p}" \
|
||||
| grep -v "$(pwd)" \
|
||||
| sed -e "s: (proc-macro)::" \
|
||||
| sort -u \
|
||||
> cargo-vendor.txt \
|
||||
}\
|
||||
)
|
||||
|
@ -0,0 +1,21 @@
|
||||
diff --git a/src/etc/rust-gdb b/src/etc/rust-gdb
|
||||
index 9abed30ea6f7..e4bf55df3688 100755
|
||||
--- a/src/etc/rust-gdb
|
||||
+++ b/src/etc/rust-gdb
|
||||
@@ -13,8 +13,6 @@ fi
|
||||
# Find out where the pretty printer Python module is
|
||||
RUSTC_SYSROOT="$("$RUSTC" --print=sysroot)"
|
||||
GDB_PYTHON_MODULE_DIRECTORY="$RUSTC_SYSROOT/lib/rustlib/etc"
|
||||
-# Get the commit hash for path remapping
|
||||
-RUSTC_COMMIT_HASH="$("$RUSTC" -vV | sed -n 's/commit-hash: \([a-zA-Z0-9_]*\)/\1/p')"
|
||||
|
||||
# Run GDB with the additional arguments that load the pretty printers
|
||||
# Set the environment variable `RUST_GDB` to overwrite the call to a
|
||||
@@ -23,6 +21,6 @@ RUST_GDB="${RUST_GDB:-gdb}"
|
||||
PYTHONPATH="$PYTHONPATH:$GDB_PYTHON_MODULE_DIRECTORY" exec ${RUST_GDB} \
|
||||
--directory="$GDB_PYTHON_MODULE_DIRECTORY" \
|
||||
-iex "add-auto-load-safe-path $GDB_PYTHON_MODULE_DIRECTORY" \
|
||||
- -iex "set substitute-path /rustc/$RUSTC_COMMIT_HASH $RUSTC_SYSROOT/lib/rustlib/src/rust" \
|
||||
+ -iex "set substitute-path @BUILDDIR@ $RUSTC_SYSROOT/lib/rustlib/src/rust" \
|
||||
"$@"
|
||||
|
@ -0,0 +1,42 @@
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2024-01-07 18:12:08.000000000 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2024-01-09 15:25:51.519781381 -0800
|
||||
@@ -2071,7 +2071,6 @@
|
||||
dependencies = [
|
||||
"cc",
|
||||
"libc",
|
||||
- "libssh2-sys",
|
||||
"libz-sys",
|
||||
"openssl-sys",
|
||||
"pkg-config",
|
||||
@@ -2113,20 +2112,6 @@
|
||||
"pkg-config",
|
||||
"vcpkg",
|
||||
]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "libssh2-sys"
|
||||
-version = "0.3.0"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "2dc8a030b787e2119a731f1951d6a773e2280c660f8ec4b0f5e1505a386e71ee"
|
||||
-dependencies = [
|
||||
- "cc",
|
||||
- "libc",
|
||||
- "libz-sys",
|
||||
- "openssl-sys",
|
||||
- "pkg-config",
|
||||
- "vcpkg",
|
||||
-]
|
||||
|
||||
[[package]]
|
||||
name = "libz-sys"
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2024-01-09 15:23:02.369032291 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2024-01-09 15:24:44.015679666 -0800
|
||||
@@ -40,7 +40,7 @@
|
||||
curl-sys = "0.4.70"
|
||||
filetime = "0.2.22"
|
||||
flate2 = { version = "1.0.28", default-features = false, features = ["zlib"] }
|
||||
-git2 = "0.18.1"
|
||||
+git2 = { version = "0.18.1", default-features = false, features = ["https"] }
|
||||
git2-curl = "0.19.0"
|
||||
gix = { version = "0.56.0", default-features = false, features = ["blocking-http-transport-curl", "progress-tree", "revision"] }
|
||||
gix-features-for-configuration-only = { version = "0.35.0", package = "gix-features", features = [ "parallel" ] }
|
@ -0,0 +1,21 @@
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2024-01-07 18:12:08.000000000 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2024-01-09 15:36:23.808367445 -0800
|
||||
@@ -2109,7 +2109,6 @@
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "cf4e226dcd58b4be396f7bd3c20da8fdee2911400705297ba7d2d7cc2c30f716"
|
||||
dependencies = [
|
||||
- "cc",
|
||||
"pkg-config",
|
||||
"vcpkg",
|
||||
]
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2024-01-07 18:12:08.000000000 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2024-01-09 15:36:18.534437627 -0800
|
||||
@@ -73,7 +73,7 @@
|
||||
pulldown-cmark = { version = "0.9.3", default-features = false }
|
||||
rand = "0.8.5"
|
||||
regex = "1.10.2"
|
||||
-rusqlite = { version = "0.30.0", features = ["bundled"] }
|
||||
+rusqlite = { version = "0.30.0", features = [] }
|
||||
rustfix = { version = "0.7.0", path = "crates/rustfix" }
|
||||
same-file = "1.0.6"
|
||||
security-framework = "2.9.2"
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue