commit
d45ca937c7
Binary file not shown.
@ -0,0 +1,11 @@
|
||||
--- zstd-0.12.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zstd-0.12.4/Cargo.toml 2023-08-01T13:08:03.435950+00:00
|
||||
@@ -15,7 +15,7 @@
|
||||
name = "zstd"
|
||||
version = "0.12.4"
|
||||
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
|
||||
-exclude = ["assets/*.zst"]
|
||||
+exclude = ["/assets/", "/appveyor.yml", "/rustfmt.toml"]
|
||||
description = "Binding for the zstd compression library."
|
||||
documentation = "https://docs.rs/zstd"
|
||||
readme = "Readme.md"
|
@ -0,0 +1,309 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
# * tests require files that are not included in published crates
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate zstd
|
||||
|
||||
Name: rust-zstd
|
||||
Version: 0.12.4
|
||||
Release: %autorelease
|
||||
Summary: Binding for the zstd compression library
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/zstd
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * exclude files that are only useful for upstream development
|
||||
Patch: zstd-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Binding for the zstd compression library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/Readme.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+arrays-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+arrays-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "arrays" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+arrays-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bindgen-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bindgen-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bindgen" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bindgen-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+doc-cfg-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+doc-cfg-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "doc-cfg" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+doc-cfg-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+experimental-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+experimental-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "experimental" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+experimental-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+fat-lto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+fat-lto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "fat-lto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+fat-lto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+legacy-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+legacy-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "legacy" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+legacy-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+no_asm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+no_asm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "no_asm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+no_asm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pkg-config-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pkg-config-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pkg-config" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pkg-config-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+thin-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+thin-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "thin" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+thin-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+thin-lto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+thin-lto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "thin-lto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+thin-lto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+wasm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+wasm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "wasm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+wasm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zdict_builder-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zdict_builder-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zdict_builder" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zdict_builder-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zstdmt-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zstdmt-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zstdmt" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zstdmt-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.12.4-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.12.4-1
|
||||
- Update to version 0.12.4; Fixes RHBZ#2224018
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Feb 23 2023 Fabio Valentini <decathorpe@gmail.com> - 0.12.3-1
|
||||
- Update to version 0.12.3+zstd.1.5.2; Fixes RHBZ#2145248
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.11.2-1
|
||||
- Update to version 0.11.2+zstd.1.5.2; Fixes RHBZ#2043686
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue Apr 12 2022 Fabio Valentini <decathorpe@gmail.com> - 0.10.0-1
|
||||
- Update to version 0.10.0+zstd.1.5.2
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jan 07 2022 Fabio Valentini <decathorpe@gmail.com> - 0.9.2-1
|
||||
- Update to version 0.9.2+zstd.1.5.1; Fixes RHBZ#2035402
|
||||
|
||||
* Sun Nov 14 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.9.0-1
|
||||
- Update to 0.9.0 Close: rhbz#1960712
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-1
|
||||
- Update to version 0.8.0+zstd.1.4.9.
|
||||
|
||||
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.1-1
|
||||
- Update to version 0.6.1+zstd.1.4.9.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 0.5.3-1
|
||||
- Update to 0.5.3+zstd.1.4.5
|
||||
|
||||
* Sat Jun 06 2020 Josh Stone <jistone@redhat.com> - 0.5.2-1
|
||||
- Update to 0.5.2+zstd.1.4.5
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Dec 16 06:14:56 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.5.1-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue