update to version 0.8.0+zstd.1.4.9

epel9
Fabio Valentini 4 years ago
parent fda04f2e05
commit be1b30f561
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/zstd-0.5.2+zstd.1.4.5.crate
/zstd-0.5.3+zstd.1.4.5.crate
/zstd-0.6.1+zstd.1.4.9.crate
/zstd-0.8.0+zstd.1.4.9.crate

@ -1,13 +1,13 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 17
# Tests require files not included in crate
%bcond_with check
%global debug_package %{nil}
%global crate zstd
%global upstream_version 0.6.1+zstd.1.4.9
%global upstream_version 0.8.0+zstd.1.4.9
Name: rust-%{crate}
Version: 0.6.1
Version: 0.8.0
Release: 1%{?dist}
Summary: Binding for the zstd compression library
@ -17,7 +17,7 @@ URL: https://crates.io/crates/zstd
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove zstd version from version field
# * Remove bindgen feature as it is now the default to build with system zstd
# * Build zstd-sys with bindgen and pkg-config
Patch0: zstd-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -58,6 +58,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+bindgen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bindgen-devel %{_description}
This package contains library source intended for building other packages
which use "bindgen" feature of "%{crate}" crate.
%files -n %{name}+bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
@ -70,6 +82,18 @@ which use "debug" feature of "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+experimental-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+experimental-devel %{_description}
This package contains library source intended for building other packages
which use "experimental" feature of "%{crate}" crate.
%files -n %{name}+experimental-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+futures-devel
Summary: %{summary}
BuildArch: noarch
@ -106,6 +130,18 @@ which use "pkg-config" feature of "%{crate}" crate.
%files -n %{name}+pkg-config-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+thin-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thin-devel %{_description}
This package contains library source intended for building other packages
which use "thin" feature of "%{crate}" crate.
%files -n %{name}+thin-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
@ -173,6 +209,9 @@ which use "zstdmt" feature of "%{crate}" crate.
%endif
%changelog
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 0.8.0-1
- Update to version 0.8.0+zstd.1.4.9.
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.1-1
- Update to version 0.6.1+zstd.1.4.9.

@ -1 +1 @@
SHA512 (zstd-0.6.1+zstd.1.4.9.crate) = 145373dd3c571e455579474c1bff847de44532b34e5f97e7c2461ac7094060fabdd1c88d8161a868f05bd75f07efeb70b020c60198479c5f6b16d5473abe8c7d
SHA512 (zstd-0.8.0+zstd.1.4.9.crate) = 71172e0ce8b4ca29c9f2cf0646c11acd2620b880d7982d380bfd78962d92742282b6677fadccbdc8daa36bbdd91112fa19879d9762d229cd0fa07b6902157740

@ -1,19 +1,20 @@
--- zstd-0.6.1+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-0.6.1+zstd.1.4.9/Cargo.toml 2021-03-06T23:20:56.770277+00:00
--- zstd-0.8.0+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-0.8.0+zstd.1.4.9/Cargo.toml 2021-05-10T14:32:17.508937+00:00
@@ -13,7 +13,7 @@
[package]
edition = "2018"
name = "zstd"
-version = "0.6.1+zstd.1.4.9"
+version = "0.6.1"
-version = "0.8.0+zstd.1.4.9"
+version = "0.8.0"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
exclude = ["assets/**"]
exclude = ["assets/*.zst"]
description = "Binding for the zstd compression library."
@@ -52,7 +52,6 @@
version = "2.2"
@@ -56,7 +56,7 @@
[features]
-bindgen = ["zstd-safe/bindgen"]
bindgen = ["zstd-safe/bindgen"]
debug = ["zstd-safe/debug"]
default = ["legacy"]
-default = ["legacy"]
+default = ["legacy", "bindgen", "pkg-config"]
experimental = ["zstd-safe/experimental"]
legacy = ["zstd-safe/legacy"]
pkg-config = ["zstd-safe/pkg-config"]

Loading…
Cancel
Save