Update to 1.6.1 Close: rhbz#1960714

epel9
Robert-André Mauchin 3 years ago
parent e5478a654c
commit 824cae7e27

1
.gitignore vendored

@ -3,3 +3,4 @@
/zstd-sys-1.4.17+zstd.1.4.5.crate /zstd-sys-1.4.17+zstd.1.4.5.crate
/zstd-sys-1.4.20+zstd.1.4.9.crate /zstd-sys-1.4.20+zstd.1.4.9.crate
/zstd-sys-1.5.0+zstd.1.4.9.crate /zstd-sys-1.5.0+zstd.1.4.9.crate
/zstd-sys-1.6.1+zstd.1.5.0.crate

@ -0,0 +1,12 @@
diff -up zstd-sys-1.6.1+zstd.1.5.0/build.rs.orig zstd-sys-1.6.1+zstd.1.5.0/build.rs
--- zstd-sys-1.6.1+zstd.1.5.0/build.rs.orig 2021-11-13 22:29:26.895153505 +0100
+++ zstd-sys-1.6.1+zstd.1.5.0/build.rs 2021-11-13 22:30:03.082902425 +0100
@@ -6,7 +6,7 @@ use std::{env, fs};
fn generate_bindings(defs: Vec<&str>, headerpaths: Vec<PathBuf>) {
let bindings = bindgen::Builder::default()
.header("zstd.h")
- .blacklist_type("max_align_t")
+ .blocklist_type("max_align_t")
.size_t_is_usize(true)
.use_core()
.rustified_enum(".*")

@ -1,12 +1,12 @@
# Generated by rust2rpm 17 # Generated by rust2rpm 18
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate zstd-sys %global crate zstd-sys
%global upstream_version 1.5.0+zstd.1.4.9 %global upstream_version 1.6.1+zstd.1.5.0
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.5.0 Version: 1.6.1
Release: %autorelease Release: %autorelease
Summary: Low-level bindings for the zstd compression library Summary: Low-level bindings for the zstd compression library
@ -17,7 +17,9 @@ Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata # Initial patched metadata
# * Remove zstd version from version field # * Remove zstd version from version field
# * Make pkg-config and bindgen default features # * Make pkg-config and bindgen default features
# * Bump bindgen to 0.59.0
Patch0: zstd-sys-fix-metadata.diff Patch0: zstd-sys-fix-metadata.diff
Patch1: Update-for-latest-bindgen.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build} %if %{__cargo_skip_build}
@ -168,9 +170,9 @@ which use "zstdmt" feature of "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{upstream_version} -p1 %autosetup -n %{crate}-%{upstream_version} -p1
%cargo_prep
# Remove bundled zstd # Remove bundled zstd
rm -rf zstd/ rm -rfv zstd/ .cargo_vcs_info.json
%cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires -a %cargo_generate_buildrequires -a
@ -181,6 +183,7 @@ echo 'pkgconfig(libzstd)'
%install %install
%cargo_install -a %cargo_install -a
rm -rfv %{buildroot}%{cargo_registry}/%{crate}-%{version_no_tilde}/.cargo
%if %{with check} %if %{with check}
%check %check
@ -188,4 +191,4 @@ echo 'pkgconfig(libzstd)'
%endif %endif
%changelog %changelog
%autochangelog %autochangelog

@ -1 +1 @@
SHA512 (zstd-sys-1.5.0+zstd.1.4.9.crate) = 0e4984d49e1d71796f6335eb37f229422307d359b98e9ebfde2807446478d95a101f506991a1eba8c7aba498019089422631dc0e5f8b58fc55758b00f4f8afb7 SHA512 (zstd-sys-1.6.1+zstd.1.5.0.crate) = 79278016fbe30f0b55195c540f31be5e8de961f6b7de7852c6870ba9d21f7be4aef8c4f57871e0a932e830484d6612c1fce808e77991bf1c6aa98d84007eb01a

@ -1,15 +1,24 @@
--- zstd-sys-1.5.0+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00 --- zstd-sys-1.6.1+zstd.1.5.0/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-sys-1.5.0+zstd.1.4.9/Cargo.toml 2021-05-10T14:23:22.388112+00:00 +++ zstd-sys-1.6.1+zstd.1.5.0/Cargo.toml 2021-11-13T21:15:23.658968+00:00
@@ -12,7 +12,7 @@ @@ -13,7 +13,7 @@
[package] [package]
edition = "2018"
name = "zstd-sys" name = "zstd-sys"
-version = "1.5.0+zstd.1.4.9" -version = "1.6.1+zstd.1.5.0"
+version = "1.5.0" +version = "1.6.1"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"] authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs" build = "build.rs"
links = "zstd" links = "zstd"
@@ -43,7 +43,7 @@ @@ -32,7 +32,7 @@
[dependencies.libc]
version = "0.2.45"
[build-dependencies.bindgen]
-version = "0.58"
+version = "0.59"
optional = true
[build-dependencies.cc]
@@ -45,7 +45,7 @@
[features] [features]
debug = [] debug = []

Loading…
Cancel
Save