update to version 1.4.20+zstd.1.4.9

epel9
Fabio Valentini 4 years ago
parent 37119e818c
commit 4f38afc761
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,3 +1,4 @@
/zstd-sys-1.4.15+zstd.1.4.4.crate /zstd-sys-1.4.15+zstd.1.4.4.crate
/zstd-sys-1.4.16+zstd.1.4.5.crate /zstd-sys-1.4.16+zstd.1.4.5.crate
/zstd-sys-1.4.17+zstd.1.4.5.crate /zstd-sys-1.4.17+zstd.1.4.5.crate
/zstd-sys-1.4.20+zstd.1.4.9.crate

@ -1,13 +1,13 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 16
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate zstd-sys %global crate zstd-sys
%global upstream_version 1.4.17+zstd.1.4.5 %global upstream_version 1.4.20+zstd.1.4.9
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.4.17 Version: 1.4.20
Release: 4%{?dist} Release: 1%{?dist}
Summary: Low-level bindings for the zstd compression library Summary: Low-level bindings for the zstd compression library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -17,7 +17,7 @@ Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata # Initial patched metadata
# * Remove zstd version from version field # * Remove zstd version from version field
# * Make pkg-config default # * Make pkg-config default
# * Bump bindgen to 0.56: https://github.com/gyscos/zstd-rs/pull/97 # * Temporarily downgrade bindgen from 0.57 to 0.56
Patch0: zstd-sys-fix-metadata.diff Patch0: zstd-sys-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -71,6 +71,18 @@ which use "bindgen" feature of "%{crate}" crate.
%files -n %{name}+bindgen-devel %files -n %{name}+bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages
which use "debug" feature of "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+experimental-devel %package -n %{name}+experimental-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -153,7 +165,7 @@ rm -rf zstd/
%cargo_generate_buildrequires -a %cargo_generate_buildrequires -a
echo "pkgconfig(libzstd)" echo "pkgconfig(libzstd)"
echo "bindgen" echo "bindgen"
echo "/usr/bin/llvm-config-%{__isa_bits}" echo "llvm-devel"
%build %build
export LLVM_CONFIG_PATH=/usr/bin/llvm-config-%{__isa_bits} export LLVM_CONFIG_PATH=/usr/bin/llvm-config-%{__isa_bits}
@ -171,6 +183,9 @@ export LLVM_CONFIG_PATH=/usr/bin/llvm-config-%{__isa_bits}
%endif %endif
%changelog %changelog
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 1.4.20-1
- Update to version 1.4.20+zstd.1.4.9.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.17-4 * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.17-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

@ -1 +1 @@
SHA512 (zstd-sys-1.4.17+zstd.1.4.5.crate) = 89439b20e4e0bce6455d982fb7467c45436ee68572395db662d056eb2e09e95ad600947bf11c27ba60b161c2e2511e04cac8dcfacc5f85fcf9222d4a206bdc30 SHA512 (zstd-sys-1.4.20+zstd.1.4.9.crate) = 71853b2aaeff3c0b2e6cd3bdabb21d10db3a299376338f5b491fca12432f322e96d30ff2c9e0df46ff084dcd2143315a30ff4aa702cebdb900a0cd9afcb49894

@ -1,11 +1,11 @@
--- zstd-sys-1.4.17+zstd.1.4.5/Cargo.toml 2020-06-14T06:25:46+00:00 --- zstd-sys-1.4.20+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-sys-1.4.17+zstd.1.4.5/Cargo.toml 2020-11-27T23:45:14.946189+00:00 +++ zstd-sys-1.4.20+zstd.1.4.9/Cargo.toml 2021-03-06T23:10:36.280560+00:00
@@ -12,7 +12,7 @@ @@ -12,7 +12,7 @@
[package] [package]
name = "zstd-sys" name = "zstd-sys"
-version = "1.4.17+zstd.1.4.5" -version = "1.4.20+zstd.1.4.9"
+version = "1.4.17" +version = "1.4.20"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"] authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs" build = "build.rs"
links = "zstd" links = "zstd"
@ -13,15 +13,15 @@
[dependencies.libc] [dependencies.libc]
version = "0.2.45" version = "0.2.45"
[build-dependencies.bindgen] [build-dependencies.bindgen]
-version = "0.54" -version = "0.57"
+version = "0.56" +version = "0.56"
optional = true optional = true
[build-dependencies.cc] [build-dependencies.cc]
@@ -48,7 +48,7 @@ @@ -43,7 +43,7 @@
optional = true
[features] [features]
debug = []
-default = ["legacy"] -default = ["legacy"]
+default = ["legacy", "pkg-config", "bindgen"] +default = ["legacy", "pkg-config", "bindgen"]
experimental = [] experimental = []

Loading…
Cancel
Save