update to version 1.5.0+zstd.1.4.9

epel9
Fabio Valentini 4 years ago
parent f4ced7b3bf
commit 4571e6f54b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/zstd-sys-1.4.16+zstd.1.4.5.crate /zstd-sys-1.4.16+zstd.1.4.5.crate
/zstd-sys-1.4.17+zstd.1.4.5.crate /zstd-sys-1.4.17+zstd.1.4.5.crate
/zstd-sys-1.4.20+zstd.1.4.9.crate /zstd-sys-1.4.20+zstd.1.4.9.crate
/zstd-sys-1.5.0+zstd.1.4.9.crate

@ -0,0 +1,5 @@
[DEFAULT]
buildrequires =
pkgconfig(libzstd)
lib.requires =
pkgconfig(libzstd)

@ -3,11 +3,11 @@
%global debug_package %{nil} %global debug_package %{nil}
%global crate zstd-sys %global crate zstd-sys
%global upstream_version 1.4.20+zstd.1.4.9 %global upstream_version 1.5.0+zstd.1.4.9
Name: rust-%{crate} Name: rust-%{crate}
Version: 1.4.20 Version: 1.5.0
Release: 2%{?dist} Release: 1%{?dist}
Summary: Low-level bindings for the zstd compression library Summary: Low-level bindings for the zstd compression library
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -16,7 +16,7 @@ URL: https://crates.io/crates/zstd-sys
Source: %{crates_source %{crate} %{upstream_version}} Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata # Initial patched metadata
# * Remove zstd version from version field # * Remove zstd version from version field
# * Make pkg-config default # * Make pkg-config and bindgen default features
Patch0: zstd-sys-fix-metadata.diff Patch0: zstd-sys-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -142,6 +142,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+thin-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thin-devel %{_description}
This package contains library source intended for building other packages
which use "thin" feature of "%{crate}" crate.
%files -n %{name}+thin-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+zstdmt-devel %package -n %{name}+zstdmt-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -162,14 +174,9 @@ rm -rf zstd/
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires -a %cargo_generate_buildrequires -a
echo "pkgconfig(libzstd)" echo 'pkgconfig(libzstd)'
echo "bindgen"
echo "llvm-devel"
%build %build
export LLVM_CONFIG_PATH=/usr/bin/llvm-config-%{__isa_bits}
bindgen %{_includedir}/zstd.h --ctypes-prefix ::libc --blacklist-type max_align_t --size_t-is-usize --rustified-enum '.*' --use-core -o src/bindings.rs --
bindgen %{_includedir}/zstd.h --blacklist-type max_align_t --size_t-is-usize --rustified-enum '.*' --use-core -o src/bindings_std.rs --
%cargo_build -a %cargo_build -a
%install %install
@ -177,11 +184,13 @@ bindgen %{_includedir}/zstd.h --blacklist-type max_align_t --size_t-is-usize --r
%if %{with check} %if %{with check}
%check %check
export LLVM_CONFIG_PATH=/usr/bin/llvm-config-%{__isa_bits}
%cargo_test -a %cargo_test -a
%endif %endif
%changelog %changelog
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 1.5.0-1
- Update to version 1.5.0+zstd.1.4.9.
* Wed Mar 31 21:35:34 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 1.4.20-2 * Wed Mar 31 21:35:34 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 1.4.20-2
- Remove downgrade of bindgen to 0.56 - Remove downgrade of bindgen to 0.56

@ -1 +1 @@
SHA512 (zstd-sys-1.4.20+zstd.1.4.9.crate) = 71853b2aaeff3c0b2e6cd3bdabb21d10db3a299376338f5b491fca12432f322e96d30ff2c9e0df46ff084dcd2143315a30ff4aa702cebdb900a0cd9afcb49894 SHA512 (zstd-sys-1.5.0+zstd.1.4.9.crate) = 0e4984d49e1d71796f6335eb37f229422307d359b98e9ebfde2807446478d95a101f506991a1eba8c7aba498019089422631dc0e5f8b58fc55758b00f4f8afb7

@ -1,11 +1,11 @@
--- zstd-sys-1.4.20+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00 --- zstd-sys-1.5.0+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-sys-1.4.20+zstd.1.4.9/Cargo.toml 2021-03-31T19:35:34.273275+00:00 +++ zstd-sys-1.5.0+zstd.1.4.9/Cargo.toml 2021-05-10T14:23:22.388112+00:00
@@ -12,7 +12,7 @@ @@ -12,7 +12,7 @@
[package] [package]
name = "zstd-sys" name = "zstd-sys"
-version = "1.4.20+zstd.1.4.9" -version = "1.5.0+zstd.1.4.9"
+version = "1.4.20" +version = "1.5.0"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"] authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs" build = "build.rs"
links = "zstd" links = "zstd"

Loading…
Cancel
Save