parent
d3f6db737b
commit
1f39c6bbb2
@ -1,2 +0,0 @@
|
|||||||
/zopfli-0.4.0.crate
|
|
||||||
/zopfli-0.5.0.crate
|
|
@ -1,2 +0,0 @@
|
|||||||
* Mon May 31 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.4.0-1
|
|
||||||
- Initial package
|
|
@ -0,0 +1 @@
|
|||||||
|
no longer needed
|
@ -1,88 +0,0 @@
|
|||||||
# Generated by rust2rpm 20
|
|
||||||
%bcond_without check
|
|
||||||
|
|
||||||
%global crate zopfli
|
|
||||||
|
|
||||||
Name: rust-%{crate}
|
|
||||||
Version: 0.5.0
|
|
||||||
Release: %autorelease
|
|
||||||
Summary: Rust implementation of a compression algorithm
|
|
||||||
|
|
||||||
# Upstream license specification: Apache-2.0
|
|
||||||
License: ASL 2.0
|
|
||||||
URL: https://crates.io/crates/zopfli
|
|
||||||
Source: %{crates_source}
|
|
||||||
# Initial patched metadata
|
|
||||||
# Downgrade typed-arena to version 1.7
|
|
||||||
Patch0: zopfli-fix-metadata.diff
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
|
||||||
|
|
||||||
BuildRequires: rust-packaging
|
|
||||||
|
|
||||||
%global _description %{expand:
|
|
||||||
Rust implementation of the Zopfli compression algorithm.}
|
|
||||||
|
|
||||||
%description %{_description}
|
|
||||||
|
|
||||||
%package -n %{crate}
|
|
||||||
Summary: %{summary}
|
|
||||||
# MIT
|
|
||||||
# MIT or ASL 2.0
|
|
||||||
# Unlicense or MIT
|
|
||||||
# zlib
|
|
||||||
License: MIT and ASL 2.0 and Unlicense and zlib
|
|
||||||
|
|
||||||
%description -n %{crate} %{_description}
|
|
||||||
|
|
||||||
%files -n %{crate}
|
|
||||||
%license COPYING
|
|
||||||
%doc CONTRIBUTING.md CONTRIBUTORS README.md
|
|
||||||
%{_bindir}/zopfli
|
|
||||||
|
|
||||||
%package devel
|
|
||||||
Summary: %{summary}
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description devel %{_description}
|
|
||||||
|
|
||||||
This package contains library source intended for building other packages
|
|
||||||
which use "%{crate}" crate.
|
|
||||||
|
|
||||||
%files devel
|
|
||||||
%license COPYING
|
|
||||||
%doc CONTRIBUTING.md CONTRIBUTORS README.md
|
|
||||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
|
||||||
|
|
||||||
%package -n %{name}+default-devel
|
|
||||||
Summary: %{summary}
|
|
||||||
BuildArch: noarch
|
|
||||||
|
|
||||||
%description -n %{name}+default-devel %{_description}
|
|
||||||
|
|
||||||
This package contains library source intended for building other packages which
|
|
||||||
use "default" feature of "%{crate}" crate.
|
|
||||||
|
|
||||||
%files -n %{name}+default-devel
|
|
||||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
||||||
|
|
||||||
%prep
|
|
||||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
||||||
%cargo_prep
|
|
||||||
|
|
||||||
%generate_buildrequires
|
|
||||||
%cargo_generate_buildrequires
|
|
||||||
|
|
||||||
%build
|
|
||||||
%cargo_build
|
|
||||||
|
|
||||||
%install
|
|
||||||
%cargo_install
|
|
||||||
|
|
||||||
%if %{with check}
|
|
||||||
%check
|
|
||||||
%cargo_test
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%changelog
|
|
||||||
%autochangelog
|
|
@ -1 +0,0 @@
|
|||||||
SHA512 (zopfli-0.5.0.crate) = f8ea69c3aea08a53851e177e3579c46076271d28f6fe2da55ebd46a5f6d918afd084c0dc372313f4a06798ceb35adb577ce30bf272f273b842ba95172be3c9ec
|
|
@ -1,8 +0,0 @@
|
|||||||
--- zopfli-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
||||||
+++ zopfli-0.5.0/Cargo.toml 2022-01-17T22:21:57.128813+00:00
|
|
||||||
@@ -35,4 +35,4 @@
|
|
||||||
version = "2"
|
|
||||||
|
|
||||||
[dependencies.typed-arena]
|
|
||||||
-version = "2"
|
|
||||||
+version = "1.7"
|
|
Loading…
Reference in new issue