commit
dd0a58eb78
@ -0,0 +1 @@
|
|||||||
|
SOURCES/zlib-rs-0.4.1.crate
|
@ -0,0 +1 @@
|
|||||||
|
b3fc4e045084b3018617941b0d942eccdb9bdc93 SOURCES/zlib-rs-0.4.1.crate
|
@ -0,0 +1,5 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop dependencies and internal-only features for fuzz-testing",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,31 @@
|
|||||||
|
--- zlib-rs-0.4.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ zlib-rs-0.4.1/Cargo.toml 2024-12-16T13:59:19.494265+00:00
|
||||||
|
@@ -31,17 +31,6 @@
|
||||||
|
name = "zlib_rs"
|
||||||
|
path = "src/lib.rs"
|
||||||
|
|
||||||
|
-[dependencies.arbitrary]
|
||||||
|
-version = "1.0"
|
||||||
|
-features = ["derive"]
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[dependencies.quickcheck]
|
||||||
|
-version = "1.0.3"
|
||||||
|
-features = []
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[dev-dependencies.crc32fast]
|
||||||
|
version = "1.3.2"
|
||||||
|
|
||||||
|
@@ -51,10 +40,6 @@
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-ZLIB_DEBUG = []
|
||||||
|
-__internal-fuzz = ["arbitrary"]
|
||||||
|
-__internal-fuzz-disable-checksum = []
|
||||||
|
-__internal-test = ["quickcheck"]
|
||||||
|
c-allocator = []
|
||||||
|
default = [
|
||||||
|
"std",
|
@ -0,0 +1,129 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 27
|
||||||
|
%bcond check 1
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate zlib-rs
|
||||||
|
|
||||||
|
Name: rust-zlib-rs
|
||||||
|
Version: 0.4.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Memory-safe zlib implementation written in rust
|
||||||
|
|
||||||
|
License: Zlib
|
||||||
|
URL: https://crates.io/crates/zlib-rs
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop dependencies and internal-only features for fuzz-testing
|
||||||
|
Patch: zlib-rs-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A memory-safe zlib implementation written in rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+c-allocator-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+c-allocator-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "c-allocator" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+c-allocator-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+rust-allocator-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+rust-allocator-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "rust-allocator" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+rust-allocator-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.4.1-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Mon Dec 16 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.4.1-1
|
||||||
|
- Update to version 0.4.1; Fixes RHBZ#2332559
|
||||||
|
|
||||||
|
* Wed Nov 20 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.4.0-1
|
||||||
|
- Update to version 0.4.0
|
||||||
|
|
||||||
|
* Tue Oct 29 2024 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
|
||||||
|
- Initial packaging (#2319894)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue