Update to version 0.4.0

epel10
Benjamin A. Beasley 3 months ago committed by Fabio Valentini
parent 3697abb52a
commit 5570a60ae4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/zlib-rs-0.3.1.crate
/zlib-rs-0.4.0.crate

@ -5,7 +5,7 @@
%global crate zlib-rs
Name: rust-zlib-rs
Version: 0.3.1
Version: 0.4.0
Release: %autorelease
Summary: Memory-safe zlib implementation written in rust

@ -0,0 +1,5 @@
[package]
cargo-toml-patch-comments = [
"drop dependencies and internal-only features for fuzz-testing",
]

@ -1 +1 @@
SHA512 (zlib-rs-0.3.1.crate) = 83b68185ade43ab27ff9a213a89c6ed23c9044b90402494251b4026ce7647128fac90321103e20069ebdd4a6e08b828c1aa66352e19d2056ec80edfe3d46e4c2
SHA512 (zlib-rs-0.4.0.crate) = f068ecb90393c470c39c733bc6e9ffe683b3b66027c90f03f72542b5497edc6c134bc48573483bef69f35ce20f6a4af7c8f7b205fe1f3faeccebb76873780321

@ -1,6 +1,6 @@
--- zlib-rs-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zlib-rs-0.3.1/Cargo.toml 2024-10-19T09:51:09.355690+00:00
@@ -30,23 +30,6 @@
--- zlib-rs-0.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zlib-rs-0.4.0/Cargo.toml 2024-11-20T05:03:47.033928+00:00
@@ -30,17 +30,6 @@
name = "zlib_rs"
path = "src/lib.rs"
@ -9,12 +9,6 @@
-features = ["derive"]
-optional = true
-
-[dependencies.libz-sys]
-version = "1.1.19"
-features = ["zlib-ng"]
-optional = true
-default-features = false
-
-[dependencies.quickcheck]
-version = "1.0.3"
-features = []
@ -24,12 +18,13 @@
[dev-dependencies.crc32fast]
version = "1.3.2"
@@ -56,9 +39,6 @@
@@ -50,10 +39,6 @@
default-features = false
[features]
-ZLIB_DEBUG = []
-__internal-fuzz = ["arbitrary"]
-__internal-fuzz-disable-checksum = []
-__internal-test = ["quickcheck"]
c-allocator = []
default = [

Loading…
Cancel
Save